Posts by dsat

    Moin,


    der Vollständigkeit halber: spaßeshalber habe ich meine bullseye-Installation jetzt mal einem dist-upgrade unterzogen und siehe da: es gibt jetzt ein Fernsehbild.

    Das Problem mit xineliboutput-sxfe und buffer overflows besteht aber weiterhin, ist in diesem Fall aber kein Showstopper.

    Code
    1. System: Host: server Kernel: 5.10.0-7-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.20.5
    2. Distro: Debian GNU/Linux 11 (bullseye)
    3. Machine: Type: Desktop Mobo: ASUSTeK model: PRIME A320M-C R2.0 v: Rev X.0x serial: 190755473200157
    4. UEFI: American Megatrends v: 5601 date: 07/10/2020
    5. CPU: Info: Dual Core model: AMD Athlon 3000G with Radeon Vega Graphics bits: 64 type: MT MCP L2 cache: 1024 KiB
    6. Speed: 2476 MHz min/max: 1600/3500 MHz Core speeds (MHz): 1: 2476 2: 2945 3: 2510 4: 3252
    7. Graphics: Device-1: NVIDIA GK208B [GeForce GT 710] driver: nvidia v: 460.73.01
    8. Display: server: X.Org 1.20.11 driver: loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa
    9. resolution: 1920x1080~60Hz
    10. OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01

    Hi und pardon,


    ich habe nicht gesehen, dass sich hier etwas getan hat, da ich keine Nachricht bekommen habe.


    Mit Kubuntu 20.04 habe ich jetzt mal getestet. Kernel 5.11, Grafik nouveau. Rudimentären vdr installiert wie oben beschrieben.


    Es scheint ein Signal zu geben, aber es kommt kein TV-Bild. Aufnahmen werden aber mit Bild wiedergegeben. Also wie gehabt.


    Gruß dsat

    Hi,


    in Vorbereitung auf das zukünftigen Debian 11 habe ich mir ein System mit bullseye installiert, indem ich buster neue installiert habe, die sources.list um bullseye erweitert habe und dann ein dist-upgrade gemacht habe. Dann habe ich noch vdr vdr-plugin-xineliboutput und xineliboutput-sxfe installiert sowie eine remot.conf nach /var/lib/vdr kopiert. Fertig ist ein rudimentärer vdr. Dieser vdr hat leider einen gravierenden Haken: es gibt keinen Fernsehempfang. Vorhandene vdr-Aufnahmen werden aber wiedergegeben.


    Hardware:


    OS:


    Alternatives OS:


    Wie schon erwähnt gibte es keinen Fernsehempfang mit dem bullseye-Kernel 5.10.0-6, erstaunlicherweise aber mit dem buster-Kernel 4.19.0-16. Wird die alte Fernsehkarte vom neuen Kernel nicht mehr unterstützt?


    Außerdem hat xineliboutput-sxfe nach wenigen Kanalwechseln Probleme mit buffer overflows und bleibt hängen:


    Wie kann ich das lösen?


    Gruß dsat

    Die Links habe ich mir angesehen. Das mit dem selbst Kompilieren usw. ist nicht so mein Ding. Ich denke ich werde eine Nvidia-Karte dazustecken und gut ist.


    Besten Dank für die Hinweise.


    Gruß dsat

    Moin,


    auf dieser Hardware soll je gar kein easyVDR laufen, sondern ein Buster und später ein Bullseye mit VDR.

    easyVDR dient mir nur als Test, ob ein VDR überhaupt läuft, und das tut er ja mit ea50 Unstable, wenn auch etwas holperig, wie gesagt.

    Code
    1. System: Host: easyVDR Kernel: 5.4.0-26-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Console: N/A Distro: Ubuntu 20.04 LTS (Focal Fossa)
    2. Machine: Type: Desktop Mobo: ASUSTeK model: PRIME A320M-C R2.0 v: Rev X.0x serial: 190755473200157 UEFI: American Megatrends v: 5222 date: 10/14/2019
    3. CPU: Topology: Dual Core model: AMD Athlon 3000G with Radeon Vega Graphics bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 1024 KiB flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 27948 Speed: 1471 MHz min/max: 1600/3500 MHz Core speeds (MHz): 1: 1422 2: 1420 3: 1427 4: 1420
    4. Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 08:00.0 Display: server: X.org 1.20.8 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa tty: 240x75

    VDR-Aufnahmen unter Buster mit amdgpu funktionieren nicht.


    Gruß dsat

    Moin,

    für meinen neuen Server, auf dem auch VDR installiert werden soll, habe ich mir folgenden Unterbau geleistet:

    Code
    1. Machine: Type: Desktop Mobo: ASUSTeK model: PRIME A320M-C R2.0 v: Rev X.0x serial: 190755473200157 UEFI: American Megatrends v: 5222 date: 10/14/2019
    2. CPU: Topology: Dual Core model: AMD Athlon 3000G with Radeon Vega Graphics bits: 64 type: MT MCP L2 cache: 1024 KiB Speed: 1589 MHz min/max: 1600/3500 MHz Core speeds (MHz): 1: 1589 2: 1520 3: 1619 4: 1522
    3. Memory: RAM: total: 7.79 GiB used: 884.0 MiB (11.1%)

    Dieses Brett hat noch einen PCI-Slot in dem eine TT-budget S2-3200 HDTV-S2 steckt.


    Dabei ergibt sich folgende Situation:

    Mit Nvidia-Karte und Nvidia-Treiber funktioniert der VDR wie erwartet, soweit so gut. Der amdgpu-Treiber mit Kernel 4.19 funktioniert jedoch nicht, KDE startet nicht.

    Code
    1. System: Host: test-server Kernel: 4.19.0-10-amd64 x86_64 bits: 64 Console: tty 3 Distro: Debian GNU/Linux 10 (buster)
    2. Graphics: Device-1: NVIDIA GF108 [GeForce GT 430] driver: nvidia v: 390.138 Display: server: X.Org 1.20.4 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz OpenGL: renderer: GeForce GT 430/PCIe/SSE2 v: 4.6.0 NVIDIA 390.138

    Mit amdgpu und Kernel 5.8-bpo läuft ein VDR insoweit, als das Menü bedienbar ist, Aufnahmen abgespielt werden können und Infos zu Sendungen, Sender und Signal usw. angezeigt werden. Aber es gibt kein Fernsehbild.

    Code
    1. System: Host: test-server Kernel: 5.8.0-0.bpo.2-amd64 x86_64 bits: 64 Console: tty 3 Distro: Debian GNU/Linux 10 (buster)
    2. Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel Display: server: X.Org 1.20.4 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz OpenGL: renderer: AMD RAVEN2 (DRM 3.38.0 5.8.0-0.bpo.2-amd64 LLVM 7.0.1) v: 4.5 Mesa 18.3.6

    So ist das aber nicht beabsichtigt. Das System soll mit der integrierten amd-Grafik funktionieren.

    Woran muss ich drehen, welches Paket/Treiber/Firmware fehlt da?


    Testweise habe ich es auch mal mit der Installation eines easyvdr-5-alpha-010 Stable und eines easyvdr-5-alpha-010 Unstable ohne Nvidia-Grafik-Karte versucht.

    Stable-Installation und Setup laufen zwar durch, aber Grafik (gewählt: x-Standard) und TT-budget S2-3200 (gewählt: keine Spezialtreiber) werden nicht erkannt. Nach dem ersten Start des VDR aus dem Setup gibt es ein Fernsehbild und der VDR läßt sich bedienen. Nach dem ersten Reboot startet dann aber kein VDR und das System will einen Drucker für den User easyvdr installieren. An der Stelle habe ich abgebgochen.


    Unstable-Installation und Setup erkennen Grafik (gewählt: x-Standard) und TT-budget S2-3200 (gewählt: keine Spezialtreiber) auch nicht. Das Sytem übersteht aber ein reboot und der VDR läuft. Allerdings etwas holperig, es gibt Bild- und Tonausetzer bei Kanalwechseln und Menüaufrufen, aber der VDR läuft.


    Die Installation des amdgpu-pro-20.40 von der amd-Seite ändert nichts.


    Hat jemand einen Tipp wie ich Buster mit VDR aber ohne Nvidia ans laufen bekomme?


    Gruß dsat

    Hi,


    auf welche vdr-Version ist der patch anwendbar?


    Ich bin hier mit der amd64-Version aus debian sid unterwegs:


    Code
    1. # apt-cache policy vdr
    2. vdr:
    3. Installiert: 2.0.6-1
    4. Installationskandidat: 2.0.6-1
    5. Versionstabelle:
    6. *** 2.0.6-1 0
    7. 500 http://http.debian.net/debian/ unstable/main amd64 Packages
    8. 100 /var/lib/dpkg/status


    Wenn ich den patch anwende werden drei hunks zurückgemeldet:


    Code
    1. # patch /usr/bin/vdr < ~/vdr-2.0.6-hevc.diff
    2. patching file /usr/bin/vdr
    3. Hunk #1 FAILED at 373.
    4. 1 out of 1 hunk FAILED -- saving rejects to file /usr/bin/vdr.rej
    5. patching file /usr/bin/vdr
    6. Hunk #1 FAILED at 744.
    7. Hunk #2 FAILED at 1459.
    8. 2 out of 2 hunks FAILED -- saving rejects to file /usr/bin/vdr.rej


    Mache ich etwas verkehrt?


    Gruß dsat

    Hi zamm,


    die Ankündigung ist zwar äußerst kurzfristig, aber immer noch besser als nimmer, und sie kann auf die Zukunft angewendet werden.


    In München und drum herum gibt es wohl VDR-User, aber ich habe nicht ausfindig machen können, ob sie sich treffen würden. VDR-Basis ist häufig ein Debian, wenn nicht gar ein SID. sidux/aptosid ist Debian SID pur. Ich benutze beides. Die Münchener sidux-Gemeinde trifft sich morgen, den 09.04., wie übrigens:


    jeden 2ten Samstag eines Monats um 18:00 Uhr im DILO, Pariser Straße 19, 81667 München (sidux-Stammtisch).


    Warum sollten wir uns nicht einmal zusammen treffen? Linux ist übrigens nicht immer das bestimmende Gesprächsthema.


    Wer sich eingeladen fühlt, ist also herzlich angesprochen einmal vorbei zu schauen :] .


    Beste Grüße und bis dahin


    dsat

    Aller besten Dank für VDR.


    Viele hier sagen ja, dass sie sich fern sehen ohne VDR gar nicht mehr vorstellen können. Ich frage: wie geht fern sehen ohne VDR??


    Ohne VDR wäre ich nie zu Linux gekommen.


    Gruß dsat

    Geniale Idee. Wir haben uns ganz früher Raumpatrouille im Fernsehen angesehen, natürlich ohne Ton, und dazu Deep Purple und Led Zeppelin über die Stereo-Anlage gehört. Es ist ganz erstaunlich, wie viel Lippensynchronität man dabei entdecken kann :lachen3


    Gruß dsat

    Hi,


    es muss nicht das CICAM selbst sein. Ich habe hier z. B. eine TT FF 2.3, an der will partout kein einziges von drei CICAMs funktionieren. Alle drei laufen aber mit anderen Karten (TT FF 1.3 und Nexus-S 2.1) einwandfrei. Es ist mir schleierhaft aber so ist es.


    Gruss dsat