Posts by gehlhajo

    >> Was kann hierfür die Ursache sein?


    Ein grottig programmierter Zweipunktregler im Bios ? Schau mal im Bios nach, ob Du die Hysterese einstellen kannst. Falls ja , experimentiere mit den Werten. Dabei immer die Temperatur im Auge behalten....


    Viele Grüße

    Hi all


    Ich habe jetzt ein wenig mit der "STL" sowie "getopt" herumgespielt und es it so ziemlich genau das , was ich ich gesucht habe. (Auch mal beim "Chef" gespiekt, wie er "getopt" einsetzt :=))
    Bei XML bin ich noch nicht sicher. Werde es wohl mal mit "boost" versuchen.
    Vielen Dank Euch allen und ein schönes Wochenende ;D

    Hallo erstmal


    Ich habe schon Erfahrung mit SW-Entwicklung unter Windows (c++/c#). Nun wollte ich mich mal an ein erstes kleines c++ (Raspberry) Projekt wagen. Natürlich habe ich schon gewisse Ideen. Leider kommen darin ausschließlich Dinge aus der Microsoft Welt vor. Um das Rad nicht zum zweiten Mall zu erfinden dachte ich, ich frage einfach mal die Profies hier. Was benutz Ihr;Was ist "State of the Art" ?
    Ich bräuchte.....


    - HashTable
    In der MS Welt c++ bisher benutzt: CMapStringToString oder CMapStringToObjekt oder einfach nur CMap;


    Code
    1. CMap<CString,LPCTSTR,LABEL,LABEL>


    - Objekte Serial/Deserialsieren
    in c++ noch keine richtige Erfahrungen gesammelt, In c# funktioniert das ja "Out of the Box"


    -Comandline Parser
    Benutz Ihr sowas oder macht Ihr das alles selber "from the scratch" ?


    Ach ja, und wie man so ein Makefile erstellt, wüsst ich auch gerne mal..... ;D


    Vielen Dank schon mal.....

    Hallo erstmal......


    Ich benutze auf dem Desktop den Arch-Ableger Manjaro. Gleichzeitig befindet sich auf dem Rechner ein VDR mit TBS DVB-Karte.
    Da Manjaro (Arch?) kein DKMS unterstützt, sieht meine Updateprodezedur wie folgt aus:


    Code
    1. pacman -Suy


    Dann schauen , ob ein neuer Kernel mitgekommen ist. Falls ja , dann:


    Code
    1. reboot


    Und im Anschluss


    Code
    1. yaourt -S tbs-dvb-drivers


    Der reboot ist deshalb notwendig, da die Installation der DVB-Treiber sonst in den gerade laufenden Kernel erfolgt und nicht in den neu installierten.
    Ich frage mich, ob man das ganze nicht durch ein Script in einem Rutsch erledigen kann....?


    Schönes WE Euch allen......

    Jetzt läuft gerade der selbstgebaute VDR und und die Fernbedienung funktioniert. Trotzdem zeigt vdr --showargs kein LIRC an
    vdr --showargs
    --chartab=ISO-8859-15
    --epgfile=/mnt/data_usb/epg/vdr
    --grab=/tmp
    --log=3
    --no-kbd
    --user=root
    --video=/mnt/data_usb/video
    --watchdog=30
    --plugin=epg2vdr
    --plugin=rpihddevice
    --plugin=scraper2vdr --imagedir=/mnt/data_usb/epg/scraper2vdr --mode=client
    --plugin=skindesigner
    --plugin=streamdev-client
    --plugin=svdrpservice
    [root@moe2 ~]#


    Gesendet von meinem ME302KL mit Tapatalk

    Hallo Copperhead


    VDR versehentlich ohne LIRC Support gebaut ?


    Mein gebauter VDR sagt:


    Code
    1. Mär 22 21:21:47 moe2 vdr[1193]: [1193] setting current skin to "nopacity"
    2. Mär 22 21:21:47 moe2 vdr[1193]: [1193] loading /var/lib/vdr/themes/nopacity-default.theme
    3. Mär 22 21:21:47 moe2 vdr[1193]: [1193] remote control LIRC - keys known
    4. Mär 22 21:21:47 moe2 vdr[1193]: [1219] LIRC remote control thread started (pid=1193, tid=1219, prio=high)
    5. Mär 22 21:21:47 moe2 vdr[1193]: [1193] switching to channel 1 (Das Erste HD)
    6. Mär 22 21:21:47 moe2 vdr[1193]: [1193] streamdev-client: Connected to server 192.168.0.4:2004 using protocol version 1.0
    7. Mär 22 21:21:47 moe2 vdr[1193]: [1193] streamdev-client: Connected to server 192.168.0.4:2004 using protocol version 1.0
    8. Mär 22 21:21:47 moe2 vdr[1193]: [1220] device 2 receiver thread started (pid=1193, tid=1220, prio=high)
    9. Mär 22 21:21:47 moe2 vdr[1193]: [1193] setting watchdog timer to 30 seconds
    10. Mär 22 21:21:47 moe2 vdr[1193]: [1193] OSD size changed to 1920x1080 @ 1,77778


    Der VDR von VDR4ARCH nach heutigem Update an gleicher Stelle



    Fernbedienung funktioniert hier nicht.
    Viele Grüße

    Hi seahawk


    Ich habe den VDR ganz normal aus dem git geholt und gebaut, ohne irgendetwas zu patchen.



    Aber Deine Erklärung klingt für mich sehr plausibel. Ich habe leider bereits alles wieder auf einen "alten" VDR umgebaut, damit ich fernsehen kann. Ich probiere das die Tage gleich mal aus.
    Vielen Dank :tup

    Hilfe


    Habe heute den Raspberry mit ARCH upgedatet. Seitdem kriege ich immer Neustarts vom VDR. [mvdr.service: Start operation timed out. Terminating.]
    Zwischen Neustarts läuft der VDR völlig normal. Habt Ihr eine Idee ?


    Logfile:



    Viele Grüße



    Lösung: Entweder VDR mit notify Support bauen ( siehe unten) oder im Service 'Type=notify' entfernen.

    Hallo 3PO


    Was war es denn nun. Habe gerade das gleiche Problem. Habe skindesigner aus dem git gebaut.


    Viele Grüße

    Erledigt, Fehler gefunden, ....

    Irgendetwas scheint da nicht zu passen:


    Code
    1. Jan 30 14:20:38 [vdr] [11876] loading plugin: /usr/lib/vdr/plugins/libvdr-skindesigner.so.2.2.0
    2. Jan 30 14:20:38 [vdr] [11876] ERROR: /usr/lib/vdr/plugins/libvdr-skindesigner.so.2.2.0: undefined symbol: _ZN15skindesignerapi20cSkindesignerOsdMenu14AddStringTokenESsSs


    libskindesigner wurde neu ausgecheckt, neu gebaut und installiert.

    Also soweit ich das verstanden habe (so stehts auch in der Doku glaube ich ), sollte pro Gerät immer ein nur ein EPG-manipulierendes Plugin verwendet werden.
    tee

    Quote

    HINTS:
    - Don't load the epgtableid0 (epgtableid0 disables VDRs new EPG handler interface)
    - Don't load the noepg plugin
    (best you don't load any other epg manipulating plugin or patch if you not shure how they work together ;))

    Bei mir läuft auf dem VDR-Server epg2vdr + epgd und auf dem Client epgsync. Das funktioniert bei mir bis jetzt man besten.



    Viele Grüße

    Hi

    ich hoffe ihr könnt mir ein paar Infos geben mit welcher distribution das am besten zu machen ist

    Ich habe es mit gentoo und mit arch probiert und beides hat funktioniert. Das DVB-Device war eine TT DVB-S2 3600 und eine Terretec DVB-C PCI
    Ich konnte die S400 jedoch nicht dazu überreden, von USB Festplatte zu booten. War aber kein Problem. Habe die CF-Karte als /boot genommen und von ihr gebootet.
    WakeonLAN hat auch funktioniert. Ich meine ( ist schon ein Weilchen her), ein Problem mit dem ACPI WakeUp gehabt zu haben.
    Wie Du allerdings mit dem Ding Aufnahmen wiedergeben willst, ist mir ein Rätsel.


    Gruß gehlhajo