Posts by twoofseven

    Quote

    warum heißt den die Karte Linux4Media. Ich dachte der Hersteller sei DigitalDevices und Media Pointer war ursprünglich der Reseller?


    DigitalDevices hatte uns gebeten den Namen entsprechend anzupassen, da Media-Pointer nur als Distributor die Karte vertreibt. Die Karte selbst kommt jedoch von Linux4Media. Die Bezeichnung der baugleichen Mystique hat sich jedoch nicht geändert.
    Bitte fragt mich nicht wie die drei Firmen genau zusammenarbeiten bzw. zusammengehören. Dies interessiert mich auch nicht wirklich, solange die Kommunikation mit DigitalDevices so gut funktioniert wie aktuell.


    Gruß,
    Matthias

    Hallo,


    nachdem Oliver die Erkenntnisse aus dem ngene-test Repo ins ngene-Repo übernommen hat und der Treiber die Firmware v15 verwendet, hab ich das LinuxTV Wiki entsprechend angepasst, sodass der Nutzer jetzt zumindest eine wieder passende Anleitung hat. Dazu hab ich die Zeilen aus dem Makefile.bin einfach abgeändert und direkt ins Wiki geschrieben.


    Siehe:
    http://www.linuxtv.org/wiki/in…_cineS2_DVB-S2_Twin_Tuner
    http://www.linuxtv.org/wiki/index.php/Mystique_SaTiX-S2_Dual


    Nicht wundern, die Karte heißt übrigens richtig: "Linux4Media cineS2 DVB-S2 Twin Tuner".


    Gruß,
    Matthias

    DaCHRlS :


    Code
    1. modprobe ngene one_adapter=0


    Die Tuner werden immer automatisch geladen. Jedoch wird mit "one_adapter=0" zwei adapter mit jeweils einem frontend pro Karte unter /dev/dvb angelegt. Ansonsten wird nur ein adapter mit mehrere frontends angelegt. Letzteres wäre eigentlich richtig, aber wird noch nicht von jeder Applikation unterstützt, sodass nur das frontent0 erkannt und frontend1 ausgelassen wird. Oliver hat dies dem VDR Verantwortlichen jedoch schon zurückgemeldet. Mythtv hat glaub ich das gleiche Problem.


    Ich würde vorschlagen den kompletten ../ngene Pfad zu löschen und noch einmal "sudo make install" im ngene Ordner aufzurufen.


    Gruß,
    Matthias

    @ DaCHRlS:


    Quote

    Schlagen bei euch eigentlich auch die Treiber der FireDTV im make fehl


    Ja, ich muss auch immer erst einmal im mittels make menuconfig FirDTV deaktivieren. Liegt vielleicht am Ubuntu 9.10 Kernel. Hab mich jedoch nicht drum gekümmert näher nachzuforschen.


    Zu dem anderen Problem kannst du mal schauen, ob das alte ngene Modul aus dem GIT-Repo noch in deinem kernel tree vorhanden ist. Bei mir war das der Fall als ich vom GIT auf das HG Repo umgestiegen bin, ohne das alte ngene-Modul unter "/lib/modules/<uname>/kernel/drivers/media/video/ngene" zu löschen.


    Gruß,
    Matthias

    @ abesse:


    Kannst du mal folgendes für den ngene ausprobieren:

    Code
    1. modprobe ngene one_adapter=0 adapter_nr=0,1,2,3


    und für alle anderen dvb-treiber die nachfolgenden Adapternummern manuell angeben:

    Code
    1. modprobe xxx adapter_nr=4
    2. modprobe yyy adapter_nr=5 ...


    Dies sollte meiner Meinung nach sicherstellen, dass die Karten immer wieder in der gleichen Reihenfolge angelegt werden.


    Gruß,
    Matthias

    abesse :


    Du hast Recht, Modul Parameter kann man offensichtlich über udev nicht mitgeben. Namen anscheinend jedoch schon (http://www.reactivated.net/writing_udev_rules.html). Leider ist mir bei meinen Versuchen mit zwei Karten und dem Vergleichen der Rückgabe aller "udevadm info -a --name /dev/dvb/adapterX/frontend0", "... /dev/dvb/adapterX/dvr0" und "... /dev/dvb/adapterX/demux0" (X=0...3) auch keine Lösung eingefallen.
    Bei dem beschriebenen Vorgehen über die "adapter_nr module option" unter http://www.mythtv.org/wiki/Device_Filenames_and_udev geht man auch davon aus, dass verschiedene Karten mit verschiedenen Modulen geladen werden.
    Generell wirst du meiner Meinung nach dieses Problem aktuell jedoch mit jeder zweifachen Dual-Tuner-Konstelation haben. Aber irgendwie kann ich mir auch nicht vorstellen, dass der Kernel die Reihenfolge der Karten beim Abarbeiten der Initialisierung wild auslost, da bei mir immer schön:


    erst Karte 1:
    looking at device '/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/dvb/dvb0.frontend0':
    looking at device '/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/dvb/dvb1.frontend0':


    und dann Karte 2:
    looking at device '/devices/pci0000:00/0000:00:1c.3/0000:03:00.0/dvb/dvb2.frontend0':
    looking at device '/devices/pci0000:00/0000:00:1c.3/0000:03:00.0/dvb/dvb3.frontend0':


    geladen wurde.


    Ist dies denn bei dir anders?


    Gruß,
    Matthias

    abesse :


    Quote

    Es scheint nicht möglich zu sein eine udev-Regel für diese Karte zu schreiben, da man nicht zwischen Tuner 0 und Tuner 1 unterscheiden kann.


    Die Vergabe der Tuner pro Karte erfolgt statisch und ist durch die I2C-Adressierung im nGene-Treiber festgelegt. "Tuner 0" entspricht dabei dem "unteren" Anschluss beschriftet mit "Tuner 1" und "Tuner 1" entspricht dabei dem "unteren" Anschluss beschriftet mit "Tuner 2".


    Quote

    Wenn man den Treiber ngene ohne Parameter lädt, kann man dann sicher sein, dass adapter0 immer dem mit "Tuner 1" auf dem Slotblech gekennzeichneten Tuner entspricht?


    Ja, dies ist auch durch die statische I2C-Adressierung der Tuner im Treiber festgelegt. Deswegen macht es auch IMHO keinen Sinn udev-Regel in Abhängigkeit der einzelnen Tuner zu definieren.


    Quote

    in den Ausgaben erscheint die Ausgabe "LNBx2x attached on addr=b" immer vor "LNBx2x attached on addr=8". Was bedeutet diese Ausgabe? Entspricht addr=b immer dem Tuner der auf dem Slotblech mit "Tuner 1" gekennzeichnet ist?


    Diese Ausgabe erfolgt durch das Modul lnbh24. Die angeführte Adresse bezieht sich auf die I2C Adresse, unter der LNBH24 für den spezifischen Ausgang (insgesamt 2x vorhanden) angesprochen wird.


    Gruß,
    Matthias

    @ UFO:

    Quote

    Steht ja im Log, daß er diese Karte hat. Wird also erkannt.


    Deswegen hatte ich doch gefragt. Wollte nur sicher gehen, dass randy auf jeden Fall auch eine im System hat. Zudem hab ich die "lspci -vvvnn" Ausgabe der "Mystique SaTiX-S2 Dual" noch nie gesehen und bräuchte diese, um einen Eintrag im LinuxTV Wiki zu erstellen und den im VDR Wiki (http://www.vdr-wiki.de/wiki/in…/DVB-S2_Budget-PCI-Karten) anzupassen. Denn irgend jemand hat, die IMHO falsche SubsystemID ("18c3:abc3, 18c3:abc4" anstatt "18c3:db01"), im VDR Wiki eingetragen.


    @ randy: Kannst du mir bitte die Ausgabe von "lspci -vvvnn" aus den oben genannten Gründen zukommen lassen?


    Gruß,
    Matthias

    Hallo randy,



    Kann es sein, dass du eine "Mystique SaTiX-S2 Dual" hast? Könntest du die Ausgabe von "lspci -vvvnn" posten, um dies zu verifizieren?


    Ist es dir möglich die Karte unter Windows zu testen, um einen Hardwaredefekt auschließen zu können?


    Gruß,
    Matthias

    Code
    1. $ lspci -vvvnn
    2. 02:00.0 Multimedia video controller [0400]: Micronas Semiconductor Holding AG Device [18c3:0720]
    3. Subsystem: Micronas Semiconductor Holding AG Device [18c3:abc3]
    4. Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    5. Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
    6. Latency: 0, Cache Line Size: 32 bytes
    7. Interrupt: pin A routed to IRQ 16
    8. Region 0: Memory at fe8f0000 (32-bit, non-prefetchable) [size=64K]
    9. Region 1: Memory at fe8e0000 (64-bit, non-prefetchable) [size=64K]
    10. Capabilities: <access denied>

    Gibt alle Informationen aus. Statt abc3 in [18c3:abc3] sollte halt db01 stehen.

    Laut Media-Pointer besitzt die Mystique SaTiX-S2 Dual die Subsystem ID 0xdb01, welche ich bereits im Treiber aufgenommen habe. Da mir jedoch der Name der Karte noch nicht bekannt war, wird die Karte aktuell als MP-S2 erkannt.
    Leider konnte ich dies noch nicht testen. Falls also jemand die Karte besitzen sollte, waere es nicht schlecht den Treiber mal auszuprobieren und entsprechend zurueckzumelden.


    Gruß,
    Matthias