Posts by hego

    Hi Greeven,


    konkrete Lösung für dein Problem


    1. Verzeichnis /Medium am besten dem User ftp und der Gruppe "ftp" zuordnen

    Code
    1. chmod ftp:ftp /Medium


    2. Zugriffsrechte setzen


    Code
    1. chmod ugo-rwx /Medium ( erst mal allen alle Rechte entziehen)
    2. chmod ug+rwx /Medium ( Rechte für Eignetümer un Gruppe setzten)
    3. chmod o+r /Medium ( jetzt für "others" eingeschränkte Rechte setzten.)


    Damit sollte der User "ftp" und alle die zur Gruppe "ftp" gehören vollen Zugriff haben, alle anderen, auch der "Gast" dürfen nur lesen (Der Gast darf natürlich nicht der Gruppe ftp angehören ;).
    Beachten: Executerechte nur für Verzeichnisse setzten, nicht für Dateien!!!


    3 Link vom Homeverzeichnis /home/gast des Gast setzten auf /Medium


    Code
    1. ln -s /Medium /home/gast/daten


    Jetzt sollte der User "Gast" über das "Verzeichnis" daten in das Verzeichnis /Medum gelangen und nur lesen dürfen ;)


    Gruß,
    Hego

    Handelt es sich bei "/media/ um einen Mountpoint oder nur um einen ordinären Ordner?
    Aus deiner Frage entnehme ich, dass es sich bei "/media/" um ein einfach es Verzeichnis handelt.
    Wenns nur ein Verzeichnis ist, dann geht da nix über die fstab, die ist für das Filesystem zuständig nicht für simple Verzeichnisse (lass mich aber auch gerne belehren).
    Als doch zum Link greifen.


    Ich kenn das ProFTPD nicht, aber wenn du die Zugriffsrechte richtig einstellst, dann ists völlig egal, obs ein Verzichnis, oder ein Link zu einem Verzeichnis ist.


    Ich denke da musst du noch an den Zugriffsrechten arbeiten.


    Verzeichnise /home/ftp/ und /media müssen execute und Leserechte für deinen FTP-Server besitzen.
    Dann den Link anlegen "ln -s /media /home/ftp/daten" und das sollte es gewesen sein.
    Jeder Zugriff auf /home/ftp/daten ist dann ein Zugriff auf /media.
    Sollten wir aber in deinem Thread "Zugriffsrechte" klären :)


    Gruß
    Hego.

    Quote

    oder das geht auch nicht


    Inhalt der fstap


    Code
    1. :
    2. /media /home/ftp/daten none bind 0 0


    so geht das irgendwie nicht


    Sieht doch gut aus :)


    Aber das ist ja auch nur die halbe Wahrheit ;o) Wie sieht den der Inhalt der fstab bzg. /media aus?


    Aber eigentlich kann ich mich nur C-3PO anschließen

    Quote

    Warum fstab????


    Weshalb legst Du nicht einfach, so wie ich oben beschrieben habe, einen Symlink an???

    Quote


    Mal die Zahlen von chmod einfach erklärt:


    Die erste Zahl steht für die Rechte des Users, dem die Datei gehört, die zweite für die Rechte der Gruppe. Beides Änderbar über

    Code
    1. chown $user:$gruppe $datei


    Ich möchte doch noch ein paar Details ergänzen, zumal hier die Rechte für "$other" nicht erwähnt wurden


    Unter Linux setzten sich die Zugriffsrechte imme aus den Rechten für den
    Eigentümer (user, u ), Gruppe ( group, g ), Anderen ( others, o ) zusammen


    Dabei wiederum gibt es für alle 3 u/g/o wiederum 3 verschiedene Attribute Lesen (read, r ), Schreiben (write, w) und Ausführen (execute, x)

    Wenn du ein "ls -al" in einem Verzeichnis ausführtst, werden dir diese Attributte für Dateien und Verzeichnisse mit angezeigt
    z.b.:
    -rwxr-xr-- 1 ftp ftp 412 2006-12-15 23:53 dummy.txt


    Entscheident sind die ersten 10 Zeichen, bzw. die Zeichen 2 bis 9:
    (1.Zeichen gibt an um Welche Art von Device es sich handelt: Ordner, Datei, Link, Gerätedatei ...)
    Zeichen 2-10 zeigen die aktuell gesetzten Zugriffrechte an. Davon stehen die ersten 3 drei Buchstaben für die Rechte des Users, die 2ten drei für die Rechte der Gruppe und die letzten drei für die Rechte aller Anderen.


    Also am Beilspiel "rwxr-xr--" heisst das:
    1. Der User hat "rwx" read(r),write(w), execute (x) Rechte
    2. Gruppe hat nur noch "r-x" read, execute, aber KEINE Schreibrechte
    3. Andere dürfen nur noch lesen "r--"


    Nun zur eingentlichen Frage:

    Quote

    Wie kann ich den für verschidene gruppen verschidene rechte verteieln????


    Vielleicht habe ich deine Frage missverstanden, aber es ist nicht möglich, z.B. für 4 verschiedene Gruppen jeweils unterschiedliche Rechte auf eine Datei/Verzeichnis zu Vergeben!!!
    Bei der Datei wird nur zwischen der Gruppe, der die Datei "angehört", und allen anderen Gruppen unterschieden.
    Es geht NICHT, 12 verschiedene Gruppen z.B. user1 user2 ... user12 anzulegen, um diesen dann für eine Datei aus der Gruppe "user2" jeweils andere Rechte zu vergeben;o)


    Das Ändern der Rechte für eine Datei geht recht simpel:
    Da kannst du das Zahlengedöns "777" "744" .... getrost vergessen ;o)
    Geht mit dem Befehl "chmod" einfach über die Abkürzungen "u/g/o" und "r/w/x" und den Parameter "+" hinzufügen oder "-" entziehen


    Beispiel du willst dem User und der Gruppe einer Datei Lese- und Schreibrechte einräumen, allen anderen nix.


    1. chmod ug+rw DATEI für user "u" und Gruppe "g" werden Lese "r" und Schreibrechte "w" hinzugefügt "+"
    2. chmod o-rwx DATEI für ALLE ANDEREN "o" werden "rwx" entzogen "-"



    Und bevor du deinen FTP-Server aus dem Internet zugänglich machst überlegt dir ganz genau was du tust und ließ vielleicht noch das ein oder andere Fachbuch dazu !!!


    Gruß
    Hego

    Schreibrechte sollte doch sinnvoller Weise nur der Eigentümer haben.
    Gruppe und andere User nur Leserechte: also die Rechte für das Verzeichnis auf 755 (Executerechte müssen für alle gesetzt sein, da sonst der Gast nicht reinkommt ins Verzeichnis) und für die Dateien darin auf 744 (nur lesen) setzten.


    Gruß
    Hego

    Quote

    geht das auch wenns eine festplatte ist die mit FAT32 / NTFS formatiert ist ? als windos format ?


    Dem VDR ist das Format des Filesystems egal, das organisiert das Betriebssystem.
    Also wenn du die Festplatte mounten kannst und lesen kannst , kann der VDR das auch, wenn der VDR lese/schreibrechte dafür besitzt.

    Quote

    bei mir zeigt er leider nix an


    1. Lese/schreibrechte prüfen
    2. Der VDR zeigt nichts an, wenn die Aufnahmen nicht richtig abgelegt/verlinkt sind.

    Quote

    ich würde das mounten nicht unbedingt mit der fstab machen, sondern evtl. mit der runvdr.


    Verändert nicht zuviel an den vdr-scripten, beim nächsten Update kuckt ihr sonst in die Röhre, und fangt von vorne an.


    Für solche speziellen Zwecke habe ich ein eigenes Skript, das ich bei mir über einen Link aus dem entsprechenden Runlevel aus aufrufe: z.B. bei mir
    /etc/rc2/S99boot.user.local -> /local/bin/boot.usr.local
    Aus dieser Datei "/local/bin/boot.usr.local" rufe ich alle mögliche eigene Scripte, Deamons oder Befehle auf, die ich nach Abschluss des Bootvorgangs brauche.
    Über die Nr. "S99" ist sichergestellt, dass dieses skript erst nach allen anderen Initskripten
    ausgeführt wird, also nach VDR und portmapper start ...


    Quote

    Im Endeffekt ist es voellig egal, WIE man es macht, solange man versteht, WAS man macht...nur fuer eine spaetere Fehlersuche ist es halt sinnvoll, sich vorher auf eingefahrenen Wegen bewegt zu haben. Oder wisst Ihr nach 3-6 Monaten noch genau, was Ihr geaendert habt?


    ... und deshalb möglichst alle Veränderungen und eingene Skripte in ein eigenes Verzeichnis. Bei mir ist das "/local/bin" und die "/local/ ist eine eigneständige Partition, auf der alle meine eigenen oder modifizierten Skripte landen, damit sie bei einem VDR update nicht überschrieben werden.

    Quote

    1. Im VDRAdmin wird mir unter "Was läuft zurzeit" o.ä. immer nur ein par wenige Sender gezeigt, ich kann nicht mehr auswählen. Sind dann Sender wie RTLSHop, Sat 1 usw... Kann man das ändern?


    Dies kannst du im VDRadmin unter dem Punkt Konfiguration einstellen, welche Sender dir da Angeboten werden sollen.


    Quote

    Ich vermute, es liegt daran, dass der Sender nicht auf dem selben Transponder liegt, wie der, der grade auf dem VDR an sich läuft. Wie kann ich das umgehen?


    Beim Streamen bin ich nicht fit, aber dieses Problem dürfte nur dann auftreten, wenn du nur eine DVB-Karte im Einsatz hast. Dann hilft nur ein Programmwechsel, oder besser eine 2te Karte.

    Quote

    2. Ich habe den VDRServer (streamdev) installiert. Wie kann ich bspw. jetzt mit VLC den angebotenen Stream öffnen? Die Suche hat mir nicht wirklich viel gebracht. Nur Lösungen für Mplayer o.ä.


    Ich würde erwarten, das die Lösungen für den Mplayer dir auch helfen, da dies die "Client-Seite" betrifft, und da sollte der gewählte Player keine große Rolle spielen.

    Quote

    PS: Oder sollte ich lieber noch einen neuen Thread dazu aufmachen?


    Ja, dann kucken auch die Leute rein, die mehr Ahnung davon haben ;o)
    Gruß,
    Hego

    Habe grad noch ein bisserl gegoogled:
    Falls es unter /sbin/ nur "start-stop-deamon.REAL" gibt, dann benenne das mal in "start-stop-deamon" um und reboote. Vielleicht hilft das dann.

    Zum manuellen starten der Deamons probier mal noch:
    start-stop-daemon --start -x /sbin/syslogd


    und


    start-stop-daemon --start -x /usr/sbin/sshd


    Dann solltest du zumindest eine Rückmeldung bekommen.
    Die Pfade zu den deamons musst du eventuell anpassen.

    Fällt mir nicht mehr viel ein.
    Wie wäre's mit der härteren Gangart:
    apt-get remove ssh
    und
    apt-get install ssh
    Dann sollte er den Deamon doch mal starten.
    Wenns klappt das gleiche dann mit dem sysklogd

    Dann probier mal erst die beiden Deamon wieder ans laufen zu bekommen:
    versuchs mal mit
    dpkg-reconfigure ssh
    für den ssh deamon
    für den syslogd bin ich mir nicht ganz sicher aber das müsste das Paket sysklogd sein:
    dpkg-reconfigure sysklogd

    Prüfe mal ob der der syslogd und der sshd laufen:


    Befehle:
    ps aux | grep sshd
    ps aux | grep syslogd


    Die Ausgabe für den syslogd sollte sowas wie:
    root 2045 0.0 0.1 1628 620 ? Ss 20:49 0:00 /sbin/syslogd
    root 2610 0.0 0.1 3484 624 pts/0 R+ 21:01 0:00 grep syslogd
    sein. Analog für den sshd.
    Welches System verwedest du?

    wie lautet den die Fehlermeldung beim Verbindungsversuch via ssh?
    syslog muss nicht gelöscht werden, die wird im Regelfall vom syslog Deamon selbstständig gzippt gespeichert und eine neue angelegt. Ich vermute mal du hast sie als "root" gelöscht, und als "root" wieder eine neue angelegt. Jetzt hat der Syslog-Deamon keine schreibrechte auf diese Datei. Lösch sie einfach nochmal und leg keine neue an. Das macht der Deamon von sich aus.

    Bin mir nicht sicher, und habe auch keinen Zugriff auf meinen VDR im Augenblick,aber gibts da nicht unter den Einstellungen->Plugins beim DVD-Plugin eine Einstellung Menueintrag ein/aus ???

    Hi Harry,


    wenn der Fehler für die remote.conf jetzt nicht mehr auftaucht, brauchen wir aber wieder die Ausgabe in der "syslog" Datei, da der VDR jetzt wohl an einer anderen Stelle aussteigt.
    Poste jetzt noch mal die aktuelle syslog. Oder such nach der ersten Zeile in der sowas wie "deleting plugin ..." drin steht, und schau dir Zeilen darüber näher an. Da findet man in der Regel den Hinweis was schief läuft.


    Gruß
    Hego

    Hi Harry,


    du hast ein Problem mit deiner /var/lib/vdr/remote.conf Datei.
    Aus dem Syslog zu ersehen:
    "ERROR: error in /var/lib/vdr/remote.conf, line 25"
    Schau dir mal die Datei und Zeile 25 näher an, oder poste den Ausschnitt.


    Vielleicht weißt du auch, ob du was dran verändert hast
    Aber ne Neuinstallation wirst du wohl nicht brauchen ;o)


    Gruß,
    Hego