Posts by hego

    Ich habe zwar keine Ubuntu aber ich glaube auch da kannst du mit dem script
    "/usr/share/vdr/shutdown-hooks/S90.custom den shutdown" beeinflussen. Und somit dort
    den shutdown z.B. zwischen Uhrzeit X und Uhrzeit Y verhindern oder erlauben.
    Entscheidend ist der Rückgabewert des Skripts. Ich glaube Rückgabewert 0 ist Shutdown erlaubt, und ungleich 0 ist shutdown nicht erlaubt.


    Gruß
    Hego

    Du musst erst mal prüfen, ob das Skript ausgeführt wird, normalerweise müssen die Skripte selbst nicht editiert werden!


    Such mal im Logfile /var/log/syslog nach der Shutdownsequenz und prüfe ob die Skripte auch wirklich ausgeführt werden.
    Da sollte sowas wie

    Code
    1. executing /usr/share/vdr/shutdown-hooks/S90.acpiwakeup as shell script


    eingetragen sein.
    Ist das nicht der Fall dann musst du den Fehler finden, warum das Skript nicht ausgeführt wird.

    Quote

    WCLOCK update beim Herunterfahren ist abgeschaltet. Ist das normal?


    ja, das ist gut so, da bei manchen Biose durch das updaten der HWCLOCK beim shutdown die wake-up Zeit wieder gelöscht oder deaktiviert wird.


    Welchen Befehl hast du zum setzten der Wakeup Zeit verwendet?
    Probiers mal mit

    Code
    1. echo `date '+%F %T' '-d + 5 minutes'` > /proc/acpi/alarm


    Damit setzt er bei mir sauber die aufwachzeit auf "jetzt" + 5 Minuten inclusive Datum

    Hallo Robert,


    erst mal :welcome im Forum und beim VDR :)


    Die Dateien für den Shutdown sind schon am richtigen Platz, da musst du nichts verschieben/kopieren
    Pfad: /usr/share//vdr/shutdown-hooks/


    Für das Aufwachen, musst du entweder das "ACPI" addon oder "NVRAM-Wakeup" installieren.
    Damit wird dann auch jeweils ein shutdownskript unter "shutdown-hooks" angelegt. Da muss im Regelfall nichts verändert werden.
    Nur für deine Eigenen individuellen Wünsche ist die Datei "S90.costum" gedacht. Da kannst du für deine eigenen Wünsche noch befehle/skripte ausführen beim Shutdown, oder auch den Shutdown abbrechen lassen, wenn z.B. noch ein User am System angemeldet ist.


    Nun zu deinem konkretem Problem:
    Bin mir nicht sicher ob ich da die Lösung habe, aber versuchs mal damit:
    Such mal in der Datei /et/defaults/vdr eine Variable "ENABLE_SHUTDOWN" und setzt die auf eins

    Code
    1. ENABLE_SHUTDOWN=1


    Zum beobachten was während des Shutdowns passiert gibts mehrere Möglichkeiten.
    1.) Nach erneutem Booten das Logfile durchsuchen "/var/log/syslog"
    2.) Gleich beim shutdown die Logdatei mit beobachten mit dem Befehl

    Code
    1. tail -f /var/log/syslog


    Gruß,
    Hego

    Die "/usr/vdr/shutdown-hooks/S90.custom" sollte aber die richtige Datei für dich sein.


    Bin mir nicht ganz sicher obs so funktioniert, aber ich würde folgendes versuchen:
    Wenn du grundsätzlich via S90.custom den ersten Shutdown-Versuch des VDRs unterbindest (exitcode des Scripts > 1) dann hast du standartmäßig 5min Zeit bis der VDR den nächsten Versuch unternimmt. In dieser Zeit sollte dein TV laufen und du solltest wieder die Change vom VDR bekommen, via Fernbedienung durch einen X-beliebigen Tastendruck den Shutdown abzubrechen.


    Gruß
    Hego

    Quote

    Ab nicht desto trotz werde ich wohl mal alle unnötigen PlugIns deinstallieren und dann mal gucken was passiert.


    du musst die Plugins nicht deinstallieren.
    In der Datei "/etc/vdr/plugins/order.conf" kannst du die Plugins deaktivieren indem du die Plugins einträgst, und ein "-" davor setzt. Dann werden sie beim VDR start nicht geladen.


    Gruß,
    Hego

    Hallo Wacholder,


    erst mal Herzlich Willkommen!


    Zu deinem Problem:
    Bin mir nicht ganz sicher, aber ich denke du musst nur im Vdr-Menü die Zeit für "VDR ausscahlten bei Inaktivität" runter setzten.
    Zu finden im Hauptmenü unter "System/Einstellungen/8.Sonstiges"


    Gurß
    hego

    Quote

    Gib jemand Hungernden etwas zu essen und du hilfst ihm einen Tag - zeige ihm zu jagen und du hilfst fürs Leben.


    Dann versuch ich mal für's leben zu helfen. ;)


    Quote

    Ich unmounte eine Partition. umount vermeldet: "Device or Resource is busy"
    Wie bekomme ich raus, wer dafür verantwortlich ist ?


    fuser -uvm "mount-point"


    zum Beenden (killen) der Prozesse, die das Filesystem "blockieren"


    fuser -km "mount-point"


    Gruß
    Hego

    Oh, wenn ich's richtig gesehen habe hast du gen2vdr.
    Da muss ich jetzt leider passen ich habe c't vdr der auf Debian basiert da ists die Datei /etc/default/vdr. Im Gen2Vdr ???


    Aber die Suche ist unser Freund probiers mal mit der Datei:


    Code
    1. /etc/vdr.d/conf/gen2vdr.cfg


    Aber vorsicht da muss es wohl

    Code
    1. VIDEO="/mnt/video"


    heißen



    Gruß
    Hego

    0.) VDR stoppen

    Code
    1. /etc/init.d/vdr stop


    1.) mit fdisk Partitionen auf der Festplatte anlegen. Wenn du die HD nur für die Videos nutzen willst reicht es wenn du nur eine Partition anlegst


    Code
    1. fdisk /dev/hdc

    (fdisk wie unter windows nutzen.)


    Wenn du eine Partition angelegt hast sollte jetzt ein Device /dev/hdc1 existiert


    2.) Filesystem erzeugen "ext3"
    Vorsicht: Wenn du hier das falsche Device angibst gibts Datenverlust. (Auf deinem System sollte aber noch nicht viel sein ;)

    Code
    1. mkfs.ext3 /dev/hdc1


    3.) Mountpoint für die Festplatte anlegen


    Code
    1. mkdir /mnt/video


    4.) Festplatte mounten

    Code
    1. mount /dev/hdc1 /mnt/video


    5.) Zugriffsrechte setzten, damit der VDR in das Verzeichnis schreiben darf

    Code
    1. chmod ugo+rxw /mnt/video


    damit darf jeder auf dieses Verzeichnis zugreifen.


    6.) Diese Festplatte festlegen als Videodirectory für den VDR
    In der Datei /etc/defaults/vdr den Eintrag "VIDEO_DIR=???" anpassen


    Code
    1. VIDEO_DIR="/mnt/video"


    7.) VDR neu starten

    Code
    1. /etc/init.d/vdr restart


    8.)Videoverzeichnis in /etc/fstab mit eintragen damit es automatisch gemountet wird beim Rechnerstart.


    Code
    1. /dev/hdc1 /mnt/video auto noatime 1 2


    9.) Testen ob das Mounten über die Datei "fstab" funktioniert
    Erst den VDR stoppen


    Code
    1. /etc/init.d/vdr stop


    dann das Verzeichnis umounten und nochmal neu mounten diesmal nicht wie weiter oben mit der Deviceangaben, sonder ohne Device, dass Device holt sich der Rechner nun ja aus der fstab.

    Code
    1. umount /mnt/video
    2. mount /mnt/video


    es darf keine Fehlermeldung erscheinen.


    10.)VDR starten

    Code
    1. /etc/init.d/vdr start


    und glücklich sein, die nächsten 6 Monate, dann ist die Platte voll ;)



    Gruß
    Hego

    Quote

    ist da die zweite platte schon aufgeführt. sodass ich nur noch was ändern muss oder muss die zeile von dir nur dazu geschrieben werden ?


    Klares nein! Es ist nur eine Festplatte "hda" eingebunden.


    Um festzustellen welche Festplatten, usb-Sticks oder ander Speichermedien an deinem Rechner angeschlossen sind den folgenden Befehl verwenden:

    Code
    1. cat /proc/partitions


    Dieser Befehl gibt alle Speichermedien aus, die der Kernel aktuell verwaltet, inclusive der Partitionen und deren Größe.


    Bei dir sollte also deine erste Festplatte in folgender form
    /dev/hda
    /dev/hda1
    /dev/hda2
    /dev/hda3
    /dev/hda5


    angezeigt werden + Infos über Größe.
    Zusätzlich sollte deine 2te HD in ähnlicherform mit ausgegeben werden


    wenn es eine IDE HD ist als:
    /dev/hdb
    /dev/hdb1
    /dev/hdb2
    .....


    oder wenn es eine SCSI o. SATA HD ist als
    /dev/sda
    /dev/sda1
    /dev/sda2


    Danach Mountverzeichnis anlegen und verlinken wie von Albi76 beschrieben. Aber vorsicht, das Verzeichnis an welches die Festplatte gemountet wird muss Schreibrechte für den VDR bekommen, sonst wirst du sie im VDR auch nicht sehen.
    - Verzeichnis in die Datei /etc/fstab eintragen wie bereits beschrieben.
    - Am Ende den VDR neu starten mit dem Befehl: "/etc/init.d/vdr restart"



    Tipp: Wenn du das Mount-Verzeichnis anlegst, dann nenne es nicht "hdb5" oder so, sondern vergibt einen aussagekräftigen Namen damit du in 4 Monaten noch weißt zu welcher HD dieses Verzeichnis "gehört", zumal sich die Devicezordnung "hda, hdb, ..." verändern kann, wenn du HD's ein und ausbaust. Als Linux Einsteiger würde ich sie mindestens ein "160GB" in den Namen mit einfügen, dann weißt du immer, dass das deine "große" HD ist.



    Hego

    Hallo zusammen,


    anbei für alle die das gleiche Board haben die nvram-wakeup.conf die bei mir funktioniert.
    guess-helper hatte ursprünglich noch einen falschen Wert "addr_stat=0xB2" ausgegeben, aber mit den Werten unten tut's wunderbar. :)


    • Parameter "--directisa" notwendig
    • kein reboot notwendig




    (ACPI habe ich lange und vergeblich probiert mit c't VDR: 1.6.0-8ctvdr1 und Kernel : 2.6.18 )


    Gruß
    Hego

    Hi HTPC-Schrauber,


    völlig egal ob ACPI oder NVRAM, ich brauch ne Lösung die mit dem HP-Compaq funktioniert!
    Wie es grundsätzlich geht, weiß ich, hab's oft genug mit anderen Rechnern gemacht :)
    Nur mit diesem Compaq tut's eben nicht.
    Bisher habe ich's nur mit Kernel 2.6.18 getestet.
    Wenn du aber sagst mit nem neueren Kernel tuts, dann werd ich mir doch noch einen selber backen.
    Wenn's dann tut werd ichs hier posten.


    Gruß
    Hego

    Quote

    2 Variablen: x^2 + y^2 = 2009 Dieses beschreibt einen Kreis in der Ebene.....
    Wenn man den Lösungsraum als ganze Zahlen beschränkt würde man da weiter kommen...
    3 Variablen: x^2 + y^2 + z^2 = 2009 Diese Gleichung beschreibt eine Kugel im Raum..... Auch hier wäre der Lösungsraum auf ganze Zahlen zu beschränken.....


    Eine Gleichung und 2 Variablen, bzw. gar eine Gleichung 3 Variablen.
    Da die Einschränkung auf die ganzen Zahlen nur bedingt hilft, gibts da keine eindeutige Lösung, was man ja an der Vielzahl von Lösungen sieht.
    Man muss also doch noch etwas "probieren"


    Gruß
    Hego.