Posts by goldbär

    Code
    1. $ apt-cache policy binutils
    2. binutils:
    3. Installiert: 2.23.52.20130612-1ubuntu1~r~gd
    4. Installationskandidat: 2.23.52.20130612-1ubuntu1~r~gd
    5. Versionstabelle:
    6. *** 2.23.52.20130612-1ubuntu1~r~gd 0
    7. 100 /var/lib/dpkg/status
    8. 2.23.2-2ubuntu1 0
    9. 500 http://de.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

    Hallo Lars,


    meine Launchpad Pakete habe ich deaktiviert. Sonst sollte da eigentlich nichts anderes sein.


    Hallo,


    ich versuche mein Xubuntu 13.04 auf 13.10 zu updaten. Leider gelingt das nicht.


    Code
    1. $ cat /etc/lsb-release
    2. DISTRIB_ID=Ubuntu
    3. DISTRIB_RELEASE=13.04
    4. DISTRIB_CODENAME=raring
    5. DISTRIB_DESCRIPTION="Ubuntu 13.04"




    24 Pakete scheinen wohl schon auf Stand 13.10 zu sein.


    Offenbar ist auch schon der Kernel 3.11 installiert. Den gibt es doch bei Ubuntu 13.04 nicht oder?

    Code
    1. $ uname -a
    2. Linux verleihnix 3.11.3 #1 SMP Wed Oct 2 22:19:32 CEST 2013 x86_64 x86_64 x86_64 GNU/Linux


    Wie komme ich ohne Neuinstallation sauber auf die 13.10?


    Gruß
    Guido

    Hallo,


    ich habe mir epgd und epg2vdr aus dem git installiert.
    Die Daten hole ich von tvm.


    In einem Screenshot habe ich gesehen, dass ein EPG-Bild oben rechts angezeigt wird.
    Bei mir werden die Bilder immer ganz am Ende der EPG-Daten angezeigt.
    Wie bekomme ich das Bild nach oben?


    Gruß
    Guido

    Hallo,


    ich wollte mal das Modul dbus2vdr.py ausprobieren.
    Leider bekomme ich einen Fehler beim Erzeugen der Instanz


    In meinem Programm erzeuge ich eine Instanz von DBus2VDR

    Code
    1. self.dbus2vdr = DBus2VDR(dbus.SystemBus(), instance=0, watchdog=True)


    Im Debugger sieht das so aus


    Beim super-Aufruf werden doch drei Argumente übergeben. Ich stehe etwas auf dem Schlauch


    Edit: Natürlich wurden an super() keine Argumente übergeben sondern an __init__

    Hallo,


    habe folgendes Problem:

    Code
    1. Nov 1 17:32:11 miraculix vdr: [2646] no DVB device found


    ich gebe zu, dass ich nicht den gesamten Thread gelesen habe. Nur die letzten Seiten.


    Muss ich für raring den Treiber wie im ersten Post selbst kompilieren oder gibt es ein fertiges Paket?


    Hier noch Infos zum System:


    Code
    1. uname -a
    2. Linux miraculix 3.8.0-32-generic #47-Ubuntu SMP Tue Oct 1 22:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


    Code
    1. dmesg | grep "Digital Devices"
    2. [ 2.903367] Digital Devices PCIE bridge driver, Copyright (C) 2010-11 Digital Devices GmbH
    3. [ 2.904082] DDBridge driver detected: Digital Devices PCIe bridge


    Code
    1. [lspci -vvvnn | grep -i dvb
    2. 03:00.0 Multimedia controller [0480]: Digital Devices GmbH Octopus LE DVB adapter [dd01:0003]


    Vielleicht sollte ich noch erwähnen, das die Karte per Unicable LNB angeschlossen ist.


    /var/lib/vdr/scr.conf

    Code
    1. # Inverto Unicable Quad LNB IDLB-QUDL42-UNI2L-1PP
    2. 0 1210
    3. 1 1420
    4. 2 1680
    5. 3 2040


    /var/lib/vdr/diseqc.conf

    Code
    1. # SCR (Satellite Channel Routing):
    2. #
    3. S19.2E 11700 V 9750 t v W10 S0 [E0 10 5A 00 00] W10 v
    4. S19.2E 99999 V 10600 t v W10 S1 [E0 10 5A 00 00] W10 v
    5. S19.2E 11700 H 9750 t v W10 S2 [E0 10 5A 00 00] W10 v
    6. S19.2E 99999 H 10600 t v W10 S3 [E0 10 5A 00 00] W10 v


    Vielen Dank

    Hallo Lars,


    bin doch schon zum Testen gekommen. Habe ein neues Paket mit deinem Patch gebaut.
    Sieht gut aus.


    Habe erst den VDR gestartet, etwas gewartet, dann inputlirc
    Nach dem Start von inputlirc verbindet sich der VDR direkt mit dem Socket


    Gruß
    Guido

    Wie löse ich jetzt mein Problem?


    1. Lösungsvorschlag von Lars:

    Moin!
    Also bei inputlirc bei "start on" noch zusätzlich "and starting vdr". inputlirc wird also nur dann gestartet, wenn der vdr gestartet werden soll, aber auf alle Fälle vor dem vdr.


    Damit wird inputlircd zwar vor dem VDR gestartet.
    Wenn dann das Device aber noch nicht da ist, wird auch der Socket nicht angelegt und der VDR kann sich nicht verbinden.
    Da das beim Start des VDR passiert, wird auch kein erneuter Verbindungsversuch unternommen.
    Kann so mMn nicht funktionieren. Oder habe ich das falsch verstanden?


    2. Lösungsvorschlag von Lars bzw. Seahawk:

    Code
    1. start on input-device-changed DEVPATH=/dev/input/by-id/usb-15c2_ffdc-event-if00


    Hier sehe ich das gleiche Problem wie beim 1. Lösungsvorschlag


    3. Lösungsmöglichkeit
    Im Upstart-Script des VDR warten bis der Socket /var/run/lirc/lircd bereit ist.
    z.B.

    Code
    1. sudo netstat --listening --unix | grep lircd
    2. unix 2 [ ACC ] STREAM HÖRT 24355 /var/run/lirc/lircd


    4. Lösungsmöglichkeit
    Umstellung auf eventlircd + Lösungsvorschlag 1
    Da der Socket beim Start von eventlircd direkt angelegt wird (auch wenn noch kein Device vorhanden ist), kann der VDR direkt darauf zugreifen.
    Das Device wird dann eingebunden, wenn es verfügbar ist



    Passt das soweit?

    Habe jetzt nochmal getestet


    Bei laufendem inputlirc den VDR gestartet ==> Verbindung zum Socket ist erfolgreich
    Inputlirc gestopped ==> Verbindung zum Socket geht verloren
    Inputlirc wieder gestartet ==> Verbindung zum Socket wird erneut hergestellt



    Bei gestopptem inputlirc den VDR gestartet ==> keine Verbindung zum Socket
    Inputlirc gestartet ==> kein erneuter Verbindungsversuch

    Code
    1. Oct 14 13:16:35 miraculix vdr: [3940] ERROR (lirc.c,45): /var/run/lirc/lircd: Verbindungsaufbau abgelehnt
    2. Oct 14 13:16:35 miraculix vdr: [3940] ERROR: remote control LIRC not ready!
    3. ...
    4. Oct 14 13:18:18 miraculix inputlirc.conf: Starting inputlirc mit -g -m 0 /dev/input/by-id/usb-15c2_ffdc-event-if00...
    5. Oct 14 13:18:18 miraculix inputlircd: Started
    6. ...



    D.h. der VDR versucht sich nur dann erneut mit dem Socket zu verbinden, wenn er beim Start eine Verbindung bekommen hat. So wie Lars es geschrieben hat.