Posts by goldbär

    Hallo,


    wenn ich den VDR mit scraper2vdr und epg2vdr starte, ruckelt das Bild häufig sehr stark.


    Code
    1. ps axu | grep scrap
    2. vdr 2645 14.2 17.2 1898512 353260 ? S<sl 19:18 0:50 /usr/bin/vdr --lirc=/var/run/lirc/lircd -v /srv/vdr/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown.wrapper -E /var/cache/vdr/epg.data -u vdr -g /tmp --port=6419 -Psofthddevice -f -D -d :1 -a hw:1,3 -Pdbus2vdr -Pmenuorg -Pepg2vdr -Ptvguide -l /usr/share/vdr/channel-logos/ -e /var/cache/vdr/epgimages -Pepgsearch -Plcdproc -Plive --port=8008 --ip=0.0.0.0 --log=INFO --epgimages=/var/cache/vdr/epgimages -Pskinnopacity -l /usr/share/vdr/channel-logos/ -e /var/cache/vdr/epgimages -Pmarkad -b /usr/bin/ -l /usr/share/vdr/markad/logos/ -Pstreamdev-server -scraper2vdr -i /var/cache/vdr/epgimages/ -m client -v /srv/vdr/video -w 60


    Und das Log dazu http://paste.ubuntu.com/7354015/



    jetzt in /etc/vdr/plugins/order.conf das Plugin scraper2vdr und epg2vdr entfernt (-scraper2vdr -epg2vdr)



    Woran kann das liegen?

    Soll das conf.d Konzept die bisherige Vorgehensweise bestehend aus
    /etc/vdr/plugins/order.conf (Reihenfolge der Plugins)
    /etc/vdr/plugins/plugin.<name>.conf (Parameter der Plugins)
    usr/lib/vdr/plugin-loader2
    ablösen?
    Im Prinzip machen doch beide Konzepte das gleiche. Oder habe ich das falsch verstanden?


    Soll keine Kritik sein, sondern nur eine Verständnisfrage.

    Mein Problem hat sich erledigt.


    In meinem Makefile patch fehlte
    CXXTOOLVER = $(shell cxxtools-config --version | sed -e's/\.//g' | sed -e's/pre.*//g' | awk '/^..$$/ { print $$1."000"} /^...$$/ { print $$1."00"} /^....$$/ { print $$1."0" } /^.....$$/ { print $$1 }')
    und
    DEFINES += -DCXXTOOLVER=$(CXXTOOLVER)


    Vielen Dank an seahawk

    Ich habe auch ein Problem beim Bauen des live-plugin unter trusty


    Code
    1. tntconfig.cpp:11:30: fatal error: cxxtools/loginit.h: Datei oder Verzeichnis nicht gefunden
    2. #include <cxxtools/loginit.h>


    Die Header-Datei gibt es offenbar unter trusty nicht mehr

    Code
    1. dpkg -S loginit.h
    2. dpkg-query: Kein Pfad gefunden, der auf Muster *loginit.h* passt


    Es gibt nur eine log.h

    Code
    1. dpkg -S log*.h | grep cxx
    2. libcxxtools-dev: /usr/include/cxxtools/log/cxxtools.h
    3. libcxxtools-dev: /usr/include/cxxtools/log.h


    Code
    1. apt-cache policy libcxxtools9
    2. libcxxtools9:
    3. Installiert: 2.2.1-1
    4. Installationskandidat: 2.2.1-1
    5. Versionstabelle:
    6. *** 2.2.1-1 0
    7. 500 http://de.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
    8. 100 /var/lib/dpkg/status


    Gibt es hierfür bereits eine Lösung?

    Es gibt jetzt allerdings einige deprecated warnings


    Code
    1. apt-cache policy libavcodec-ffmpeg-dev
    2. libavcodec-ffmpeg-dev:
    3. Installiert: 2.2~trusty~ppa1
    4. Installationskandidat: 2.2~trusty~ppa1
    5. Versionstabelle:
    6. *** 2.2~trusty~ppa1 0
    7. 500 http://ppa.launchpad.net/samrog131/ppa/ubuntu/ trusty/main amd64 Packages
    8. 100 /var/lib/dpkg/status

    Hallo Gandalf,


    vielen Dank für die Antwort.


    Ich habe mir das jetzt nochmal genauer angesehen.


    Das ffmpeg-Paket wird wie oben schon geschrieben nach /opt/ffmpeg installiert
    Es werden aber auch Links gesetzt

    Code
    1. ll /usr/include/libav*
    2. lrwxrwxrwx 1 root root 30 Feb 27 18:49 /usr/include/libavcodec -> /opt/ffmpeg/include/libavcodec/
    3. lrwxrwxrwx 1 root root 31 Feb 27 18:49 /usr/include/libavformat -> /opt/ffmpeg/include/libavformat/
    4. lrwxrwxrwx 1 root root 29 Feb 27 18:49 /usr/include/libavutil -> /opt/ffmpeg/include/libavutil/


    Code
    1. ll /usr/lib/pkgconfig/libav*
    2. lrwxrwxrwx 1 root root 46 Mär 27 01:45 /usr/lib/pkgconfig/libavcodec.pc -> /opt/ffmpeg/lib/pkgconfig/libavcodec.ffmpeg.pc
    3. lrwxrwxrwx 1 root root 47 Mär 27 01:45 /usr/lib/pkgconfig/libavformat.pc -> /opt/ffmpeg/lib/pkgconfig/libavformat.ffmpeg.pc
    4. lrwxrwxrwx 1 root root 45 Mär 27 01:45 /usr/lib/pkgconfig/libavutil.pc -> /opt/ffmpeg/lib/pkgconfig/libavutil.ffmpeg.pc


    Beim Bauen des Pakets wird aber nach libavcodec.ffmpeg.pc gesucht, wofür kein Link angelegt wurde.


    Ich hätte gern eine Lösung, mit der das Paket auch auf Launchpad gebaut werden kann und nicht nur lokal.

    Ich habe immer noch ein kleines Problem das Paket unter trusty mit ffmpeg zu bauen.


    Was ich bisher gemacht habe:


    Die ffmpeg Pakete eingebunden

    Code
    1. sudo add-apt-repository ppa:samrog131/ppa


    Die ffmpeg Pakete installiert

    Code
    1. sudo aptitude install libavcodec-ffmpeg-dev libavformat-ffmpeg-dev libswresample-ffmpeg-dev libavutil-ffmpeg-dev libavcodec55-ffmpeg libavformat55-ffmpeg


    Die Dateien werden nach /opt/ffmpeg installiert.
    U.a. gibt es /opt/ffmpeg/lib/pkgconfig/


    In debian/control u.a. die folgenden Abhängigkeiten eingetragen

    Code
    1. libavcodec-ffmpeg-dev, libavformat-ffmpeg-dev, libswresample-ffmpeg-dev, libswresample0-ffmpeg, libavutil-ffmpeg-dev, libavcodec55-ffmpeg, libavformat55-ffmpeg, libavutil52-ffmpeg


    Beim Bauen des Pakets werden die Bibliotheken allerdings nicht gefunden

    Code
    1. Package libavutil.ffmpeg was not found in the pkg-config search path.
    2. Perhaps you should add the directory containing `libavutil.ffmpeg.pc'
    3. to the PKG_CONFIG_PATH environment variable


    Ich vermute, dass ich PKG_CONFIG_PATH noch setzen muss, da /opt/... nicht im Default-Pfad von pkg-config liegt.
    Also PKG_CONFIG_PATH=/opt/ffmpeg/lib/pkgconfig/
    Die Frage ist nur
    Wo trage ich das ein?


    Hat jemand einen Tipp für mich?

    Habe hier noch einen kleinen Patch für das Makefile des tvm Plugins.
    Dadurch werden die beiliegenden Configs analog zum epgdata Plugin ins config-Verzeichnis kopiert.
    Evtl. kanns ja jemand gebrauchen.

    Hallo,
    ich bin Amazon.de Prime Kunde und wohne in Frankreich.


    Habe pipelight installiert und den user agent geändert.
    Beim Starten des Films wird aber offenbar die IP geprüft.
    Ich erhalte die Meldung "This video isn't available due to geographical licensing restrictions."


    Das Eintragen eines deutschen Proxies bringt nichts.


    Gibt es eine _kostenlose_ Möglichkeit den Dienst zu nutzen?

    Ich habe vorhin mal so ziemlich alles was mir hier als "Added ... to the remove list" angezeigt wurde gepurged und neu installiert.
    Jetzt läuft do-release-upgrade durch


    Habe jetzt noch folgendes gefunden


    Da ist doch etwas ziemlich schief gelaufen