Posts by Kleo

    Danke für die weiteren Hinweise und die Bestätigung bzgl. DVB-S/S2 und mpeg2/4. ;)


    Der VDR läuft schon seit ein paar Jahren (bei den Eltern) und HD war irgendwie nie Thema (weil lange eine MediaMVP der Haupt-Client war).
    Das heißt es gibt eine ziemlich schmale channels.conf und UpdateChannels ist auf 3 (also Namen und PIDs) gesetzt.

    Deswegen war der Sendersuchlauf der erste Ansatz um die HD-Sender hinzuzufügen. Allerdings waren dabei
    beide Karten eingebaut. Ich fand' nur die Beobachtung interessant, dass wirbelscan zwischendurch ausgegeben hat, dass
    gerade keine DVB-S2 taugliche Karte verfügbar wäre (die war durch LIVE-TV belegt). Bei suspendetem VDR
    wurde der Scan nach HD-Sendern dann tatsächlich (allerdings ergebnislos) durchgeführt. Deutet für mich darauf hin, das
    tatsächlich ein Unterschied bezüglich Rev 2.6 und Rev 2.8 der Skystar und dem DVB-S/S2-Support besteht.


    Aber warum lange frickeln wenn man für 10€ das Problem beheben kann.
    Eine Frage noch: Sind im Parallelbetrieb zweier exakt identischer Karten Probleme zu erwarten?

    Guter Tipp:

    Code
    1. Jun 21 11:35:24 vdr: [23685] frontend 0/0 provides DVB-S with QPSK ("ST STV0299 DVB-S")


    Code
    1. Jun 21 11:35:24 vdr: [23685] frontend 1/0 provides DVB-S with QPSK ("Conexant CX24123/CX24109")



    Das widerspricht den Informationen, welche ich bisher über die Chipsatz-Versionen gefunden habe, allerdings ist es ein Ubuntu 12.04 (also älter)
    und auf meinen Streifzügen habe ich irgendwo gelesen, dass es mal ein Treiber-Problem gab, welches auf eigentlich geeigneter Hardware
    DVB-S2 verhindert hat.


    Na mal sehen. Ich habe noch die verlinkte Karte von Pollin, welche ich noch nicht testen konnte und ein anderes LNB
    und auf 16.04 wollte ich auch demnächst updaten.


    Wie gesagt. Vielen Dank an euch beide für die schnellen Rückmeldungen und Tipps. :)

    Danke für die Antwort.

    Allerdings ist mein Kenntnisstand, dass die eine der beiden Karten HD über DVB-S2 kann. Das Wirbelscan-Plugin beschwert sich auch darüber, dass
    es auf der anderen Karte keinen DVB-S2 Scan ausführen kann. Währenddessen es auf der "HD"-fähigen den Scan abschließt, aber keine
    Sender findet (außer SD).

    Insofern denke ich, dass man DVB-S und S2 nicht mit mpeg2 und mpeg4 gleichsetzen kann.
    Ich habe meine Zweifel, dass es für die SAT-Hardware (LNB, Kabel, Budget-TV-Karte) relevant ist, ob der Videostrom
    mpeg2 oder mpeg4 ist. Bin aber kein Experte auf dem Gebiet und lasse mich gern vom Gegenteil überzeugen.


    Ist diese Karte denn geeignet, um die ÖR in HD zu empfangen:
    LINK ?

    Grüße, Kleo

    Hallo,

    ich versuche die öffentlich rechtlichen HD Sender in einer VDR-Installation mit Sat-Empfang über Astra zum Laufen zu bekommen.

    Ein Sendersuchlauf mittels wirbelscan-Plugin findet keine neuen (HD) Sender und manuelles Kopieren der Einträge in die channels.conf
    für zu "Kanal nicht verfügbar!" Meldungen. Im System läuft ein vdr 2.2.0 mit zwei Skystar 2 Karten, welche direkt an einem UN 4144
    Quattro Switch LNB hängen.

    Mittlerweile habe ich rausgefunden, dass die Skystar-Karten unterschiedliche Revisionen haben (eine mit Conexant CX24123/CX24109/CX24113 Chipsatz,
    die andere mit STV0299). Laut Internet ist eine davon DVB-S2 tauglich, die andere nicht. Nichtsdestotrotz bin ich davon ausgegangen, dass im Sendersuchlauf
    unter Benutzung der DVB-S2-tauglichen Karte HD-Kanäle zu finden sein müssten. Oder dass ich im femon-plugin zwischen den Karten wechseln kann und damit auf
    der geeigneten Karte HD zu sehen bekommen müsste. Leider hat alles nicht gefruchtet und ich bin verunsichert, ob es nicht doch an dem über 10
    Jahre alten LNB liegen könnte. WDR HD kann ich empfangen, aber die senden wohl als einzige (?) HD über DVB-S.


    Gibt es noch andere Fehlerquellen, die ich beachten sollte?

    Vielen Dank schon mal.
    Kleo

    Danke für die Denkanstösse. Dann werde ich mir mal überlegen,
    ob selbst gebaut wird oder eher auf Multicasting umgestiegen wird.


    Auf die zwanzig bin ich gekommen, weil ich mit netstat nach den auf Port 3000
    verbundenen Clients geschaut habe und das ist sicherlich nicht 100% zuverlässig.
    Ich vermute auf Port 3000 findet eher die Kontaktaufnahme und die Kontrolle des Streams statt.


    Eine Sache noch...solche Konstanten wie MAXRECEIVERS haben doch auch ihren Sinn!?
    Den Wert auf 25 oder so zu erhöhen, ist in diesem Fall sicher unkritisch,
    Aber wesentlich mehr als das sollte es wahrscheinlich nicht werden...


    Grüße, Alex

    Danke für die Antwort.


    Zu deiner ersten Vermutung:
    Mich verwundert, dass sich - bei 20 ARD schauenden Clients - ohne Probleme
    weitere auf ZDF (also einem anderen Stick) verbinden können.
    Einzig weitere Verbindungsversuche auf ARD werden mit der genannten Fehlermeldung quittiert.


    Multicasting wäre sicherlich die bessere Variante. Aber soweit ich weiß, müssen dann die Router usw.
    speziell konfiguriert werden und die liegen nicht in meinem direkten Zugriff.
    Aber ausgeschlossen ist ein Wechsel auf Muklticasting trotzdem nicht.


    Grüße, Kleo

    Hallo,


    ich habe anlässlich der Fußball-WM in unserer Firma einen VDR in Version 1.7.4
    auf Ubuntu 10.04 mit 3 Hauppauge Nova-T DVB-T Sticks in Betrieb genommen,
    um die Spiele in's Netzwerk zu streamen.
    Die Clients sind VLC 1.0.5 und das Streaming funktioniert auch soweit.
    Die Clients verbinden sich direkt mit dem VDR und empfangen den Stream
    ohne Transkodierung als TS oder PS.


    Beim heutigen Eröffnungsspiel kam es zu folgendem Phänomen:
    Ab ca. 20 Verbindungen wurde weitere Verbindungsversuche auf dem selben
    Sender mit der VDR-Fehlermeldung "no free receiver slot" im syslog quittiert.
    Dabei war es immer noch möglich einen anderen Sender als Stream zu empfangen.
    Nur auf dem Sender, der bereits von 18/19 Clients bezogen wurde, war keine Verbindung mehr möglich.


    Kennt jemand dieses Merkwürdigkeit?
    Ist das eine Limitation der verwendeten DVB-T Sticks?
    Bisher war ich davon ausgegangen, dass eher das Netzwerk
    beim Unicast-Streaming der limitierende Faktor ist als der VDR.


    Grüße und vielen Dank für jeglichen Ratschlag
    Kleo

    karlsons Idee ging mir auch durch den Kopf.


    Für mich sehen die Alustäbchen auch so aus, als sollten sie normalerweise im Elko verschwinden. Mein Plan wäre es also den Elko abzuziehen, den Sockel drauf zu lassen und an die Stummel einen neuen Elko anzulöten.


    Thomas  
    Es wäre sehr nett von Dir, wenn Du mal nach einem entsprechenden Elko schauen würdest. Falls Du was findest, schreib' mir doch bitte eine PN.


    Grüße, Kleo

    Danke für den vielen hilfreichen Hinweise.


    Frei nach dem Motto "ein Bild sagt mehr als 1000 Worte" hänge ich noch ein
    recht aussagekräftiges Foto an.


    Die Karte war tatsächlich ein Ebay-Schnäppchen und wurde - wie bereits vermutet - nahezu ungeschützt in einem Luftpolster-Umschlag der Post ausgeliefert.


    Eigentlich treibt mich eher der sportliche Ehrgeiz, ob man das reparieren kann.


    Grüße, Kleo

    Danke für das Feedback. Morgen vormittag werde ich noch zwei andere Bilder reinstellen.
    Da sieht man besser was los ist.


    Verbal kann man es so beschreiben:


    Der Elko ist auf so einer Art Plastiksockel. Dieser Sockel war einen Hauch angehoben und
    der Elko an sich war ziemlich weit umgebogen. So weit, dass zwischen Sockel und Elko
    zwei (Aluminium)-Stäbchen sichtbar waren, welche wohl normalerweise im Elektrolyt des Kondensators stecken.


    In meiner Naivität hatte schon die Hoffnung, dass man den oberen Teil des Kondensators
    einfach in die Ausgangsposition zurückbiegt, so dass die beiden Stäbchen wieder im Innern des Elko verschwinden!?


    Grüße, Kleo

    Guten Abend,


    vielleicht kann mir ja jemand weiterhelfen wenn ich weitere Informationen beisteuere.


    Ich hab' mir den Inhalt der installierten xine-spezifischen Pakete und den Inhalt
    des Ordners /usr/lib/xine/plugins angeschaut.


    Dabei ist mir aufgefallen, dass es im Ordner /usr/lib/xine/plugins zwei Unterordner gibt:
    1.26 und 2.0. Das xvdr-inputplugin (xineplug_inp_xvdr.so) liegt mit anderen im Unterordner 2.0.
    Im Ordner 1.26 gibt es kein xvdr-inputplugin. Muss dass so sein?
    Mich irritiert, dass die Datei xineplug_inp_xvdr.so aus dem .deb-Paket libxine1-xvdr stammt,
    aber im 2.0 Plugin-Ordner landet.


    Meinem Eindruck nach sucht vdr-sxfe bei Start im 1.26-Ordner nach inputplugins für xine
    und findet dort das xvdr-inputplugin nicht (liegt ja auch nur im 2.0-Unterordner).


    Scheinbar habe ich da Einiges verpasst in letzter Zeit. :-/


    Ich wäre für eine kurze Aufklärung sehr dankbar.


    Grüße, Kleo

    Hallo,


    ich hab' folgendes Anliegen und hoffe mir kann ein Experte auf die Sprünge helfen.
    Ich habe vor kurzem mein Netbook auf Ubuntu Netbook Remix 9.10 aktualisiert.
    Danach habe ich den darauf installierten vdr inkl. xineliboutput aus den vdr-team-repositories
    neu installiert (deb http://ppa.launchpad.net/the-v…/vdr-ubuntu-karmic/ubuntu karmic main).


    Die jetzt installierten Pakete (vdr* & xine*) sind:


    Der vdr an sich funktioniert. Ich kann mit vlc auf den streamdev-server zugreifen und erhalte Fernsehbild und -ton.
    Wenn ich aber bei laufendem vdr versuche vdr-sxfe zu starten, bricht es nach 1 bis 2 Sekunden mit folgenden Konsolenausgaben ab:


    Im Syslog steht:


    Code
    1. Nov 16 18:18:30 acer vdr: [2696] [discovery] Received valid discovery message VDR xineliboutput DISCOVERY 1.0#015#012Client: 255.255.255.255:37890#015#012#015
    2. Nov 16 18:18:30 acer vdr: [2696] [discovery] BROADCAST: VDR xineliboutput DISCOVERY 1.0#015#012Server port: 37890#015#012Server address: 127.0.0.1#015#012Server version: xineliboutput-1.0.90-cvs#015#012#015


    Ich kann mir das Ganze nicht so richtig erklären.
    Wahrscheinlich habe ich die falsche Version einer Bibliothek.
    Insbesondere kann ich mit libxine2 nicht allzu viel anfangen.


    Hat jemand einen Tipp für mich?


    Vielen Dank im Voraus
    Kleo


    EDIT:
    Nach einer kompletten Neuinstallation von Ubuntu 10.04 ist das Problem behoben.
    Offensichtlich ist bei dem vorher erfolgten Distributionsupgrade etwas in die Hose gegangen.

    Hallo,


    ich bin mittlerweile ein Stück weiter.
    Nachdem ich noch einmal in Ruhe probiert habe, läuft jetzt das XBMC von Hepi mit
    dem VDR von gda. Ich musste meine alten xbmc-Einstellungen in "/home/user/.xbmc" beiseite räumen.


    Nach ein paar oberflächlichen Versuchen scheint es auch wesentlich stabiler und flüssiger zu laufen
    als in den Vorversionen.


    Und es reicht bei Standardinstallation tatsächlich den VDR-Client hinzuzufügen und zu aktivieren.


    Vielen Dank an alle Beteiligten und besonders hotzenplotz5 für seine Mühe beim Upload seiner Pakete. :-)


    Grüße, Kleo

    Danke für den Hinweis.
    Der VDR von gda funktioniert bei mir allerdings nicht mit dem XBMC aus hepi's Repository.
    Ich habe es mit dem 1.6.0-VDR von gda und dem XBMC für Ubuntu 9.04 von Hepi vor ca.
    2-3 Tagen probiert. Die Symptome sind die gleichen: Sofortiger Absturz von XBMC wenn ich den TV-Service aktiviere.


    Vielleicht kann jemand verifizieren, dass er XBMC & VDR aus diesen beiden Quellen erfolgreich einsetzt,
    oder es findet sich jemand der XBMC & VDR aus einer Hand anbietet.
    Gda und hepi müssen ja beide auch ein XBMC bzw. einen VDR im Einsatz haben.


    Grüße, Kleo


    -- Edit:
    hotzenplotz5
    Ich werde mir die Links noch einmal in Ruhe anschauen.
    Eventuell habe ich auch etwas den Überblick bei den Versionen verloren.

    Hallo,


    ich habe in den letzten Tagen verschiedene im Portal kursierende Pakete und Howtos
    (z. B. http://vdr-portal.de/board/thread.php?threadid=86403&hilight=xbmc) ausprobiert, um
    zu einem XBMC mit VDR-Support und einem passenden VDR als TV-Service zu kommen (unter Ubuntu 9.04).


    Leider haben die Bemühungen nicht zu einem befriedigendem Ergebnis geführt.
    Wenn ich nach dem Kompilieren den TV-Service in XBMC aktiviere, stürzt XBMC trotz
    gepatchtem VDR + Streamdev kommentarlos ab. Der VDR läuft und ich kann mich mit
    anderen Clients (VLC) auch über's Netzwerk verbinden. Macht es eigentlich einen Unterschied,
    ob ich den Streamdev-VDR-to-VDR-Server an 127.0.0.1 oder an die IP-Adresse der
    Netzwerkschnittstelle binde (XBMC und VDR laufen bei mir auf der gleichen Maschine)?


    Meine eigentliche Frage ist aber:
    Kennt jemand ein Repository, wo XBMC und VDR fertig gepatcht und zueinander passend
    als deb-Paket verfügbar sind?


    Vielen Dank im Voraus
    Kleo

    hotzenplotz5


    Hallo,


    sehr interessanter Hinweis mit den gepatchten & vorkompilierten deb-Paketen von
    https://launchpad.net/~javoxg/+archive/ppa.


    Hast du beim Einsatz der Pakete irgendwelche Auffälligkeiten bemerkt?


    Ich habe sie gestern unter Ubuntu 8.10 installiert.
    Vorher hatte ich 8.04 im Einsatz mit ungepatchtem xbmc aus den Ubuntu-Archiven.


    Leider läuft's bei mir nicht so rund.
    Mit der gepatchten Version habe ich eigentlich permanent 100% CPU-Auslastung.
    Und die Live-TV-Wiedergabe (gespeist vom gepatchten vdr-plugin-streamdev) liegt
    bei ruckelnden 15-20 FPS.


    Alles in allem sieht es aber sehr vielversprechend aus. :-)


    Grüße, Kleo