Posts by conectas


    Leider immer noch aktuell..

    Wird aber (leider) nicht mehr daran gearbeitet wie es aussieht.. schade.


    > Gibt es bereits jemanden der das restfulapi plugin bereits auf dem VDR 2.4 einsetzt?

    Michael hat 2.4 am Start.. ich ziehe mir "denächst" mal nen Clone, dann kann ich gerne mal schauen, interessiert mich auch ob es läuft.


    Restfulapi-Plugin 0.2.6.5


    Timer Update:


    url: http://192.168.0.28:8002/timers

    httpMethodStr: PUT

    httpBodyStr: timer_id=S19.2E-1-1011-11110:0:1530828000:1900:1920&start=1900&stop=2020

    curl -X PUT -i 'http://192.168.0.28:8002/timers' --data 'timer_id=S19.2E-1-1011-11110:0:1530828000:1900:1920&start=1900&stop=2020'


    erzeugt bei mir: Status Code: 500 internal server error


    HTTP/1.1 500 internal server error

    Content-Type: text/plain

    Connection: close

    Content-Length: 41

    Server: cxxtools-Http-Server 2.2.1

    Date: Fri, 06 Jul 2018 14:54:31 GMT


    auf der Konsolle / Firefox (mit Plugin) / App getestet


    Ideen?


    > Schön das es nun funktioniert, aber welche Karte mit zwei Tunern hast Du da nun wirklich eingebaut?


    Bau die Karte jetzt nicht aus.. ;-) .. evtl. habe ich noch irgendwo den Karton (evtl.)

    Wenn ich jetzt (03:19 Uhr) nach nem Karton suche.. gibt´s auf Lebenszeit keine Lebensqualität mehr.. 8o


    n8

    > jetzt wolfi.m  Projekt ;-)


    Das klappt!! Danke!

    :thumbup:


    ;-) jetzt muss ich es nur noch auf meine "saubere" Installation anwenden..




    Nachtrag:


    frontend0 bleibt 0 -> adapter0/1/2


    /dev/dvb/adapter0:

    insgesamt 0

    crw-rw---- 1 root video 212, 0 Nov 29 20:46 demux0

    crw-rw---- 1 root video 212, 1 Nov 29 20:46 dvr0

    crw-rw---- 1 root video 212, 3 Nov 29 20:46 frontend0

    crw-rw---- 1 root video 212, 2 Nov 29 20:46 net0


    /dev/dvb/adapter1:

    insgesamt 0

    crw-rw---- 1 root video 212, 13 Nov 29 20:46 audio0

    crw-rw---- 1 root video 212, 4 Nov 29 20:46 demux0

    crw-rw---- 1 root video 212, 5 Nov 29 20:46 dvr0

    crw-rw---- 1 root video 212, 7 Nov 29 20:46 frontend0

    crw-rw---- 1 root video 212, 6 Nov 29 20:46 net0

    crw-rw---- 1 root video 212, 14 Nov 29 20:46 osd0

    crw-rw---- 1 root video 212, 12 Nov 29 20:46 video0


    /dev/dvb/adapter2:

    insgesamt 0

    crw-rw---- 1 root video 212, 8 Nov 29 20:46 demux0

    crw-rw---- 1 root video 212, 9 Nov 29 20:46 dvr0

    crw-rw---- 1 root video 212, 11 Nov 29 20:46 frontend0

    crw-rw---- 1 root video 212, 10 Nov 29 20:46 net0

    habe gerade ..


    sudo apt-get install --reinstall media-build-experimental-dkms



    Ergebnis:


    ------------------------------

    Deleting module version: 0~20150719.122100

    completely from the DKMS tree.

    ------------------------------

    Done.

    Entpacken von media-build-experimental-dkms (0~20150719.122100-2yavdr0~trusty) über (0~20150719.122100-2yavdr0~trusty) ...

    media-build-experimental-dkms (0~20150719.122100-2yavdr0~trusty) wird eingerichtet ...

    Loading new media-build-experimental-0~20150719.122100 DKMS files...

    First Installation: checking all kernels...

    Building only for 4.4.0-101-generic

    Building for architecture x86_64

    Building initial module for 4.4.0-101-generic

    Error! Bad return status for module build on kernel: 4.4.0-101-generic (x86_64)

    Consult /var/lib/dkms/media-build-experimental/0~20150719.122100/build/make.log for more information.

    dpkg: Fehler beim Bearbeiten des Paketes media-build-experimental-dkms (--configure):

    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 10 zurück

    Fehler traten auf beim Bearbeiten von:

    media-build-experimental-dkms

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    root@vdrhd:~# sudo apt-get install --reinstall media-build-experimental-dkms

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    0 aktualisiert, 0 neu installiert, 1 erneut installiert, 0 zu entfernen und 0 nicht aktualisiert.

    1 nicht vollständig installiert oder entfernt.

    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.

    E: Internal Error, No file name for media-build-experimental-dkms:amd64



    ==============


    jetzt wolfi.m  Projekt ;-)

    > Äh, wieso frontend 1 und frontend 2? die S2-3200 hat doch nur einen Tuner?


    Karte hat 2 Tuner // (frontend0 ist lo-Karte)


    > apt-get update && apt-get dist-upgrade

    ?? Auf was bezogen..


    sudo apt-get install linux-generic-lts-xenial linux-headers-generic-lts-xenial linux-image-generic-lts-xenial

    apt update && apt upgrade


    apt-get update

    apt-get dist-upgrade


    Ist jetzt für mein Problem auch glaube Wurst..

    ========================================

    Kernel ALT // yavdr 0.6 // lspci -v | less

    ========================================

    0e:00.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)

    Subsystem: Technotrend Systemtechnik GmbH S2-3200

    Flags: bus master, medium devsel, latency 32, IRQ 19

    Memory at f7100000 (32-bit, non-prefetchable) [size=512]

    Kernel driver in use: budget_ci dvb




    ========================================

    Kernel NEU

    ========================================

    02:00.0 Multimedia controller: Philips Semiconductors SAA7160 (rev 02)

    Subsystem: Technotrend Systemtechnik GmbH Device 300a

    Flags: bus master, fast devsel, latency 0, IRQ 10

    Memory at f7800000 (64-bit, non-prefetchable) [size=1M]

    Capabilities: [40] MSI: Enable- Count=1/32 Maskable- 64bit+

    Capabilities: [50] Express Endpoint, MSI 00

    Capabilities: [74] Power Management version 2

    Capabilities: [80] Vendor Specific Information: Len=50

    Capabilities: [100] Vendor Specific Information: ID=0000 Rev=0 Len=088




    ========================================

    dmesg | less

    ========================================

    [ 11.543222] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver

    [ 11.563497] saa7146: register extension 'budget_ci dvb'

    [ 11.563643] saa7146: found saa7146 @ mem ffffc90000e96000 (revision 1, irq 19) (0x13c2,0x1019)

    [ 11.563646] saa7146 (0): dma buffer size 192512

    [ 11.563647] DVB: registering new adapter (TT-Budget S2-3200 PCI)

    [ 11.599176] adapter has MAC addr = 00:d0:5c:df:16:8f

    [ 11.632523] usbcore: registered new interface driver ath3k

    [ 11.640228] usb 2-1.7: USB disconnect, device number 4

    [ 11.754123] Registered IR keymap rc-tt-1500

    [ 11.754188] input: Budget-CI dvb ir receiver saa7146 (0) as /devices/pci0000:00/0000:00:1c.7/0000:06:00.0/0000:07:08.0/0000:0d:00.0/0000:0e:00.0/rc/rc0/input6

    [ 11.754225] rc0: Budget-CI dvb ir receiver saa7146 (0) as /devices/pci0000:00/0000:00:1c.7/0000:06:00.0/0000:07:08.0/0000:0d:00.0/0000:0e:00.0/rc/rc0

    [ 11.767768] usbcore: registered new interface driver usbserial

    [ 11.767777] usbcore: registered new interface driver usbserial_generic

    [ 11.767786] usbserial: USB Serial support registered for generic

    [ 11.815066] kvm: disabled by bios



    Einigst auffällige ist aus der dmesg ist:


    ==========================================================

    [ 2.834271] clocksource: Switched to clocksource tsc

    [ 3.496369] init: plymouth-upstart-bridge main process (242) terminated with status 1

    [ 3.496378] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.497802] init: plymouth-upstart-bridge main process (253) terminated with status 1

    [ 3.497809] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.498847] init: plymouth-upstart-bridge main process (255) terminated with status 1

    [ 3.498856] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.500103] init: plymouth-upstart-bridge main process (256) terminated with status 1

    [ 3.500110] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.501021] init: plymouth-upstart-bridge main process (258) terminated with status 1

    [ 3.501028] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.502732] init: plymouth-upstart-bridge main process (259) terminated with status 1

    [ 3.502738] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.503623] init: plymouth-upstart-bridge main process (261) terminated with status 1

    [ 3.503628] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.504788] init: plymouth-upstart-bridge main process (262) terminated with status 1

    [ 3.504795] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.505738] init: plymouth-upstart-bridge main process (264) terminated with status 1

    [ 3.505745] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.506916] init: plymouth-upstart-bridge main process (265) terminated with status 1

    [ 3.506923] init: plymouth-upstart-bridge main process ended, respawning

    [ 3.507837] init: plymouth-upstart-bridge main process (267) terminated with status 1

    [ 3.507843] init: plymouth-upstart-bridge respawning too fast, stopped

    [ 9.495146] Adding 8353764k swap on /dev/sda5. Priority:-1 extents:1 across:8353764k FS

    > Wie verhält sich das System wenn du nicht Updatest sondern yavdr neu installierst?

    falsch ausgedrückt ... yavdr 0.6 ist eine Neuinstallation

    Danach Kernel Update..


    > Was sagt "lspci" bzw. "lspci -v" ... ?

    exakt kann ich es nachher schreiben..

    aber wie man auch an dmesg | grep DVB sieht Karte ist da .. es wird nur kein frontend1 und frontend2 angelegt.


    Denke SAA716xx (Kernel fw) tut es nicht..


    > Nvidia ist installiert worden falls, ja mit welcher Version?

    Die Grafikkarte läuft .. die TT-Budget S2-3200 PCI tut es nicht..


    nvidia-smi

    Tue Nov 28 19:51:19 2017

    +-----------------------------------------------------------------------------+

    | NVIDIA-SMI 384.90 Driver Version: 384.90 |

    |-------------------------------+----------------------+----------------------+

    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |

    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |

    |===============================+======================+======================|

    | 0 GeForce GT 430 Off | 00000000:01:00.0 N/A | N/A |

    | 35% 57C P0 N/A / N/A | 255MiB / 961MiB | N/A Default |

    +-------------------------------+----------------------+----------------------+


    +-----------------------------------------------------------------------------+

    | Processes: GPU Memory |

    | GPU PID Type Process name Usage |

    |=============================================================================|

    | 0 Not Supported |

    +------------------

    Moin!


    Ich habe vor 2 Wochen? auf yavdr 0.6 upgedatet, habe aber das Problem das nach ca. 1 .. 1,5h massiv Artefakte auftreten (Sender egal) ..

    Nicht immer .. aber immer öfter (Nerv)


    Idee war also .. evtl. neuer Kernel:


    Schups gemacht:

    sudo apt-get install linux-generic-lts-xenial linux-headers-generic-lts-xenial linux-image-generic-lts-xenial

    apt update && apt upgrade


    Ich habe 2 Karten drin:

    TT-Budget S2-3200 PCI

    STB0899 Multistandard


    dmesg | grep DVB

    [ 12.006928] DVB: registering new adapter (TT-Budget S2-3200 PCI)

    [ 12.867282] budget_ci dvb 0000:0e:00.0: DVB: registering adapter 0 frontend 0 (STB0899 Multistandard)...


    leider findet er (yavdr) nur die STB0899 Multistandard


    crw-rw---- 1 root video 212, 0 Nov 28 20:43 demux0
    crw-rw---- 1 root video 212, 1 Nov 28 20:43 dvr0
    crw-rw---- 1 root video 212, 3 Nov 28 20:43 frontend0
    crw-rw---- 1 root video 212, 2 Nov 28 20:43 net0


    An sich sollte die Karte ohne zusätzliche fw laufen...


    (habe natürlich nen Backup - hänge ich das rein ist die Karte da. Also nix Kaputt oder so)


    Für jeden Tipp/Hilfe dankbar..

    (Kann ja nicht immer Micha quälen ;-)



    P.S.


    Nov 28 21:05:16 vdrhd vdr: [1259] dynamite: menu action: scan for dvb devices

    Nov 28 21:05:16 vdrhd vdr: [1259] [softhddev]GrabImage: 0, 1, 80, 729x480

    Nov 28 21:05:16 vdrhd vdr: [1259] dynamite: /dev/dvb/adapter0/frontend0 is a dvb adapter trying to set card index to 0

    Nov 28 21:05:16 vdrhd vdr: [1259] dynamite: /dev/dvb/adapter0/frontend0 is already attached

    Nov 28 21:05:17 vdrhd vdr: [1259] [softhddev]GrabImage: 0, 1, 80, 729x480



    P.S. II


    kernel: [ 22.520666] systemd-udevd[1374]: failed to execute '/bin/systemctl' '/bin/systemctl start --no-block nvidia-persistenced.service': No such file or
    directory


    hat die Base 0.6 aber glaube ich auch schon gemacht..

    Wie ist der "Seahawk1986's Workaround"? jetzt bitte nicht suche sagen (Problem besteht bei einer Installation 18.11.2017 .. immer noch)


    -> Netzwerkkabel abziehen probiere ich gerade.


    .. super landet in der Console


    -- Install2 Dito, Nvida TT / Nvidia Poblem

    Der master-Branch ist für yavdr 0.6, benutze mal testing-0.5.
    Oder upstream für die reinen Quellen ohne Debianpaketzeugs.

    Ha ha nehme auch yavdr 0.6 ?(
    zumal 0.5 heute auch nicht mehr sauber durchläuft, bricht bei Install Programme? ab (kein CD Fehler) von Hand lässt sich yavdr dann aber überreden.

    Ich sehe gerade, testing-0.5 ist nicht ganz aktuell, also dann am besten den Branch upstream nehmen und mit make/make install installieren.
    Vorher ggf. die build-deps installieren.


    Lars

    ppa ist damit gemeint?


    https://launchpad.net/~yavdr/+…eld.series_filter=precise



    upstream ??


    /sg

    Moin!


    Arbeite mich durch..


    Heute yavdr komp. nochmal neu aufgesetzt. Github Daten gelöscht (lokal) und neu gezogen von:

    Mein Github verwende ich nur für Testzwecke. Benutze bitte das Github von yavdr. Da liegt die "offizielle" Version. https://github.com/yavdr/vdr-plugin-restfulapi

    dpkg-buildpackage -tc -us -uc
    dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
    dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
    dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
    dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
    dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
    dpkg-buildpackage: Quellpaket vdr-plugin-restfulapi
    dpkg-buildpackage: Quellversion 0.2.4.1-1yavdr0~trusty
    dpkg-buildpackage: Quellen geändert durch Henning Künne <@gmx.net>
    dpkg-buildpackage: Host-Architektur amd64
    dpkg-buildpackage: Warnung: debian/rules ist nicht ausführbar: wird korrigiert
    dpkg-source --before-build vdr-plugin-restfulapi
    «kg-source: Fehler: ungültiges Formatfeld »3.0 (native)
    dpkg-buildpackage: Fehler: Fehler-Exitstatus von dpkg-source --before-build vdr-plugin-restfulapi war 25


    gleiche also



    --- Nachtrag 01 ---


    make
    Package Magick++ was not found in the pkg-config search path.
    Perhaps you should add the directory containing `Magick++.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'Magick++' found
    g++ -DUSE_LIBMAGICKPLUSPLUS -c -DPLUGIN_NAME_I18N='"restfulapi"' -o restfulapi.o restfulapi.cpp
    restfulapi.cpp:10:24: schwerwiegender Fehler: vdr/plugin.h: Datei oder Verzeichnis nicht gefunden
    Kompilierung beendet.
    make: *** [restfulapi.o] Fehler 1




    Gibt es irgendwas aufälliges im Syslog?

    Nein.

    Hallo!


    Vorwort:
    Nach dem ich mal meine Apple App soweit am Start habe (bissel Werbung) bin ich mal zu allen vdr Freunden (Hallo Micha!) rum um Sie zu testen (sollte man evtl. vorher machen – habe aber ja 5 Beta Tester - und da war alles super)


    Jedenfalls musste ich feststellen dass die App nicht überall so läuft wie es sollte. Also habe ich kurzer Hand einen tau frischen yavdr (DVB-T) aufgesetzt.


    Zum Thema:
    Micha hat das PPA von gandalf geladen (stable-vdr).
    Restfulapi-Plugin: 0.2.3.6 und was soll ich sagen nicht meine App verreckt sondern die Api verreckt.


    URL: http:// 192.168.0.187:8002/events/T-8468-258-14.json?start=0&limit=2
    response: 200
    URL: http:// 192.168.0.187:8002/events/T-8468-514-514.json?start=0&limit=2
    response: 200
    URL: http:// 192.168.0.187:8002/events/T-8468-769-16408.json?start=0&limit=2
    response: 200
    URL: http:// 192.168.0.187:8002/events/T-8468-773-16405.json?start=0&limit=2
    ladeEinzelEpgSatzAlert: Error LadeEinzelEpgDatenDelegate/NSURLConnection 01: Zeitüberschreitung bei der Anforderung.


    (Leerzeichen nach http://_ von mir per Hand eingefügt um die Link Automatik zu killen)


    Reproduzierbar kommt mal nach 1. Aufruf mal nach 4. => mehr als 3 schafft er NIE.


    Test lade mal 150 Epg Daten von einem Kanal:
    http:// 192.168.0.187:8002/events/T-8468-258-14.json?start=0&limit=150
    Was soll ich sagen verreckt genauso.
    Die Version(en): die Original bei der yavdr64 0.5.0a.hybrid (0.1.3 oder so) und die 0.2.3.1 konnte das noch.


    Okay denke ich mir - schau ich mir also wieder: hannemann/vdr-plugin-restfulapi an.


    Na ja - halte mich wie immer an die INSTALL: dpkg-buildpackage -tc -us -uc (ja ich lese die noch):
    dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
    dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
    dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
    dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
    dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
    dpkg-buildpackage: Quellpaket vdr-plugin-restfulapi
    dpkg-buildpackage: Quellversion 0.2.3.8-1yavdr0~trusty
    dpkg-buildpackage: Quellen geändert durch Henning Künne <hier steht eine E-Mail Adresse: hannemannXXX@gmx.net>
    dpkg-buildpackage: Host-Architektur amd64
    dpkg-source --before-build vdr-plugin-restfulapi
    «kg-source: Fehler: ungültiges Formatfeld »3.0 (native)
    dpkg-buildpackage: Fehler: Fehler-Exitstatus von dpkg-source --before-build vdr-plugin-restfulapi war 25
    root@vdrhdt:~/vdr-plugin-restfulapi#


    wie schon gesagt: "Ich bin jetzt nicht so der Makefile Mensch.. "


    ===


    Woran liegt es? Im Webbrowser treten die Fehler exakt genauso auf.
    Also die Version von gandalf ist zumindest für Precise, die github scheinbar nicht (dpkg-buildpackage: Quellversion 0.2.3.8-1yavdr0~trusty)


    Leute, keine Ahnung.


    Gefrustet!
    Mfg.
    Stefan (conectas)



    === Nur Daten zur Information. ===


    vdr 2.06


    Welcome to Ubuntu 12.04.5 LTS (GNU/Linux 3.2.0-90-generic x86_64)


    * Documentation: https://help.ubuntu.com/


    0 packages can be updated.
    0 updates are security updates.



    {"channel":"T-8468-514-514","diskusage":{"description_localized":"Disk 4% - 47:41 frei", "free_mb":67217,
    "free_minutes":2861,
    "used_percent":4},
    "duration":5700,
    "eventid":1368,
    "services":[
    {"path":"/info","version":1},
    {"path":"/channels","version":1},
    {"path":"/channels/groups","version":1},
    {"path":"/channels/image","version":1},
    {"path":"/events","version":1},
    {"path":"/events/image","version":1},
    {"path":"/events/search","version":1},
    {"path":"/recordings","version":1},
    {"path":"/recordings/cut","version":1},
    {"path":"/recordings/marks","version":1},
    {"path":"/remote","version":1},
    {"path":"/timers","version":1},
    {"path":"/osd","version":1},
    {"path":"/searchtimers","version":1},
    {"path":"/scraper","version":1},
    {"path":"/wirbelscan","version":1},
    {"path":"/wirbelscan/countries","version":1},
    {"path":"/webapp","version":1},
    {"path":"/femon","version":1
    }
    ],
    "start_time":1441754100,
    "time":1441755857,
    "title":"Angst hat viele Gesichter","vdr":{"devices":[
    {"adapter":0,
    "atsc":false,
    "channel_id":"T-8468-514-514","channel_name":"ZDF","channel_nr":2,
    "dvb_c":false,
    "dvb_s":false,
    "dvb_t":true,
    "frontend":1083133953,
    "has_ci":false,
    "has_decoder":false,
    "live":true,
    "name":"Zarlink MT352 DVB-T","number":0,
    "primary":false,
    "signal_quality":84,
    "signal_strength":91,
    "type":"DVB-T"},
    .... rausgeschmissen
    ],
    "plugins":[
    {"name":"tvscraper","version":"0.2.0"},
    {"name":"dbus2vdr","version":"22"},
    {"name":"extrecmenu","version":"1.2.4"},
    {"name":"quickepgsearch","version":"0.0.1"},
    {"name":"menuorg","version":"0.5.1"},
    {"name":"restfulapi","version":"0.2.3.6"},
    {"name":"xvdr","version":"0.9.9"},
    {"name":"epgsearch","version":"1.0.1.beta5"},
    {"name":"markad","version":"0.1.5pre"},
    {"name":"femon","version":"2.0.0"},
    {"name":"conflictcheckonly","version":"0.0.1"},
    {"name":"live","version":"0.3.0"},
    {"name":"skinpearlhd","version":"0.0.1"},
    {"name":"iptv","version":"2.0.3"},
    {"name":"skinnopacity","version":"1.1.3"},
    {"name":"epgsearchonly","version":"0.0.1"},
    {"name":"wirbelscan","version":"0.0.7"},
    {"name":"systeminfo","version":"0.1.2"},
    {"name":"streamdev-server","version":"0.6.1-git"},
    {"name":"softhddevice","version":"0.6.1rc1"},
    {"name":"graphtftng","version":"0.4.10"},
    {"name":"channellists","version":"0.0.5"},
    {"name":"text2skin","version":"1.3.2+git"},
    {"name":"dynamite","version":"0.2.1"
    }
    ],
    "version":"2.0.6"},
    "version":"0.2.3.6"
    }



    Also sauber.

    https://github.com/hannemann/vdr-plugin-restfulapi


    Update Status:


    vdr-plugin-restfulapi_20150419212959testing/
    -> vdr-plugin-restfulapi-master_20150506.zip
    Darin entpackt.
    Makefile geändert
    debian/rules angepasst
    dpkg-buildpackage -tc -us -uc => will nicht
    dpkg-buildpackage -d -tc -us -uc = tut es dann


    Version: 0.2.3.1 am kochen


    Also Danke erst einmal soweit.. Testing folgt jetzt.


    Update02
    http://192.168.0.28:8002/info.json


    Mann ist das eine schöne (lange) Liste... :]
    => die in "channel": "S19.2E-1-1011-11110", steht ist die aktive?

    dpkg-buildpackage -tc -us -uc scheint das nicht zu interessieren, was vergesse ich da?
    1h später immer noch nicht gefunden => ich schau mir das morgen nochmal an. => make clean => make rennt durch..

    Denkfehler => es knallt beim debian Pakete Check?
    Nix nur Makefile..?
    Von dpkg habe ich keinen Plan (wir haben hier redhat, CentOs (und Fedora) und rpmbuild fasse ich auch nicht an)


    CU

    Libmagick ist optional. Schau mal ins Makefile. Ich hab das Flag gerade nicht im Kopf.
    Das wird nur verwendet um skalierte Scraper Images auszuliefern.

    Okay.. :D Mutti würde sagen => dann mach es Optional ;D


    Ich bin jetzt nicht so der Makefile Mensch.. (seit Jahren quälen mich die Menschen mit Ihrem Automake (Grüße an F. Naumann+ (Mint) => ist ein anderes Thema))


    #USE_LIBMAGICKPLUSPLUS ?= 1


    #ifeq ($(USE_LIBMAGICKPLUSPLUS), 1)
    #INCLUDES += $(shell pkg-config --cflags Magick++)
    #LIBS += $(shell pkg-config --libs Magick++)
    #CXXFLAGS += -DUSE_LIBMAGICKPLUSPLUS
    #endif


    dpkg-buildpackage -tc -us -uc scheint das nicht zu interessieren, was vergesse ich da?
    1h später immer noch nicht gefunden => ich schau mir das morgen nochmal an. => make clean => make rennt durch..


    Eigentlich ist das so auch gar nicht so verkehrt... dann sieht man, was er so macht. Vielleicht lässt sich ja für jedes Gerät der aktuelle Kanal liefern...

    Das wäre auch super.. allerdings wäre es gut rauszufinden (mitzuliefern) welcher der primäre ist (das bräuchte ich für meine Anwendung).
    -> ich will halt eigentlich den aktiven Sendernamen in meiner App anzeigen.


    Wunschprogramm ON: wenn man schonmal drann ist wäre es auch möglich nicht nur "channel": "S19.2E-1-1026-10050" mitzuliefern sondern auch den Channel Namen (ARD HD) zum Bsp. => würde ich mir eine weitere abfrage mit channel und eventid zu machen ersparen => "start_time": / "time": / "title": wird ja auch schon eh geliefert...


    ???


    n8

    Hallo!


    Frage: http://<ip>:8002/info.json


    Liefert ständig neue Werte/Channel:


    "channel":"S19.2E-133-4-14","eventid":35812,
    "channel":"S19.2E-133-1-42","eventid":61782,


    sprich neue TV Kanäle, denke vom EPG Scan (andere SAT Karten), ist das Absicht, soll das so sein?
    Gibt es eine andere Möglichkeit den aktuellen Kanal oder Video ausgabe herauszufinden, von dem Kanal der gerade aktiv im TV angezeigt wird?


    Anfrage bezieht sich auf:


    vdr-plugin-restfulapi_20150210221708testing-0yavdr2~precise.tar.gz


    (vdr-plugin-restfulapi_20150419212959testing-0yavdr0~precise.tar.gz
    => bekomme ich nicht durch den dpkg-buildpackage
    => dpkg-checkbuilddeps: Nicht erfüllte Bauabhängigkeiten: libmagick++-dev)


    CU


    P.S. Habe jetzt auf HttpRequester 2.1 umgestellt, hier lag wohl mein POST Problem.


    P.S. II und bevor jetzt wieder einer schreibt dann übersetzte dir doch libmagick++-dev
    dpkg-checkbuilddeps: Nicht erfüllte Bauabhängigkeiten: chrpath libbz2-dev libdjvulibre-dev libexif-dev libfreetype6-dev libgraphviz-dev libjasper-dev libjpeg-dev liblcms-dev liblqr-1-0-dev libltdl-dev libopenexr-dev libperl-dev libpng-dev librsvg2-dev libtiff-dev libwmf-dev libx11-dev libxext-dev libxml2-dev libxt-dev
    ... und das hört erfahrungsgemäß ja nie wieder auf.