Posts by wbreu

    Nabend Copperhead,


    merci für die Anpassungen des extpng an den VDR 1.7.19.


    Zwei Kleinigkeiten beim Compile gibts Fehler die durch den Patch reinkommen:


    1. Nach dem Patchen


    Code
    1. diseq.c Zeile 111 fehlt #endif /* UNICABLE */ vorher nur #endif /*



    2. Bei dem
    Fehler:



    Code
    1. menu.o: In function `cMenuChannelItem::Set()':
    2. /usr/local/src/VDR/menu.c:370: undefined reference to `IsLangUtf8()'
    3. /usr/local/src/VDR/menu.c:368: undefined reference to `IsLangUtf8()'
    4. /usr/local/src/VDR/menu.c:372: undefined reference to `IsLangUtf8()'
    5. menu.o: In function `cMenuScheduleItem::Update(bool)':
    6. /usr/local/src/VDR/menu.c:1595: undefined reference to `IsLangUtf8()'
    7. /usr/local/src/VDR/menu.c:1593: undefined reference to `IsLangUtf8()'
    8. menu.o:/usr/local/src/VDR/menu.c:1594: more undefined references to `IsLangUtf8()' follow
    9. collect2: ld returned 1 exit status
    10. make: *** [vdr] Fehler 1


    wird mit WAREAGLEICON = 1 compiliert, es fehlt im Makefile:


    Code
    1. ifdef WAREAGLEICON
    2. OBJS += iconpatch.o
    3. endif




    Gruß
    Wolfgang

    Servus,


    die Größen der Logos sind meines Wissens nicht komplett frei konfigurierbar übers OSD, sowohl Width als auch Height sollten übers OSD im jeweiligen Bereich von 80 bis 270 bzw. von 80 bis 201 noch konfigurierbar gemacht werden.


    Habe es schon lange nicht mehr mit 80x80er-Logos getestet.


    Das Logoformat bitte nur erweitern, das "alte" Format kann ruhig bleiben.


    Im übrigen bekomme ich immer komplette Logosammlungen (ca. 3000) aus einem anderen Bereich, die werden per Skript mit Gimp gewandelt und schon sind sie fertig für Enigma-NG.


    Gruß
    Wolfgang

    Moin,


    toller Thread, wenn man hier die Meinungen so liest...., gab es aber schon gefühlt 100mal.


    Aber man sollte mal klarstellen was man hier versucht zu vergleichen. Und vorallem sollte der Threadstarter definieren was er genau vor hat.


    Ansonsten macht das alles keinen Sinn, egal für welche Lösung man sich entscheidet....



    Wenn du "nur" einen VDR haben willst


    - ohne WIedergabemöglichkeit von anderen Formaten


    - ohne Möglichkeit der funktionierenden Anbindung von Pay-TV (egal ob Hardware oder Software...)


    - ohne Mediaplayer


    - ohne Mediatheken


    - ohne Webbrowser


    - ohne Femon-Plugin


    - dafür mit Klötzchenbildung beim VDR-Start


    - dafür defekte Aufnahmen auf dem 2. Tuner


    - dafür einen verdammt heissen Kühlkörper auf der Karte, der vernünftige Kühlung braucht.


    - usw.


    dann nimm ne TT-6400er und finde dich damit ab.


    Wenn du mich fragst, ist die TT-6400er-Lösung im Moment genau da, wo vdpau mit dem xine-plugin vor ca. 1 Jahr war.


    Ich bin nach wie vor der Meinung die Karte ist für das was sie jetzt kann zu teuer, zu unflexibel und technisch nicht ausgereift.
    Gibt ja einen ellenlangen Thread darüber was für Probleme die einzelnen User mit der Karte ab Erscheinen haben.


    PS: Sorry, aber diese Kritk an der Karte muss sein, nach der langen Entwicklungszeit und dem Verkaufspreis im Vergleich zu komplett fertigen Receiverlösungen.


    Gruß
    Wolfgang

    Nabend,


    mal auch hier eine kleine Rückmeldung geben....


    Auch bei mir läuft die Karte in diversen Boards nicht sauber. Insgesamt 7 Boards mit diversen Chipsätzen und aktuellen Treibern/Firmware.


    Fehlerbild nach dem Kaltstart Klötzchenbildung und/oder ein Tuner tunt nicht..... , somit gehen Aufnahmen in die Hose.


    Aus der Erfahrung raus würde ich sagen, die Boards spielen keine Rolle, entweder hat die Hardware=Karte ein grundsätzliches Problem oder die Treiber sind murks, kann ja nicht sein, dass die Tuner nicht gleich beim Start da sind.


    Wäre echt mal Interessant, was die Herstellerfirma bzw. die Treiberentwickler dazu sagen?


    Haben die auch Probleme dieser Art?


    In diesem Zustand muss man ganz klar sagen, wir setzen alle Standardhardware ein, die Karte, bzw. Treiber, machen Probleme, und nicht die Boards.


    Wenn man sich die Entwicklung der cine-Karten ansieht, da gabs Anfangs auch diverse Probleme mit den beiden Tunern, man hat 5 Revisionen der Karten rausgebracht, ab der dritten Revision liefen die beiden Tuner hardwaremäßig sauber.
    Bei den Treibern gabs diverse Nachbesserungen, bis auch hier der Stand erreicht wurde, der super ist.



    Was mich ein bisschen nachdenklich stimmt, warum äussert sich niemand von den Treiberentwicklern hier zu dem mittlerweile breitgefächertem Problem?


    Gruß
    Wolfgang

    Nabend,


    auch wenn ich im Moment keine Zeit habe, ..., mal ein zwei Tips.


    Das hört sich bei dir ganz so an, als ob du verschiedene xine-libs, in verschiedenen Versionen, in verschiedenen Verzeichnissen gleichzeitig liegen hast.


    Also, wenn du von Hand baust,


    1. immer alle xine-libs und vdr-plugins deinstallieren, löschen, runter vom System. Gerade bei den VDR-Plugins schiesst man sich schnell ins Bein, wenn man da nicht aufpasst, => man hat zwei unterschiedliche xine-libs auf dem System.
    Die VDR-Plugins bauen immer gegen die xine-lib die sie als erste findet, bzw. gelinkt ist/wird.


    2. Dann nach und nach alle notwendigen libs von Hand neubauen und installieren, aufpassen wohin installiert wird und ob die compiles alle saueber laufen.
    Reihenfolge findest du auf meiner Homepage.


    3. Es gibt hier auch ein paar Skripte, die holen und bauen automatisieren, in der Regel ist das immer der gleiche Vorgang.


    Gruß
    Wolfgang

    Nabend zusammen,


    da hier immer wieder nach aktuellen Nvidia's gefragt wird, habe ich mal eine Geforce GT 520 getestet.


    Und zwar eine low-profile Asus GT520 Silent


    Link


    Die Karte bleibt bei 1920x1080i (Sky HD und usw.) mit temporal-spatial Deinterlacer bei 45 Grad extrem kühl, ein leiser 80er Lüfter bläst mit 800 U/min auf die Karte.


    Wie der qvdpautest zeigt, ist temporal-spatial als Deinterlacer in allen gängigen Auflösungen problemlos möglich.



    Mit aktuellem alsa bzw. Kernel-2.6.38.3 funzt der Sound via Hdmi auch einwandfrei.


    Wie auf den Bildern im Link zu sehen ist die Karte durch den Kühlkörper etwas breiter und dadurch wird der benachbarte Slot belegt.


    Die Karte verbraucht maximal ca. 29 Watt, bei mir im Testrechner ca. 23 Watt mit temporal-spatial als Deinterlacer bei HD-Content.


    Falls zukünftige Nachfragen nach aktuellen Karten erfolgen sollten, jepp die GT520 ist voll vdpau/VDR-tauglich.


    Gruß
    Wolfgang

    Nabend,


    erster Ansatz wäre mal dem Treiber das MSI-Signal sauber beizubringen....


    Ich habe bereits vier Boards mit unterschiedlichen Chipsätzen (GeForce® 9300 , Intel P55, Intel® NM10 Express, Intel® G45 Express) durch, bei keinem klappt das MSI um eben die IRQ's sauber zu verteilen.


    Teilweise lässt sich der Treiber gar nicht laden, wenn man den Parameter int_type=1 oder 2 mitgibt


    Auszug modinfo saa716x_ff:
    parm: int_type:force Interrupt Handler type: 0=INT-A, 1=MSI, 2=MSI-X. default INT-A mode (int)



    Also irgendwas ist da gewaltig faul.


    Dass da jetzt die Boards schuld sind glaube ich nicht, jede andere Karte (cine-s2 z.B) hat damit keine Probleme.


    Gruß
    Wolfgang

    Moin,


    tja die Karte ist mittlerweile sehr schwer zu bekommen.


    Alternativen gibts aber schon.


    1. Brandneu die 520er, aber da ist alsa noch nicht soweit, und auch Tests ob die Karte temporal_spatial schafft. Könnte insgesamt knapp werden mit temporal_spatial bei HD-Content.


    2. Eine 220er GT dürfte auch nicht mehr brauchen, da vdpau die GPU nicht komplett auslastet, ich schätze mal die maximal-Werte (Verbrauch in Watt) dürften da nicht erreicht werden.


    3. Eine 430er, habe ich selbst am Rennen, braucht bei vdpau mit temporal_spatial bei HD-Content ca. 30 Watt. Im Idle zieht die Karte ca. 7 Watt. Max. soll sie 49 Watt ziehen.


    Such dir eine aus, wenn du ein bisschen warten kannst nimm eine 520er, die liest sich sehr vielversprechend.


    Bei allen Karten, auch passive Karten, unbedingt auf gute Kühlung achten!


    Gruß
    Wolfgang

    naja dann müsste vdpau aber 1080i an den tv syncron senden können. das kann vdpau nicht, daher ist auch der vergleich murks.


    im endeffekt hast du aber recht, es wird der vdpau deinterlacer mit dem deinterlacer des tv verglichen.


    nochmal zum thema "wibbern". irgend ein sender hatte mal eine studie in auftrag gegeben was bei einem kunden besser aussieht. 720p oder 1080i. und die mehrheit fand das 720p bild subjektiv besser. war das nicht sogar ard/zdf und senden daher auch 720p? mich würde mal interessieren, ob ein 720p bild besser mit vdpau aussieht als mit der 6400. das wäre ein fairerer vergleich find ich.

    Naja,


    in meinen Augen zählt das Gesamtpaket und dann eben die Frage mit welchen Möglichkeiten kann ich das Optimale wie erreichen.


    Übrigens sehe ich keinen Sinn in 720p-Tests, denn das ist nur eine Variante der Bildausgabe und die ist mehr als veraltet, aktuelle TV's haben 1920x1080er Auflösung, warum soll ich den mit 720p-Auflösung fahren.


    Gruß
    Wolfgang

    spitzb ,


    mach mal halblang.


    Ich nehme einen VDR und schliesse den an den LCD an und vergleiche ohne viel Verstellen am LCD das Bild.


    Dabei kommt das heraus was ich oben geschildert habe und nix anderes.


    Ist halt bei Vergleichen so.


    Wie das Bild an den LCD gelangt ist erstmal egal. Bei vdpau gibts Möglichkeiten die man nutzen kann und bei der TT auch.


    Mir gehts auch nicht darum, die TT schlecht zu machen oder vdpau gut zu reden, oder umgekehrt.
    Wenn die TT das nicht besser hinbekommt, das ist das halt so! => deshalb kaufe ich mir aber keinen neuen LCD.


    Im übrigen kann man bei vdpau das Deinterlacing nicht abschalten, da es fest im Code verdrahtet ist.


    Das was ich oben geschildert habe ist mein subjektiver Eindruck. Den übrigens auch andere teilen und hier schon geschildert haben.


    Gruß
    Wolfgang

    Nabend,


    soweit ich das ausgetestet habe, hat die Karte mit dem jetzigen Stand der Treiber Probleme mit der Nutzung von MSI-Interupts.


    Mir ist es noch nicht gelungen die Karte in die höheren IRQ's zu schieben.


    Code
    1. SAA716x FF FPGA version 1.02
    2. SAA716x FF loader version 1.02
    3. DVB: registering new adapter (SAA716x dvb adapter)
    4. stv6110x_attach: Attaching STV6110x
    5. DVB: registering adapter 0 frontend 0 (STV090x Multistandard)...
    6. DVB: registering new adapter (SAA716x dvb adapter)
    7. stv6110x_attach: Attaching STV6110x
    8. DVB: registering adapter 1 frontend 0 (STV090x Multistandard)...
    9. SAA716x FF 0000:02:00.0: PCI INT A disabled
    10. SAA716x FF: probe of 0000:02:00.0 failed with error -1


    Das ist sehr oft der Fall, wenn man int_type=1 in den Moduleoptions beim direkten Neustart arbeitet.
    Dann kommt auch keine Bildausgabe.
    Das ganze ist mit drei Kernels zu beobachten, 2.6.35.10, 2.6.38.3 und dem 2.6.39-rc3.


    Mit int_type=2 wird generell nur IRQ 19 genutzt. Hier sollte eigentlich auch der MSI greifen.


    Generell geht bei dem Board MSI:



    Eventuell kommen daher auch ein paar Seiteneffekte die schon berichtet wurden (z.B Tonprobleme bei gleichzeitiger Aufnahme).


    Geht überhaupt bei jemandem MSI mit der Karte?


    Gruß
    Wolfgang

    Nabend,


    ich kippe mal noch einen nach, gerade läuft Fußball, 1080i-Kontent, die TT "wabert" ohne Ende bei Kameraschwenks, sieht man schön am Rasen und dessen Kontur.


    Bei vdpau, mit temporal-Deinterlacer ist das "wabern" ganz leicht zu erkennen, bei weitem nicht so auffällig.


    Mit temporal_spatial-Deinterlacer bei vdpau ist das Wabern/Verschwimmen gar nicht da.


    Beide Geräte sind an einem Samsung LCD 650B per HDMI angeschlossen. Beide Anschlüsse sind auf Werkseinstellungen justiert.


    Wenn man also jetzt ne Skala aufmachen würde, dann macht die TT von der Qualität her, zu 50% temporal-Deinterlacing, aber immerhin noch besser als der bob-Deinterlacer.


    Die Skala geht von bob über temporal zu temporal_spatial.


    Wie schon mal gesagt, meine subjektiven Eindrücke.


    Gruß
    Wolfgang

    Ich will dir ja nicht zu nahe treten, aber wie kommst du dazu,der TT ein schlechtes Deinterlacing zu unterstellen? Da dort nur 1080i und kein 1080p herauskommt, macht die Karte logischerweise kein Deinterlacing. Damit wird das "naja" Deinterlacing höchstens von deinem Fernseher verursacht.


    Falk


    Nabend,


    naja, mir ist das wurscht, wer was macht, die Bildquali insgesamt muß stimmen. Und genau das ist dann das Problem hier bei der 50i-Ausgabe macht das der TV und da gibts gute und schlechte. Bei 1080-50p habe ich noch keinen gesehen der da nicht zumindest gut war....


    Gruß
    Wolfgang

    Nabend Ufo,


    mit welchem Code arbeitet die beiliegende FB der TT-FF?


    Ich hoffe mal mit RC5, dann könnte man auch einen Atric-Einschalter verwenden...


    Danke für die Antwort.


    Gruß
    Wolfgang

    wbreu : Hast du eigentlich auch eine? Dein Meinung würde mich brennend interessieren.


    Hi,


    jepp, ich habe seit heute auch so eine Karte, um mal einen Vergleich zu haben, was das Dingen kann und wie die Karte im Vergleich zu Softwarelösungen abschneidet.


    Ich habe übrigens erst am Montag bestellt, ging wirklich fix.


    Erste Eindrücke nach der Treiberinstall sind durchaus positiv, aber das Deinterlacing...., naja Geschmackssache.


    Allerdings ist das schon komisch, wenn ich mir jetzt vdpau mit dem alternativen Decoder anschaue und das neue xine-Plugin dazunehme, ist vdpau von der Bildquali her wesentlich besser, auch schon mit temporal-Deinterlacer.
    Mit Temporal-Spatial-Deinterlacer kann die TT einpacken.


    Umschaltzeiten und Handling sind identisch, kommt halt aufs xine-Setup an.


    Wenn du einen speziellen Punkt hast, dann Frag ruhig, ich habe beide bzw. eigentlich alle drei (inkl. vaapi) Lösungen nebeneinander stehen und man kann gut vergleichen.


    Gruß
    Wolfgang