Übertrgaungsgeschwindigkeit mit Samba zwischen windows und YaVdr

  • Hallo,


    ist es denn normal das ich für ein 2Gb-File ca. 120Min. benötige um es von Windows auf
    meinen HTPC zu verschieben??
    Verwende Samba als Server, und verschiebe via WLan.


    Falls ich mich nicht verrechnet habe sollte das eine Übetragungsgeschwindigkeit von gerade mal rund 0,3MB/sec sein, was mir etwas wenig vorkommt.


    lg
    ingo

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

  • Ich denke es liegt an der Verbindung, also WLAN.


    Versuche das gleiche mal mit einen NW-Kabel zu testen.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Quote

    Original von ingostar
    von Windows


    wobei er hier gerade auch jehova gesagt hat :-)


    allerdings hab ich auf meinem ubuntuserver zwischen win und linux ne aehnliche performance.... linux <=>linux hingegen geht ratz fatz


    gruss gerd

    vdr => p8b75-m lx / pentium g2020t / 8 GB Ram / zotac gt 630 / cine S2 V5.5 / 60 gb ocz ssd / 640 gb wd scorpio blue / display noritake 256x64-3900 / chenbro PC71023 gehaeuse / yavdr stable / softhddevice


    spielsystem => p8b75-m le / intel core i3 3220T / ubuntu lts 14.04 / 16 GB ram / zotac gt 630 / cine S2 V6.2 / yavdr stable pakete / softhddevice / pulseaudio+alsa


    spielwiese => Zotac Zbox ID45 / 120 GB mSATA / via Satip => Octopus Net / yavdr stable / softhddevice

  • Hallo,


    also wenn ich hier über mein Gigabit-Netzwerk (Kabel) zwischen meinem Fileserver (Linux) und dem Arbeitsplatz-PC VDR-Files kopiere, ist die Übertragungsrate über Samba auch nur zwischen 8-10MB/s. Wenn ich das von Linux zu Linux über NFS mache, habe ich immer den ca. 3 bis 4 fachen Durchsatz. Scheinbar ist Samba wohl nicht so die schnellste Lösung, oder ich habe die Parameter meines Samba-Servers so beschi**en eingestellt. :)
    Aber mit W-Lan macht das Kopieren von Filmen wirklich keinen Spass. Ich habe das damals schon mit meinem 100MBit-Lan als unzumutbar empfunden. Also besser einen 'GB-Strick' nehmen als durch die Luft zu beamen. Bei 54MBit W-Lan gehen doch sowieso maximal 6,75MByte/s Brutto, wobei die Netto-Rate noch deutlich schlechter ausfallen dürfte. Aber 0,3MB/s sind wirklich nicht gerade üppig... Hängt aber sicher auch von der Verbindungsqualität ab.


    Gruss Steve135

  • Danke für die rasche Hilfe.


    Anscheinend liegts echt an der Verbindung zwischen den beiden Rechnern.


    Aber finds schade das die Übertragungsgeschwindigkeit zwischen Windoof und Linux
    um so viel schlechter ist als Linux-Linux.


    Woran kann denn das liegen??


    lg
    ingo

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

  • Noch etwas "lustiges" ist mir aufgefallen, wenn ich ein netzwerkkabel verwende, geht wlan nicht mehr.


    ist das normal??


    lg
    ingo

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

  • nanana, dann sage ich auch mal "jehova"... :schiel


    von meinem windows-pc nach yavdr gehts mit ca. 40MByte/sec und das über ein uraltes nw-kabel an einer isdn-dose...

    streamdev-Server: MLD 5.5 testing, Mystique SaTiX-S2 V3 Dual + DuoFlex S2, J3160, 8GB, 60GB System,

    streamdev-Client 1: NUC6CAYH (Intel HD Graphics 500) + MLD 5.5 testing, One For All URC 7960,

    streamdev-Client 2: RPI4, MLD 5.5 testing, One For All URC 7960,

    Media-Server: Synology DS215j

    AV-Geräte: Hisense H65MEC5550, Dali Zensor 5 AX

  • Quote

    Original von ingostar
    Noch etwas "lustiges" ist mir aufgefallen, wenn ich ein netzwerkkabel verwende, geht wlan nicht mehr.


    ist das normal??


    lg
    ingo

    ja, das ist normal.


    vdr-box


  • Weil "Windoofs" sich nicht an die geltenden RFC Standards hält und somit unsaubere Netzwerk-Protokolle benutzt.... das ist der einzige Grund.


    Ein 100MBit LAN sollte immer 10.9MB/Sek oder mehr schaffen (mal eine evtl. Last auf beiden Rechner vernachlässigt)
    Im GB-LAN sollten es deutlich über 48MB/Sek sein.


    Eine weiterer Grund kann eine unsaubere Kompilierte Samba Verseion und oder schlechte Konfiguration von Samba selbst sein.....


    sers

    VDR 1: P.o.V. M-ATX ATOM D510, 4GB, 2x 2TB WD EARS, 1x Cine S2 - Duale DVB-S2 HDTV, 1x Digital Devices DuoFlex S2 miniPCIe , 2x TT-budget S2-1600 * MLC-Core 2010.1 (Warbird-Srv)-2.6.35.1-1mlc Atom64-H3 Kernel* -Multimedia Kernel-
    VDR 2: 19Zoll Rack Server, Atom D525, 4GB RAM, 3x 2TB WD EARS, Cine S2, TBS Dualhaed HD, * MLC-Core 2010.1 (Warbird-Srv)-2.6.38.8-1mlc Atom64-H3 Kernel*
    VDR 3: 19Zoll Rack Server, Atom D525, 4GB RAM, 3x 2TB WD EARS, Cine S2, TBS Dualhaed HD, * MLC-Core 2010.1 (Warbird-Srv)-2.6.38.8-1mlc Atom64-H3 Kernel*

    The post was edited 1 time, last by Schnulli ().

  • Ich habe 4 unterschiedliche Geräte im Netz, Windows XP, Mac, vdr mit gen2vdr und ein NAS auf dem ein mir unbekanntes linux läuft. Alle Geräte sind am Router mit 100er Anschlüssen. Die Geschwindigkeit habe ich nicht gemessen, da es zwischen vdr, Mac und NAS flott läuft hatte ich das nicht nötig. XP zu Mac oder XP zu vdr geht auch brauchbar, aber zwischen XP und NAS ist es unerträglich langsam und wenn ich große Datenmengen kopieren will gibt es Abbrüche. Ich behelfe mir damit dass ich am Mac per SMB je ein Verzeichnis vom XP und NAS mounte und die Dateien direkt, ohne sie auf dem Mac abzuspeichern kopiere. Das geht wesentlich schneller als direkt zwischen beiden Geräten und ohne Abbrüche. Wenn ich auf dem XP-Rechner von einer anderen Festplatte verschiedene Test-VDR boote, ist die Netzwerk-Geschwindigkeit auch optimal.


    Für mich steht der Schuldige fest, er wird demnächst eingesperrt und nur noch virtuell auf dem Mac überleben.

  • Ich möchte diesen alten Thread nochmal ergänzen, da ich glaube das mein "Problem" hier gut reinpasst.


    Ich habe bei mir einen yaVDR basierten Server (0.3.0a), einen yaVDR Client (0.3.0a), einen MacMini (OSX 10.6), einen WinXP und einen Win7 Rechner. Auf dem yaVDR Server läuft Samba und NFS als Server. Alles ist über Gig-Ethernet verbunden. Die Performance beim Kopieren von und zu dem Server sind wie folgt:


    WinXP: 35 - 50 mb/s
    Win7: 55 - 85 mb/s
    OSX: 70 - 95 mb/s
    yaVDR nfs: 25 - 55 mb/s
    yaVDR smb: 15 - 18 mb/s


    Der IP-Stack oder die CIFS-Implementation von Win7 scheint also erheblich besser zu sein als bei XP. OSX scheint mir eher durch die Leistung der Platte begrenzt zu sein, ist aber nur eine Vermutung.


    Was mich stutzig macht, sind die Transferleistungen zwischen yaVDR Client und yaVDR Server. Gerade hier hätte ich die beste Performance erwartet, da hier auch die schnellsten Platten verbaut sind. Mangelnde Prozessorleistung schliesse ich auch aus, da der Client die schnellere CPU hat als der Server.


    Aber gerade dort benötige ich die Performance, da die Aufnahmen auf dem Server im Keller gemacht werden und ich diese auf dem Client schneide.


    Meine smb.conf auf dem Server:


    [global]
    workgroup = HomeOffice
    security = user
    announce as = NT Server
    announce version = 2000
    server string = vdr-server
    hosts allow = 192.168.1.0/255.255.255.0
    interfaces = 192.168.1.0/255.255.255.0
    bind interfaces only = yes


    log file = /var/log/samba/log.%m
    log level = 0
    max log size = 1000
    syslog = 0


    dns proxy = no
    guest account = nobody
    keep alive = 30
    os level = 2
    kernel oplocks = false
    encrypt passwords = true
    ssl = yes
    time server = true
    socket options = TCP_NODELAY IPTOS_LOWDELAY
    map to guest = bad user
    wins support = no
    os level = 33
    browse list = yes
    unix charset = ISO8859-15
    dos charset = CP850
    load printers = 0
    [data]
    netbios name = vdr-server
    netbios aliases = vdr-server
    comment = data
    path = /mnt/srv.data
    guest ok = yes
    writable = yes
    browseable = yes
    follow symlinks = yes
    preserve case = yes
    directory mode = 0775
    create mode = 0664
    force user = vdr
    force group = vdr


    Die fstab auf dem Client:


    //192.168.1.10/data /mnt/smb.data smbfs user,rw,noauto,username=user,password=pwd 0 0
    192.168.1.10:/mnt/srv.data /mnt/nfs.data nfs rw,hard,intr 0 0


    Hat jemand eine idee?


    Danke im voraus,


    Andreas

  • Also wenn hier schon alle "Jehova" rufen, mach ich das auch mal.


    Die besten Übertragungsraten habe ich _immer_ dann, wenn ich meinen Windows 2008 Server R2 als Datenquelle oder -Ziel verwende. 110 MB pro Sekunde bei großen isos? Kein Problem dabei...


    Als ich noch einen Linux-Fileserver hatte, lagen damals die Transferraten bei ca. 40 MB/sec.


    Das Zusammenspiel Windows 7 mit Windows 2008 Server ist optimal.


    Aber: Auch von einem easyvdr, bei dem ich den Windows-Server mit NFS eingebunden habe, habe ich eine Top-Performance.


    Nun direkt zur Frage:


    Samba war bei mir immer schlechter in der Performance als NFS. Ist also auch meine Beobachtung.


    Ich schaue mal in meine Fstab, wie ich nfs gemountet habe... Sieht aer ähnlich aus wie deine (hae nur noch users als Parameter drin. Wenn ich auf den VDR komme (bin gerade unterwegs) poste ich mal einen Auszug...


    VG


    Oliver