mittels VLC auf streamdev zugreifen

  • Hallo,


    ich versuche gerade via vlc auf einen streamdev stream zuzugreifen.
    habe im osd des vdr dem streamdev server für http eine ip gegeben, und auf PES eingestellt.
    wenn ich nun aber mit dem VLC zugreifen möchte, dann bekomme ich folgende Meldung:
    Ihre Eingabe konnte nicht geöffnet werden:
    VLC kann die MRL 'http://192.168.0.222:3000/PES/3' nicht öffnen. Sehen Sie für Details im Fehlerprotokoll nach.


    Kann mir bitte jemand weiter helfen??
    Kann es daran liegen das ich als Ausgabe xineliboutput verwende?


    Der zugriff via samba auf dei freigaben funzt.


    Danke schon mal für eure Hilfe.


    lg
    ingo

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

    The post was edited 1 time, last by ingostar ().

  • Hallo,


    danke für die Hilfe.


    Ich verwende nur eine DVB-Karte da ich entweder im Wohnzimmer Fernsehen möchte, oder im Schlafzimmer.


    Ich habe in der /etc/vd/plugins/streamdevhosts.conf die IP meines Computers eingegeben, aber leider
    ohne Erfolg.


    Die IP die ich dem Stremdev server im OSD eingetragen habe muss nicht mit der IP
    vom Wlan des YaVdr Rechners überinstimmen, oder??


    Oder muss man den Streamdev server erst manuell starten??


    lg
    ingo

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr


  • Die IP MUSS die selbe sein wie der Rechner indem die DVB-Karte steckt.. nach jeder Änderung musst du vdr neu starten.. wenn du ein gutes runvdr script benutzt, einfach ein HUP oder Kill an den vdr senden und schwup sind die geänderten Einstellungen übernommen weil neu gestartet


    In der streamdevhost.conf trägst du die IP´s ein die du erlauben willst.. also alle PC´s etc die du evtl. benutzt um TV schauen zu können.....
    wenn du das vdr-plugin-playlist installiert hast... einfach mal das:
    http://<ip-des-vdr-rechners>:3000
    im Browser aufrufen und oben rechts findest du den DL-Link zur Playliste mit m3u Endung.....
    Speichern.... rechts Klick darauf.. Eigenschaften.. öffnen mit.. VLC-Player..... "das wars Lars" ^^


    sers

    VDR 1: P.o.V. M-ATX ATOM D510, 4GB, 2x 2TB WD EARS, 1x Cine S2 - Duale DVB-S2 HDTV, 1x Digital Devices DuoFlex S2 miniPCIe , 2x TT-budget S2-1600 * MLC-Core 2010.1 (Warbird-Srv)-2.6.35.1-1mlc Atom64-H3 Kernel* -Multimedia Kernel-
    VDR 2: 19Zoll Rack Server, Atom D525, 4GB RAM, 3x 2TB WD EARS, Cine S2, TBS Dualhaed HD, * MLC-Core 2010.1 (Warbird-Srv)-2.6.38.8-1mlc Atom64-H3 Kernel*
    VDR 3: 19Zoll Rack Server, Atom D525, 4GB RAM, 3x 2TB WD EARS, Cine S2, TBS Dualhaed HD, * MLC-Core 2010.1 (Warbird-Srv)-2.6.38.8-1mlc Atom64-H3 Kernel*

  • Hallo,


    leider muss ich dieses Thema nochmal ausgraben, weil ich nach der neuinstallation meines YaVdr ein Problem mit Streamdev-server habe.


    ich komme mit 192.168.1.5 auf das Webfrontend von yavdr sowie in das vdr.live plugin auf Port 8008, habe die streamdevhosts.conf und in /var/lib/vdr/setup.conf
    Suspend erlaubt und den Mode auf 1 gesetzt, die IP meines Rechner (192.168.1.5) eingetragen TS eingestellt, und Port 3000 gelassen.


    Nur kann ich leider 192.168.1.5:3000 mittels Browser nicht erreichen, und mit einem Ping bekomme ich auch eine Fehlermeldung das der Host nicht gefunden werden konnte


    Kann mir da bitte jemand weiter helfen?


    verwende einen TP-Link TL-WR1043N Router.


    Ich sollte vielleicht noch dazusagen, das ich eine Fixe Ip in /etc/network/interfaces mit folgenden einträgen eingestellt habe:
    address 192.168.1.5
    netmask 255.255.255.0
    gateway 192.168.0.1



    lg
    ingo

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

    The post was edited 1 time, last by ingostar ().

  • Hallo,


    langsam gehen mir echt die wenigen Ideen, und die Infos aus dem Netz aus.


    Habe aber im Logfile folgende Zeilen gefunden:

    Code
    1. Sep 17 20:37:58 yavdr vdr: [1600] starting plugin: streamdev-server
    2. Sep 17 20:38:07 yavdr vdr: [1688] Streamdev: Accepted new client (HTTP) 192.168.1.100:1569
    3. Sep 17 20:38:07 yavdr vdr: [1688] streamdev: client 192.168.1.100:1569 not allowed to connect
    4. Sep 17 20:38:07 yavdr vdr: [1688] streamdev: closing streamdev connection to 192.168.1.100:1569


    Ich habe im OSD sowie in /var/lib/vdr/setup.conf 192.168.1.5 eingetragen und der Router hat 192.168.1.1


    Bitte kann mir jemand helfen?


    lg
    ingo

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

  • locate streamdevhosts.conf


    /var/lib/vdr/plugins/streamdev-server/streamdevhosts.conf


    In my system is it /var/lib/vdr/plugins/streamdev-server/streamdevhosts.conf


    vi /var/lib/vdr/plugins/streamdev-server/streamdevhosts.conf


    #
    # streamdevhosts This file describes a number of host addresses that
    # are allowed to connect to the streamdev server running
    # with the Video Disk Recorder (VDR) on this system.
    # Syntax:
    #
    # IP-Address[/Netmask]
    #


    127.0.0.1 # always accept localhost
    192.168.1.0/24 # any host on the local net
    #204.152.189.113 # a specific host
    #239.255.0.0/16 # uncomment for IGMP multicast streaming
    #0.0.0.0/0 # any host on any net (DON'T DO THAT! USE AUTHENTICATION)


    So all clients on network 192.168.1.0/24 can connect.


    In setup.conf of VDR:
    streamdev-server.AllowSuspend = 0
    streamdev-server.HTTPBindIP = 0.0.0.0
    streamdev-server.HTTPServerPort = 3000
    streamdev-server.HTTPStreamType = 0
    streamdev-server.IGMPBindIP = 0.0.0.0
    streamdev-server.IGMPClientPort = 1234
    streamdev-server.IGMPStreamType = 0
    streamdev-server.MaxClients = 5
    streamdev-server.ServerPort = 2004
    streamdev-server.StartHTTPServer = 1
    streamdev-server.StartIGMPServer = 0
    streamdev-server.StartServer = 1
    streamdev-server.SuspendMode = 2
    streamdev-server.VTPBindIP = 0.0.0.0


    And do what Schnulli has posted and you can watch with vlc.


    You have to restart your vdr, otherwise streamdev will not load the new setting you have in streamdevhosts.conf

  • Hi,


    thank you for your help, i´ve done everything you told me, but i still can´t reach 192.168.1.5:3000


    I´ve noticed that the following entries in the setup.conf are changed after restart of the vdr.
    The new values are the values from the OSD menu.


    streamdev-server.AllowSuspend = 0
    streamdev-server.HTTPBindIP = 0.0.0.0
    streamdev-server.HTTPStreamType = 0
    streamdev-server.MaxClients = 5
    streamdev-server.VTPBindIP = 0.0.0.0


    Do you have any other ideas??


    Here is the logfile after starting streamdev-server:


    I can´t see any errors

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

    The post was edited 1 time, last by ingostar ().

  • Jaaaaaaaaa Fehler gefunden :D in
    /var/lib/vdr/plugins/streamdev-server/streamdevhosts.conf


    der Fehler war:
    192.168.100.1/24,
    hätte aber in meinem Netz
    192.168.1.1/24 sein sollen.


    Jetzt funktioniert auch das Streamen, aber ein kleiner Schönheitsfehler bleibt leider noch
    ich kann im VLC nicht alle Sender anschauen, weil einige Sender einfach übersprungen werden.
    Mir ist weiters aufgefallen, das die Kanäle am VDR nicht gleichzeitig auch umgeschalten werden.


    Wie kann ich das denn ändern?
    Im OSD menü habe ich das Pausieren für den Client erlaubt


    Bitte um Hilfe.


    lg
    ingo


    Quote

    Im OSD menü habe ich das Pausieren für den Client erlaubt

    Genau das war das Problem, hab in diesem Link:http://www.vdr-wiki.de/wiki/in…plugin#Umschaltprobleme_1
    gefunden das ich auf "immer pausieren" stellen muss.

    Zotac ION Mainboard, 2GB Ram, 1,5TB HDD, TT-Connect S2 3650 CI
    (ALT: TechniSat TechniCAM/TechniCrypt CW Cryptoworks CA-Modul)
    Aktuell: Cryptoworks CAM/CI-Modul inkl. ORF-Karte
    Yavdr

    The post was edited 2 times, last by ingostar ().