Tester gesucht libva

  • Quote

    Original von lola
    vlc hat zwar mehr Systemlast durch die bidirektionale Kommunikation, gibt doch aber Hoffnung.


    Ne ne, an sich funktioniert das Abspielen ja. Nur bei bei einem neuen Stream - in xine-lib Umschalten, in meinem Testprogramm simuliert oder beim mplayer durch springen in der Playlist - also wenn (ein) Surface(s) zerstört wird und neue erstellt werden, gibts Probleme. Anscheinend wird das nicht (richtig) freigegeben. Wenn ich nur ein File abspiele und das Progr. beende, kann ich das auch beliebig oft machen.


    edit:


    Quote

    Original von lola
    klappt das so bei Dir, bei ati/AMD müsste das doch mit -vo vaapi:gl übergeben werden


    Das geht auch ohne 'gl'.

  • Quote

    Original von tbshl-vdr
    und dabei den Speicherverbrauch beobachten.
    ... Wahrscheinlich wird er jedesmal weiter steigen


    jo ist so. CPU Last bleibt auf gleichem Niveau, MEM steigt beim springen jeweils um 4% (kann also ca. 20mal umschalten ;) )


    Gruß Fr@nk

  • Quote

    Original von lola
    jo ist so. CPU Last bleibt auf gleichem Niveau, MEM steigt beim springen jeweils um 4% (kann also ca. 20mal umschalten ;) )


    So hängts dann vom Speicher ab, wie oft man umschalten kann. Irgendwie suboptimal ;)
    Da ja einiges auf xvba als Ursache hindeutet, hab ich mal im phoronix-Forum ein Post abgesetzt.
    Hoffe man versteht mich da, aber viel und kompliziert hab ich denk ich auch nicht geschrieben...

  • Quote

    Original von tbshl-vdr
    Da ja einiges auf xvba als Ursache hindeutet, hab ich mal im phoronix-Forum ein Post abgesetzt.


    ein 'mplayer -xv -playlist usw' hat zumindest keine solchen Symptome


    übrigens das Speicherleck, welches ich in der 0.7.1 und .2 reproduzieren konnte, ist in der 0.7.4 weg. Mit mplayer habe ich diese Version seit einigen Tagen im Dauerlauf, absolut stabil, die geposteten CPU-Peaks waren ein Einzelfall/nicht mehr reproduzierbar.


    Gruß Fr@nk

  • Quote

    Original von lola
    übrigens das Speicherleck, welches ich in der 0.7.1 und .2 reproduzieren konnte, ist in der 0.7.4 weg. Mit mplayer habe ich diese Version seit einigen Tagen im Dauerlauf, absolut stabil, die geposteten CPU-Peaks waren ein Einzelfall/nicht mehr reproduzierbar.


    Das ist ja gut.


    Ja, mit 'xv' o.a. dürfte nix passieren. Ich hab das erst mit dem Testprogr. festgestellt - dort beim Abspielen alle paar Frames Surfaces zerstört und neu angelegt, wobei definitiv was nicht freigegeben wird.
    Um sicherzugehen wollte ich das ähnlich mal im mplayer einbauen, weil eigentlich tritt das nicht auf, weil der ja jedesmal beendet wird. Dann kam die Idee, dass es mit einer Playlist gehen könnte.
    Bin mir jedenfalls jetzt sehr sicher, dass da was in xvba ist, hoffentlich wird auch in nicht allzu langer Zeit was gefunden...

  • Ich hab mich ja mal im phoronix-Forum eingeklinkt, das Problem ist jetzt auch bekannt. Jetzt kann ich da aber keine Anhänge einstellen, und weiss auch grad nicht, wo ich das mal eben ablegen könnte.
    Deswegen mach ich mal nen Umweg und verweise dort auf hier und den Anhang.