Probleme mit Umlauten im EPG

  • Hi,


    ich habe seit längerem schon ein Problem mit Umlauten und dem ß.
    Zum anzeigen wird text2skin mit pearlhd und dem plugin epgsearch verwendet.


    Das komische ist, das auf der ersten seite von "ÜBERSICHT/JETZT" in epgsearch alles korrekt angezeigt wird. (Die ersten 11 Sender).
    Dort wird also äüö und ß korrekt angezeigt.
    Scolle ich jetzt weiter runter (Sender 12-usw) werden äüö und ß nichtmehr korrekt angezeigt.


    Hat einer eine Idee woran das liegt?
    Genau das Selbe Problem hatte ich auch bei einer frischen installation von yavdr 0.2.0 auf einer anderen platte. Deswegen gehe ich mal von irgend einem bug aus?! Vielleicht in epgsearch?


    Ich befinde mich auf den Screenshots in -> epgsearch:
    Menü -> Programmführer (epgsearch) -> (JETZT/ÜBERSICHT)


    info:
    vdr 1.7.15
    text2skin cvs vom 16.06.10 mit text2skin_progressbar.diff
    PearlHD
    vdr-epgsearch-0.9.25.beta16


    runvdr:

    Code
    1. export LANG=de_DE.utf8
    2. export LC_COLLATE=de_DE.utf8


    vdr output beim starten:

    Code
    1. VDR version 1.7.15 started
    2. switched to user 'root'
    3. codeset is 'UTF-8' - known


    /var/log/user.log

    Code
    1. Hier mit korrektem ß auf RTL HD:
    2. EPGSearch: timer 5 (4 1900-2040 'RTL FIFA Fußball-WM 2010: Countdown') added (active)


    Code
    1. Hier mit dem Problem auf SKY SPORT HD (aus ß wird 7/8 pder ^):
    2. EPGSearch: timer 6 (23 1315-1540 'Live Fu^ball: FIFA WM 2010') added (active)


    Und hier noch ein paar Bilder des Problems:


    OK (KANÄLE 1-11)
    [IMG:http://91.121.154.212/~usr/vdr/ok1.jpg]


    OK (EPG_DAS ERSTE HD)
    [IMG:http://91.121.154.212/~usr/vdr/ok2.jpg]


    NICHT_OK (KANÄLE 12-ENDE)
    [IMG:http://91.121.154.212/~usr/vdr/not_ok1.jpg]


    NICHT_OK (EPG SKY SPORT HD)
    [IMG:http://91.121.154.212/~usr/vdr/not_ok2.jpg]


    :lovevdr iby

  • Das hat nix mit der ersten und zweiten Seite zu tun sondern das Sky die Umlaute im EPG anders codiert als die anderen Sender.


    Der VDR sagt dazu

    Code
    1. Workaround for providers not encoding their EPG data correctly
    2. --------------------------------------------------------------
    3. According to "ETSI EN 300 468" the default character set fo SI data is
    4. ISO6937. But unfortunately some broadcasters actually use ISO-8859-9 or
    5. other encodings, but fail to correctly announce that.
    6. Users who want to set the default character set to something different can
    7. do this by setting the environment variable VDR_CHARSET_OVERRIDE to something
    8. like ISO-8859-9.


    Bei mir tuts auch ein

    Code
    1. export VDR_CHARSET_OVERRIDE="ISO-8859-9"


    in der Runvdr.


    cu

  • ich habe dieses problem leider auch (nutze runvdr extreme 0.4.2 mit vdr 1.7.14)


    in der config steht:


    Code
    1. # Set language for locale to run VDR on.
    2. # This affects sort options in recordings.
    3. LANGUAGE="de_DE.iso8859-1"
    4. # Set character set that VDR shoud use
    5. VDR_CHARSET_OVERRIDE="ISO-8859-9"


    die sky umlaute werde auch bei mir falsch dargestellt :-(


    evtl. liegt es am skin (pearlhd?)

  • Nur mal so als Idee: Ihr habt auch den VDR beendet und die epg.data gelöscht (inkl. der Kopie in /var falls das son RAMDISK System ist)?


    cu

  • Zitat

    Original von Keine_Ahnung
    Nur mal so als Idee: Ihr habt auch den VDR beendet und die epg.data gelöscht (inkl. der Kopie in /var falls das son RAMDISK System ist)?


    cu


    jap, das war das Problem, er hatte natürlich noch die alten EPG Daten


    danke !

  • Nach langem suchen und probieren bin ich auf diesen Thread gestoßen.
    Löschen der epg.data hat mein Problem behoben. :lovevdr

  • Da der Thread dann durch dich ganz nach oben gelangt ist, bin ich auch zufällig reingestolpert. Cool, das störte mich schon die ganze Zeit
    Danke!!

    HW: Asus A8N-SLI Premium | Athlon 64 3700+ | Hauppauge WinTV Nova-HD-S2 | 1Gb Kingston RAM |


    SW: Ubuntu 12.04 | VDR 2.0.2 | NVIDIA Treiber | xine-lib-1.2 | Xineliboutput Plugin (1.0.90-cvs) | Live Plugin (0.3.0) | xmltv2vdr (0.2.0pre) | scheduler-Plugin (0.1.6) | epgsearch-Plugin (1.0.1.beta5) | markad-Plugin (0.1.5pre ) | extrecmenu (1.2.2)

  • Super Sache, das werde ich nachher mal direkt testen! :D Danke!!!


    Es ist doch blöde mit diesen locales ;)

    Mein VDR: Zotac IonTX-F-E Motherboard
    Techsolo TC-2200 Gehäuse M-ATX HTPC 350W Alu
    DigitalDevices PCI-Express TWIN-DVB-S2 HDTV
    Kingston 2 X 2GB DDR2 PC2-6400
    yavdr 0.5

  • Ich hatte auch Probleme mit den Umlauten und den anderen deutschen Sonderzeichen und habe das Problem gelöst nachdem ich in die /etc/default/vdr zwei Zeilen hinzugefügt habe:
    VDR_CHARSET_OVERRIDE=UTF-8
    VDR_LANG=de_DE.UTF-8


    sudo gedit /etc/default/vdr


    # /etc/default/vdr
    #
    # See also /usr/share/doc/vdr/README.Debian.gz
    #
    VDR_CHARSET_OVERRIDE=UTF-8
    VDR_LANG=de_DE.UTF-8

    # Change to 1 to enable vdr's init-script
    ENABLED=1


    # Change this to 1 if you want vdr to be able to shutdown the
    # computer
    ENABLE_SHUTDOWN=1


    # Options that will be passed to vdr's commandline
    # for example: OPTIONS="-w 15"
    OPTIONS="-w 60"

    Ubuntu 10.04.3 Lucid + TechniSat SkyStar USB HD mit unicable
    vdr (1.7.27/1.7.27) - xineliboutput (1.0.90-cvs) - streamdev-client (0.6.0-git) - radio (0.9.0) - Radio Background-Image/RDS-Text