[0.2] shutdown funktioniert nicht

  • hrpmf,


    dann ists etwas am thema vorbei, hier gehts mehr um das extb von tbe das deswegen der shutdown nicht will...

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • also der shutdown funktioniert, ich hab nur das Problem das nach dem Suspend to Ram beim starten kein Bild da ist. Egal ob ich in der force-reload-modules.list nvidia eingetragen hab oder nicht...


    ich bin echt am verzweifeln..

    HD: yaVDR 0.3, AT3IONT-I, CINE2S, NVRAM, X10, 2.5´ 320GHDD
    SD: ctvdr 7 vdr 1.6.0, MSI 6318 (Medion2000), 667MHz, NVRRAM, WOL 500G HD
    TV: Sharp LC52XL2E (100Hz), Beamer: Sanyo Z5

  • opk,


    fehler reproduzierbar gefunden, es geht an anderer stelle weiter...

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Also bei mir passiert das gleiche mit dem Shutdown, er macht als würde er aus gehen und dann geht er wieder an, es ist aber kein Neustart im Log steht

    Code
    1. Sep 2 11:37:03 htpc vdr-shutdown: Shutdown aborted by /usr/share/vdr/shutdown-hooks/S91.lifeguard with exitcode 1

    ASUS P5QPL-VM EPU | NVIDIA GT220 | CORE2DUO | 2 GB RAM | OCZ SSD | SkyStar HD 2 | yaVDR 0.2

  • Quote

    Original von Ph0xEn
    Also bei mir passiert das gleiche mit dem Shutdown, er macht als würde er aus gehen und dann geht er wieder an, es ist aber kein Neustart im Log steht

    Code
    1. Sep 2 11:37:03 htpc vdr-shutdown: Shutdown aborted by /usr/share/vdr/shutdown-hooks/S91.lifeguard with exitcode 1


    Es scheint als ob jemand auf den VDR zugreift, Lifeguard verhindert dann das Herunterfahren.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Hallo,
    g3joker : Tut das jetzt bei Dir? Ich habe auch das extb-Board bei mir verbaut, es wird aber nie ein Timer ins extb-Board geschrieben. :(


    Wenn ich dem extb-poweroff.pl Skript auf der Kommandozeile einen Aufwachtermin mitgebe, funktioniert das prima. Leider interessiert das den VDR null...


    Gruß
    Stefan

  • hi,


    habe das thema extb aufgegeben und habe mir ein neues gehäuse mit imon gekauft, damit kann ich auch den rechner aufwachen lassen...


    timer interessieren mich nicht so wirklich da aufnahmen der vdr-server erledigt und per nfs bereitstellt.


    ich hatte es zum schluss auch so das die kiste sauber runterfährt, es lag anscheinend daran das ich, um uids und gids auf client und server zu synchronisieren, wohl irgéndwas übersehen hatte. nach dem letzten dist-upgrade funktionierte das runterfahren dann auch letztendlich (dafür s3 nicht mehr ;)).


    die timer-funktion hatte ich zwar mal getestet und es hatte auch funktioniert meine ich, mangels nutzen habe ich das aber auch nicht weiter verfolgt...


    wenn er den timer nicht ins board schreibt kann es sein das vdr zu schnell beendet bzw. das lirc zu früh abgeschossen wird...poste mal ein log hier rein, vielleicht kann ich dir helfen...

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Hi,
    im log steht dazu leider nix. Das sieht exakt so aus wie die logs auf Seite 1 des Threads.
    Ich habe mittlerweile das Originale (yavdr) S91.extb shutdown-hook-script gegen das ausgetauscht, das beim extb-plugin dabei ist (shutdown99.extb.sh)

    und dieses wieder in S91.extb umbenannt. Den Pfad auf das extb-poweroff-script angepasst dann "chmod +x S91.extb". Wenn ich das dann ausführe kommt folgender Fehler:

    Code
    1. root@vdr:/usr/share/vdr/shutdown-hooks# ./S91.extb
    2. ./S91.extb: Zeile 2: EXT_POWEROFF: Kommado nicht gefunden.
    3. ./S91.extb: Zeile 6: : Kommando nicht gefunden.


    Wenn ich "/usr/bin/extb-poweroff.pl" auf der Kommandozeile ausführe tut es wie es soll.


    Bin echt ratlos.
    Gruß
    Stefan

  • Hi,
    ich hab's nun doch hinbekommen:


    Ich habe einfach in /etc/init/vdr.conf bei shutdown den vdr-shutdown.wrapper entfernt und das extb-poweroff.pl eingetragen. Und im extb-poweroff.pl als shutdown-Befehl den vdr-shutdown.wrapper. (Und das S91.extb-shutdown-hook-script gelöscht)


    Tut nun prima. :)


    Gruß
    Stefan