[Partially solved] yaVDR: XBMC "channel can not be played" and other problems (need help)

  • Hi.


    Firstly I'd like to complement the yaVDR team - finding this had a profound "WOW!" effect on me.


    Secondly .... Hi, I'm new here. :)


    Thirdly, I'm sorry for writing in english, but my "deutsch ist nicht sehr gut". I can somewhat understand it, but my english is much better. I haven't noticed any obligatory language in the forum rules. Please correct me if I'm wrong, I'll try to translate it if necessary.


    Finally to the point: Installed the ISO, updated distro and everything...
    The first real problem I have is the XBMC VDR connection.
    I can see the channel in default VDR-HD. I can even do this:
    mplayer http://localhost:3000/6
    but XBMC says: "channel can not be played".


    XBMC log attached.


    PS: I'm not a linux novice, but I'm no expert either. Even pointers in the right direction are appriciated.



    Edit:
    Hardware info: Zotac MAG mini pc (Atom 330, nvidia ION, 2GB ram, 1Gb LAN)
    No extra TV cards or anything, only IPTV needed.


    Tried with "XBMC only" setup (my IPTV channel list as .M3U list) and worked perfectly. Even HD is running smooth - which at this moment does not work in VDR-HD for some reason, but will check this later (probably wrongly edited channels.conf).

    Dateien

    • xbmc.zip

      (9,57 kB, 218 Mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von raw ()

  • "Trying to help myself"...


    I've reinstalled the ISO, tried without updating, changed the channel.conf (added a few IPTV channels), reloaded myTV.db, checked other configs (port 2004 ...). Everything looks ok. Unfortunately still no picture in XBMC LiveTV.


    XBMC Log looks like this:


  • Whoa. You guys are fast.


    OK, here's the package list:


    Keep in mind that this is the unupdated-clean install yaVDR ISO. Will update the system again and post the results.


    Everything is default install. The XBMC was started from OSD ("m", "5" ...); also tried "start-xbmc" script but the result was the same.


    Edit: There are no recordings running in the background (have tried with recording (pause) trick that I saw on the forum somewhere, but nothing worked)

  • Here's the updated package list:
    (ran apt-get update & upgrade ...)


  • Uh, sorry for not making it obvious - yea tried that too. It's the same result.
    I'll try with mplayer once more to see if that still works.


    Edit:
    It seems it's completely the same. Stream is picked up by mplayer normally:



    XBMC doesn't show any error. Plugin should be connected and working. I also tried to access the port through netcat "nc localhost 2004" with the response: "220 Welcome to Video Disk Recorder (VTP)", so this part should also be OK.


    At this moment I don't have the slightest idea what else I can try. Any pointers maybe? Are there any version issues that you are aware of?

  • You said, you have some IPTV channels.
    There was a discussion on this board some days or weeks ago, that IPTV channels can not be streamed with streamdev-server.


    Greetings
    stefha


    edit: here: "Standart"-YAVDR-IPTV funzt nicht in XBMC
    and here: [url=http://www.vdr-portal.de/board/thread.php?threadid=93817&hilight=iptv+stream]kann ich mittels streamdev einen IPTV kanal über VTP streamen?[/url]

  • Crap. "Pardon my french"


    Any possible solutions? Is there any future releases planned to support IPTV streaming? Or maybe pointers - I want something like XBMC with PVR options running on my Zotac.


    Thanks for the help guys. [goes to the corner and :dead]

  • One possible solution could be the new VNSI-plugin, which is currently being build by hotzenplotz5 in the yaVDR-repository.


    I have the same problem, but I can not yet test.
    First, I want to teach my XBMC the RemoteControl (X10, Medion 20014752).
    Then I have to look, if XBMC in yaVDR already supports this very new technic.


    By the way, my fresh installed yaVDR runs with VDR 1.7.14 from here: https://launchpad.net/~the-vdr…+archive/unstable-plugins


    Greetings
    stefha

  • Success!


    I just forgot my Remote Control.


    I installed XBMC 29507 and vdr-plugin-vnsiserver.
    What can I say: everything works.


    I can see and enjoy my IPTV channels from Alice, especially Das Erste HD, ZDF HD and all others, that I have configured in my yaVDR in this new XBMC.


    Greetings
    stefha

  • That was fast. Congrats on success! :respekt


    I'm not exactly sure what did you do. How are you watching IPTV? Can you record it also? A small tutorial in steps? Please?

  • Ok, what I have:


    I have an Acer Revo 3600 and a WIN-TV Nova-T stick.
    Yesterday I made a fresh install of yaVDR 0.1.1.


    Here I added this https://launchpad.net/~the-vdr…+archive/unstable-plugins repository .
    With sudo apt-get update
    and then sudo apt-get upgrade
    my VDR switched to version 1.7.14.
    (1.7.14 is not necessary, if you wait some hours, the vdr-plugin-vnsiserver will hopefully be available in the normal repository for VDR 1.7.10).


    My Revo is connected to my Fritz!Box 7270, which provides IPTV from Alice and the normal Internet-connect over one single link (better said, on all ports; for the german readers: have a look at http://www.ip-phone-forum.de/showthread.php?t=190207; it runs fine for me; channel-switching is very fast, no matter if it is DVB-T or IPTV).


    My channels.conf contents a mix of DVB-T and IPTV channels.
    All of them can I watch and record fine with VDR.


    XBMC was until now not important for me.
    Then I saw your posting and remembered, that there were several people with similar problems in the last weeks. It seemed, that streaming of IPTV channels is not possible.
    I had to try by myself.
    I started XBMC (Menu, 5, XBMC).
    I could watch all DVB-T channels, but the IPTV channels gave the same error message as you described.


    pingpong invented the new VNSI (Sind Umschaltzeiten unter einer Sekunde OK? VNSI-Server für XBMC ist da!), which has several improvements over the former method of using streamdev-server.


    sudo apt-get install vdr-plugin-vnsiserver installs the plugin in the yaVDR (hopefully in some hours also for 1.7.10).


    Then I added https://launchpad.net/~henningpingel/+archive/xbmc to sources.list.
    Again sudo apt-get update
    apt-get upgrade
    This installed hepi´s new build of XBMC 29507.


    The first test was unsuccesfull, I had to delete /var/lib/vdr/.xbmc/userdata.
    Then I started XBMC again and activated the VNSI-Addon.


    The result is, that I can watch all my channels, that work in VDR, also in XBMC.


    But, be warned: there are everywhere possibilities to crash your install.
    It would be good to have a backup of your running system.


    Everything I described here, is highly experimental.
    The yaVDR maintainers always warned, that this is not for production use.


    Greetings
    stefha

  • Whoa! Thanks for all the info. Much appriciated!


    ... Trying to follow your steps:
    updated to VDR version 1.7.14
    added henningpingel PPA
    apt-get update didn't update xbmc (i think.. where's the version number in this thing?:) )


    oh, and dont worry it's for my living room "production use". :) So a crash here and there is no prob.


    Edit:
    "apt-get install xbmc" upgraded xbmc... i think.


    Edit2:
    Hmmm. None of my channels work since the update. Not even in VDR-HD ("Channel not available!"). Are there any extra settings to check? Can you post your channels.conf?


    Edit3:
    Tried everything from scratch, tested, changed a few things ... the bottom line is: since the VDR update not even the default IPTV channels (3Sat, N-TV) work


    Edit4:
    Saw the IPTV version change (0.4.1), changed the channels.conf a bit, now the default channels work! Checked the VNSI in XBMC and is also OK - I can see the channels! Nice.
    Now I need to fix my IPTV channels entries also 'cause they are not working ATM. Any pointers at the channels.conf structure?

  • Made some progress.
    Tried different formats for the channel string in channels.conf, now I can see my IPTV channel in VDR-HD and XBMC.


    Now to the next two problems.
    1. HD IPTV channels don't work ("channel not available"). I'm assuming channels.conf configuration is to blame.


    2. While watching channel with VDR-HD, "top" reveals that xine takes about 10% of CPU and VDR 6%.
    If I run XBMC, watch LIVE TV (same channel) it's OK at first, but when I try to change channel a vlc process gets stuck and it takes 100% CPU. If I close XBMC the vlc process stays there. While playing with XBMC, more than one vlc process can be stuck. (solution: "killall vlc").


    Edit:
    Tried playing a HD movie from windows share in XBMC. Started OK but after 10 minutes all CPU cores were on 100% (atom 330) and 8 vlc processes running and stuck. ??


    Edit2:
    Removed default IPTV channels from the channels.conf and added a few of my own. Tested XBMC LiveTV for an hour without any problems.


    At the moment the biggest problem is HD IPTV channels. Still can't get it to work.

  • Is there a way to convert a .M3U to channels.conf ?
    I have all my channels listed the playlist. HD's still not playing ...


    The .M3U looks like this:


  • Okay. I added one HD program through VDR-HD OSD somehow. It sort of works in VDR (video stutters), but if I try to open it in XBMC/Live TV, XBMC crashes every time... gotta check the logs. (larger buffer for HD?)


    Edit: As I suspected - the default buffer sizes are too small. For testing I maxxed them out. Now HD is playing smooth - even in XBMC. Will try to find the best buffer size later.


    Now I have to find out why XBMC won't record (record and pause buttons are grayed out).


    Edit2: Changed some options in VNSI plugin in XBMC. Now recording button is enabled while watching IPTV. I can start and finish the recording but the recording videos are not seen in XBMC or specified folder.
    Another thing is the pause button. It's still disabled. I can however pause in OSD (TV LIVE options - tab button shows some options on the left panel, including pause.) unfortunately this works only for 10 seconds, then XBMC crashes.

  • Current status (yaVDR 0.1.1 with updated VDR & XBMC, using VNSI ):


    Works:

    • IPTV (VNSI) plugin
    • SD & HD channels (buffers need some fine tuning)


    Problems:

    • XBMC crashes from time to time. (surfing the channels usually - pid problems?)
    • Recording & Pause don't work.


    ... about recording: After 10-20secs XBMC crashes. There are no recordings in specified folder. Pause button is disabled when watching TV (top OSD menu - TV is fullscreen).


    Current VNSI plugin settings:
    hostname: 127.0.0.1
    port: 34890
    priority: 70
    Charset conver: Enabled
    Timeout: 5
    VDR messages: Enabled
    Read recordings from dir: Enabled
    VDR recordings dir: /media/recordings/ (permissions are set to all)



    ToDo:

    • EPG
    • Remote control config