Sind Umschaltzeiten unter einer Sekunde OK? VNSI-Server für XBMC ist da!

  • edit:


    Habe nun alles gebaut und schon ein wenig getestet!


    Also Plugin kompiliert funktioniert in dem man einfach mit apt-get source die Sorucen des Paketes holt und die aktuelleren Sourcen drüberkopiert und neu baut.


    Umschaltzeiten: Absolut genial! Hätte nicht merh gedacht dass dies möglich ist :-)
    Keine Klötzchenbildung oder ähnliches, nur ganz kurze Verzögerung bis das Bild da ist aber das wird wohl nicht vermeidbar sein!


    Aufnahmen abspielen und Spulen funktioniert einwandfrei.


    Signalqualität anzeigen funktioniert auch, wobei es bei mir durchgehend bei 97% ist? Ist das okay so, hab mir das noch nie angesehen? :-)


    Ein paar Dinge sind mir aufgefallen:


    * Die Senderliste scheint mir etwas durcheinander gebracht zu worden sein?


    * Das Umschalten funktioniert noch nicht ganz perfekt, weiß aber nicht genau wie ich das beschreiben soll. Ist es möglich dass in XBMC mit Pfeil auf und ab auch ncoh was anderes außer den Sendern gesteuert wird? Also der 10min-Vorsprung z.B.? Dass es da vielleicht noch manchmal Probleme gibt? Werde mich aber deswegen wieder melden wenn ich mehr herausgefunden habe.


    * Die geschnittenen Aufnahmen werden ohne %Zeichen angezeigt, planst du da noch etwas zu ändern? Ist nämlich leider so etwas unübersichtlich.


    * Per Keyboard kann man noch Schnell Vor- und Rücklauf aktivieren. (Bin zufällig darauf gestoßen als ich die Zoom-Funktion von XBMC suchte)



    Ansonsten bin ich schon ganz begeistert davon!


    mfg

  • hi,


    ich habe mal die Aktuelle svn29121 und das neue vdr-plugin kompiliert und installiert.
    soweit so gut,
    das Problem, wenn der neue pvr-klient aktiviert ist und ich vom live-tv ins menü will bleibt alles dunkel.
    Es werden die Skin xml und einige andere Sachen nicht mehr gefunden.
    Die Probleme treten sowohl nach einem XBMC /VDR (mit neuem Plugin)-UPDATE (debian testing vom 1.4.10 als auch bei einer frischen Installation von heute auf)


    mfg
    jobit

    Files

    OpenElec auf raspberry pi / Cubieboard2
    Fernbedienungen: Handy, Fhem

    The post was edited 4 times, last by jobit ().

  • Wie bekommt man den pvr-klient in das aktuelle XBMC von yaVDR? Muß ich mir die PVR testing Sourcen ziehen und neu bauen? Das VDR-PlugIn hab ich von Seite 1 installiert, aber es gibt keine PlugIn Einstellungen, ist das richtig? Kommt es Streamdev in die quere oder kann man beide parallel laufen lassen?
    Ich hoffe ich bin nicht zu offtopic mit meinen Fragen. Danke im Voraus

  • super, hab nur im testing-xbmc noch nichts gefunden gehabt :-)


    und um das aktuelle Plugin zu kompilieren quote ich mich selbst:


    Quote

    Also Plugin kompiliert funktioniert in dem man einfach mit apt-get source die Sorucen des Paketes holt und die aktuelleren Sourcen drüberkopiert und neu baut.


    mfg

  • Quote

    Original von aelo
    Also Plugin kompiliert funktioniert in dem man einfach mit apt-get source die Sorucen des Paketes holt und die aktuelleren Sourcen drüberkopiert und neu baut.


    Darf ich mal fragen aus welchem Rep du die Sourcen mit apt-get holst? Tobi ja wahrscheinlich nicht oder?


    Gruss
    G.

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • @ a-user


    Ist im Source Zweig dabei wenn du pvr-testing lädst.


    Gruss,
    G.

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • verzeih, aber ich lad normalerweise die packete von hepi, also schon compiliert. die aktuellen haben auch schon das xbmc-client blugin drinn.


    aber woher bekomme ich, bzw wie bekomme ich das server plugin für vdr?


    ausserdem steht doch hier, dass im repro eben nciht die aktuelle ist, sondern man erst die aktuelle source da erst drüber kopieren soll. also ich steh auf den schlauch...

  • aelo


    Danke, werde mir das mal temporär einrichten und das Plugin runterladen, die Sourcen habe ich gerade per svn up auf den neuesten Stand gebracht.


    Hoffentlich baut es auch problemlos mit meinem c't vdrdevel 1.7.14...


    Zunächst einmal muss der xbmc build durchlaufen. Hatte da ein paar Fehler sodass ich erstmal einen make clean losgelassen habe.


    Wir werden sehen,
    G.

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • Servus,


    hab jetzt das ganze mit VNSI in einem HowTo zusammengefasst: http://schnere.bveml.net/node/11 .
    Verwendet wird dabei e-Tobi's VDR 1.7.14 unter Ubuntu 9.10 . Würde mich freuen, wenns jemand testet.



    Bei mir funktionieren übrigens auch die h264-Kanäle, aber wieder teilweise ohne vdpau, wodurch es auch bei einem Athlon 64 6000+ teilweise zu Rucklern kommt.
    Auch Aufnahmen, EPG funktioniert alles wunderbar, nur femon spuckte bei einem kurzen Test keine Daten aus.
    Wie ich das verstanden habe, bekommt XBMC jetzt die Aufnahme-Pfade direkt vom VDR? Beim VNSI-Plugin gibt es nämlich eine Option, um den Aufnahme-Pfad anzugeben, was bei mir ein Problem sein dürfte, da ich /var/lib/video.00, /var/lib/video.01, etc. nutze.


    pingpong : vielen Dank, klasse Arbeit!


    MfG

    VDR: AMD E-450, 8GB RAM, 120GB SDD | Ubuntu 13.10 | yaVDR 2.0.4 streamdev-server, femon, live, vnsi, xmltv2vdr, iptv, epgsearch | DVB-C | XBMC Gotham
    Client1: OUYA | XBMC Gotham, VNSI
    Client2: Zotac ZBox HD-ND22 | XBMC Gotham, VNSI

  • I've checked the code quickly, and saw interesting features as native Timers & recording management without svdrp & some get frame functions to handle probably FFD/RWD and jump in recordings isn't it ?


    Could you just list the actual & planned features, and what it brings against streamdev pvr client ?



    Thanks a lot for your work. I'm in the hurry to test this :)

  • Quote

    Original von a-user
    schnere :
    danke, werd mir das mal genauer anschaun.
    eines nur, für die wintv nova hd2 bracuht man nicht die lipliani treiber. da sind schon kernel treiber dabei. einzig die firmware ist ggf. zu kopieren.


    thx für die Info, habs angepasst. Ein paar Altlasten sind teilw. nicht zu vermeiden ;)

    VDR: AMD E-450, 8GB RAM, 120GB SDD | Ubuntu 13.10 | yaVDR 2.0.4 streamdev-server, femon, live, vnsi, xmltv2vdr, iptv, epgsearch | DVB-C | XBMC Gotham
    Client1: OUYA | XBMC Gotham, VNSI
    Client2: Zotac ZBox HD-ND22 | XBMC Gotham, VNSI

  • hmm, ich weiß jetzt nicht genau ob ich das heir fragen sollte, aber ich hab die hoffnung einer von euch weiß was dazu. hepi hat ja seine pakete aktualisiert. und diese version funzt nu plötzlich nicht mehr mit streamdev. im log wird zwar mit vdr verbunden, aber laut log enthält der stream keine video und audio daten.


    einzig "das erste hd" klappt und für ca 2 sec klappte einmal ndr.


    liegt das an hepis build? oder auch an den aktuellen quellen?


    ... werd wohl mal xbmc selbst kompilieren müssen.

  • Quote

    Original von schnere
    thx für die Info, habs angepasst. Ein paar Altlasten sind teilw. nicht zu vermeiden ;)


    Das "--enable-vdpau" ist afaik auch nicht mehr nötig.


    Auch von mir vielen Dank an Pingpong für die Super Arbeit, ich teste gleich auch mal :)

    silence: Ubuntu 9.10 | Asus M3N78-VM | AMD 4450e | TT-budget S2-1600 DVB-S2 | 5 X 1TB Raid5 | vdr (1.7.10) | xbmc opdenkamp master | Optoma HD65 Beamer | Samsung LE37B530 LCD | Onkyo 605 AVR | Heco Victa 700/300/100/25A


  • FFD/RWD when playing recordings works perfectly now, I tested it yesterday.


    You can find a (German) TODO-List here:
    http://vdr-portal.de/board/thread.php?threadid=93638


    nice regards