Automatisches herunterfahren nach Aufnahme

  • Hallo!


    ich hatte den yaVDR heute morgen in den S3 geschickt.
    Um 17.30 hatte ich einen Timer gesetzt.
    Der yavdr hat sich zur richtigen Uhrzeit eingeschaltet und
    die Aufnahme gestartet.
    Nach der Aufnahme ist der yaVDR aber nichtmehr in den S3
    gegangen, sondern ist einfach angeblieben.


    Was läuft hier falsch?


    Gruß,
    Peter

  • Ja! Es war ein Bildschirmschoner an, das müsste der suspend output sein.
    Nach 2 Stunden macht er das sowie ich es verstehe.


    Gibt es eine möglickeit, das der VDR wieder in S3 geht, wenn ein Timer abgelaufen ist?

  • Seh ich das richtig?
    VDR ausschalten bei Inaktivität (min) steht auf 300 Minuten.


    Der Suspend Output geht nach 120 Minuten an. Ist der Suspend Output eine dauerhafte
    aktivität? Da die 300 Minuten Inaktive timer nicht gegriffen haben.

  • Hallo,


    das wäre interessant zu wissen, da ich genau das selbe Problem habe mein Rechner zwar zum programmierten Timer hochfährt und die Aufnahme startet, jedoch nach der Aufnahme nicht mehr selbst ausschaltet. Wenn ich nach der Aufnahme die Powertaste auf der Ferbedienung drücke, startet der PC jedoch jedes mal durch, also fährt in S3 und schalten sich sofort wieder ein und fährt wieder in den VDR.


    Meine Hardware: Zotac MAG, USB-DVB-TT-s2400 connect

  • Quote

    Original von peter2
    Nach der Aufnahme ist der yaVDR aber nichtmehr in den S3
    gegangen, sondern ist einfach angeblieben.


    Schau doch mal im syslog, ob da im fraglichen Zeitraum etwas von "PM: finishing wakeup" steht. Wenn ja, geht's dir wie Chris_AS und mir: das Board geht nur einmal in S3, jeder weitere Versuch führt stattdessen zum direkten Wiederaufwachen (die Kiste ist also nicht angeblieben, sondern nur direkt neu gestartet).


    Ich fürchte, das ist ein Hardware- bzw. BIOS-Problem, das nicht Linuxseitig gefixt werden kann (würde mich aber liebend gern eines Besseren belehren lasssen).


    Wer alkoholfreies Bier trinkt, wählt auch kompetenzfreie Politiker [frei nach Volker Pispers]

    The post was edited 1 time, last by NullP ().

  • Also ich musste gerade feststellen, als ich meine Aufnahme von Montag und heute gucken wollte, das der VDR zwar angegangen ist, aber wohl irgentwie
    hängen geblieben ist, da er gar nichts aufgenommen hat. Das ist vieleicht nun
    auch die Erklärung, warum er nicht heruntergafhren ist.


    Frag ich mich jetzt allerdings wieso der yaVDR aus dem S3 nicht ordentlich
    startet.


    Gibt es micro ATX Boards, bei denen man weis das das S3 Wakeup und auch wieder in S3 gehen ordentlich funktioniert.
    Ich suche ein Board mit Sockel 775 und DDR2 Speicher.

  • Quote

    Original von Chris_AS
    Was nutzt du denn für eine Hardware? Hast du schon eine Lösung für unser Problem?

    HW siehe Sig.
    Bin noch am Basteln.
    Die von Sven erwähnten Threads habe ich natürlich alle verfolgt, haben mich keinen Deut weiter gebracht (oder ich hab was überlesen); mit entladen oder doch-nicht-entladen des einen oder anderen Moduls lässt es sich nach meinen Versuchen nicht beheben.
    Was dvb-Treiber betrifft: zwangs-reload bewirkt immerhin, dass die Tuner nach dem ersten resume wieder funktionieren, hat aber keine Auswirkung auf das Versagen des nächsten suspend.
    Mein Problem mit dem Grafiktreiber: einer der Lösungsvorschläge geht davon aus, dass es am Entladen des nvidia-Treibers liegt, das man deswegen abstellen sollte - bei mir scheitert das Entladen aber sowieso, also kann's das eigentlich nicht sein. Also habe ich mal den umgekehrten Weg versucht, den Treiber also doch zwangsweise zu entladen, was aber nur bestätigt hat, das der das gar nicht mag...


    Wenn (falls?) ich weiterkomme, geb' ich Laut ;)


    Wer alkoholfreies Bier trinkt, wählt auch kompetenzfreie Politiker [frei nach Volker Pispers]

  • Was ist den jetzt der gangbare Weg, dass das automatsiche Hochfahren und Herunterfahren vor und nach einer Aufnahme funktioniert. Aus dem FAQ werde ich nicht
    schlau, da alle Tips, die dort zu S3 stehen, nicht funktionieren.


    Ich hab das Gefühl, dass mein TestVDR aus dem S3 nicht richtig hochfährt, wenn der LCD TV aus ist, also wenn nichts angeschlossen ist.

  • Quote

    Original von peter2 Aus dem FAQ werde ich nicht
    schlau, da alle Tips, die dort zu S3 stehen, nicht funktionieren.


    Geht mir leider auch so.


    Quote

    Original von peter2Ich hab das Gefühl, dass mein TestVDR aus dem S3 nicht richtig hochfährt, wenn der LCD TV aus ist, also wenn nichts angeschlossen ist.


    Wenn's wirklich daran liegt, sollte das mit einer geeigneten xorg.conf lösbar sein - automatische Erkennung abschalten und Modelines fest vorgeben, evtl. eigene edid.bin vorgeben. Dazu hat's im Forum etliche Beispiele, auf wbreu's website gibt's auch Beispiele zum download.


    Ich habe inzwischen recherchiert, dass das Problem auf verschiedenster Hardware schon seit Jahren immer mal wieder mit bestimmten Treiberversionen von nvidia auftritt, scheint ein Dauerbrenner zu sein, der sich mit etwas Glück irgendwann mit einer kommenden Treiberversion von selbst erledigt. Ich verzichte jetzt erstmal auf S3, obwohl ich es dringend bräuchte, da ich von usb-stick boote - dauert trotz teurem hi-speed-200x-stick ewig.


    Ach ja, zum ursprünglichen topic: der vdr fährt trotzdem nach einer Aufnahme nicht runter. Beim Start steht im log etwas von "assuming automatic start" oder ähnlich, aber trotzdem schaltet er nur auf suspendoutput.
    Deswegen stellt sich auch mir jetzt die noch offene Frage:

    Quote

    Original von peter2Ist der Suspend Output eine dauerhafte
    aktivität? Da die 300 Minuten Inaktive timer nicht gegriffen haben.


    Das Gleiche Problem übrigens auch ohne wakeup o.ä. - bei Ausschaltversuch im laufenden Betrieb und laufender Aufnahme kommt zwar der Hinweis, dass eine Aufnahme läuft, aber nach Aufnahmeende bleibt er auch an (mit suspendoutput).


    Wer alkoholfreies Bier trinkt, wählt auch kompetenzfreie Politiker [frei nach Volker Pispers]

  • sorry, doppelpost


    Wer alkoholfreies Bier trinkt, wählt auch kompetenzfreie Politiker [frei nach Volker Pispers]

    The post was edited 1 time, last by NullP ().

  • Das Plugin vdr-plugin-suspendoutput scheint zum yavdr-essential zu gehören.


    Wenn ich es entferne, will es auch yavdr-essential entfernen.


    Dadurch bekomme ich im Nachgang die Meldung das dutzend andere Pakete mit autoremove entfernen soll.


    Das natürlich nicht so schick, aber ich ignoriere es ;)

    MAIN: La Scala SST-LC04 Gehäuse / Asus P5N7A-VM / Intel E7500 / YaVDR 0.1 / TT-DVB-S2 / IR-Einschalter Atric / Wakeup-On-Call


    ICH: Bin Microsoft, Cisco, VMware und NetApp zertifiziert

  • Mich interessiert jetzt mal der Grund, warum suspendoutput überhaupt mit zur Standardinstallation von yaVDR (ist das so?) gehört.


    Lt. VDR-Wiki


    Quote

    Das Plugin zeigt ein Standbild anstelle von einem Live-Programm an.
    Es gibt den aktuellen Kanal für Aufnahmen frei und spart etwas Rechenzeit der CPU.
    Das Ausschalten der Bildanzeige, während die Wiedergabe angehalten wurde (Pause/Standbild), kann das Einbrennen von Bildinformationen verhindern.


    ist das doch bei heutigen LCDs doch nicht mehr notwendig? Wenn der VDR nach Timeout (120/180/whatever Minutes) runterfährt, brennt doch ein Schwarzbild nicht ein?


    Bitte um sachliche Aufklärung...


    BJ1

  • Quote

    Original von BJ1
    ist das doch bei heutigen LCDs doch nicht mehr notwendig? Wenn der VDR nach Timeout (120/180/whatever Minutes) runterfährt, brennt doch ein Schwarzbild nicht ein?

    Zumal neuere Geräte - egal, ob Monitor oder TV - sich sowieso selbst ausschalten, wenn kein Signal anliegt.
    Aber was soll's, man kann das Plugin ja auch manuell entfernen oder (wie ich) den Timeout auf Null stellen, dann klappt's wieder mit dem runterfahren.


    Wer alkoholfreies Bier trinkt, wählt auch kompetenzfreie Politiker [frei nach Volker Pispers]


  • Na und? Was ist mit der 2. Begründung? Ist aber auch egal, das Plugin ist sowieso schon längst draußen.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470