Erfahrungsberichte zur jeweils aktuellen pvr-testing2 Version

  • SVN 29768


    Laufzeit 4 Stunden


    System: Debian Testing Stand 04.05.2010, VDR 1.7.14, VNSI Server, wirbelscan-0.0.5-pre11e, derzeit aktuellste pvr-testing2 SVN Version.


    Erfahrungsbericht:
    Kompilieren ----------------------------> OK
    deb-Pakete bauen -------------------> OK
    Installation bzw.Update ------------> OK
    Einrichten -------------------------------> OK
    Erweiterungen -------------------------> OK
    pvr-Client-VNSI -----------------------> OK
    Signalqualität Anzeige -------------> OK
    Zeitleiste --------------------------------> OK
    Radiosender ----------------------------> OK
    TeleText -----------------------------------> OK
    Live-TV Vollbild EPG ---------------> OK
    Aufnahme-Verzeichnis ---------------> Fehler ----> keine Aufnahmen sichtbar
    Kanalsuche-Menü ----------------------> OK
    Kanalsuche DVB-S ohne HD-----> teilweise --> Fortschritt-Anzeige bleibt bei 2% stehen, Deaktivierte Kanäle werden auch in die Kanalliste aufgenommen.
    Direktaufnahme -----------------------> OK ----> Während der Aufnahme CPU-Last ca 30-35% (ohne VDPAU) --> wird die Aufnahme dann z.b. manuell beendet ist alles soweit OK, Live-TV läuft, XBMC kann weiter bedient werden aber die Aufnahme ist unter XBMC nicht im Aufnahmeordner sichtbar.
    45sek. nach beendeter Aufnahme steigt die CPU-Last wieder auf 100 % ( Aufnahme liegt jetzt in (video.00). Live-TV läuft weiter aber XBMC kann nicht mehr bedient werden. Schaltet man jetzt von
    Live-TV-Vollbild auf das Hauptmenü bleibt der Bildschirm dunkel, schaltet man zurück erscheint das Live-TV Bild wieder. Im log sind dann wirre Meldungen, dass z.B. ...xml Dateien nicht gefunden werden usw.


    bisher 3 Abstürze beim umschalten.


    mfg
    jobit

    OpenElec auf raspberry pi / Cubieboard2
    Fernbedienungen: Handy, Fhem

    The post was edited 3 times, last by jobit ().

  • SVN 29790


    Laufzeit 2 Stunden


    System: Debian Testing Stand 05.05.2010, VDR 1.7.14, VNSI Server, wirbelscan-0.0.5-pre11e, derzeit aktuellste pvr-testing2 SVN Version. (mit Gnome Desktop)


    Erfahrungsbericht:
    Kompilieren ----------------------------> OK
    deb-Pakete bauen -------------------> OK
    Installation bzw.Update ------------> OK
    Einrichten -------------------------------> OK
    Erweiterungen -------------------------> OK
    pvr-Client-VNSI -----------------------> OK
    Signalqualität Anzeige -------------> OK
    Zeitleiste --------------------------------> OK
    Radiosender ----------------------------> OK
    TeleText -----------------------------------> OK
    Live-TV Vollbild EPG ---------------> OK
    Aufnahme-Verzeichnis ---------------> Fehler ----> keine Aufnahmen sichtbar
    Kanalsuche-Menü ----------------------> OK
    Kanalsuche DVB-S ohne HD-----> teilweise --> Fortschritt-Anzeige bleibt bei 2% stehen, Deaktivierte Kanäle werden auch in die Kanalliste aufgenommen.
    Direktaufnahme -----------------------> OK ----> Während der Aufnahme CPU-Last ca 30-35% (ohne VDPAU) --> wird die Aufnahme dann z.b. manuell beendet ist alles soweit OK, Live-TV läuft, XBMC kann weiter bedient werden aber die Aufnahme ist unter XBMC nicht im Aufnahmeordner sichtbar.
    45sek. nach beendeter Aufnahme steigt die CPU-Last wieder auf 100 % ( Aufnahme liegt jetzt in (video.00). Live-TV läuft weiter aber XBMC kann nicht mehr bedient werden. Schaltet man jetzt von
    Live-TV-Vollbild auf das Hauptmenü bleibt der Bildschirm dunkel, schaltet man zurück erscheint das Live-TV Bild wieder. Im log sind dann wirre Meldungen, dass z.B. ...xml Dateien nicht gefunden werden usw.


    mfg
    jobit

  • jobit : Danke für Deine gute und unermüdliche Testarbeit.


    Vorschlag: Die beiden Skin-Pakete werden zu leeren Pakethülsen, die keinen Schaden anrichten. (Sonst kommte es zu Problemen beim apt-get upgrade)
    Dafür füge ich ein neues Paket hinzu namens xbmc-addons, wo einfach alle Addons reinkommen. Dann mache ich xbmc-bin abhängig von xbmc-addons, damit das automatisch installiert wird.


    (Das ist natürlich nur ein Workaround für uns, weil Addons ja später mal per Repository nachinstalliert werden können sollen.)


    Wenn Du nix dagegen hast, poste ich hier einen Patch, sobald ich das gemacht habe.


    Gruß
    hepi


  • warum sollte ich was dagegen haben, immer rein damit. Wäre vielleicht auch schön gleich eine Erfahrungsbericht mit zu posten. Dann bleibt das ganze hier schön sauber, man hat sofort einen Überblick (vor allem pingpong !!) und es gibt eine zentrale Stelle wo man nicht hunderte Beiträge lesen muss nur um zu wissen wie der aktuelle Stand ist.
    übrigens benutze ich schon seit anfang an seit ( pvr-testing ) ein separates xbmc-addons.install beim packen


    mfg
    jobit

    OpenElec auf raspberry pi / Cubieboard2
    Fernbedienungen: Handy, Fhem

    The post was edited 3 times, last by jobit ().

  • Quote

    Original von a-user
    hättest du deinen post nicht einfach editieren können mit statt alles + die mini änderung als zitat nochmal zu posten?


    so bleibt der thread alles andere als sauber -.-


    @ a-user Erstmal an die eigene Nase fassen denn hell sehen kann hier niemand.

    Quote

    kein timeshift: man kann tv-playback nicht mehr pausieren.


    Quote

    alles klar, dann verhunz ihn halt selber weiter. so ein schwachsinn....


    und immer schön sachlich bleiben.
    ich wünsche dir das du niemals ein doppel post machen mögest !


    hättest du nicht erst den aller ersten post hier lesen können !


    so, nun aber genug Diskussion hier


    mfg
    jobit

    OpenElec auf raspberry pi / Cubieboard2
    Fernbedienungen: Handy, Fhem

    The post was edited 2 times, last by jobit ().

  • SVN 29790 mit pingpong's Anpassung in VNSIData.cpp Zeile 641 ( bool haveCheckedLocalAccess = false; auf true)


    Laufzeit 1 Stunden


    System: Debian Testing Stand 05.05.2010, VDR 1.7.14, VNSI Server, wirbelscan-0.0.5-pre11e, derzeit aktuellste pvr-testing2 SVN Version. (minimal Installation nur X,vdr,pvr-testing2)
    Compiler gcc version 4.4.3 20100108 (prerelease)
    OS 32bit
    User xbmc=mce, vdr=vdr


    Erfahrungsbericht:
    Kompilieren ----------------------------> OK
    deb-Pakete bauen -------------------> OK
    Installation bzw.Update -------------> OK
    Einrichten -------------------------------> OK
    Erweiterungen -------------------------> OK
    pvr-Client-VNSI -----------------------> OK


    Live-TV & Radio:
    Signalqualität Anzeige ---------------> OK
    Zeitleiste --------------------------------> OK
    Radiosender ----------------------------> OK
    TeleText ---------------------------------> OK
    Live-TV Vollbild EPG -----------------> OK
    Kanalsuche-Menü ----------------------> OK
    Kanalsuche DVB-S ohne HD-----> teilweise --> Fortschritt-Anzeige bleibt bei 2% stehen, Deaktivierte Kanäle werden auch in die Kanalliste aufgenommen.


    VDR Aufnahmen:
    Aufnahme-Verzeichnis ---------------> teilweise --> siehe weiter unten
    Direktaufnahme -----------------------> OK
    Timer-Aufnahme ----------------------> OK
    Wiedergabe ----------------------------> OK
    Spulen -----------------------------------> nein


    100% CPU-Last Problem tritt nicht auf so lange die Aufnahmen unter "video.00" liegen.
    Dabei ist es völlig egal ob video.00 ein link oder das original vdr Aufnahmeverzeichnis ist. Es werden alle (vdr-1.6 bis vdr-1.7.14) Aufnahme-Formate angezeigt und abgespielt :)
    ABER wenn unter Erweiterungen vnsi.... konfigurieren ein anderes Verzeichnis aktiviert wird
    (auch wenn es das selbe wie das weiter oben erwähnte ist (link auf video.00) steigt die CPU-Last auf 100% !!!




    mfg
    jobit

    OpenElec auf raspberry pi / Cubieboard2
    Fernbedienungen: Handy, Fhem

    The post was edited 4 times, last by jobit ().

  • Revision 29790


    mit ./configure --enable-goom


    wird nicht durchkompiliert.....goom.vis fehlt
    ist aber schon seit einigen Revisionen so....ca. ab 23.04.2010
    Tschau, Karsten.

    Mein VDR: LianLi-Gehäuse, AMD X2 64 5200+ auf Biostar TA690G, 768MB Ram, 250 GB HD, TT S3200, ne Airstar2 DVB-T und nen Touchpanel:-), Ubuntu Karmic , VDR 1.7.12 Extensionpatch mit x-vdr gebaut.

    The post was edited 1 time, last by kwacker ().

  • SVN 29874 mit pingpong's Anpassung in VNSIData.cpp Zeile 641 ( bool haveCheckedLocalAccess = false; auf true) (Skin-Update)


    Laufzeit 10 min


    System: Debian Testing Stand 05.05.2010, VDR 1.7.14, VNSI Server, wirbelscan-0.0.5-pre11e, derzeit aktuellste pvr-testing2 SVN Version. (minimal Installation nur X,vdr,pvr-testing2)
    Compiler gcc version 4.4.3 20100108 (prerelease)
    OS 32bit
    User xbmc=mce, vdr=vdr


    Erfahrungsbericht:
    Kompilieren ----------------------------> OK
    deb-Pakete bauen -------------------> OK
    Installation bzw.Update -------------> OK
    Einrichten -------------------------------> OK
    Erweiterungen -------------------------> OK
    pvr-Client-VNSI -----------------------> OK


    Live-TV & Radio:
    Signalqualität Anzeige ---------------> OK
    Zeitleiste --------------------------------> OK
    Radiosender ----------------------------> OK
    TeleText ---------------------------------> OK
    Live-TV Vollbild EPG -----------------> OK
    Kanalsuche-Menü ----------------------> OK
    Kanalsuche DVB-S ohne HD-----> teilweise --> Fortschritt-Anzeige bleibt bei 2% stehen, Deaktivierte Kanäle werden auch in die Kanalliste aufgenommen.


    VDR Aufnahmen:
    Aufnahme-Verzeichnis ---------------> teilweise --> siehe weiter unten
    Direktaufnahme -----------------------> OK
    Timer-Aufnahme ----------------------> OK
    Wiedergabe ----------------------------> OK
    Spulen -----------------------------------> nein


    100% CPU-Last Problem tritt nicht auf so lange die Aufnahmen unter "video.00" liegen.
    Dabei ist es völlig egal ob video.00 ein link oder das original vdr Aufnahmeverzeichnis ist. Es werden alle (vdr-1.6 bis vdr-1.7.14) Aufnahme-Formate angezeigt und abgespielt smile
    ABER wenn unter Erweiterungen vnsi.... konfigurieren ein anderes Verzeichnis aktiviert wird
    (auch wenn es das selbe wie das weiter oben erwähnte ist (link auf video.00) steigt die CPU-Last auf 100% !!!




    mfg
    jobit

  • SVN 29909 mit pingpong's Anpassung in VNSIData.cpp Zeile 641 ( bool haveCheckedLocalAccess = false; auf true) (Skin-Update)


    Laufzeit 4 Stunde


    System: Debian Testing Stand 07.05.2010, VDR 1.7.14, VNSI Server, wirbelscan-0.0.5-pre11e, derzeit aktuellste pvr-testing2 SVN Version. (minimal Installation nur X,vdr,pvr-testing2)
    Compiler gcc version 4.4.3 20100108 (prerelease)
    OS 32bit
    User xbmc=mce, vdr=vdr


    Erfahrungsbericht:
    Kompilieren ----------------------------> OK
    deb-Pakete bauen -------------------> OK
    Installation bzw.Update -------------> OK
    Einrichten -------------------------------> OK
    Erweiterungen -------------------------> OK
    pvr-Client-VNSI -----------------------> OK --> Nach einiger Zeit Meldung "vnsi client - vdr wird in xmin yy seccunden beendet".
    Meldungen erscheinen obwohl shutdown im VDR deaktiviert ist.
    Meine vorläufige Lösung
    /var/lib/vdr/setup.conf MinUserInactivity = 300 auf MinUserInactivity = 3000 setzen.


    Live-TV & Radio:
    Signalqualität Anzeige ---------------> OK
    Zeitleiste --------------------------------> OK
    Radiosender ----------------------------> OK
    TeleText ---------------------------------> OK
    Live-TV Vollbild EPG -----------------> OK
    Kanalsuche-Menü ----------------------> OK
    Kanalsuche DVB-S ohne HD-----> teilweise --> Fortschritt-Anzeige bleibt bei 2% stehen, Deaktivierte Kanäle werden auch in die Kanalliste aufgenommen.


    VDR Aufnahmen:
    Aufnahme-Verzeichnis ---------------> teilweise --> siehe weiter unten
    Direktaufnahme -----------------------> OK
    Timer-Aufnahme ----------------------> OK
    Wiedergabe ----------------------------> OK
    Spulen -----------------------------------> nein


    100% CPU-Last Problem tritt nicht auf so lange die Aufnahmen unter "video.00" liegen.
    Dabei ist es völlig egal ob video.00 ein link oder das original vdr Aufnahmeverzeichnis ist. Es werden alle (vdr-1.6 bis vdr-1.7.14) Aufnahme-Formate angezeigt und abgespielt smile
    ABER wenn unter Erweiterungen vnsi.... konfigurieren ein anderes Verzeichnis aktiviert wird
    (auch wenn es das selbe wie das weiter oben erwähnte ist (link auf video.00) steigt die CPU-Last auf 100% !!!




    mfg
    jobit

    OpenElec auf raspberry pi / Cubieboard2
    Fernbedienungen: Handy, Fhem

    The post was edited 4 times, last by jobit ().

  • hi jobit.
    kurze Frage: was meinst du mit "skin-update"?


    Gruß

    VDR1: yavdr 0.5.0 beta auf einem ASUS P5QPL-AM mit Tevii S480
    VDR2: debian-SERVER (dockstar) mit 3x Nova-T-USB-Sticks und yavdr 0.4 auf Zotac Ion-A als client

  • 30871: Debian-Pakete werden erfolgreich erstellt, XBMC crasht aber beim Start wegen fehlernder Libs.
    Abhilfe bringt dieser Patch: Rev. 30823, 30871 Some problems


    XBMC crasht nun mit bestehendem Profilordner, ich benutze einen frischen Ordner und es läuft erstmal. Aber: Ich schaffe es nicht, den PVR-VNSI-Klienten erfolgreich zu aktivieren, im Log steht:


    Code
    1. 01:12:00 T:140037784762432 M:2885545984 DEBUG: PVR: VDR VNSI Client - Creating PVR-Client AddOn
    2. 01:12:00 T:140037784762432 M:2885545984 DEBUG: ADDON: Dll Initializing - VDR VNSI Client
    3. 01:12:00 T:140037784762432 M:2885545984 DEBUG: SECTION:LoadDLL(/usr/share/xbmc/addons/pvr.vdr.vnsi/XBMC_VDR_vnsi.pvr)
    4. 01:12:00 T:140037784762432 M:2885545984 DEBUG: Loading: /usr/share/xbmc/addons/pvr.vdr.vnsi/XBMC_VDR_vnsi.pvr
    5. 01:12:00 T:140037784762432 M:2885545984 ERROR: ADDON: Dll VDR VNSI Client - Client returned bad status (4) from Create and is not usable
    6. 01:12:00 T:140037784762432 M:2885545984 DEBUG: CDatabase: Connecting to database Addons at /home/hp/.xbmc/userdata/Database:
    7. 01:12:00 T:140037784762432 M:2885545984 INFO: Called Add-on status handler for '4' of clientName:VDR VNSI Client, clientID:pvr.vdr.vnsi (same Thread=no)
    8. 01:12:00 T:140037486491408 M:2885545984 DEBUG: thread start, auto delete: 1
    9. 01:12:00 T:140037784762432 M:2885545984 ERROR: PVR: couldn't load any clients


    Gruß
    hepi

  • Wie Hepi oben angemerkt hat, crasht xbmc, solange ein altes Profil beim Start verwendet wird.


    Bei einer Änderung der Datei guisettings.xml (siehe unten) tritt das Problem nicht mehr auf:


    Neuer Inhalt (alter Block wurde überschrieben):

    Code
    1. <pvrmanager>
    2. <channelmanager></channelmanager>
    3. <channelscan></channelscan>
    4. <enabled>false</enabled>
    5. <resetdb></resetdb>
    6. </pvrmanager>


    So weit meine Erfahrung zum Problem - der Crash tritt nicht immer auf.

  • Nachdem euch das Einhalten der selbst auferlegten Regelungen und Formalismen wichtiger zu sein scheint als ein funktionierendes Xbmc Media Center, hab ich meinen Beitrag oben nun adaptiert.


    Der sollte nun den Wünschen des Großmeisters entsprechen.

  • Quote

    Original von löwe
    Nachdem euch das Einhalten der selbst auferlegten Regelungen und Formalismen wichtiger zu sein scheint als ein funktionierendes Xbmc Media Center, hab ich meinen Beitrag oben nun adaptiert.


    Der sollte nun den Wünschen des Großmeisters entsprechen.


    Warum so aggressiv, ein funktionierendes Xbmc Media Center ist uns sehr wichtig!
    Aber versetze dich mal in die Lage der Entwickler, und hangel dich durch tausende Beiträge aus denen nicht mal die Versionsnummer zu entnehmen ist, dann ordne das Problem auch noch zu.
    In dieser Zeit könnte das Problem schon gefixt sein.
    Des weiteren haben deine Persönlichen userdaten absolut nichts mit der Funktion von pvr-testing2 zu tun.
    mfg
    jobit