[ANNOUNCE] iStreamdev-1.0.1 - stream vdr & media files to your Iphone

  • 02/04/2010 - 1.0.1


    VDR & media streaming to your iPhone



    download: http://projects.vdr-developer.…cts/list_files/istreamdev



    http://projects.vdr-developer.org/projects/show/istreamdev


    README: http://projects.vdr-developer.org/wiki/istreamdev/README
    INSTALL: http://projects.vdr-developer.org/wiki/istreamdev/INSTALL


    Screenshots: http://projects.vdr-developer.…ki/istreamdev/SCREENSHOTS



    History:



    02.04.2010 - 1.0.1


    - Added fix for PHP version < 5.2.0
    - added php module check and dynamic loading if possible.
    - some client speedups and optimisations
    - removed custom segmenter code, no need for a modifief version anymore
    - now stores segmenter and ffmeg pids to kill them
    - removed AT dependency


    03.29.2010 - 1.0.0


    - Massive rework from scratch
    - Now based on JQuery/JQTouch
    - Fully Ajax/Json based. Server only send Json data to client.
    - Client fully webapp compatible. All the client is loaded in the same html page.
    - New skin with animated transitions. Hardware accelerated animations.
    - Added recording from Channel info.
    - Encoding status message is now updated live.
    - Added new status "Encoding finished" for recording and videos files. It appears without "*" character before the name in Home sessions menu too.
    - Added Electronic Program Guide with add timer feature.
    - Dynamic minimise and compression of the css & js files. Now cached.
    - gzip compression of all json data



    Git repository for development version:


    Code
    1. git clone git://projects.vdr-developer.org/









  • Hi alib


    works like a charm - exept highest rate. i changed "Very High" and "Best" in index.php and in include.php to "Highest" - then it works...
    thanks - now it's up to you to integrate an EPG or to extend the station-list with the actual broadcast running... (little feature request :-))
    linking station png's from the actual skin into your logo's folder would be good (did it by hand for now)
    where is the "Stop" button gone? is your program stopping the segmnter's and ffmpeg process automatically now?


    thanks


    daniel

    easyvdr 1.7.14 - vdr 1.7.0
    AMD Sempron 140 - Asus M3N78 Pro - DVB-S FF TT 2300 - Mystique SaTiX-S2 Dual - DVD-R - 1TB WD - 2048MB RAM - rebach HTPC extension

  • I've updated the download file. There was a typo for Very high.
    Or just edit in index.php "Very High" by "Very high"


    The stop button has been removed. Now Home button ( at the top left ) kill ffmpeg server directly.


    For Next release I plan to navigate by Category, with Itunes list ( Logo + Channel ID + Program Title )
    The html templates are ready, need to redo the php.
    You can preview it on your iphone here:


    http://xmltv.free.fr/iphonstream/test/

  • i dont have the binary segmenter where can i get the right one?


    thanks mentox


    i ve found this


    http://svn.assembla.com/svn/legend/segmenter/

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von mentox ()

  • i can't get it works ..


    i use gentoo ..


  • Zitat

    Original von neumann2k
    Ich bekomme beim Aufruf der Seite teilweise den php code angezeigt. es fängt an mit "; print " und so weiter.


    Bin in PHP eigentlich recht gut bewandert, finde jedoch den Fehler nicht. Hat jemand rat?


    Hi, das Problem hatte ich auch mit lighthttpd.
    Du musst in der index.php und include.php die

    Code
    1. <?

    Tags durch

    PHP
    1. <?php

    ersetzen
    Dann sollte es funktionieren.

  • Zitat

    Original von mentox
    i can't get it works ..


    i use gentoo ..



    For me the -bt option was wrong (in istream.sh), i had to use -b instead. Then it works.

  • now it works very cool .. thanks


    perhaps is is a good idea to add some >>$LOG for debugging :-)


    thanks for istream

  • Hi, thanks for this, it works great - for a few seconds anyway in my case :)


    My vdr is a rather slow box (P4 2 GHz, 1 GB RAM). After watching a stream for a few seconds (sometimes a few minutes) it begins to stutter and gets rather unusable.


    I see ffmpeg taking 80-90% CPU, and the load gets up.


    Is this box simply to ancient for this, or is there any tweaking I could do?


    Details:
    - Debian Lenny
    - vdr 1.6.0 + streamdev cvs
    - ffmpeg svn
    - x264 from git
    - segmenter from http://svn.assembla.com/svn/legend/segmenter/


    Thanks in advance
    K.

  • Now i have the problem, that ffmpeg is working in the background, in the ram directory, there a files created by ffmpeg, but on my iphone, when i click the quicktime icon, the quicktime player opens, but no video appears. The Player always says "loading movie".


    Is this a problem with my iphone?

  • kuminamoya yes your PC is too slow to encode h264 in realtime. Try to lower output resolution, but i doubt it will be sufficient.


    neumann2k , I don't think it's a problm with your iphone. But you can try to reboot it, as after many test, it seems the quicktime player come sometimes instable.
    By the way, try to reach the .ts file from your PC browser to check if all the files are reachable by your webserver.
    Can you show me an axemple of the generated m3u8 ?



    For those who have problem with old streamdev rev, we've redone the parsing channel script with channels.conf and no streamdevchannels.html url for next version, as i was needding category too.


    Build is on it's way for this weekend i think. You will love it.

  • wer kann mir bitte helfen:


    root@ubuntu:/var/www/istream# make
    gcc -Wall -g segmenter.c -o segmenter -lavformat -lavcodec -lavutil
    In file included from segmenter.c:21:
    /usr/include/libavformat/avformat.h:117: error: redefinition of ‘struct AVPacket’
    /usr/include/libavformat/avformat.h:163: error: conflicting types for ‘AVPacket’
    /usr/include/libavcodec/avcodec.h:964: note: previous declaration of ‘AVPacket’ was here
    /usr/include/libavformat/avformat.h:166: error: conflicting types for ‘av_destruct_packet_nofree’
    /usr/include/libavcodec/avcodec.h:2775: note: previous declaration of ‘av_destruct_packet_nofree’ was here
    /usr/include/libavformat/avformat.h:171: error: conflicting types for ‘av_destruct_packet’
    /usr/include/libavcodec/avcodec.h:2780: note: previous declaration of ‘av_destruct_packet’ was here
    /usr/include/libavformat/avformat.h:178: error: conflicting types for ‘av_init_packet’
    /usr/include/libavcodec/avcodec.h:2787: note: previous declaration of ‘av_init_packet’ was here
    /usr/include/libavformat/avformat.h:188: error: conflicting types for ‘av_new_packet’
    /usr/include/libavcodec/avcodec.h:2797: note: previous declaration of ‘av_new_packet’ was here
    /usr/include/libavformat/avformat.h:204: error: conflicting types for ‘av_dup_packet’
    /usr/include/libavcodec/avcodec.h:2811: note: previous declaration of ‘av_dup_packet’ was here
    /usr/include/libavformat/avformat.h:211: error: conflicting types for ‘av_free_packet’
    /usr/include/libavcodec/avcodec.h:2818: note: previous declaration of ‘av_free_packet’ was here
    make: *** [all] Fehler 1



    installiert:
    ii libavformat-dev 4:0.5+svn20090706-2ubuntu2 development files for libavformat
    ii libavformat52 4:0.5+svn20090706-2ubuntu2 ffmpeg file format library

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.5 testing, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: lg 60pk-550 full-hd amp: yamaha rx-v367

  • Zitat

    Original von kuminamoya
    izeman : Bei mir hat´s so funktioniert:


    gcc -Wall -g segmenter.c -o segmenter -lavformat -lavcodec -lavutil -lbz2 -lm -lz -lfaac -lmp3lame -lx264 -lfaad -lpthread


    Gruß
    K.


    danke. aber das ergebnis ist genau das selbe :(

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.5 testing, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: lg 60pk-550 full-hd amp: yamaha rx-v367

  • Um ganz ehrlich zu sein: Ich war gaaaanz tief in der library hell, und habe lange rumprobiert, bis es endlich funktioniert hat, kann also nicht mehr alles ganz nachvollziehen.


    Ich habe jedenfalls weder libavformat-dev noch libavformat52 bei mir installiert - alle benötigten Libs wurden durch die Installation von ffmpeg (svn) geliefert. Kannst Du die Pakete mal testweise entfernen, oder hast Du Abhängigkeiten?


    Achtung: Bei mir halt Debian Etch, kein Ubuntu...


    Grüße
    K.

  • Hallo ich verwende auch easyvdr 0.7.14 (vdr 1.7.0) und habe ffmpeg via svn kompiliert. sowei so gut.
    nun habe ich aber auf einmal probleme beim streamen mit dem streamdev-server.


    Ausgabe von : "./istream 24 128k"


    Gleichzeitig die ausgabe in Syslog :



    am schlimmsten ist es bei ARD und ZDF. auch beim streamen eines normalen TS stream (also z.B. von http://vdr:3000/TS/24 ohne externremux o.ä.) habe ich jetzt alle paar sekunden ein stehendes bild.
    ein streamen über istream oder externremux.sh geht eigentlich gar nicht mehr - bild steht - buffer overflow - siehe augabe von syslog und istream oben ! ist mir nach der installation von ffmpeg-svn gleich aufgefallen, da es sich hier um einen easyvdr-streamdev-server-only handelt.


    eventuell habe ich einen fehler gemacht, indem ich auch libx264 per git neu installiert habe ?!
    hab ich irgendwelche abhängikeiten vom streamdev erwischt ?


    ansonsten fällt mir nur ne komplette vdr neu installation ein, und dann nochmal von vorne ....


    gruesse