yaVDR 0.1.x: Webfrontend Update + Paketupdates

  • es gibt wieder mal einen schwung updates:


    da kommt recht viel zusammen:


    ich poste daher mal die "history".
    bei fragen nur zu ...
    beim update gibt es ein paar "sicherungen" der configs ABER wir garantieren für nichts.
    also bitte kümmert euch vorher um die sicherung.



    yavdr-utils:


    yavdr-statup:


    yavdr-essential


    Code
    1. add support for nfs
    2. remove burn
    3. add vdpauinfo



    EDIT: die meisten probleme hier im thread waren kleinigkeiten, die grosse probleme verursachen konnten :D
    ab 7.2. 19:20 sollte das gefixt sein.
    gibt es noch update-fehler, dann bitte unbedingt melden !!

  • Hallo, hier meine ersten Erfahrungen mit diesen update.


    vdr startet hier nurnoch nachdem ich "start vdr" auf der console eingegeben habe.


    engine.buffers.audio_num_buffers:2300
    engine.buffers.video_num_buffers:5000


    wurde wieder als default gesetzt was bei mir über SAT zu restarts von xine führt wenn man über HD Sender switche.


    Wieder,
    engine.buffers.audio_num_buffers:275
    engine.buffers.video_num_buffers:1800
    eingestellt und die restarts von xine sind Geschichte. (kann bei Kabel natürlich anders sein)


    Ein "reboot" auf der console via putty hängt an einer mir im Moment unbekannten stelle und dieser wird auch nach 5 min nicht ausgeführt.

    HW1: Tyan S2915|2x AMD Opteron 2216 HE|pcie 8400GS|TeVii S470 |LSI 8888ELP|SAS Expander|15x2TB mit mhddfs|32" SONY 32EX705
    HW2: Zotac ION|Tevii S650|Samsung 60GB 2,5"|HDMI an 52" Toshiba
    SW 1-2: Xubuntu 10.4, VDR 1.7.14, xine-vdpau, xbmc

  • Läuft bis jetzt alles Super hier bis. Vorallem Firefox gefällt auf diese Art sehr.
    Was ich nicht ganz nachvollziehen kann ist warum ihr config files einfach so ohne Abfrage überbügelt. Mit Rückfragen wie bei der xine config und vdr irgendwas (weiss nicht mehr welche) das ist ok, dann kann mann auch die Änderungen anschauen und entscheiden, aber dass meine mühsam erarbeitete xorg.conf weg war und N24 wieder geruckelt hat schockierte mich schon ein wenig. ;)
    Ist dieses Verhalten beabsichtigt oder wird dies noch einer Änderung unterzogen?


    Danke

    Backend (zurzeit nicht mehr in Betrieb): yaVDR diskless - Asus M4N78 PRO - Nvidia GeForce 8300 onboard - AMD Athlon II X2 240 - Ram 4GB - 2x Terratec Cinergy C PCI HD

    yaVDR 0.4 Zotac MAG HD-ND01 ATOM 330 ION Mini PC - TT S2-3600 - LG 32LH3000

    ***************************************************************************

    "Es gibt Tage an denen verliert man, und es gibt Tage an denen gewinnen die anderen."

  • die xorg.conf.yavdr wurde gesichert (sollte) in /var/lib/vdr/yavdr-backup


    zum ganzen system "warum" man das nur so machen kann, sagt bestimmt gda noch was.
    es ist möglich eigene "templates" zu erstellen.
    mir fehlt im moment die puste das zu erklären :D
    das dauert.
    es lässt sich leider "nie" nicht immer umgehen, das diverse configs einfach drübergebügelt werden.
    deshalb der erste satz im ersten post.
    wie gesagt, sollte das mit den templates mal erklärt sein. muss man auch kein update mehr fürchten.

  • Zitat

    Original von hotzenplotz5
    die xorg.conf.yavdr wurde gesichert (sollte) in /var/lib/vdr/yavdr-backup


    Das ist Super, hat auch funktioniert, der Backup wurde aber offensichtlich zu spät gemacht. Backup enthält die Original xorg.conf.yavdr
    Dazu muss ich aber noch sagen dass ich einen dist-upgrade gemacht habe, nur zur Info.

    Zitat


    zum ganzen system "warum" man das nur so machen kann, sagt bestimmt gda noch was.
    es ist möglich eigene "templates" zu erstellen.
    mir fehlt im moment die puste das zu erklären :D
    das dauert.


    Das mit den templates hört sich super an, werde ich mir zu gegebenem Zeitpunkt anschauen.

    Zitat


    es lässt sich leider "nie" nicht immer umgehen, das diverse configs einfach drübergebügelt werden.
    deshalb der erste satz im ersten post.
    wie gesagt, sollte das mit den templates mal erklärt sein. muss man auch kein update mehr fürchten.


    Wegen dem machen wir ja alle immer schön Backups. :unsch


    Aber wahrscheinlich wolltest du Dich ja eh nur für gestern rächen. :lol2

    Backend (zurzeit nicht mehr in Betrieb): yaVDR diskless - Asus M4N78 PRO - Nvidia GeForce 8300 onboard - AMD Athlon II X2 240 - Ram 4GB - 2x Terratec Cinergy C PCI HD

    yaVDR 0.4 Zotac MAG HD-ND01 ATOM 330 ION Mini PC - TT S2-3600 - LG 32LH3000

    ***************************************************************************

    "Es gibt Tage an denen verliert man, und es gibt Tage an denen gewinnen die anderen."

  • Perfekt, danke


    Backups sind für Sitzpinkler, Warmduscher, Vorwärtsparkierer und Paranoide. :lol2

    Backend (zurzeit nicht mehr in Betrieb): yaVDR diskless - Asus M4N78 PRO - Nvidia GeForce 8300 onboard - AMD Athlon II X2 240 - Ram 4GB - 2x Terratec Cinergy C PCI HD

    yaVDR 0.4 Zotac MAG HD-ND01 ATOM 330 ION Mini PC - TT S2-3600 - LG 32LH3000

    ***************************************************************************

    "Es gibt Tage an denen verliert man, und es gibt Tage an denen gewinnen die anderen."

  • so kleines aber gemeines update wird gleich hinterhergeschoben.
    die configs sollten jetzt "richtig" im backup landen. (also zu rechten zeit).


    was aber wichtiger war, wir mussten eine kleine änderung einbauen, damit gda ein neues "iso" backen
    kann. leider macht das ein neues utils-paket "notwendig".

  • Zitat

    Original von hotzenplotz5
    damit gda ein neues "iso" backen


    Das habt ihr nicht gelesen, da ist ein PAL-Feld drum.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Meiner hat das Update irgendwie nicht überlebt.
    Was ich so in den Logs gefunden habe, was neu ist.

    Code
    1. ERROR: no OSD provider available - using dummy OSD!


    start vdr
    ergibt

    Code
    1. vdrhd@VDRHD:~$ start vdr
    2. start: Rejected send message, 1 matched rules; type="method_call", sender=":1.11
    3. " (uid=1000 pid=3697 comm="start) interface="com.ubuntu.Upstart0_6.Job" member="
    4. Start" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (
    5. uid=0 pid=1 comm="/sbin/init"))


    Ich habe gemacht
    1. sudo apt-get dist-upgrade
    2. sudo apt-get update
    3. sudo apt-get upgrade


    Was soll ich euch an Logs zur Verfügung stellen

  • Zitat

    Original von oldspies2

    Code
    1. vdrhd@VDRHD:~$ start vdr


    Auch als root versucht?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Ich hätte es mir ja denken können, sudo heilt alles....
    aber wie kann ich das heilen das VDR wieder automatisch nach dem Neustart da ist?
    Nur so für den WAF...



    Bwi mir gibt es keine Probleme mit den HD Kanälen
    Rücksetzen von
    Wieder,
    engine.buffers.audio_num_buffers:275
    engine.buffers.video_num_buffers:1800
    hat keine Auswirkung auf die HD Ausgabe oder den Autostart

  • oldspies2  
    die Buffer haben auch nichts mit den Neustart zu tun.


    @HoldeR

    Code
    1. apt-cache policy autofs
    2. autofs:
    3. Installiert: (keine)
    4. Kandidat: 4.1.4+debian-2.1ubuntu2
    5. Versions-Tabelle:
    6. 4.1.4+debian-2.1ubuntu2 0
    7. 500 http://de.archive.ubuntu.com karmic/main Packages


    Ich nehme mal an das es dann damit zusammenhängt ?

    Code
    1. start on (filesystem and
    2. autofs-up and
    3. net-device-up IFACE=lo and
    4. (net-device-up IFACE=eth0 or
    5. net-device-up IFACE=wlan0))


    Ich hab dann mal

    Code
    1. apt-get install autofs


    gemacht, und siehe VDR startet auch nach einen S5 wieder sofort. Nach einen S3 ging es auch ohne autofs schon wenn vdr vorher mal gestartet wurde.

    HW1: Tyan S2915|2x AMD Opteron 2216 HE|pcie 8400GS|TeVii S470 |LSI 8888ELP|SAS Expander|15x2TB mit mhddfs|32" SONY 32EX705
    HW2: Zotac ION|Tevii S650|Samsung 60GB 2,5"|HDMI an 52" Toshiba
    SW 1-2: Xubuntu 10.4, VDR 1.7.14, xine-vdpau, xbmc