[workaround] yaVDR 0.1Installation klappt nicht - wegen dmraid

  • Zitat

    Original von m. keller
    So Installation lief (leider ;) ) durch.


    Die Logs sind leider bisschen groß.
    KLICK


    Ich zähle hier mal "im Glücksfall" und "leider" zusammen, und erhalte als Ergebnis, dass du hepis Vorschlag beherzigt und das Standard ISO von Ubuntu Alternate 9.10 installiert hast. Dieses ließ sich installieren, mit yaVDR gibt's leider die von dir geschilderten Probleme.


    Richtig?


    Gruß
    Holger

  • Zitat

    Original von HolgerR
    Ich zähle hier mal "im Glücksfall" und "leider" zusammen, und erhalte als Ergebnis, dass du hepis Vorschlag beherzigt und das Standard ISO von Ubuntu Alternate 9.10 installiert hast. Dieses ließ sich installieren, mit yaVDR gibt's leider die von dir geschilderten Probleme.


    Richtig?


    Gruß
    Holger



    so hatte es bei mir ohne den ubuntu-live-dmraid-umweg auch geklappt

    FestWare: Gigabyte GA-EP43-UD3L | Intel Q6600 2400Mhz | 4GB RAM | Nvidia GF GT220 1024MB DDR3 Colorful | DVB-S: WinTV Nova-S Plus, (DVB-C: Satelco Easywatch DVB-C) | 1TB SATA || WeichWare: Ubuntu Lucid x64, yaVDR repository + XBMC

  • Moin!


    Hab jetzt endlich aus herumliegenden Teilen noch einen Test-VDR zusammenbasteln können...


    Ich hatte auch Probleme mit der Installation des Grundsystem, manuelles Löschen aller Partitionen und LVM-Volumes und Installation ohne LVM "auf gesamte Platte" hatte dann keine Probleme mehr.


    mini.

  • Gut! So langsam bewegt sich dieser Thread doch noch wieder in die richtige Richtung. Ich dachte schon, der "Geplänkel" Thread bekommt wieder Zuwachs. ;)


    Bitte hier nicht in's "Trollen" verfallen!


    Max Headroom
    Ich habe mir deine Posts zum Thema mal durchgelesen: Die Ursache deines Problems ist mir noch nicht klar, allerdings scheint es sich doch um einen "Exoten" zu handeln. Der von uns verwendete Ubuntu Alternate Installer ist weltweit erprobt und funktioniert generell bestens. Die Analyse deines persönlichen Problems ist also eher komplex und ein Geben und Nehmen von Informationen. Du hast dich für ein "Parken" von yaVDR entschieden, belassen wir es also vorerst dabei. Wenn es dich doch irgendwann noch mal reizen sollte, yaVDR auf deiner Hardware zu installieren, können wir das Thema gerne erneut aufgreifen.


    Gruß
    Holger

  • gda und HolgerR
    Sorry hätte mich genauer ausdrücken sollen. das "leider" bezog sich darauf, dass es mit Ubuntu klappt und mit yaVDR nicht, also nicht (unbedingt) an der HW liegen muss und ich euch weiter belästigen muss.


    Also ich habe die normale Ubuntu ALternate CD runtergeladen und installiert, mit Erfolg. Die logs von der erfolgreichen Installation von Ubuntu sind verlinkt, falls es da interesse gibt.


    Vielen Dank für eure Mühen!


    Marshal
    sehr guter Tipp. Werde ich mal versuchen. Die Frage taucht bei mir nämlich auch auf, hatte zwar nie ein RAID hier installiert, werde aber mal meine beiden PLatten abhängen und eine jungfreuliche Platte verwenden.

    VDR-Server: AMD Athlon X2 5200+ ,ASUS M3N78 (Geforce8200), 2x 2GB RAM, 2xTT DVB-C 1501, 3x WD AV-GP 2000GB in RAID5, yaVDR 0.5
    Client 1: Desktop PC, Win7

  • Also die Installation klappt, wenn die Platte komplett sauber davor ist einwandfrei.
    Hab dazu meine zwei SATA Festplatten mit Ubuntu, Debian, Win7, WinXP abgehängt und eine saubere ATA Festplatte angeschlossen.
    Demnach muss das Problem wirklich bei der Soft-RAID Erkennung, stichwort dmraid liegen. Da kenne ich mich aber nicht gut genug aus.


    Marshal
    Vielleicht kannst du dein Lösungsweg noch etwas genauer beschreiben

    VDR-Server: AMD Athlon X2 5200+ ,ASUS M3N78 (Geforce8200), 2x 2GB RAM, 2xTT DVB-C 1501, 3x WD AV-GP 2000GB in RAID5, yaVDR 0.5
    Client 1: Desktop PC, Win7

  • ich kenne mich auch nicht wirklich damit aus, da ich auf der festplatte allerdings nichts zu verlieren hatte, habe ich einfach rumprobiert. genaue befehlsabläufe jetzt nur aus dem gedächtnis:


    1. booten von einer live-cd (ich hatte eh noch ein ubuntu karmic auf cd)
    2. dmraid installieren (über ein terminal apt-get install dmraid)
    3. im terminal musst du dann dmraid mit passendem paramater starten, "sudo dmraid --test". bei mir hat er dann auf der fraglichen festplatte fehlerhafte raid-infos entdeckt.
    4. mit "sudo dmraid -x" werden die infos gelöscht, danach konnte ich yavdr installieren.


    wie gesagt, ich hatte nicht wirklich eine ahnung davon was ich tue =), daher kann ich es auch nicht genauer beschreiben.

    FestWare: Gigabyte GA-EP43-UD3L | Intel Q6600 2400Mhz | 4GB RAM | Nvidia GF GT220 1024MB DDR3 Colorful | DVB-S: WinTV Nova-S Plus, (DVB-C: Satelco Easywatch DVB-C) | 1TB SATA || WeichWare: Ubuntu Lucid x64, yaVDR repository + XBMC

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Marshal ()

  • dmraid ist auf der yavdr Installations-CD enthalten, man kann damit mittels "dmraid -rE" die Raid-Daten (falls nicht mehr wirklich benötigt!) löschen. Danach geht die Installation sauber durch, ich habe das gerade durchexerziert ;)


    Schritte zur Installation:

    • Installer erkennt Raid-Daten und frägt nach, ob dmraid aktiviert werden soll
    • Mit CTRL-F2 auf Konsole umschalten, aktivieren
    • "dmraid -rE" löscht die Raid-Daten
    • Mit CTRL-F1 wieder zurück zum Installskript, "no" auswählen
    • Installation zu Ende führen (bei mir nur ohne lvm möglich).


    cu
    Markus

  • das ist natürlich noch viel besser

    FestWare: Gigabyte GA-EP43-UD3L | Intel Q6600 2400Mhz | 4GB RAM | Nvidia GF GT220 1024MB DDR3 Colorful | DVB-S: WinTV Nova-S Plus, (DVB-C: Satelco Easywatch DVB-C) | 1TB SATA || WeichWare: Ubuntu Lucid x64, yaVDR repository + XBMC

  • Muß das nicht:


    CTRL-ALT-F2
    bzw.
    CTRL-ALT-F1
    heißen?
    Will hier nicht den Besserwisser spielen, könnte aber ein Stolperstein für Newbies sein (spreche lediglich aus eigener Erfahrung).


    gruss

    Server: yavdr-0.3, Asus M3N78-VM Geforce 8200, X2 5200+,2GB, KNC-One DVB-C, Cinergy T2
    HD-vdr: yavdr-0.3, Asus M4N78-VM Geforce 8200, X2 240, 1GB
    4 x m740 mit open7x0-vdr-fw-ng


  • Diese Kombinationen braucht man nur, um von X zu den Konsolen zu wechseln.
    Oben geschriebenes ist trotzdem falsch, man braucht ALT+F# um zwischen den Konsolen zu wechseln, NICHT STRG+X zumindest bei mir :)


    gruß red