yaVDR, keine Tastatur im Firefox

  • Hi,
    ich habe yaVDR auf meinem Notebook installiert (Amilo PI3560). Folgende Probleme sind mir aufgefallen:
    - Bei der Installation muß zwingend Netzwerkanschluß per Kabel bestehen, bei WLAN scheitert die Installation, wie bekomme ich das WLan eingerichtet (das finde ich bestimmt bei Ubuntu)?
    - Wenn ich Firefox starte habe ich nur die Maus, aber keine Tastatur. In der Konsole und im VDR dagegen schon
    - Auch ich vermisse mc
    - Keine Senderliste für Sat, dafür aber 3 IP Sender ;) Wie kann ich meine Senderliste vom USB Stick einspielen? Ich vermute übers WebIF oder MC, aber dafür muß die Tastatur funktionieren.


    Bis auf die WLAN Geschichte finde ich die Installation sehr gut, vor allem weil man nicht ein starres Dateisystem "aufgedrückt" bekommt. Eine Parallelinstallation ist somit einfach möglich.


    Bei den Plugins würde ich sogar durchaus noch weniger vorauswählen, statt dessen übers WebIF einfach eine Pluginliste zum Auswählen. Das wäre doch Spitze und Easy vom Händling.


    Im Menü fände ich noch zusätzlich einen normalen Shutdown praktisch. Und eventuell fände ich eine Einstellmöglichkeit zum S3 oder Shutdown einzustellen auch sinnvoller (im Web-IF), damit diejenigen, bei denen es nicht funktioniert einfach darauf verzichten können.


    Generell ist das Web-IF ein gutes Instrument für alle selten benötigten Funktionen zum Konfigurieren.


    Sehr schön das ganze und für dieses frühe Beta Stadium schon eine stolze Leistung.


    Thx

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Hi,


    Quote

    Original von Torsten73
    - Wenn ich Firefox starte habe ich nur die Maus, aber keine Tastatur. In der Konsole und im VDR dagegen schon


    Ist das reproduzierbar, oder nur beim ersten Mal aufgetreten? Interne Tastatur, oder externe?


    Quote

    - Auch ich vermisse mc


    Wenn du möchtest, dass gda aka Gerald noch weiter unter uns weilt, vergiss den Wunsch. "Nur über seine Leiche" ;) Ich finde aber auch, dass es nicht in den Standard gehört. Ernsthaft: Wird nicht passieren, nachinstallieren ist ja ziemlich leicht.


    Quote

    - Keine Senderliste für Sat, dafür aber 3 IP Sender ;) Wie kann ich meine Senderliste vom USB Stick einspielen? Ich vermute übers WebIF oder MC, aber dafür muß die Tastatur funktionieren.


    Webinterface wäre der einfachste Weg. Zur Not über einen zweiten Rechner.


    Quote

    Im Menü fände ich noch zusätzlich einen normalen Shutdown praktisch. Und eventuell fände ich eine Einstellmöglichkeit zum S3 oder Shutdown einzustellen auch sinnvoller (im Web-IF), damit diejenigen, bei denen es nicht funktioniert einfach darauf verzichten können.


    Letzteres wird (da verrate ich wohl nicht zu viel) demnächst kommen. Von Ersterem bin ich noch nicht überzeugt, dass es dann noch gebraucht wird.


    Quote

    Sehr schön das ganze und für dieses frühe Beta Stadium schon eine stolze Leistung.


    Danke! :)

  • Der Tastaturfehler tritt immer auf und reproduzierbar, eine externe Tastatur werde ich noch mal testen. Geht dann nur über USB natürlich.
    Wie gesagt, merkwürdigerweise nur bei Firefox...


    Gegen vi als Editor habe ich nichts, für Anfänger wie mich ist vi aber zu umständlich und die Suche in den vielen Verzeichnissen wo was ist geht mit MC recht einfach. Aber ich möchte bestimmt nicht das Gerald Herzklabaster bekommt wenn MC mit an Board ist :unsch .
    Ich werde MC mir immer nachinstallieren. Ich hoffe Gerald redet nun noch mit mir.


    Der S3 steht bei mir Hoch im Kurs, da beim mir der Bootvorgang beim Biostest mit gut 20s. leider sehr lange dauert. Irgendwie will mein Board keinen ordentlich schnellen Speichertest machen. Deshalb die Möglichkeit das optional zu aktivieren wäre toll. (dies
    gilt nur für den Rechner aus der Sig)

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Quote

    Original von Torsten73
    Der S3 steht bei mir Hoch im Kurs, da beim mir der Bootvorgang beim Biostest mit gut 20s. leider sehr lange dauert. Irgendwie will mein Board keinen ordentlich schnellen Speichertest machen. Deshalb die Möglichkeit das optional zu aktivieren wäre toll. (dies
    gilt nur für den Rechner aus der Sig)


    Den verstehe ich nun wieder nicht: S3 ist doch standardmässig aktiv?!? Das wird auch so bleiben. Wir reden hier höchstens von einem optionalen *de*aktivieren des S3.


    Gruß
    Holger

  • Ob, so oder anders rum, pro S3 Mode, egal ob Standard oder nicht. Aber die Möglichkeit zum Ausschalten ist sinnvoll.


    Du meintest, dass er möglicherweise nicht mehr gebraucht wird. Deshalb meine Antwort, dass ich den sehr wohl gut finde.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Quote

    Original von Torsten73
    Du meintest, dass er möglicherweise nicht mehr gebraucht wird. Deshalb meine Antwort, dass ich den sehr wohl gut finde.


    Achso...nee, Mißverständnis: Ich meinte, wenn man im Webinterface den S3 abstellen kann, braucht's im Menü keinen separaten Aufruf für's Runterfahren in den S5.


    Gruß
    Holger


    PS: Und berichte bitte mal vom Ergebnis deines Tests mit der USB-Tastatur.

  • Quote

    Original von HolgerR


    Ist das reproduzierbar, oder nur beim ersten Mal aufgetreten? Interne Tastatur, oder externe?


    Firefox zickt tatsächlich manchmal mit der Tastatur. Ich habe es allerdings bisher immer geschafft mit ein paar beherzten Mausklicks in die Eingabefelder, ihn zu überreden die Tastatur doch noch zu akzeptieren. Hast du das versucht? Das ist sowieso eine Baustelle an der wir noch etwas arbeiten.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Moin,


    erstmal vielen Dank für die tolle Distri, bin seit dem ersten Tag dabei ;)


    Weil es hier grad um den integrierten Firefox geht, eine (blöde?) Frage dazu: wie bekomme ich die Schrift im Menü und in der Adressleiste größer? Die Darstellung sonst ist in Ordnung...

    Klemens


    HD-VDR1:
    ASUS M3N78-EM mit Athlon X2 4400, 640GB, 2 GB RAM, Alphacool LCD,
    Satelco-Easywatch DVB-C, Atric-Einschalter, yavdr
    HD-VDR2:
    Asrock B75-Pro3-M, Celeron G550, Nvidia GT620, Linux4Media Cine C/T, yavdr

  • Quote

    Originally posted by Klema
    Weil es hier grad um den integrierten Firefox geht, eine (blöde?) Frage dazu: wie bekomme ich die Schrift im Menü und in der Adressleiste größer? Die Darstellung sonst ist in Ordnung...


    Hallo Klema,


    Du meinst das "Drumherum", also das Firefox UI, ja? Du kannst Firefox über userchrome.css und usercontent.css anpassen, aber welche Klassen das sind, kann ich Dir nicht sagen:


    http://www.mozilla.org/unix/customizing.html


    Viele Grüße
    hepi

  • Ich hab eine /root/.Xdefaults angelegt mit dem Inhalt:


    Xft*dpi: 192
    Xft*antialias:true
    Xft*hinting:hintslight


    Unt in der /etc/X11/xinit/xinitrc ein xrdb -merge /root/.Xdefaults eingefügt. Damit haben alle Schriften eine annehmbare Grösse. Die DPI Anzahl kann man ja anpassen.


    Hat den Vorteil, dass es für Thunderbird oder ähnliches auch gilt.


    Grüsse
    TheChief

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 2 times, last by TheChief ().

  • Hallo,


    danke für die Rückmeldungen.


    TheChief : leider hats das noch nicht rausgerissen, brauche ne Lupe, um die Menü(-punkte) zu erkennen, auf einem 42er LCD wohlgemerkt :)


    hepi : genau. Die Webseiten sind normal zu lesen, aber das Menü, die Untermenüs und z.B. Fenster für die Einstellungen sind halt eine extrem kleine Schriftart. Ich sehe mir das mit den *.css mal an.


    Gruß

    Klemens


    HD-VDR1:
    ASUS M3N78-EM mit Athlon X2 4400, 640GB, 2 GB RAM, Alphacool LCD,
    Satelco-Easywatch DVB-C, Atric-Einschalter, yavdr
    HD-VDR2:
    Asrock B75-Pro3-M, Celeron G550, Nvidia GT620, Linux4Media Cine C/T, yavdr

  • Hi,
    merkwürdiger Weise funktioniert es seitdem ich eine externe Tastatur (USB Stick für Mircrosoft Wireless Desktop 6000) angeschlossen habe. Nun funktioniert es sogar auch ohne externe Tastatur.


    Ich kann mir keine logische Erklärung dazu geben. Ich weiß auch nicht, was ich sonst machen kann um den Fehler näher einzugrenzen.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Bei mir funktioniert das mit nem 46 Zöller. ;) Eventuell muss das bei yaVDR ja in nen anderes Userverzeichniss, denn bei mir läuft alles unter root. kenn mich auch mit Ubuntu nicht aus, aber ist ja eigentlich ein Debian ableger. Achso, xserver neustarten nich vergessen.


    Hier steht auch nochwas dazu: http://www.mozilla.org/unix/dpi.html



    Grüsse
    TheChief

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 4 times, last by TheChief ().


  • Hi,


    ja ich kämpfe mit dem selben Problem. Was sagt bei Dir folgender Befehl:


    DISPLAY=:1 xdpyinfo | grep resolution


    Schön wären hier Angaben wie:


    resolution: 117x117 dots per inch


    Bei mir sind es dann z.B. 22x22


    Ein Versuch wäre Eintrag in der /etc/X11/xorg.conf.yavdr:


    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Screen 0
    Option "UseEdidDpi" "FALSE"
    Option "DPI" "116x116"
    EndSection


    Gruß
    Arno

  • Bei mir zeigt er folgendes an:



    Code
    1. DISPLAY=:1 xdpyinfo | grep resolution resolution:
    2. 38x38 dots per inch


    mit der xorg.conf werd ichs mal versuchen.


    Gruß

    Klemens


    HD-VDR1:
    ASUS M3N78-EM mit Athlon X2 4400, 640GB, 2 GB RAM, Alphacool LCD,
    Satelco-Easywatch DVB-C, Atric-Einschalter, yavdr
    HD-VDR2:
    Asrock B75-Pro3-M, Celeron G550, Nvidia GT620, Linux4Media Cine C/T, yavdr

  • Probierts doch wie bei Mozilla beschrieben:


    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB


  • Nachtrag: Die Option "UseEditDpi" ist nicht unbedingt notwendig. Bei mir klappt es auch ohne. Sie hat den Nachteil, dass dann die physikalische Auflösung des Displays nicht verwendet wird. Versuch es also erstmal ohne.


    Arno

  • glotze44 : Super, danke, damit haut das hin!


    TheChief : Irgendwie klappt das nicht, evtl. weil FF als User vdr ausgeführt wird? Zum Beispiel lässt sich die layout.css.dpi per about:config nicht ändern, auch die Aktion mit der ~/.Xresources hat nicht funktioniert. Dennoch vielen Dank!


    Gruß

    Klemens


    HD-VDR1:
    ASUS M3N78-EM mit Athlon X2 4400, 640GB, 2 GB RAM, Alphacool LCD,
    Satelco-Easywatch DVB-C, Atric-Einschalter, yavdr
    HD-VDR2:
    Asrock B75-Pro3-M, Celeron G550, Nvidia GT620, Linux4Media Cine C/T, yavdr

  • Quote

    Original von Klema
    TheChief : Irgendwie klappt das nicht, evtl. weil FF als User vdr ausgeführt wird? Zum Beispiel lässt sich die layout.css.dpi per about:config nicht ändern, auch die Aktion mit der ~/.Xresources hat nicht funktioniert.


    Das müssen wir aber klären. Sonst stösst der nächste auf das Problem, der was am Firefox-Profil ändern will. Ich schaue mir das mal an.


    Gruß
    hepi

  • Hi Klemens,


    das eigentliche Problem war aber ja das keyboard, oder??


    Geh mal nach


    /var/lib/vdr/.mozilla/firefox/<profil id>


    Lösche da


    sessionstore.js
    sessionstore.bak


    und füge in prefs.js


    user_pref("browser.startup.page", 1);


    ein. Ansonsten kann es sein, dass alte sessions reaktiviert werden, die dann im Anmelde-Popup hängen und den FF unbedienbar machen.


    Gruß
    Arno