[ANNOUNCE] yaVDR: Die neue VDR-Distribution auf Ubuntu-Basis

  • Quote

    Original von HolgerR
    PS: Kannst du mit "dmesg" mal schauen, ob du einen zur Soundkarte passenden Fehler findest?


    Hilft das?


    Code
    1. bitkit@easyVDRHD:~$ cat /proc/asound/cards
    2. 0 [NVidia ]: HDA-Intel - HDA NVidia
    3. HDA NVidia at 0xfe020000 irq 21
    4. bitkit@easyVDRHD:~$ dmesg | grep HDA
    5. [ 14.911990] HDA Intel 0000:00:07.0: PCI INT A -> Link[AAZA] -> GSI 21 (level, low) -> IRQ 21
    6. [ 14.912013] HDA Intel 0000:00:07.0: setting latency timer to 64
    7. [ 15.560096] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:07.0/input/input7
    8. bitkit@easyVDRHD:~$ aplay -l
    9. aplay: device_list:223: keine Soundkarten gefunden...
    10. bitkit@easyVDRHD:~$


    oder wonach kann ich noch suchen?


    Bitkit

    ARCTIC COOLING Silentium T2 - ASUS M3N78 Pro AMD X2 4850e 2GB RAM - 250+400+500GB Samsung

    Skystar1(TT Rev. 1.3) - Skystar HD S2 - AV-Board 1.2 - PS2 TFT - MediaMVP

    easyVDR 0.7.10

    The post was edited 1 time, last by bitkit ().

  • Klar, sollte auch keine Kritik oder äußerung über meinen Mißmut sein. Habe beruflich mit EDV zu tun und der Begriff Beta bzw. Version 0.0.1 ist eindeutig xD
    Bin schon froh das meine Freundin dieses Gebastel aktuell mitmacht :) Seit der Satix S2 Anschaffung zwischen den Jahren ists Essig mit dem Rund laufenden VDR.


    Ich hatte dmesg, syslog und messages nach snd und cmi durchsucht. Es gab kein einziges vorkommen :( Werde aber nachher nochmal mit less nachsehen ;)


    Aber ganz nebenbei, aktuell bin ich auf ner normalen Karmic Installation (x64) auf der selben Hardware. Also default Karmic von Alternate CD und dann das VDR Team repository. Funktioniert soweit alles und ich konnte mit der CMI erstmals mit dem VDR über SPDIF die Lautstärke Regeln und Muten (Pass-Trough und Volume control Hardware waren die xineliboutput Einstellungen).
    Könnten da Dateien interessant sein die ich lieber gleich mal irgendwohin bunkern sollte ? Eine /etc/asound.conf gibt es auch hier nicht, auch im Homeverzeichnis finde ich nichts alla .asound*...aber es funktioniert
    Musste eben nur xineliboutput umstellen und hatte Ton über den Stereo Ausgang der onboard Karte.


    Jörg

    1. Lucid x64, Core2Duo 6600, 4GB, Video auf Raid 1 (NFS Server), 2 * Avermedia DVB-T, Nvidia GT220/1024*768/xineliboutput/VDPAU/VGA)
    2. Lucid x64 ESXI 4.1 - Avermedia DVB-T per PCI Passtrough
    3. Inaktiv: yaVDR DVB-S2 TT-3200 VDPAU/HDMI SPDIF


    Linux User #292118
    VDR User #895


  • Ja sieht das bei mir auch aus. Füge sie einfach in /etc/default/vdr mittels "-v /var/libvideo.01" zusätzlich ein. Wenn sie als zusätzliche Platte angegeben ist startet der vdr auch dann wenn das Mounten mal nicht geklappt hat.


    Arno


    Edit: Am besten klappt das übrigens mit autofs. Dann bleibt der Rechner auch nicht beim Hochfahren stehen, falls der Server nicht da ist.

  • Hmmm, letzte blöde Frage.


    Wenn ich unter Windows Netzwerk Suche auf den VDR zugreifen möchte schlägt er mir fest einen Benutzer, der aus meinem VDR Namen-Zahlen/Gast besteht, vor. Das Passwort vom VDR nimmt er nicht an. Er möchte doch bestimmt ein Passwort vom VDR, oder??


    Lars

    Das war einmal:
    DIGN HV5 silber, MSI K9MM-V, 512MB,400GB HD400LD , LG DVD, BE 2300, 1x TT 2.1 DVB-C Premium + 2x TT DVB-C budget, AV Board, Denon 1905 DD. EasyVDR 0606


    Jetzt: Technisat HD K2 mit 320GB 2,5" Festplatte...und das Teil läuft super mit HD:-))

  • Lars  :ot
    naja normalerweise ist in yaVDR kein Samba installiert soweit ich das gesehen hab. Wenns nur um konfigurationsdaten geht kannst du entweder das Webfrontend oder SCP nutzen. Mit SCP (für Windows z.B. WInSCP) kannst du dann zumindest auf /home/Benutzername schreibend zugreifen.
    Um auf das gesamte Dateisystem zuzugreifen musst du entweder root aktivieren (sudo passwd root)
    oder eben die Dateien in der Konsole mit sudo cp an die richtige Stelle kopieren.


    ... BTW: Es würde dir sicher helfen wenn du dich etwas in Linux einarbeitst, in dem du z.B. Ubuntu ausprobierst (ob in einer VM oder normal ist egal)

    VDR-Server: AMD Athlon X2 5200+ ,ASUS M3N78 (Geforce8200), 2x 2GB RAM, 2xTT DVB-C 1501, 3x WD AV-GP 2000GB in RAID5, yaVDR 0.5
    Client 1: Desktop PC, Win7

  • "smbpasswd deinusername" fehlt dir vielleicht ?

    HW1: Tyan S2915|2x AMD Opteron 2216 HE|pcie 8400GS|TeVii S470 |LSI 8888ELP|SAS Expander|15x2TB mit mhddfs|32" SONY 32EX705
    HW2: Zotac ION|Tevii S650|Samsung 60GB 2,5"|HDMI an 52" Toshiba
    SW 1-2: Xubuntu 10.4, VDR 1.7.14, xine-vdpau, xbmc

  • Ach so! Man muss das alles mit Rootrechten ausführen. Dann bekommt man auch info's :


    bitkit@easyVDRHD:/var/lib/vdr$ lsmod | grep snd
    snd_hda_codec_nvhdmi 4828 1
    snd_hda_codec_realtek 203328 1
    snd_hda_intel 26920 6
    snd_hda_codec 75708 3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep 7200 1 snd_hda_codec
    snd_pcm 75296 3 snd_hda_intel,snd_hda_codec
    snd_timer 22276 2 snd_pcm
    snd 59204 16 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
    soundcore 7264 1 snd
    snd_page_alloc 9156 2 snd_hda_intel,snd_pcm
    bitkit@easyVDRHD:/var/lib/vdr$ ^C
    bitkit@easyVDRHD:/var/lib/vdr$ iecset
    snd_ctl_open: No such file or directory
    bitkit@easyVDRHD:/var/lib/vdr$ lspci | egrep -i audio
    00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
    bitkit@easyVDRHD:/var/lib/vdr$ sudo alsamixer


    bitkit@easyVDRHD:/var/lib/vdr$ sudo alsactl store
    bitkit@easyVDRHD:/var/lib/vdr$ sudo aplay -l
    **** Liste von PLAYBACK Geräten ****
    Karte 0: NVidia [HDA NVidia], Gerät 0: ALC1200 Analog [ALC1200 Analog]
    Untergeordnete Geräte: 0/1
    Untergeordnetes Gerät '0: subdevice #0
    Karte 0: NVidia [HDA NVidia], Gerät 1: ALC1200 Digital [ALC1200 Digital]
    Untergeordnete Geräte: 1/1
    Untergeordnetes Gerät '0: subdevice #0
    Karte 0: NVidia [HDA NVidia], Gerät 3: NVIDIA HDMI [NVIDIA HDMI]
    Untergeordnete Geräte: 1/1
    Untergeordnetes Gerät '0: subdevice #0
    bitkit@easyVDRHD:/var/lib/vdr$


    aber noch keinen Ton...


    Bitkit

    ARCTIC COOLING Silentium T2 - ASUS M3N78 Pro AMD X2 4850e 2GB RAM - 250+400+500GB Samsung

    Skystar1(TT Rev. 1.3) - Skystar HD S2 - AV-Board 1.2 - PS2 TFT - MediaMVP

    easyVDR 0.7.10

    The post was edited 1 time, last by bitkit ().


  • http://paste.pocoo.org/show/166052/
    ganze setup.conf, finde nichts zu den SoftOSD Einstellungen.$


    Quote

    Unter der Haube ist yaVDR ein "ganz normales" Ubuntu Karmic. Die verwendeten Pakete stammen aus unserem Repository. Wenn du tatsächlich ein Plugin in der riesigen Liste in unserem Repo vermissen solltest, kannst du dir das Paket entweder direkt auf dem yaVDR-Rechner bauen, oder du setzt dir eine separate Entwicklungsumgebung auf. Howtos, wie man unter Ubuntu Pakete baut gibt es ja wie Sand am Meer. Nimm auf jeden Fall unser "vdr-dev" Paket, keine anderen Quellen, sonst wird das Plugin nicht passen.


    Gruß
    Holger


    Also plugin wurde compiliert und hab das Paket installiert. Leider wird es nicht geladen. Muss ich es noch in eine Liste schreiben oder wo ist das vdr-log zum nachsehen ob es einen Fehler gibt?


    Gruss


  • Das hatte sich übrigens bereits geklärt. Ganz normal mounten als "/var/lib/video.xx" funktioniert auch und entspricht eher dem Standard. Der VDR ist nur von "/var/lib/video.00" abhängig. Wenn die zusätzlichen Verzeichnisse beim Starten nicht da sind, ist das erst mal egal. Man kann dann halt erst nach einem Update des Videoverzeichnisses drauf zugreifen ;)


    Gruß
    Holger

  • Doch Sound geht. Habe in die /.xine/config für Stereo hw:0,3 eingetragen und habe nun Ton. Wird vermutlich auch mit einer entsprechenden asound.conf funktionieren.


    Bitkit


    EDIT: Ja geht auch mit asound.conf.
    Also war alles OK nur eine asound.conf fehlt. aplay -l funktioniert nur mit sudo daher dachte ich das keine Treiber geladen waren.

    ARCTIC COOLING Silentium T2 - ASUS M3N78 Pro AMD X2 4850e 2GB RAM - 250+400+500GB Samsung

    Skystar1(TT Rev. 1.3) - Skystar HD S2 - AV-Board 1.2 - PS2 TFT - MediaMVP

    easyVDR 0.7.10

    The post was edited 1 time, last by bitkit ().

  • also mein erster statusbericht:
    hat ganz toll funktioniert die installation. eine bitte: ideal waere installation von usb stick. leider will er NUR von cdrom installieren.


    nach der installation kam auch gleich ein bild.


    lirc hat nicht funktioniert. da musste ich ihm noch ein
    setserial /dev/ttyS0 uart none mitgeben und
    lircd haendisch starten.


    keine ahnung was hier nicht passt.


    ich habe auch ein tft an vga laufen, das mit
    DISPLAY=:0.1 /usr/bin/graphtft-fe -h localhost -e 2 -n -W 800 -H 600 -f -r
    und graphtft-plugin gestartet wird.


    jetzt sehe ich das graphtft plugin installiert ist, aber plugins liste scheint es nicht auf. wie aktiviere ich das?


    und dann auch noch die frage wie ich den zweiten x-server starte damit das graphtft den nutzen kann.


    danke inzwischen!!! tolle arbeit!

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.6.1, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: samsung 75" amp:denon avr-x1300

  • habe auch mal versucht die vdr sourcen zu installieren. da installiert er aber nur vdr-1.6.0. ist das ok so? oder muss ich dann erst die ganzen patches installieren damit der zu 1.7.10 wird?

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.6.1, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: samsung 75" amp:denon avr-x1300

  • Quote

    Original von izeman
    habe auch mal versucht die vdr sourcen zu installieren. da installiert er aber nur vdr-1.6.0. ist das ok so? oder muss ich dann erst die ganzen patches installieren damit der zu 1.7.10 wird?


    Nein, bloss nicht!! Unsere "/etc/apt/sources.list.d/yavdr.list" enthält keine Einträge für die Quellen. Daher würdest du dir die Quellen des Karmic VDR installieren. Wenn du partout die Sourcen unseres VDRs brauchst, trag's dir in o.g. Datei ein.


    Gruß
    Holger

  • ah ok. schaut jetzt so aus



    root@ubuntu:/# cat /etc/apt/sources.list.d/yavdr.list
    deb http://ppa.launchpad.net/the-v…/vdr-ubuntu-karmic/ubuntu karmic main
    deb http://ppa.launchpad.net/the-vdr-team/ppa/ubuntu karmic main
    deb http://ppa.launchpad.net/the-vdr-team/yavdr/ubuntu karmic main
    deb-src http://ppa.launchpad.net/the-vdr-team/yavdr/ubuntu karmic main


    die sourcen holt er sich aber immer noch vom alten rep.

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.6.1, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: samsung 75" amp:denon avr-x1300

    The post was edited 2 times, last by izeman ().


  • Wenn du die Quellen zu unserem VDR willst trag das hier ein:

    Code
    1. deb-src http://ppa.launchpad.net/the-vdr-team/vdr-ubuntu-karmic/ubuntu karmic main


    Wie schon im Announcement steht:
    yaVDR basiert auf unseren üblichen Launchpad-PPA-Repositories.


    Gruß
    Holger

  • Quote

    Original von baetmaen
    Klar, sollte auch keine Kritik oder äußerung über meinen Mißmut sein. Habe beruflich mit EDV zu tun und der Begriff Beta bzw. Version 0.0.1 ist eindeutig xD


    Kam auch nicht so rüber, keine Sorge! Ich muss hier nur manchmal etwas "knapp" antworten. Aber zu deinem Problem:


    Hast du das

    Code
    1. aplay -l


    mit root-Rechten ausgeführt?


    Ansonsten mach doch bitte mal ein

    Code
    1. sudo aplay -l


    (siehe auch den Post von bitkit )


    Gruß
    Holger

  • Moin


    Mein Kompliment an die Macher von yaVDR die Installation hat Super geklappt. Nach anpassen der diseqc.conf und channels.conf ein super Bild selbst auf den HD Sendern.


    Nur leider bekomme ich meine Fernbedienung nicht zum laufen.
    Ich verwende den Ir-Einschalter am com Port. Ich habe meine lircd.conf nach etc kopiert und in der Weboberfläche Home-brew (16x50 UART compatible serial port) und dev/ttyS0 eingestellt. Aber leider gibt es noch Probleme, hat von euch jemand eine Idee wie ich meine Fernbedienung zur Mitarbeit bewegen kann?


    mfg azuver

    VDR: Selbstbaugehäuse, H61M/U3S3 + G530, 4 GB Ram, Nvidia G210, LG 6,4 TFT per VGA, TBS 6981 + CT-3650 USB , IR-Einschalter, yavdr, mit 1920x1080_50 an 40er Samsung LCD

    The post was edited 1 time, last by azuver ().

  • Holger


    habe die Kiste grad wieder mit der yaVDR SSD hochgefahren und das mit sudo aplay versucht. Mann ist mir das peinlich, nutze Ubuntu nun schon seit über nem Jahr und komme da nicht selbst drauf.


    Also die /etc/asound.conf angepasst und nun habe ich Stereo Ton (onboard). Leider beim Umschalten Krächzgeräusche, arme Boxen. Das kann so nicht bleiben ;)


    Nun wieder die CMI eingebaut und wieder per SPDIF Digital Ton. Dieses mal auch ohne Aussetzer, keine Ahnung woran das liegt. Allerdings scheint sich der VDR beim Ton auf ARD bzw. ZDF (SD) Umschalten gerne aufzuhängen. Leider kein Stereo über SPDIF. Bei easyvdr oder karmic war folgendes immer hilfreich...


    ~/.xine/config_xineliboutput


    # device used for stereo output
    # string, default: plug:front:default
    audio.device.alsa_front_device:plug:iec958


    Leider finde ich in ~ noch nichtmal einen .xine Ordner. Jemand einen Tipp wo ich drehen muss ?


    Jörg

    1. Lucid x64, Core2Duo 6600, 4GB, Video auf Raid 1 (NFS Server), 2 * Avermedia DVB-T, Nvidia GT220/1024*768/xineliboutput/VDPAU/VGA)
    2. Lucid x64 ESXI 4.1 - Avermedia DVB-T per PCI Passtrough
    3. Inaktiv: yaVDR DVB-S2 TT-3200 VDPAU/HDMI SPDIF


    Linux User #292118
    VDR User #895

  • Quote

    Original von hepi
    izeman : Deine deb und deb-src-Einträge sind von der URL her überwiegend falsch.


    Die korrekten Einträge kann man auf diesen Seiten nachlesen:
    https://launchpad.net/~the-vdr…archive/vdr-ubuntu-karmic
    https://launchpad.net/~the-vdr-team/+archive/ppa
    https://launchpad.net/~the-vdr-team/+archive/yavdr


    danke. werde ich aendern. das was ich gepostet habe, waren die originalen die von der disti aus vorinstalliert waren. bloss um die src zeile ergaenzt.

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.6.1, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: samsung 75" amp:denon avr-x1300