aspect=auto & VDPAU

  • Hallo


    Mein Problem ist, dass ich gerne eine vollständige Bild-Ausnutzung meines 16:9 Fernsehers auch bei 4:3 Material hätte (also ein verzogenes Bild ohne schwarze Balken links und rechts).


    Beim Start von vdr-sxfe mit


    Code
    1. /usr/bin/vdr-sxfe -f "xvdr+tcp://127.0.0.1:37890" --nokbd --video=vdpau --post=tvtime:method=uses_vo_driver --fullscreen --reconnect --aspect=auto


    habe ich jedoch nur einen etwa 1 Pixel breiten vertikalen Streifen in der Bildmitte und folgende Fehlermeldung:


    Code
    1. assert: vo_scale.c:84: _x_vo_scale_compute_ideal_size: Assertion `this->gui_pixel_aspect != 0.0' failed.


    Gibt es dafür eine Lösung?


    Alternativ könnte ich, da ich sowieso kein HDTV habe. anstelle von VDPAU XV verwenden.
    Reicht XV um auf einem Atom 330 problemlos SD-Material von einer PVR500 in 1920x1080 zu schauen?


    PS:
    Ich verwende Ubuntu 9.10 und aktuell folgende VDR-Pakete:


  • Hi,


    schon probiert? Steht im VDPAU-Wiki unter Tipps und Tricks, wenn es mal nicht so läuft...


    Quote

    - Nur einen ganz schmalen Streifen (ca. 4mm) in der Mitte des Bildschirms (nach Neuinstallation xineliboutput):
    Im OSD unter den Plugin-Einstellungen für xineliboutput einstellen:
    Lokale Einstellungen -> Fenster-Seitenverhältnis auf CenterCutOut stellen. Im OSD speichern und VDR neustarten.


    Oder einfach in setup.conf folgendes einfügen: xineliboutput.DisplayAspect = CenterCutOut


    BTW: Ich gab den Parameter aspect=auto nie in vdr-sxfe mit sondern hatte nur die Einstellung im Setup!

    The post was edited 3 times, last by Taipan ().

  • "xineliboutput.DisplayAspect = CenterCutOut" habe ich bereits ausprobiert, leider habe ich trotzdem mit "aspect=auto" einen 1px breiten Strich, und ohne "aspect=auto" Balken links und rechts bei 4:3 Material.


    Hier meine ganze setup.conf, vielleicht findet ja jemand einen Fehler. Mangels Dokumentation für viele der Parameter habe ich Sie grösstenteils aus Beispielen zusammenkopiert.


  • Hallo!


    Hast du eigentlich eine lösung für dein problem gefunden?


    Ich habe ein ähnliches problem:
    das xine-plugin läuft bei mir recht instabil, deswegen verwende ich lieber sxfe.
    bei einigen kanälen und sendungen (zb bei vielen serien auf kabel1) kommt das bild nur mit etwa einem viertel der bildschirmfläche daher. beim xine-plugin passt sich dagegen bei diesen kanälen und sendungen die darstellung nach 1-2 sekunden automatisch auf bildschirmfüllend an.


    im osd ist in den xine-einstellungen seltsamerweise die lokale ausgabe auf aus. wenn ich sie aktiviere, folgt ein fehler bei der initialisierung der ausgabe (!?). ich hab dann die entsprechenden einstellungen händisch in die setup.conf eingetragen - leider ohne ergebnis. wenn ich den sxfe-aufruf mit aspect=auto mache, bekomme ich auch diesen wenige pixel breiten streifen in der mitte des schirms....


    ich nutze auf diesem rechner yavdr 0.1.1 mit den standard-paketen und einer nvidia-karte, die per hdmi mit meinem fullhd-plasma verbunden ist....


    hat irgend jemand eine idee, was ich noch versuchen könnte?


    cheers,


    Otto


    edit: hab nach tagen des suchens doch noch eine lösung gefunden: http://www.vdrportal.de/board/thread.php?threadid=97374 (thread wurde aber erst heute eröffnet ;-) )

    VDR-User 132
    server: Fedora 20, 2 x dvb-s2 (unicable), intel core 2 duo E8400@3GHz, vdr 2.0.2
    clients: xbmc auf raspi (openelec) mit xvdr, android


    The post was edited 2 times, last by oTTo001 ().