Anfrage: VDR1.7.x + vdpau + xbmc



  • Ich hoffe ja dies hier nun nicht untergeht ;)


    ogv ist ja nun nicht soooo unwichtig :)


    EDIT:
    Hab das Problem gerade "ausfindig" gemacht
    Die Endung .ogv wird warscheinlich einfach nicht erkannt/zugeordnet ...... nachdem ich das jetz mal nach file.ogg umbenannte habe, wird es angezeigt und abgespielt.
    Komisch :D

    HW 1
    Case: Pegasus "PT 760"
    Mainboard: Intel "DP67BGB3"
    PSU: Seasonic 400W Fanless
    Tuner: Mystique SatiX S2


    HW 2
    Case: Silverstone "LC16MR"
    Mainboard: ASRock "P45DE"
    PSU: Corsair 520W
    Tuner: TechnoTrend 3650 USB+CI Box (läuft nicht rund)

    The post was edited 1 time, last by thomas-f ().


  • Habe mal den Source von Tobi für libxine 1.1.19 gezogen und kompiliert. Die fehlenden Dateien sind nach dem Kompilieren enthalten scheinen beim Paketisieren jedoch nicht brücksichtigt zu werden. Habe die Dateien einfach nach /usr/lib/xine/plugins/1.29 kopiert und in der Konsole ldconfig ausgeführt. Nun gehts auch mit libxine 1.1.19 von Tobi. :) Ihr könnt die Dateien von hier herunterladen (leider nur für i386):


    http://www.justlinux.de/vdr/lostfiles_i386.tar.gz


    Gruß,


    Rasczak

    VDR 1.7.19 + ExtP-NG V6, Debian Squeeze, 2.6.32-5-686-bigmem Kernel, libxine 1.2, NVIDIA 290.10, ASUS M3N78-EM,
    AMD Athlon II X2 240e, 8 GB RAM, NVIDIA GeForce 8300 onboard, TechnoTrend S2-1600, picoPSU, 40 GB SSD

    Mein Skin: http://anthra.uk.to

  • Quote

    Original von Tobi
    Sollte sich mit der neuen Version des Paketes erledigt haben. Ich hoffe es passt jetzt. Sorry für die Unannehmlichkeiten!


    Sieht gut aus! :) Danke Dir!


    Hast Du das mit dem vdr-plugin-dvdswitch gelesen?


    Viele Gruesse,
    Martin

    Hardware: Intel E5300, Gigabyte GA-EP41-UD3L, 4GB DDR2-RAM, 60GB 2.5" System, 3TB 3.5" Daten, L4M Cine S2 V6.5 DuoFlex S2 V4, Samsung 46" LED-LCD TV
    Software: yaVDR mit diversen Plugins und XBMC
    Ambilight: SEDU Board, 112 * WS2801 LEDs, boblight/vdr-plugin-seduatmo


    Pro-Taucher - Tauchplätze weltweit

  • Hi Tobi,


    hab oben geschrieben, dass vdr-addon-dvdswitch deinstallatiert musste beim dist-upgrade da es eine Abhaengigkeit gibt, die nicht aufgeloest werden konnte. Glaube, das basierte auf einem 1.6er VDR.


    Absicht? Nicht Absicht? Sollte man was anderes nehmen als dieses Plugin?


    Viele Gruesse,
    Martin

    Hardware: Intel E5300, Gigabyte GA-EP41-UD3L, 4GB DDR2-RAM, 60GB 2.5" System, 3TB 3.5" Daten, L4M Cine S2 V6.5 DuoFlex S2 V4, Samsung 46" LED-LCD TV
    Software: yaVDR mit diversen Plugins und XBMC
    Ambilight: SEDU Board, 112 * WS2801 LEDs, boblight/vdr-plugin-seduatmo


    Pro-Taucher - Tauchplätze weltweit

  • Hallo Tobi!


    Quote

    Original von Tobi
    Also vdr-plugin-dvdswitch (nicht vdr-addon-dvdswitch, das gibts nicht!) installiert bei mir problemlos. Bei Bedarf probiers nochmal mit vdr-experimental/squeeze, vdr-ng-experimental verschwindet sowieso bald. Falls es immernoch nicht klappt, poste mal stdout/err.


    Hm, hat jetzt geklappt. Bin ratlos, aber nicht unzufrieden. ;)


    Kannst Du uns hier im Thread Bescheid geben, sobald vdr-ng-experimental verschwunden ist und in vdr-experimental ueberfuehrt wurde?


    Habe hier noch ein Problem. Seit kurzem (genauer kann ich es nicht einstufen), geht der Restart des VDR aus dem OSD nicht mehr. Der VDR beendet sich, startet sich aber nicht neu. Ueber die SSH-Console dann kein Thema, aber das ist nicht frauenkompatibel. ;) Habe nach weiter o.g. sources.list nur die aktuellsten Pakete drauf, der vdr ist Version 1.7.16-1devel1.


    Leider muss der VDR hin und wieder neu gestartet werden hier bei uns. Grund: Ab und an faengt das Bild an zu zucken, so im Sekundentakt. Das kommt immer dann, wenn man umschaltet oder mit dem xineliboutput Player ein Video abspielt. Kommt so alle 1-2 Tage irgendwann abends vor. Idee? (Hab jetzt faulerweise noch nicht hier im Forum nach diesem Fehler gesucht.)


    Viele Gruesse,
    Martin

    Hardware: Intel E5300, Gigabyte GA-EP41-UD3L, 4GB DDR2-RAM, 60GB 2.5" System, 3TB 3.5" Daten, L4M Cine S2 V6.5 DuoFlex S2 V4, Samsung 46" LED-LCD TV
    Software: yaVDR mit diversen Plugins und XBMC
    Ambilight: SEDU Board, 112 * WS2801 LEDs, boblight/vdr-plugin-seduatmo


    Pro-Taucher - Tauchplätze weltweit

  • vdr-experimental/squeeze ist bereits auf dem aktuellen vdr-ng-experimental-Stand. Letzteres Repository werde ich spätestens am WE löschen. vdr-experimental/sid werd ich heute Abend aktualisieren.


    Der Restart funktioniert bei mir. Bitte mal in folgender Datei eine kleine Änderung vornehmen:


    /usr/share/vdr/command-hooks/commands.ctvdr.conf


    Code
    1. - VDR neu starten? : nohup sh -c "( sleep 2 && /usr/lib/vdr/ctvdrwrapper --restart )" >/dev/null 2>&1 &
    2. + VDR neu starten? : nohup sh -c "( sleep 2 && /usr/lib/vdr/ctvdrwrapper --restart )" >/tmp/restart.log 2>&1 &


    Zu xineliboutput kann ich im Moment nicht viel sagen. Bin immernoch auf der Suche nach passender Hardware für einen neuen VDR (siehe http://www.e-tobi.net/blog/201…brauche-neuen-vdr-rechner )

  • Quote

    Original von Tobi
    vdr-experimental/squeeze ist bereits auf dem aktuellen vdr-ng-experimental-Stand. Letzteres Repository werde ich spätestens am WE löschen. vdr-experimental/sid werd ich heute Abend aktualisieren.


    Ok. Meine jetzige sources.list schaut so aus:



    Dh ich loesche einfach die vdr-ng-experimental Zeile und gut?


    Oder gehe ich bei vdr-experimental von squeeze auf sid wenn ich die neuesten Pakete haben will? Und sollte ich dann auch beim Rest auf sid gehen?


    Quote

    Original von Tobi
    Der Restart funktioniert bei mir. Bitte mal in folgender Datei eine kleine Änderung vornehmen:


    Aenderung ist drin, Restart mache ich nachher noch und poste hier das Log, grad laeuft ne Aufnahme.


    Quote

    Original von Tobi
    Zu xineliboutput kann ich im Moment nicht viel sagen. Bin immernoch auf der Suche nach passender Hardware für einen neuen VDR (siehe http://www.e-tobi.net/blog/201…brauche-neuen-vdr-rechner )


    Hab Dir das grad auch in Deinen Post geschrieben:


    Also ich bin mit dieser Hardware superzufrieden. War ne kleine Geburt bis wir das Anfang des Jahres hier im Forum entwickelt haben. Deckt sich bis auf die Onboard Graka und den gewünschten Slots (es kommt halt drauf an, was Du für TV-Karten verwenden möchtest) mit Deinen Vorstellungen.


    Viele Grüße,
    Martin

    Hardware: Intel E5300, Gigabyte GA-EP41-UD3L, 4GB DDR2-RAM, 60GB 2.5" System, 3TB 3.5" Daten, L4M Cine S2 V6.5 DuoFlex S2 V4, Samsung 46" LED-LCD TV
    Software: yaVDR mit diversen Plugins und XBMC
    Ambilight: SEDU Board, 112 * WS2801 LEDs, boblight/vdr-plugin-seduatmo


    Pro-Taucher - Tauchplätze weltweit

  • @ Roi: Meinst du mit Zucken, dass zwischendurch ein schwarzes Bild/Frame angezeigt wird? Das wäre ein Problem, das mit der 4:3/16:9-Erkennung zusammenhängt. Wurde schon mehrfach hier im Forum erwähnt, aber anscheinend gibt's dafür immer noch keinen Fix. Wenn man die Automatik in den Xineliboutput-Plugin-Preferences ausschaltet, dann kommt das nicht vor. Dummerweise sind dann 4.3-Inhalte verzerrt.

  • Ja, das klingt nach dem Thema.


    Kriegt man das wieder weg irgendwie ohne den VDR neu zu starten?


    Bloede Sache.

    Hardware: Intel E5300, Gigabyte GA-EP41-UD3L, 4GB DDR2-RAM, 60GB 2.5" System, 3TB 3.5" Daten, L4M Cine S2 V6.5 DuoFlex S2 V4, Samsung 46" LED-LCD TV
    Software: yaVDR mit diversen Plugins und XBMC
    Ambilight: SEDU Board, 112 * WS2801 LEDs, boblight/vdr-plugin-seduatmo


    Pro-Taucher - Tauchplätze weltweit

  • Ich glaube nicht, zumindest hab ich da auch nichts rausgefunden bislang. Ich hab die Automatik ausgeschaltet, da ich recht selten Sendungen in 4:3 schaue. Aber nerven tut's schon.


    Den Fehler gibt es schon seit vielen Monaten (oder seit es die 4:3-Automatik gibt), unverständlich, dass das nie gefixt wurde. Weiss jemand, wo/wem man einen Bug Report senden könnte? Das wäre wohl nicht der erste, aber vielleicht erhält dann ein Bugfix dieses lästigen Fehlers höhere Priorität, wenn ihn viele melden...

  • Quote

    Original von Tobi
    Der Restart funktioniert bei mir. Bitte mal in folgender Datei eine kleine Änderung vornehmen:


    /usr/share/vdr/command-hooks/commands.ctvdr.conf


    Nach der Aenderung klappt der Neustart...?!?


    Muss ich das verstehen? Ist doch nur geaendert von der Ausgabe her.


    Ich lass das mal so und beobachte weiter.


    Spannend...

    Hardware: Intel E5300, Gigabyte GA-EP41-UD3L, 4GB DDR2-RAM, 60GB 2.5" System, 3TB 3.5" Daten, L4M Cine S2 V6.5 DuoFlex S2 V4, Samsung 46" LED-LCD TV
    Software: yaVDR mit diversen Plugins und XBMC
    Ambilight: SEDU Board, 112 * WS2801 LEDs, boblight/vdr-plugin-seduatmo


    Pro-Taucher - Tauchplätze weltweit

  • Hi Tobi,


    habe ich mal so geaendert, habe aber die backports drinnen gelassen, die ich bauch beim vdr-ng-experimental drinnen hatte. Konnte auch direkt ein paar Pakete aktualisieren.


    Viele Grüße,
    Martin

    Hardware: Intel E5300, Gigabyte GA-EP41-UD3L, 4GB DDR2-RAM, 60GB 2.5" System, 3TB 3.5" Daten, L4M Cine S2 V6.5 DuoFlex S2 V4, Samsung 46" LED-LCD TV
    Software: yaVDR mit diversen Plugins und XBMC
    Ambilight: SEDU Board, 112 * WS2801 LEDs, boblight/vdr-plugin-seduatmo


    Pro-Taucher - Tauchplätze weltweit

  • Mein HD-vdr besteht aus:


    einem Gigabyte P35-S3G (5xPCI, je 1x PCIe 16 und 1x), einem Dual-Celeron 3300 und ner GT 220. erste Tests an einem Philpis TV sahen recht ordentlich aus (hab noch keinen LCD-TV zu Hause, vielleicht bringt ihn ja der Weihnachtsmann??? ;)
    Wenn dann die S2-Karte da ist, kanns richtig los gehen :)


    Bin in letzter Zeit mit Gigabyte immer sehr gut gefahren und zur Auswahl des Boards bezüglich Ausstattung kann ich nur die sehr differenzierte Auswahl bei heise empfehlen.


    Gruß Micha

  • Hallo,


    ich habe nun auch zu meinem normalen debian squeeze Quellen die von etobi hinzugefügt.


    Code
    1. root@marge:~# awk '/^[^#]/' /etc/apt/sources.list
    2. deb http://ftp.de.debian.org/debian/ squeeze main contrib non-free
    3. deb-src http://ftp.de.debian.org/debian/ squeeze main contrib non-free
    4. deb http://security.debian.org/ squeeze/updates main
    5. deb-src http://security.debian.org/ squeeze/updates main
    6. deb http://www.debian-multimedia.org squeeze main
    7. deb http://e-tobi.net/vdr-experimental squeeze base addons vdr-multipatch


    Die /etc/apt/preferences habe ich ebenfalls aktualisiert, damit die etobi-Pakete installiert werden können.


    Code
    1. Package: *
    2. Pin: release o=Debian,a=testing
    3. Pin-Priority: 600
    4. Package: *
    5. Pin: release o=e-tobi,a=testing
    6. Pin-Priority: 1000


    Habe dann ein apt-get update und apt-get upgrade gemacht, damit die Pakete von e-tobi genommen werden, falls dies noch nicht geschehen ist.


    Wie muss ich dann weiter vorgehen?

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • Kann mir keiner "kurz" beschreiben, welche Pakete ich aus dem e-tobi Repository installieren muss?

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV