Netceiver Probleme auf Ubuntu Karmic mit VDR VDPAU

  • Hallo,


    ich versuche für einen bekannten einen Netceiver mit einem VDPAU-VDR 1.7.9 aus dem Hotzenplotz PPA in Betrieb zu nehmen.
    Als Hardware kommt wie bei mir ein ASUS M3N78-EM zum Einsatz.
    Ich habe derzeit leider das Problem, dass ich von mcli die Meldung
    "Discontinuity on receiver 0x..." am laufenden Band ausgeworfen bekomme + die passenden Bildfehler.
    Während ich diese Zeilen gerade schreibe fällt mir gerade ein, dass es mit Cool & Quiet zusammenhängen könnte. Er hat einen Athlon 64 X2 4600+ drin. Könnte das sein, oder liegt es an etwas anderem?


    Weiterhin habe ich noch ein paar fragen zur Einbindung des Ganzen in die Systemtiefen. Bin ja eigtl. selber noch ein halber Einsteiger, aber ich will meinem Bekannten gern weiterhelfen, dass er ein lauffähiges System bekommt. Eine Frage ist, wie starte ich mcli passend, vor dem VDR unter Karmic?
    Auch nicht hinbekommen, habe ich bis jetzt Diseqc. Ich habe eine Diseqc.conf von mcli erstellen lassen und auch die A1...A4 rausgelöscht, dennoch scheint der VDR mit dem Format nichts anfangen zu können. Wenn ich Diseqc aktiviere geht gar nichts mehr. Verwende ich eine Standard diseqc.conf ist es das Gleiche. Nur ohne Diseqc bekomme ich ein Bild, aber halt nur die Programme vom ersten Sat.
    Also wie muss das korrekt aussehen?


    Ciao ciao


    gto

  • Hi,


    nur mal zum Thema Diseqc-Konfiguration: Ich habe das vor ein paar Monaten mal gemacht, völlig ohne Vorerfahrungen, an einem der einfachsten überhaupt existierenden Diseqc-Switches. Es hat sehr lange gedauert, bis ich es hinbekommen habe. Meine Erfahrung letztendlich war (und ich mag hier irren), dass es unheimlich hilft, nach jeder Änderung der conf-Datei vor dem Testen den Rechner komplett neu zu booten, wobei auch der DVB-S-Tuner vom Strom genommen wird. Vielleicht ist es übertrieben, aber es hat mich am Ende zum Ziel geführt.


    Gruß
    hepi

  • das mit dem netceiver wurde doch jetzt umgestellt und das dvbloop und mlci wird nicht mehr benötigt


    für den vdr gibt es da jetzt ein Plugin was die dvbkarten bereitstellt


    über dvbloop/mcli hatte ich ähnliche probleme

  • Hmm, also ich habe auch die Kombination Netceiver und VDPAU zu laufen und bis auf Probleme mit SEHR hohen Bitraten (derzeit nur auf Sky Sport HD bei deutschem Live-Fußball, das scheint aber am VDPAU Teil zu liegen) läuft es wunderbar. Ich habe auch noch die Kombination mcli/dvbloop.


    Mit dem ION-Onboard Netzwerk (forcedeth) klappte es nicht so gut, aber wie ich sehe läuft Dein Board ja über den Realtek Treiber, daran sollte es also nicht liegen...

  • Moorviper :


    Das klingt ja interessant, wo findet man Infos drüber? Hier im Portal steht ja überall nur, dass es ein vdr-plugin gibt, aber dass es sich nur um eine aufgestülpte Lösung handelt, die auf mcli,netcvupdate und netcvdiag aufsetzt. Zumindest kann ich nix anderes finden.

  • Das Problem mit der "komischen" diseqc.conf ist, dass der vdr darüber die tatsächliche Sat-Position "tunnelt", weil man sie sonst über die DVB-API nicht rüberbekommt.


    Es gibt einen Legacy-Modus, der kann nur Mini-Diseqc und eigentlich schon zwei Sats (die 1:1 durchgereicht werden), aber gut getestet ist er nicht.


    Entscheidend an der vom mcli erzeugten diseqc.conf ist, dass das Kommando in den [] genauso für den Satellit und seine Bänder benutzt wird. "Normale" Kommandos gehen nicht, ebenso nicht irgendwie veränderte.


    Das mit den Netzwerkproblemen (Paketverlusten) ist uns bei einem anderen AMD-Board mit Realtek und Dual-Core auch schon aufgefallen. Mit Single-Core gehts, mit Dual nicht. Ein Intel-Dual-Core macht aber auch keine Probleme. Den Realtek (und Treiber) halt ich da auch für unschuldig (weiss ja nix vom Dual-Core...), es könnte zB. irgendwas beim Cache-Snooping etc. daneben gehen. Aber weiter sind wir da auch noch nicht...

  • GTO :


    Das PI ist in den Sourcen mit drin. Es gaukelt dem vdr ein DVB-Device vor, ohne über die DVB-API zu gehen. Das ist eigentlich die wesentlich bessere Methode, weil der Diseqc-Kram wegfällt und auch nur so CAMs für mehrere Clients transparent behandelt werden können. Der vdr braucht aber zur vollen Nutzung ein paar Patches, da das ganze System schon ziemlich auf die FF-Karte getrimmt ist und mit den dann virtuellen Tunern etwas verschwenderisch umgeht...


    Wenn man keine CAMs braucht, tuts auch der mcli-Dämon, evtl. kommt da noch irgendwann mal ein Hack rein, dass darüber auch wieder CAMs laufen. Dann braucht er aber auch eine Kanalliste, weil die Service-ID benötigt wird.

  • HI,


    bevor Du lange suchst, das problem ist der Netzwerktreiber. Unter Linux wird der forcede(a)th Treiber verwendet und leider verursacht DER immer Discontinuity Errors am laufendem Band.


    Egal welcher Kernel, egal welche Einstellungen, egal welches linux. Ich habe Tage daran rumgeschraubt, helfen tut nur eine andere NIC.


    Es gibt im vdr-wiki eine Netceiver-Sektion, leider hatte ich in letzter Zeit weniger Zeit zur Verfügung wie ich eigentlich gedacht hatte (es sind aber gerne alle herzlich eingeladen, dies zu ergänzen ;) )


    hier findest Du infos zum mcli-Plugin und dessen Kompilierung


    MfG
    KRis

    Intel DN2800MT 4GB RAM; 32GB mSata, Ubuntu 15.04, TVHeadend 4.1, Digibit R1 SatIP

    The post was edited 1 time, last by kris ().

  • HI,


    so, bin endlich zuhause.


    Razorblade

    Quote

    bei Asus in der Download-Sektion auf LAN-Treiber gehe bekomme ich einen RTL8111 angeboten und das ist bekanntermaßen die Onboard-Variante des RTL8169...


    Keine Ahnung wo Du da rtl8111 siehst (selbst im Handbuch steht nichts), das Asusboard hat zwar eine externe Realtek-Phy aber keinerlei Treiber laufen damit. Ich hatte damals von de realtek seite die r8168 Treiber bereits runtergeladen und kompiliert. Lief aber leider nicht.


    Fakt ist leider, das M3N78-EM mit forcede(a)th Treiber in Verbindung mit dem Netceiver die Fehler verursachen. Daher habe ich eine 08/15 Billig NIC eingebaut und seither keinerlei Probleme.


    Mittlerweile gibt es zwar bei Realtek neue Treiber aber da ich eine 2.6.31 Kernel fahre, lassen sie die Module nicht kompilieren. Sollte etwas neues kommen, melde ich micht :)


    MFG
    Kris

    Intel DN2800MT 4GB RAM; 32GB mSata, Ubuntu 15.04, TVHeadend 4.1, Digibit R1 SatIP

    The post was edited 1 time, last by kris ().

  • Hallo,


    ich bin jetzt wieder an dem VDR aktiv.
    Habe inzwischen eine PCI-Netzwerkkarte eingebaut und angeschlossen.
    dvbloop lade ich nicht mehr.
    Habe das mcli-Plugin in Version 0.9.0 kompiliert und den vdr neugestartet, Bild läuft jetzt ohne Aussetzer auch mit CnQ. Was ich noch nicht hinbekomme, ist Hotbird-Sender anzutunen. Astra 19.2 geht.

    ASUS M3N78-EM, Athlon II X2 215, Technotrend 1600, yaVDR, Pollin X10

    The post was edited 1 time, last by GTO ().

  • Wenn die Tuner alle an die "Multiswitch 1"-Liste gebunden sind, sollte das gehen. Schau bitte mal die "netcvdiag -s"-Ausgaben an, wenn 13.0 getuned ist. Ein Tuner sollte einen Usage-Count !=0 haben und die Position bei dem auch auf 13.0 stehen...

  • > UUID <fe80::208:54ff:fe55:1c8b>:
    > slot 0.1, type DVB-S, used: 7
    > LOCK , frequency 11804000kHz (1201.4MHz), position <13.0E>
    > strength f8f8, snr ebd9, ber 0000, unc 0000
    > NIMCurrent 89
    > RotorStatus 0, RotorDiff 0.0


    Sieht alles gut aus, wird benutzt *und* hat Lock. D.h. am NetCeiver ist alles angekommen. Nachdem der Frequenzoffset von 3 MHz (1204-1201) auch recht klein ist, kann man auch ausschliessen, dass der LNB wg. Diseqc-Problemen auf Astra steht und einen in der Nähe liegenden Transponder noch gerade so erwischt hat.


    Stimmen die Pids? RAI Gulp geht zB. bei mir mit VPID 522, APID 663 und SID 3310.

  • Hallo,


    ich bin nach wie vor noch an diesem Problem dran. Die PIDs und SID habe ich überprüft, die stehen bei mir auch so in der channels.conf von Linowsat drin, die ich testweise benutze. Ein Bild bekomm ich aber leider nicht.

  • Bin mittlerweile der Sache auf die Spur gekommen, die Diseqc-Konfiguration im Netceiver war falsch, habe diese mit netcvupdate heruntergeladen, editiert, hochgeladen und jetzt geht es.