ACPI Wakeup - shutdown-hooks werden nicht ausgeführt

  • Hallo,


    bin ein ziemlicher Neuling mit VDR. Hatte bis kürzlich eine DVB Rekorder Lösung unter Windows XP am Laufen und bin nun auf was gescheites umgestiegen. Nach einigem Gefummel und herumgesuche auch hier im Forum läuft jetzt auch fast alles.


    Tja, fast alles, ausser das Aufwachen des Rechners für Aufnahmen. Zwar funktioniert das ACPI Wakeup wenn ich es manuell ausprobiere, jedoch klappt es nicht den VDR dazu zu bewegen die Aufwachzeit beim Herunterfahren auch zu schreiben.


    Dafür gibt es ja das S90.custom Skript im shutdown-hooks Verzeichnis. Ich habe probeweise da etwas hineingeschrieben (ein schlichtes echo "Hallo" > /tmp/test.txt), habe es ausführbar gemacht und fahre den Rechner über den vdradmin-am herunter (in der "Fernbedienung" im Browser). Aber das Skript wird einfach nicht ausgeführt.

    Hier komme ich nicht weiter.


    Muss ich noch irgendwas tun damit die Skripte in shutdown-hooks auch ausgeführt werden? Umbenennen, irgendwo hinkopieren? Wo muss ich eigentlich meinen eigenen Code hinschreiben, in die S90.custom oder in andere, eigene Skriptdateien? Brauche ich das vdr-addon-acpiwakeup eigentlich dafür? Das sind doch eigentlich auch nur vorgefertigte Skripte, oder?


    Vielen Dank für Hilfe!


    Ansonsten bin ich bis jetzt echt begeistert 8)


    Ich habe ein Debian Lenny System laufen mit dem vdr 1.6.0 aus den Debian Quellen.


    Gruss, Robert

    PC: Fujitsu-Siemens Midi Tower, 3.0 GHz Pentium 4 Dual Core, Grafik Nvidia Geforce 9300GS
    Betriebssystem: Debian Jessie
    DVB: 2 x Terratec Cinergy 1200 DVB-C
    VDR: Version 2.0.3, Videoausgabe mit xineliboutput/vdr-sxfe ueber TV-Out an Roehrenglotze
    IR: Atric Empfaenger/Einschalter, Hauppauge WinTV2000

  • Hallo Robert,


    erst mal :welcome im Forum und beim VDR :)


    Die Dateien für den Shutdown sind schon am richtigen Platz, da musst du nichts verschieben/kopieren
    Pfad: /usr/share//vdr/shutdown-hooks/


    Für das Aufwachen, musst du entweder das "ACPI" addon oder "NVRAM-Wakeup" installieren.
    Damit wird dann auch jeweils ein shutdownskript unter "shutdown-hooks" angelegt. Da muss im Regelfall nichts verändert werden.
    Nur für deine Eigenen individuellen Wünsche ist die Datei "S90.costum" gedacht. Da kannst du für deine eigenen Wünsche noch befehle/skripte ausführen beim Shutdown, oder auch den Shutdown abbrechen lassen, wenn z.B. noch ein User am System angemeldet ist.


    Nun zu deinem konkretem Problem:
    Bin mir nicht sicher ob ich da die Lösung habe, aber versuchs mal damit:
    Such mal in der Datei /et/defaults/vdr eine Variable "ENABLE_SHUTDOWN" und setzt die auf eins

    Code
    1. ENABLE_SHUTDOWN=1


    Zum beobachten was während des Shutdowns passiert gibts mehrere Möglichkeiten.
    1.) Nach erneutem Booten das Logfile durchsuchen "/var/log/syslog"
    2.) Gleich beim shutdown die Logdatei mit beobachten mit dem Befehl

    Code
    1. tail -f /var/log/syslog


    Gruß,
    Hego

    VDR-Sever: ct-VDR 6 und vdrdevel 1.7.0, AthlonXP1600+,256MB RAM, 1.7TB HDD, DVB-S Technotrend 1.6
    VDR-Client:VDR-1.4.4,Sarge, VIA EP ML-6000EA Mini-ITX Motherboard 677MHz, 512MB RAM, 1050GB HDD, DVB-S Technotrend 1.6; Kernel 2.6.16-ct-1
    NFS-File-Server; openSuse10.2: Atholon 3400+, 1GB RAM, 4.0TB HD, :P
    Server: SuSE9.3, Kernel 2.6.11.4-21-7

  • Hallo Hego,


    danke, ich hab' das addon installiert und jetzt wird schonmal die Aufwachzeit ins Bios geschrieben 8) Leider aber nicht das Datum. Für eine Aufnahme am 21.10. um 8:20 sieht's im Bios so aus:




    Also nur Sternchen statt dem Datum. HWCLOCK update beim Herunterfahren ist abgeschaltet. Ist das normal?


    Nun ja, muss mal herumspielen und testen. Auf alle Fälle bin ich schonmal einen guten Schritt weiter gekommen. Vielen Dank!


    Gruss, Robert

    PC: Fujitsu-Siemens Midi Tower, 3.0 GHz Pentium 4 Dual Core, Grafik Nvidia Geforce 9300GS
    Betriebssystem: Debian Jessie
    DVB: 2 x Terratec Cinergy 1200 DVB-C
    VDR: Version 2.0.3, Videoausgabe mit xineliboutput/vdr-sxfe ueber TV-Out an Roehrenglotze
    IR: Atric Empfaenger/Einschalter, Hauppauge WinTV2000

  • Quote

    WCLOCK update beim Herunterfahren ist abgeschaltet. Ist das normal?


    ja, das ist gut so, da bei manchen Biose durch das updaten der HWCLOCK beim shutdown die wake-up Zeit wieder gelöscht oder deaktiviert wird.


    Welchen Befehl hast du zum setzten der Wakeup Zeit verwendet?
    Probiers mal mit

    Code
    1. echo `date '+%F %T' '-d + 5 minutes'` > /proc/acpi/alarm


    Damit setzt er bei mir sauber die aufwachzeit auf "jetzt" + 5 Minuten inclusive Datum

    VDR-Sever: ct-VDR 6 und vdrdevel 1.7.0, AthlonXP1600+,256MB RAM, 1.7TB HDD, DVB-S Technotrend 1.6
    VDR-Client:VDR-1.4.4,Sarge, VIA EP ML-6000EA Mini-ITX Motherboard 677MHz, 512MB RAM, 1050GB HDD, DVB-S Technotrend 1.6; Kernel 2.6.16-ct-1
    NFS-File-Server; openSuse10.2: Atholon 3400+, 1GB RAM, 4.0TB HD, :P
    Server: SuSE9.3, Kernel 2.6.11.4-21-7

  • Hab' es per Hand so gemacht:



    Dann wird das Datum auch gesetzt und der Rechner wacht brav auf. Werd' mir gleich mal das Skript da zu Gemüte führen...


    Ich hab' versucht herauszufinden was vom S90.acpiwakeup Skript ins Bios geschrieben wird, aber selbst wenn ich ganz am Anfang ein echo "$1" > /tmp/test.txt hinschreibe wird nichts geschrieben? Und wenn ich die Funktion



    abändere damit er in die Datei /tmp/wakealarm schreibt, dann schreibt er trotzdem ins Bios und nicht auf die Platte. Was'n da los? Bin gerade etwas sehr ratlos. :schiel Sheint so als hätten Änderungen am Skript keinerlei Effekt...


    Wie kann ich denn anders herausfinden was dieses Skript macht?

    PC: Fujitsu-Siemens Midi Tower, 3.0 GHz Pentium 4 Dual Core, Grafik Nvidia Geforce 9300GS
    Betriebssystem: Debian Jessie
    DVB: 2 x Terratec Cinergy 1200 DVB-C
    VDR: Version 2.0.3, Videoausgabe mit xineliboutput/vdr-sxfe ueber TV-Out an Roehrenglotze
    IR: Atric Empfaenger/Einschalter, Hauppauge WinTV2000

  • Du musst erst mal prüfen, ob das Skript ausgeführt wird, normalerweise müssen die Skripte selbst nicht editiert werden!


    Such mal im Logfile /var/log/syslog nach der Shutdownsequenz und prüfe ob die Skripte auch wirklich ausgeführt werden.
    Da sollte sowas wie

    Code
    1. executing /usr/share/vdr/shutdown-hooks/S90.acpiwakeup as shell script


    eingetragen sein.
    Ist das nicht der Fall dann musst du den Fehler finden, warum das Skript nicht ausgeführt wird.

    VDR-Sever: ct-VDR 6 und vdrdevel 1.7.0, AthlonXP1600+,256MB RAM, 1.7TB HDD, DVB-S Technotrend 1.6
    VDR-Client:VDR-1.4.4,Sarge, VIA EP ML-6000EA Mini-ITX Motherboard 677MHz, 512MB RAM, 1050GB HDD, DVB-S Technotrend 1.6; Kernel 2.6.16-ct-1
    NFS-File-Server; openSuse10.2: Atholon 3400+, 1GB RAM, 4.0TB HD, :P
    Server: SuSE9.3, Kernel 2.6.11.4-21-7

    The post was edited 1 time, last by hego ().

  • Hallo Hego,


    Oh Mann... Ich habe die ganze Zeit die Skripte in /etc/vdr/shutdown-hooks editiert... Das kann ja nicht gehen wenn der vdr Kopien der Skripte an einem anderen Ort verwendet.


    Danke für den Tip mit dem syslog!


    In /usr/share/vdr/shutdown-hooks war S90.custom mit einem Softlink auf das Skript in /etc/vdr/shutdown-hooks gelinkt, S90.acpiwakeup jedoch nicht, das war eine echte Kopie. Kann ja nicht gehen so... Habe das korrigiert und dann ging's auch.


    Etwas herumprobieren ergab dass das Skript die Aufwachzeit völlig korrekt ins Bios schreibt. Nach dem Reboot fehlt dann aber das Datum, das Board wacht auch nicht auf. Irgendwas zerstört beim Shutdown also den Eintrag im Bios, obwohl das Hardwareclock update abgeschaltet ist und auch der Kernel Parameter hpet=disable gesetzt ist. Laut kernel log sollte das Board aufwachen aus dem S5 aber unterstützen, da steht was von "ACPI supports (S1 S2 S4 S5)". Na ja...


    Ich beschreibe das Problem mal genauer in einem neuen Thread, habe nämlich auch versucht auf hibernate S4 auszuweichen, was nicht recht funktionierte weil das Board wenn vdr aktiv war in einem Zombiezustand hängen blieb in dem zwar die Festplatte abgeschaltet war, der Lüfter aber weiterlief und die Netzwerkkarte nicht auf WOL reagierte. Warst das nicht Du der auch mal sowas hatte? Wie es aussieht habe ich das (nicht ganz sauber... aber scheint zu gehen) hinbekommen. Muss das aber erst noch austesten.


    Gruss, Robert

    PC: Fujitsu-Siemens Midi Tower, 3.0 GHz Pentium 4 Dual Core, Grafik Nvidia Geforce 9300GS
    Betriebssystem: Debian Jessie
    DVB: 2 x Terratec Cinergy 1200 DVB-C
    VDR: Version 2.0.3, Videoausgabe mit xineliboutput/vdr-sxfe ueber TV-Out an Roehrenglotze
    IR: Atric Empfaenger/Einschalter, Hauppauge WinTV2000