VDR-1.7.10 -gda(Extensions-Patch v.72) + Plugins + XBMC pvr-testing für Ubuntu-Karmic + yaVDR

  • Quote

    Original von MarkusE


    Es ist mir vollkommen egal was im Kommentar steht. Ich wiederhole nochmal: Ich habe im Code nachgesehen und es ist nichts davon da! Was erwartest du noch von mir? Wenn du meiner Expertise nicht traust, was soll dann die Nachfrage? Ansonsten ist der Autor des Patches der Ansprechpartner.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

    The post was edited 1 time, last by gda ().

  • Hallo Gerald,


    vielen Dank für Dein PPA, und daß Du auf meine Anfrage sogar im Code nachgeschaut hast. Das ist eigentlich schon mehr, als man erwarten kann.


    Ich habe noch mal gefragt, in der Hoffnung, einen Hinweis auf die Lösung zu bekommen.


    Ich habe weiter gesucht und gefunden:


    - TurnOffPrimary gibt es nicht mehr im extension patch
    - Nachfolger: Einstellungen/DVB/Channelblocker: whitelist und darunter Einstellungen/DVB/Channel Blocker Filter Mode: is primary. Bewirkt, dass der Tuner der FF Karte nicht verwendet wird. Funktioniert aber nicht bei Verwendung des xineliboutput plugins, hilft mir also nicht.


    Lösung:
    a) Reihenfoge der Karten festlegen wie hier:


    http://www.vdrportal.de/board/…?postid=823970#post823970


    beschrieben.
    b) TPID in channels.conf anpassen. Geht mit:

    Code
    1. awk --field-separator ':' --assign OFS=':' '{ if ( $1 != "" && $9 == 0 ) { $9 = 2 } ; print $0 }' /var/lib/vdr/channels.conf


    Markus

    VDR1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 18.04, VDR 2.4x
    VDR2: ASUS P4B533, Celeron 2.4G, FF 1.5, Ubuntu 10.10, VDR 1.6 (SS2 Rev 2.6B)
    VDR Server: sheeva-plug

  • Quote

    Original von hotzenplotz5
    MarkusE ichweiss nicht ob das hier ein geeigneter ersatz sein könnte:
    channel-binding Patch
    wenn ja, müssen wir noch sehen ob das so einfach geht mit einbauen.


    Hallo hotzenplotz5,


    vielen Dank für Dein Angebot! Ich habe 'mein' Problem gelöst (s. meinen letzten Post), brauche diesen Patch also nicht.


    Markus

    VDR1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 18.04, VDR 2.4x
    VDR2: ASUS P4B533, Celeron 2.4G, FF 1.5, Ubuntu 10.10, VDR 1.6 (SS2 Rev 2.6B)
    VDR Server: sheeva-plug

  • Hab gerade ein devel-update eingespielt :-) (bin eben neugierig sorry :P)


    xine spielt den Stream nicht ab


    Code
    1. xine engine: Fehler
    2. Es ist kein Eingabe-Plugin vorhanden um 'vdr:/tmp/vdr-xine/stream#demux:mpeg_pes' zu verarbeiten.
    3. Vielleicht ist die MRL falsch oder Datei/Dateistrom existiert nicht.


    am VDR liegt es nicht denn streamdev und vdr-sxfe funktionieren (vdr-sxfe bei HD-Material aber nicht flüssig, vermutlich aber aufgrund der settings, habe dort nichts umgestellt da ich imemr vdr-xine verwende)


    thx im voraus!



    mfg

  • hab ich alles :P


    rechner wollte danach auch nicht gleich booten
    nvidia-xconfig hats aber gerichtet :-)


    libxine ist überall das aktuellste installiert



    (testen macht ja spaß, läuft ja schließlich immer besser, da stören mal paar kleine Probleme nicht wirklich :-) )


    mfg

  • Code
    1. apt-cache policy nvidia-195-libvdpau-dev
    2. nvidia-195-libvdpau-dev:
    3. Installiert: 195.22-1tvt2
    4. Kandidat: 195.22-1tvt2
    5. Versions-Tabelle:
    6. *** 195.22-1tvt2 0
    7. 500 http://ppa.launchpad.net karmic/main Packages
    8. 100 /var/lib/dpkg/status


    jetzt wo dus sagst, hatte damit aber beim updaten eingie Probleme, musste zuerst wirklich alles löschen, libxine, nvidia* und danach die neueren pakete installieren, sonst brachte er immer einen fehler da nvidia-195-libvdpau die selben files wie nvidia-190-libvdpau enthält und er sie nicht überschreiben konnte
    meinst du daran liegt der fehler?


    mfg

  • Code
    1. apt-cache policy libxine2
    2. libxine2:
    3. Installiert: 1.2.0+hg+vdpau+r285+crop+v11-1tvt4
    4. Kandidat: 1.2.0+hg+vdpau+r285+crop+v11-1tvt4
    5. Versions-Tabelle:
    6. *** 1.2.0+hg+vdpau+r285+crop+v11-1tvt4 0
    7. 500 http://ppa.launchpad.net karmic/main Packages
    8. 100 /var/lib/dpkg/status


    lg

  • Code
    1. apt-cache policy nvidia-glx-195
    2. nvidia-glx-195:
    3. Installiert: 195.22-1tvt2
    4. Kandidat: 195.22-1tvt2
    5. Versions-Tabelle:
    6. *** 195.22-1tvt2 0
    7. 500 http://ppa.launchpad.net karmic/main Packages
    8. 100 /var/lib/dpkg/status


    leider auch aktuell :-)


    habe auch mal libxine2 geholt und auf dem rechner kompiliert da ich dachte viellicht passen ja einige abhängigkeiten nicht, aber hat auch nicht geholfen...

  • aaaah stimmt :-)
    das hängt aktuell von libxine1 ab


    habe mir die sourcen aus dem stable-repo geholt und gebaut, läuft nun
    vdr-xine will aber root-rechte *lol*


    übrigens läuft wirklich immer besser, inzwischen kann ich auch jeden HD-Sender umschalten und das Bild ruckelt max 1 Sekunde und dann ist das 100% Stable, das schaffte ich mit älteren Versionen (VDR 1.7.9 & Co) noch nicht, egal welche Werte ich dort in der .xine/config verwendet habe :-)


    mfg


    edit: ohne Rootrechte beim starten von vdr-xine:


    Code
    1. NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
    2. vo_vdpau: Can't create vdp device : No vdpau implementation.
    3. main: Videotreiber <vdpau> konnte nicht geladen werden


    edit2:
    jetzt läuft es auch ohne Rootrechte, mein User muss aus irgendwelchen (mir nicht erklärlichen...) Gründen beim installieren des neuen Grafiktreibers aus der Gruppe VIDEO verschwunden sein, habe es hinzugefügt und nun läuft es einwandfrei :-) (sorry ich konnte nicht wiederstehen es auszuprobieren ob ich xine-ui zum laufen bekomme :D )

  • Hallo,


    also ich habe jetzt nochmal alles aktualisiert und ein paar kleinere Test gemacht. Soweit scheint erst mal alles zu funktionieren, außer bei den folgenden Plugins stürzt der VDR immer ab, wenn man versucht das Plugin per Setup im OSD:


    Code
    1. epgsearchonly - plugin setup - option ändern
    2. quickepgsearch - plugin setup - option ändern
    3. Nov 29 21:09:23 k8master kernel: [23797.390618] vdr[7638] general protection ip:80f364d sp:bf802760 error:0 in vdr[8048000+14b000]
    4. Nov 29 21:09:23 k8master kernel: [23797.390618] vdr[7638] general protection ip:80f364d sp:bf802760 error:0 in vdr[8048000+14b000]
    5. conflictcheckonly - plugin setup - option ändern
    6. Nov 29 21:16:31 k8master kernel: [24225.738072] vdr[7882] general protection ip:80f364d sp:bfa1a4e0 error:0 in vdr[8048000+14b000]


    Gruß
    KiWiX


    EDIT: Nochmal zur Hardware: VDR DVB-S FF Rev. 2.3

    server
    * Asrock, Intel Celeron, 2xDVB-S2 (nGene), Proxmox VE 5.1, Debian Stretch, e-Tobi VDR 2.4 experimental (streamdev, live, vnsi, epg)
    clients
    * none (at the moment)

    The post was edited 1 time, last by kiwix ().