[text2skin] HD Skin: PearlHD (Neu:SD+HDReady)

  • 2.6.29-gentoo-r5, vdr-1.7.9, xine-vdpau-284, vdr-xine 0.93 - 5050e, M3A78-EM, Postville, 2xTTS21600

    PearlHD text2skin

  • Eine Kleinigkeit hab ich noch gefunden: in der Menüansicht werden keine Messages angezeigt.
    Wie Warnmeldung/-frage zB von extrecmenu beim Löschen einer Aufzeichnung kommt hier nicht.


    Um's nachzuvollziehen: Cursor auf eine Aufzeichnung, Geld für editieren, nochmal gelb für löschen, dann kommt die Warnung "Aufzeichnung wirklich löschen" (hier aber eben nicht), bei OK wird wird das ausgeführt, momentan aber halt im Blindflug ;-)


    Sonst: Superspitze, ich bin grad von morgens bis abends begeistert :D


    Was ich noch gerne hätte wär ein Anzeigebereich für die nächsten Timer wie bei EnigmaNG, aber ich schätze mal das kann die aktuelle Text2Skin wohl nicht...

  • Also ich bekomme das nicht hin, kann es sein das hier mein Overscan zuschlägt?

    NFS+DVB_Server: Ubuntu 12.04 Server LTS // Intel dn2800mt mit 1xWD Red (2TB), 1xWD Green (2TB), 5xSundtek SkyTV DVB-S/S2
    VDR: Gen2VDRV4 (VDR-2.1.6) // Asus C8HM70-I/HDMI , 64GB Sandisk SSD (System), 4GB Ram (Dualchannel), Zotac GT630, 4TB über NFS (Video0+Mediadaten), 5xSundtek SkyTV DVB-S/S2 über Lan, PS3 FB // softhddevice_GIT, NV-Treiber_340.58, FFMPEG_1.2.6, Kernel_3.16.5, Alsa_1.0.28 // KODI_15.0_ALPHA
    CLIENT: (Debian) Banana Pi (VDR-2.1.7) // streamdevclient // softhddevice // PS3 FB
    TEST: Grundig GSS 400 mit Vtunerc // Satip-Plugin // TVheadend


    Je mehr man gelernt hat, desto mehr weiß man, wie wenig man weiß.

  • Quote

    Original von zwick der agent
    Also ich bekomme das nicht hin, kann es sein das hier mein Overscan zuschlägt?


    Bei mir fragt vdr-sxfe ab einer bestimmten OSD-Größe die OSD-Größe im VDR selbst ab und nimmt die. Ich musste bei Einstellungen->OSD alles ganz auf Maximum stellen. Das siehst du, wenn du beim Öffnen des Menus den syslog mitlaufen lässt. Ein paar wenige Pixel fehlen mir dann rechts trotzdem noch. Mir fehlt etwa bei der Uhrzeit oben rechts die Hälfte der letzten Stelle.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Quote

    Original von Thomas
    Was ich noch gerne hätte wär ein Anzeigebereich für die nächsten Timer wie bei EnigmaNG


    Das fand ich immer so hässlich, dadurch würde die klare Struktur wieder so zerstückelt. Lieber auf ein paar Informationen verzichten.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • gda


    Also alles auf Max gestellt und hier ein tail -f /var/log/syslog:


    Sep 30 21:55:33 freevdr vdr: [4162] Text2Skin: channelInfo display update thread started (pid=3815, tid=4162)
    Sep 30 21:55:38 freevdr vdr: [4162] Text2Skin: channelInfo display update thread ended (pid=3815, tid=4162)


    Was sagt mir das jetzt?

    NFS+DVB_Server: Ubuntu 12.04 Server LTS // Intel dn2800mt mit 1xWD Red (2TB), 1xWD Green (2TB), 5xSundtek SkyTV DVB-S/S2
    VDR: Gen2VDRV4 (VDR-2.1.6) // Asus C8HM70-I/HDMI , 64GB Sandisk SSD (System), 4GB Ram (Dualchannel), Zotac GT630, 4TB über NFS (Video0+Mediadaten), 5xSundtek SkyTV DVB-S/S2 über Lan, PS3 FB // softhddevice_GIT, NV-Treiber_340.58, FFMPEG_1.2.6, Kernel_3.16.5, Alsa_1.0.28 // KODI_15.0_ALPHA
    CLIENT: (Debian) Banana Pi (VDR-2.1.7) // streamdevclient // softhddevice // PS3 FB
    TEST: Grundig GSS 400 mit Vtunerc // Satip-Plugin // TVheadend


    Je mehr man gelernt hat, desto mehr weiß man, wie wenig man weiß.

  • Hallo,


    vielen Dank für den tollen Skin, gefällt mir sehr gut.


    Zwei kleine Probleme habe ich jedoch noch:
    1. In der Kanalliste werden die Sendernummern nur zweistellig angezeigt und beim markieren gescrollt. Schöner fände ich es wenn dort 4stellige Nummern angezeigt werden.
    2. In der Programmvorschau sehe ich bei der Anfangszeit nur den Tag und die Stunde. Wenn eine Sendung markiert ist wird die Anfangszeit gescrollt, allerdings etwas merkwürdig.
    z.B. gerade au ZDFdoku Das kleine Fernsehspiel, Beginn Mi 30.09.09 22:00 - 23:30
    Angezeigt in der Übersicht wird "Wed22:" Der Text wechselt bei Auswahl von "Wed22:" nach "ed 32:0" und "d 30:00".
    Optimal fände ich wenn in der Übersicht "Wed 22:00" angezeigt würde.
    (mein VDR steht auf english daher "Wed")


    Gruß
    Jens

    VDR1: Gigabyte E7AUM-DS2H (GF 9400), CoreDuo E5200, 2x TBS 6981, 2x Terratec Cinergy-C 1200
    Ubuntu 10.04 64Bit, VDR 1.7.16, epgsearch, xine, femon, streamdev, externalplayer, text2skin, osdteletext, tvm2vdr, imonlcd
    VDR2: MSI 915GM Speedster, PentiumM 1,8GHz, 2GB RAM, 1x Hauppauge Nova-S, yaVDR 0.3

  • Quote

    Originally posted by randy
    bei meiner gf8400gs (pci) mit 512mb geht hardware und software transparenz im
    standard-osd skin.


    -- randy


    Hi randy! Ich verwende ja auch eine PCI variante. Hast du auch das Problem, dass bei jeder OSD Aktivität (jede Auswahl eines Menüpunktes) und besonders bei laufschrift das Videobild ruckelt? Dieses Problem habe ich schon seit langem und bei jedem Skin. Mal interessant wenn jemand eine vergelichbare Karte hat. Meine hat auch einen 8400er Chip und 512MB Ram.


    Transparenz funktioniert sowohl im Hard- als auch im Software Modus. Ich habs jetzt auf VDR 1.7.0 laufen und dort 1920x1080 eingestellt. Leider ganau das gleiche wie im 1.7.9, die Dartstellung stimmt nicht.und wirkt Zerissen.


    Soweit meine Tests....


    Atech

    HTPC:
    Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
    Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, TT3650-CI USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

  • Quote

    Original von Thomas
    Was ich noch gerne hätte wär ein Anzeigebereich für die nächsten Timer wie bei EnigmaNG, aber ich schätze mal das kann die aktuelle Text2Skin wohl nicht...


    Das konnte (afaik) das echte Enigma unter text2skin auch schon seit Jahren. Also gehe ich mal nicht davon aus, daß das zum Problem werden sollte ;)


    EDIT: Ja, konnte es:


    [Blocked Image: http://brougs78.vdr-developer.org/tmp/Enigma-0.4pre8_1.jpg]


    Grüße
    Michi

    Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
    In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::


    "Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

  • Quote

    Original von gda


    Das fand ich immer so hässlich, dadurch würde die klare Struktur wieder so zerstückelt. Lieber auf ein paar Informationen verzichten.


    Gerald


    Kann ich nur unterstreichen. Würde die schöne Optik zerstören.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • Quote

    Original von Atechsystem
    Hi randy! Ich verwende ja auch eine PCI variante. Hast du auch das Problem, dass bei jeder OSD Aktivität (jede Auswahl eines Menüpunktes) und besonders bei laufschrift das Videobild ruckelt? Dieses Problem habe ich schon seit langem und bei jedem Skin. Mal interessant wenn jemand eine vergelichbare Karte hat. Meine hat auch einen 8400er Chip und 512MB Ram.


    hi,


    ja, das kann ich auch beobachten; speziell bei laufschriftem im osd geht gar nichts mehr,
    normalerweise stockt das bild fuer ca. ne halbe sekunde pro osd aenderung.


    die zeiten aendern sich auch nicht grossartig zwischen verschieden schnellen systemen,
    in dem fall habe ich einen 667mhz p3 und einen 2,4ghz p4 getestet. koennte aber leicht
    sein, das mit einer dualcore cpu das phaenomen verschwindet.


    -- randy

  • Hallo,


    ich nutze jetzt Version 0.0.3.


    Sieht echt klasse aus.
    Aber ich beobachte folgende Probleme:
    *In NordlichtsEPG werden die Fortschrittsbalken falsch dargestellt
    *In NordlichtsEPG werden die Details zum Programm nicht angezeigt (kein Text)
    *In den Aufnahmen werden links die Symbole falsch dargestellt
    *Es gibt zu wenig Platz zwischen Datum und Uhrzeit, sowie zwischen Uhrzeit und Text. Das Datum muss sogar scrollen.
    *Im Hauptmenü würde ich mir ein wenig mehr Kontrast wünschen (bei den nicht gewählten Punkten, ich nutze das default-theme.



    Gruß,
    Hendrik

  • Quote

    Original von henfri
    *In den Aufnahmen werden links die Symbole falsch dargestellt


    Das ist bei mir auch so, ich vermute das liegt an der Arial-Schriftart, die ohne die "richtigen" Symbole ist. Irgendwo hier war mal ein Thread wie man das in eine TTF-Schriftart hineinbekommt.

  • Thomas
    Es spricht nichts dagegen später den "Anzeigebereich für die nächsten Timer" auszukommentiert einzubauen. Wenn das dann jemand haben möchte kann er es dann aktivieren.

    Quote

    Irgendwo hier war mal ein Thread wie man das in eine TTF-Schriftart hineinbekommt.


    Werde mal suchen.


    henfri
    NordlichtsEPG habe ich noch nicht auf dem neuen Rechner, werde es mal testen.


    Paule99
    Mit den Listen habe ich noch ein Problem. Die Liste, welche zuerst geladen wird, bestimmt die maximale Anzahl der Items, die Formatierung und die maximale Breite für alle Folgenden. Suche da noch nach dem Workaround :)


    randy
    Gut, das man die Laufschriften fast nicht mehr benötigt (durch die Breite). Ich schaue mal wo ich die weglassen kann.

    2.6.29-gentoo-r5, vdr-1.7.9, xine-vdpau-284, vdr-xine 0.93 - 5050e, M3A78-EM, Postville, 2xTTS21600

    PearlHD text2skin

  • Zum Skin:


    find ich Klasse nur noch ein Paar Sachen und der ist ne echte konkurenz für meinen standard Skin EnigmaNG.


    Zum Thema Schriftart und Fehlende Symbole:


    Ich habe das Problem, dass ich ohne Änderungen am Skin kein Text habe
    erst wenn ich im Skin alle Vorkommen von z.B.:

    Code
    1. font="Arial.ttf:27"


    in z.B.

    Code
    1. font="Arial@27"


    änere zeigt der Skin auch Text an.
    Wenn ich jetzt anstatt Arial einfach die VDRSymbols Schriftart so

    Code
    1. font="VDRSymbols Sans:Bold@27"

    eintrage hab ich auch wieder überall die Symbole in der Aufnahmeliste usw.


    Verwenden tu ich folgende Konfiguration:
    - Easyvdr
    - VDPAU
    - VDR 1.7.0 mit HD OSD-Patch
    - Xine plugin 0.7.3
    - Full HD OSD Auflösung

  • Quote

    Original von maverick-me
    Wenn ich jetzt anstatt Arial einfach die VDRSymbols Schriftart so

    Code
    1. font="VDRSymbols Sans:Bold@27"


    Wo du doch schon beim Experimentieren bist, was passiert denn, wenn du stattdessen

    Code
    1. font="Osd"

    nimmst und du die Schriftart im OSD-Setup einstellst?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Quote

    Wo du doch schon beim Experimentieren bist, was passiert denn, wenn du stattdessen

    Code
    1. font="Osd"


    nimmst und du die Schriftart im OSD-Setup einstellst?


    Dann hab ich den gleichen Effekt wie wenn ich direkt die ttf Datei angebe,
    OSD wird dargestellt aber ohne Text


    Achso, gibts ne Möglichkeit im Skin eine Variable zu definieren, über die man dann z.B. Schriftart und Schriftgröße einmalig festlegen könnte, dann müsste man solche Änderungen nicht immer für den ganzen Skin 50 mal wiederholen?


    z.B.:

    Code
    1. stdfont=Arial
    2. stdfontsize=27
    3. <text x1... font="stdfont@stdfontsize">BlaBla</text>


    Besser wäre natürlich wenn die angaben aus dem VDR genommen würden.

  • Quote

    hi, ja, das kann ich auch beobachten; speziell bei laufschriftem im osd geht gar nichts mehr, normalerweise stockt das bild fuer ca. ne halbe sekunde pro osd aenderung. die zeiten aendern sich auch nicht grossartig zwischen verschieden schnellen systemen, in dem fall habe ich einen 667mhz p3 und einen 2,4ghz p4 getestet. koennte aber leicht sein, das mit einer dualcore cpu das phaenomen verschwindet. -- randy


    Dann liegt es also scheinbar doch an der Karte bzw. am Bus. ich habe mal xv als Ausgabedevice getestet und siehe da das ganze ist Sauber. Ich kann mir jedoch beim besten willen nicht vorstellen, dass der der PCI Bus da das Nadelöhr sein soll. Leider ist die Gemeide der PCI Karten Benutzer scheinbar sehr klein. Ich finde es toll von mapovi das er sich bezüglich der Laufschriften unserem Problem schon annimmt.


    Aber richtig skaliert bekomm ich das OSD einfach nicht. Es sieht immer aus wie ins Bild "gequetscht". Leider kann ich xine noch nicht testen da ichs (noch) nicht kompiliert bekomme. Ich halte allerdings auch xinelibout für die bessere Variante.


    Gruß
    Atech

    HTPC:
    Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
    Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, TT3650-CI USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

  • Ich habe mal ein kleine Progrämmchen geschrieben, um das Skin von "absolute" auf "relative" umzurechnen. Dabei ist mir noch ein Fehler im Skin aufgefallen. Die x-Koordianten laufen von 0 bis 1920, das kann aber nicht sein. Die x-Koordinate darf 1919 nicht überschreiten. Analoges gilt für die y-Koordinate. Das Programm dürfte sich relativ leicht anpassen lassen, um z.B. einen ersten Entwurf für einen HDReady-Skin zu errechnen.
    Wer das Programm ausprobieren will braucht flex. Aufruf mit

    Code
    1. ./abs2rel <PearlHD.skin >PearlHD.skin.out


    Getestet habe ich das Ergebnis noch nicht am lebenden Objekt.


    abs2rel.l:

    Makefile:

    Quote


    abs2rel: abs2rel.o


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

    The post was edited 1 time, last by gda ().