Debian Lenny Image für SMT7020S


  • Rofl, glaubst du wirklich, dass Serverplatten ein Problem damit haben bei 10mbit 16 parallele Datenzugriffe hinzukriegen und daher durch die Platten die Leistung um 50% sinkt?
    *Übertreibung an* Armer Irrer *Übertreibung aus*
    Da haben nichtmal Notebookplatten ein Problem mit.


    Und im Normalfall bringt dir ein DL Beschleuniger auf einem stark ausgelasteten Server (ServerUpload >> dein dowlnoad für einen Thread) tatsächlich etwas, denn der teilt die Bandbreite auf alle Threads auf.
    Sind also 1000 User drauf, und er hat ne Bandbreite von X zur Verfügung (und unter der Annahme, dass alle X/1000 vom Internet empfangen können), dann kriegst du genau X/1000. Hast du aber statt 1 Downloadthread 16 laufen, dann kriegst du 16*x/1015, also nicht ganz 16 mal so viel Bandbreite (vorausgesetzt dein Downstreamlink kann das).
    Natürlich geht das auf Kosten derer, die sowas nicht nutzen und es kostet auch gesamt etwas Performance für alle. Aber als typischer Egoist, der nur seinen eigenen Vorteil maximieren möchte ist das Verfahren quasi verpflichtend. Machen es allerdings alle, dann wirds schlecht ;)


    Wenn er durch seinen Trick nun doppelt so lange braucht, dann muss das an viel mehr liegen als nur Festplattenoverhead (der ist hier vernachlässigbar) oder TCP/IP Protokolloverhead. Da könnte vielmehr die katastrohpale Überlastkontrolle in TCP die einzelnen Threads ins oszillieren gebracht haben und so für sehr viele unnötige Retransmits gesorgt haben.
    Oder ein Router in der Verbindung hatte mit Überlast zu kämpfen.

    Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
    1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
    3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
    mit yavdr 0.4.0

  • Quote

    Original von Egalus


    Rofl, glaubst du wirklich, dass Serverplatten ein Problem damit haben bei 10mbit 16 parallele Datenzugriffe hinzukriegen und daher durch die Platten die Leistung um 50% sinkt?
    *Übertreibung an* Armer Irrer *Übertreibung aus*
    Da haben nichtmal Notebookplatten ein Problem mit.


    schön, dass du weisst auf welchem server das image liegt, welche platte der hat und wie der eingestellt ist :-)


    die kiste steht bei mir im keller, ist ein p2 mit 350mhz und die platte ist eine uuuralt ide platte im pio modus.
    die wird sehr wohl um den betrag langsamer. genau wie der ganze rechner...


    Quote


    Und im Normalfall bringt dir ein DL Beschleuniger auf einem stark ausgelasteten Server (ServerUpload >> dein dowlnoad für einen Thread) tatsächlich etwas, denn der teilt die Bandbreite auf alle Threads auf.
    Sind also 1000 User drauf, und er hat ne Bandbreite von X zur Verfügung (und unter der Annahme, dass alle X/1000 vom Internet empfangen können), dann kriegst du genau X/1000. Hast du aber statt 1 Downloadthread 16 laufen, dann kriegst du 16*x/1015, also nicht ganz 16 mal so viel Bandbreite (vorausgesetzt dein Downstreamlink kann das).
    Natürlich geht das auf Kosten derer, die sowas nicht nutzen und es kostet auch gesamt etwas Performance für alle. Aber als typischer Egoist, der nur seinen eigenen Vorteil maximieren möchte ist das Verfahren quasi verpflichtend. Machen es allerdings alle, dann wirds schlecht ;)


    nett dass du so schön einen dl beschleuniger erklärst.
    wie sinnlos es ist, sieht man aber auch daran, dass deine "unter der annahme" falsch ist.


    1. es ist keine dl beschränkung eingerichtet
    2. er war ganz allein am saugen. hätte also mit 1 dl die meiste performance gehabt.


    Quote


    Wenn er durch seinen Trick nun doppelt so lange braucht, dann muss das an viel mehr liegen als nur Festplattenoverhead (der ist hier vernachlässigbar) oder TCP/IP Protokolloverhead. Da könnte vielmehr die katastrohpale Überlastkontrolle in TCP die einzelnen Threads ins oszillieren gebracht haben und so für sehr viele unnötige Retransmits gesorgt haben.
    Oder ein Router in der Verbindung hatte mit Überlast zu kämpfen.


    nein. meine router sind bei 10mbit ganz sicher nicht überlastet:-) die kommen auch sehr gut mit den andren ports, die 100 und 1000mbit über die glasfaser machen, zurecht :-)


    ich baue bei solchen sachen erstmal auf die potenzielle vernunft der downloader; zumal ich extra geschrieben hatte, dass durch die passwort rausgabe die anzahl der downloads gesteuert werden soll.
    wenn das dann nicht klappt kommt ein download begrenzer rein.
    der ist dann aber nicht so blöd, dass er das ganze nur in slots aufteilt.
    mein dl begrenzer erkennt mehr als x connects von der selben ip und drosselt dann diese ganz runter. die helden mit dl beschleuniger haben dann zwar xx slots, aber die krebsen dann jeweils mit 50byte/sekunde da rum :-)


    zudem gehe ich ja sowieso davon aus, dass das ding schnell in bittorrent liegt, oder auf rapidshare o.ä.
    mein server ist da eher für die initiale verteilung gedacht und dazu, dass das image auch in 2 jahren noch unter dem originallink abrufbar ist, wenn es längst wieder aus allen share systemen verschwunden ist.
    jonny

  • Quote

    schön, dass du weisst auf welchem server das image liegt, welche platte der hat und wie der eingestellt ist :-)
    die kiste steht bei mir im keller, ist ein p2 mit 350mhz und die platte ist eine uuuralt ide platte im pio modus. die wird sehr wohl um den betrag langsamer. genau wie der ganze rechner...


    also ich hatte full speed yeehaa 48 kb pro sekunde :unsch DSL-Light rockt


    also ist doch der upload schon mal 5 mal schneller als bei mir



    mase  
    werds heute abend draufprügeln


    lade das image am wochenende auf meinen webspace und schicke dir nen link

    The post was edited 1 time, last by Moorviper ().

  • Hallo,
    ich kann versuchen, das image mit auf meinen server zu packen. Muss aber noch ein wenig platz machen. Irgend welche beschränkungen gibts nur bei der disk grösse.
    Das image würde mich auch für meine smt interressiern. Wie gross ist das system denn für die smt? Passt das auf 1 oder 2GB modul?


    Gruss
    PC-Doc

    ## VDR-1 ## Easy-VDR 0.6,SilverStone LC 11, Aopen S661FXm-FSN, Intel Celeron M 1,5GHz, 512MB, Technotrend 2300s, ARTIC IR-Einschalter
    ## VDR-2 ## EasyVDR 0.6, CoolerMaster CM-Media, ASUS M2NPV-VM, Athlon 3200, 2GB RAM,4GB CF-Card, 500GB HDD, Nexus-S 2.3 full TS patch, ARTIC IR-Einschalter
    ## SMT7020s ## zen2vdr noch alles original


    Wenn man immer tut, was man schon kann, bleibt man immer, was man schon ist. (Henry Ford) :lol2

  • Hallo Mase,
    kannst du mir das image irgendwie zukommen lassen?


    Gruss
    PC-Doc

    ## VDR-1 ## Easy-VDR 0.6,SilverStone LC 11, Aopen S661FXm-FSN, Intel Celeron M 1,5GHz, 512MB, Technotrend 2300s, ARTIC IR-Einschalter
    ## VDR-2 ## EasyVDR 0.6, CoolerMaster CM-Media, ASUS M2NPV-VM, Athlon 3200, 2GB RAM,4GB CF-Card, 500GB HDD, Nexus-S 2.3 full TS patch, ARTIC IR-Einschalter
    ## SMT7020s ## zen2vdr noch alles original


    Wenn man immer tut, was man schon kann, bleibt man immer, was man schon ist. (Henry Ford) :lol2

  • Ich habe die Lenny Netiso installiert und dann die tar.gz Datei auf meiner PLatte unter Knoppix entpackt. Am Ende kommt eine Fehlermeldung nach dem entpacken. Ich habe es trotzdem versucht in die SMT zu packen und zu starten. Es funzt bei mir nicht. Ich habe die minimale installation von lenny ausgeführt.


    Gibt es nicht mehr zu tun als Lenny installieren und die Datei entpacken?

  • Hallöchen,
    ich hab' die Datei mal bei LinuxTracker hinzugefügt (klick). Denke der Download per Torrent verteilt die Last etwas besser und bietet gleich einen Check auf Konsistenz.
    Ich hab' die nächsten Tage meinen Webserver dahinter hängen, damit das verteilen etwas flotter geht.

  • Die Vorinstallation von Lenny ist eigentlich nur notwendig,
    um Grub zu installieren. Ein grub-install unter Knoppix mit
    gechrooteter Platte müsste auch ausreichen. Aber mit einer
    Lenny Vorinstallation geht's schneller.
    Ich hab das Image grad wieder entpackt. Funktioniert fehlerlos.
    tar zxpvf smt-lenny.tar.gz
    Wichtig ist das "p", um die Rechte beizubehalten. Und das
    ganze als root machen. Als User krieg ich auch Fehler.

  • hi,


    Quote

    Original von gdm
    und bietet gleich einen Check auf Konsistenz.


    ah, gut dass du mich erinnerst :-)
    die md5 summe des gz lautet 81a48765c59c218e28f3986bc471813b


    ansonsten ist das allgemeine interesse bisher eher verhalten.
    es haben grad mal 10 leute das ding runtergeladen...


    jonny

  • Naja, es gibt ja auch noch Alternativen. Oder selber machen.
    Ich hatte ja weiter keine Arbeit, ausser das Ding zu archivieren.
    Und vor Squeeze wird's auch wohl keine Updates geben. Ist ja alles
    dabei, was man zum kompilieren braucht.

  • So der 1ste Test ---> Läuft nicht ^^


    Hatte ne standart Netinst gemacht alle daten auf ne installation
    geht nicht da die fstab nicht passt


    also das Videoverzeichnis auskommentiert und swap auf dev/hda5
    was bei der Installation von lenny Standard ist.
    bootet bis zum x-server (das graue Gitter ist zu sehen) im Display steht noch boot
    der Bildschirm wird schwarz und das wars dann


    hat jemand ähnliche Erfahrungen gemacht

  • Hi,
    gibt es für nen Anfänger wie mich auch eine etwas genauere Anleitung zur Installation....
    gruß
    leon357

    Test-yaVDR:Foxconn 6627MA;Intel Celeron E1200;2x512MB DDR2 Elixir;8400GS;-Skystar HD;Cyberlink FB;GLCD2USB 128x64(dank naicheben);Gehäuse=Bastelware

  • hi,
    hab die Netinst installiert...das war der einfache part...hab dein smt-lenny.tar.gz auf nen Stick gelegt - mit Knoppix gestartet und wollt dann als root mit tar zxpvf smt-lenny.tar.gz entpacken...auch wenn ich den pfad zum Stick mit angebe .. nix zu wollen----oder ich hab alles falsch gemacht ;-(

    Test-yaVDR:Foxconn 6627MA;Intel Celeron E1200;2x512MB DDR2 Elixir;8400GS;-Skystar HD;Cyberlink FB;GLCD2USB 128x64(dank naicheben);Gehäuse=Bastelware

  • Das Entpacken muss aus dem Root der Festplatte mit tar zxpvf <pfad-zu-smt-lenny.tar.gz>
    gestartet werden. Das ganze als User "root", da sonst nicht die Berechtigungen
    gesetzt werden können. Evtl. noch die fstab anpassen. Das Verzeichnis /video
    braucht die Rechte vdr:vdr.

  • Hallo,


    ich hatte die gleichen Probleme wie Moorviper.
    Irgend wie scheint das mit den Übertragen der rechte nicht richtig zu Funktionieren.
    Nach dem ich chown -R vdr:vdr /etc/vdr und bei zwei weiteren Verzeichnissen in /var/cache den Besitzer geändert habe läuft es schon mal grundsätzlich.
    /etc/lirc hat denke ich noch falschen Besitzer 1000:1000, Fernbedienung funktioniert aber.
    Das Bild hat aber noch ab und an nervöse Zuckungen.
    Netzwerk funktioniert auch noch nicht.
    Heute komme ich aber nicht mehr zum weitermachen.


    MfG
    KPL

  • ok, werd es die Tage nochmal versuchen...

    Test-yaVDR:Foxconn 6627MA;Intel Celeron E1200;2x512MB DDR2 Elixir;8400GS;-Skystar HD;Cyberlink FB;GLCD2USB 128x64(dank naicheben);Gehäuse=Bastelware