Ubuntu-Pakete XBMC-PVR-Testing auf aktuellem Entwicklungsstand verfügbar

  • hepi
    Kannst du dich noch an unsere letzten Emails erinnern?
    Ich hoffe das die HowTo genau das vermittelt was wir vermitteln wollen. :lehrer1


    @Community


    Ich hoffe das ich mit dieser HowTo der Community helfen kann. :unsch


    All-in-One HowTo – Ubuntu 10.04 – Installation & Konfiguration von NVIDIA VDPAU, VDR mit VNSI-Server & XBMC PVR-TESTING2

  • Hallo!


    Ich wollte vorschlagen ob Ihr in den XBMC builds nicht die "vaapi" zusätzlich zu "vdpau" aktvieren wollt. Die Umsetzung ist einfach, ich helfe gerne dabei und es ist eine schöne Sache für alle vdr Fans die Intel oder ATI Grafik verweden.


    Das ganze läßt sich in 2 Schritten bewerkstelligen:


    - libva1, libva1-dev, libva1-dbg installieren (deb/src gibts hier: http://www.splitted-desktop.com/~gbeauchesne/)
    -configure "--enable-vaapi"


    Grüße

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • Quote

    Original von bolzerrr
    Ich wollte vorschlagen ob Ihr in den XBMC builds nicht die "vaapi" zusätzlich zu "vdpau" aktvieren wollt. Die Umsetzung ist einfach, ich helfe gerne dabei und es ist eine schöne Sache für alle vdr Fans die Intel oder ATI Grafik verweden.


    Das ganze läßt sich in 2 Schritten bewerkstelligen:


    - libva1, libva1-dev, libva1-dbg installieren (deb/src gibts hier: http://www.splitted-desktop.com/~gbeauchesne/)
    -configure "--enable-vaapi"


    Ich schau's mir mal an, verspreche aber nix. Kannst Du mir ein geeignetes Launchpad-PPA suchen mit den libva-Paketen?


    Gruß
    hepi

  • Scheint es aktuell noch nicht zu geben, ich werd das aber im Auge behalten, wenn ich eins finde geb ich bescheid.


    Grüße

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • Super! Werd ich gleich heute abend upgraden, testen und berichten

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • Quote

    Original von feelfree
    Kann es sein, dass bei den Paketen ein --enable-dvdcss fehlt?


    Nein, kann nicht sein. Ist Absicht. Installiere dir die fehlende Bibliothek aus der bekannten Quelle und es funktioniert wieder.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • hi! der erste test war bei mir leider nicht erfolgreich, je nach konfiguration(shader) stürzt xbmc ab ode rich bekomm extrem viele fragmente- allerdings läuft die vaapi in diesem fall. gibt es user die dies bereits getestet haben und wo es klappt?

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • Quote

    Original von bolzerrr
    hi! der erste test war bei mir leider nicht erfolgreich, je nach konfiguration(shader) stürzt xbmc ab ode rich bekomm extrem viele fragmente- allerdings läuft die vaapi in diesem fall. gibt es user die dies bereits getestet haben und wo es klappt?


    Nicht, dass ich wüsste. Hast Du die Libva-Pakete aus meinem PPA dazu genommen?


    Gruß hepi

  • Quote

    Original von gda
    Nein, kann nicht sein. Ist Absicht. Installiere dir die fehlende Bibliothek aus der bekannten Quelle und es funktioniert wieder.


    Danke, hat geklappt. Muss wohl bei irgendeinem apt-get update deinstalliert worden sein, denn es ging ja schonmal...

  • Hat es schon jemand mit dem ac3 ton problem hinbekommen, oder gibt es dieses bei euch nicht? Ich habe immer noch das Problem, daß beim umschalten auf einen AC3 Sender immer der 2 Kanalton läuft, obwohl im Audiomenü AC3 ausgewählt ist. Erst ein hin und herschalten zwischen AC3 und 2Kanal bringt mir AC3 Ton.

    RPI3, DVB-Sky S960, VDR 2.4.4, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.

  • So und hallo zusammen. Erstmal vielen Dank für den wunderbaren Thread.


    Seiteinigen Tagen exprementiere ich mit XBMC auf Linux Mint 9 an einem Clarkdale System herum, TV Kare ist ne TT S2-1600 budget.


    Läuft soweit ganz gut. Bin nach der All in One Anleitung vorgegangen, habe zusätzlich


    [2010/04/28] libva
    VA API extensions for VDPAU and XvBA backends


    [2010/04/17] vdpau-video
    VDPAU backend for VA API


    [2010/04/18] xvba-video
    XvBA backend for VA API


    über die .deb installer installiert, die neuste XBMC ink PVR testing von ppa:henningpingel/xbmc installiert, DVB Treiber is s2-liplianin. Rennt soweit ganz annehmbar,


    XBC ist VAAPI aktiviert. HD Material verursacht ca 20% -30 %CPU Last -> normal mit einem i3 530? Wie sehe ich ob VAAPI auch tatsächlich aktivist.


    Gößeres Problem macht allerdings die TV Wiedergabe:


    Ich habe komische sync Probleme, den ersten Sender den ich anwähle läuft wunderbar, über Info sehe ich sync udn error werte die stabil sind, optisch sieht das Bild gut aus und der Ton passt.


    Zappe ich aber auf einen anderen Kanal, so erhalteich ein leichtes Ruckeln, irgendwelche sync Probleme, die Error und Sync Werte hüpfen durch die Gegend.


    Probiert habe ich es mit Software Rendering, auch habe ich die Sync bei System Video und Hardware / Video deaktibiert was keine Besserung brachte.


    Wenn ich nun auf diesem ruckelnden Kanal bin,also einmalig gezapt habe, dann den Tob kurz auf digital und wieder analog stelle, dann ist das Problem beholen bis ich wieder zappe.


    Hat jemand ideen? Liegts an irgend einem Audio / Video Buffer?
    Wäre nett wenn jemand Ratschläge hat.


    Edit:


    Ich hatte erst s2-liplianin mit "make install" installiert, dann beim testen im Verzeichnis "make distclear" ausgeführt und dann den v4l-dvb Treiber mittels Make install installiert. Wie kann ich schauen welcher Treiber aktiv ist? Den subjektiv is das Verhalten identisch.

  • wenn du auf "o" drückst sollte beim codec irgendwas mit -vaapi stehen. Bei mir steht ledie rnciht da, hab bei HD material ähnliche last..

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • danke das werde ich mal untersuchen. Habe den Versuchsrechner zum neuen Office PC meiner Eltern konfiged und neue Hardware (ITX Clarkdalesetting + ITX Cleron 2x2,5+gf9300 Setting) bestellt. Mal schaun wie das Ganze auf den zwei neuen ITX Kisten rennt.


    Noch ne Frage nebenbei die mir etwas Kopfzerbrechen bereitet.


    Aufnehmen? Tut, tut nich? bis jetzt reagiert der Knopf garnicht..


    Das Ruckeln des LiveTV ist allgegenwärtig... Da muss ich mal den neuen ALSA Treiber Testen, Nico gab mir den Tipp dass dieser das problem beheben könnte. Einer Erfahrung damit?

  • es gibt wohl einen neuen patch der gsgl für ati karten wieder möglich macht- vielleicht hast du ja lust das in den nächsten build mit aufzunehmen :)


    http://forum.xbmc.org/showthread.php?t=74572


    Grüße

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

    The post was edited 1 time, last by bolzerrr ().

  • Hallo,


    scheinbar gibt es ein problem moit der aktuellen version und xbmc-live:


    Code
    1. Setting up xbmc-live (pvr-testing-36~yavdr-lucid30871+6) ... update-rc.d: warning: /etc/init.d/xbmc-live missing LSB information update-rc.d: see <http://wiki.debian.org/LSBInitScripts> start: Unknown job: xbmc-live invoke-rc.d: initscript xbmc-live, action "start" failed.



    removen & neu installieren hat auch nicht geholfen


    Viele Grüße

    DVB Server Triax TSS400 SAT>IP Server
    VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
    VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
    VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
    V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

  • Quote

    Original von bolzerrr
    Hallo,


    scheinbar gibt es ein problem moit der aktuellen version und xbmc-live:
    ...


    Irgendwelche Neuigkeiten, Vorschläge, Lösungen zu diesem Thema?


    edit:
    Habe ein wenig selbst geforscht. Der Grund ist wohl, das bei Lucid die Datei /tools/XBMCLive/xbmc-live.conf nicht nach /etc/init/ kopiert wird. Da aber jetzt auch bei Lucid per Upstart gestartet wird, fkt. das nicht.


    Ich habe einfach die Datei händisch aus dem Sourcepaket genommen, dann xbmc-live nochmal installiert, und jetzt gehts wieder.