PVR-Testing Windows Build

  • Quote

    Original von freezy
    directx sdk installiert? läuft trunk durch?


    Ich habe gerade mal https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk/, letzte Revision geholt. Baut sauber durch.


    Woran könnte es liegen dass pvr-testing nicht baut?


    Viele Grüße,
    Bernd

    VDR "headless" Server:

    • Whitebox mit Supermicro X10SLL+-F, Xeon Prozessor, 16 GB RAM als ESXi Host, Debian VM für VDR, Digital Devices Cine S2 mit VT-d Passthrough an die VM
    • Debian, VDR 2.2 mit epgsearch, streamdev-server und live Plugins

    Client: Laptop, Windows und OS X, VLC Media Player

  • Ich habe noch mal weitergeschraubt... bin jetzt auf der letzten Revision (23407) von pvr-testing.


    Nachdem ich einige include-Pfade begradigt habe laufe ich in folgende Build-Fehler:



    Die vom Compiler vermissten Dateien sind weder in pvr-testing noch im trunk zu finden. Wenn ich sie im Build deaktiviere dann beschwert sich der Linker über unresolved symbols.


    Hat jemand eine Idee was das ist und wie ich es geradeziehen kann?


    Ich hab die Frage auch im XBMC Forum gestellt, siehe http://xbmc.org/forum/showthread.php?t=59078


    Vielen Dank,
    Bernd

    VDR "headless" Server:

    • Whitebox mit Supermicro X10SLL+-F, Xeon Prozessor, 16 GB RAM als ESXi Host, Debian VM für VDR, Digital Devices Cine S2 mit VT-d Passthrough an die VM
    • Debian, VDR 2.2 mit epgsearch, streamdev-server und live Plugins

    Client: Laptop, Windows und OS X, VLC Media Player

  • Quote

    Original von bienchen
    Hallo zusammen!


    Gibt es etwas Neues bzgl. der Probleme, diese Version ans Laufen zu bekommen? Ich habe die gleichen Schwierigkeiten, wie meine Vorredner :/


    Gruß
    Bienchen :)


    ich habe mich mittlerweile soweit durch XBMC gefräst dass es unter Windows baut, zwar mit ungefähr einer Tonne Warnungen, aber es geht :) Ich kann Live-TV mit XBMC schauen.


    Aus dem Kopf ist folgendes zu machen:
    - bei einigen #include Direktiven den Pfad geradebiegen
    - einige nicht existierende Source-Files aus dem Projekt entfernen
    - einige zusätzliche Source-Files zum Projekt hinzufügen


    Ich habe mal einen Patch erstellt, ist angehängt. Da drin stecken aber auch die Umstellung von Debug-Build auf Release-Build und der Versuch den die fehlende Videodarstellung beim Abspielen von VDR-Aufnahmen aus dem Dateisystem zu reparieren.


    Ich wollte das eigentlich auch beim XBMC-Projekt als Ticket einstellen, bin aber bisher nicht dazu gekommen...


    Viele Grüße,
    Bernd

    Files

    • build.diff

      (17.3 kB, downloaded 185 times, last: )

    VDR "headless" Server:

    • Whitebox mit Supermicro X10SLL+-F, Xeon Prozessor, 16 GB RAM als ESXi Host, Debian VM für VDR, Digital Devices Cine S2 mit VT-d Passthrough an die VM
    • Debian, VDR 2.2 mit epgsearch, streamdev-server und live Plugins

    Client: Laptop, Windows und OS X, VLC Media Player

  • Halo zusammen,


    ich versuche gerade die aktuelle Rev. von PVR-testing mit VisualStudio2008 zu kompilieren. Allerdings scheinen die Projektdateien nicht auf dem aktuellen Stand zu sein. Er findet diverse Dateien nicht mehr und bleibt beim build hängen.


    Was ist denn die Standard Entwicklungsumgebung des PVR-Testing branches? Hat jemand ein aktuell laufendes VisualStudio Projekt?


    Danke!


    Gruß
    Mrlight

  • Hallo Jungs,


    Hier ist der neuste Windows-Build der bei mir funktioniert.

    • Installer runterladen und installieren
    • VDR-Plugin installieren und nach "C:/Programme/XBMC/addons/pvr" entpacken
    • C:/Users/user/AppData/Roaming/XBMC/userdata/addon_data und addons.xml löschen


    Damit funkt's bei mir. Fettes Dankeschön wie immer an Alwin und alcoheca! :)

    [SIZE="10"]Ubuntu 8.10 running on: Intel E8400 | ASUS P5K-E | 2gb PC2-6400 | Nvidia GeForce 8600GT | WinTV-NOVA-T-500 | VDR 1.7.4 with XBMC Frontend[/SIZE]

  • mit dieser Version funktioniert es bei mir! Danke freezy


    Man muß aber darauf achten die richtige Streamdev-Server Version installiert zu haben. Mindestens version 0.5.0-pre-20090706 (http://streamdev.vdr-developer.org/), darunter funktioniert es nicht.
    Das war bei mir das Problem... :doof

    Aktuelles (Test)System in FullHD: JCP MI-103 Gehäuse - Asus AT3N7A-I (Atom 330 und Ion-Chipsatz) - 2 x 1024MB Transcend DDR2-800 - 160GB 2,5'' WD Scorpio - TechniSat SkyStar HD2 - Pollin X10 Fernbedienung - Aktuelles System: yaVDR (Dualboot mit Windows 7)


    Zweitsystem (stabil): MSI Mega 651 Barebone - 2,4Ghz - 1GB RAM - 250GB 3,5'' HDD - Nexus-S 1.6 - easyVDR 0.5.0


    Außerdem: Samsung SMT7020s - 250GB HDD - Gen2VDR

  • Hi,


    bei mir leider über haupt keine Addons mit dieser Version gefunden
    unter Vista 32 als Admin.



    Habe die Addons so installiert wie hier beschrieben

    Code
    1. # VDR-Plugin installieren und nach "C:/Programme/XBMC/addons/pvr" entpacken
    2. # C:/Users/user/AppData/Roaming/XBMC/userdata/addon_data und addons.xml löschen


    Bei mir gibt es nur hier nur eine Ordner "addon_data" der wenn erglöscht wird, dann wird er dem nächtsten Start wieder erstellt.


    "addons.xml" kann ich hier nicht finden?


    Was fehlt um das VDR-Plugin einzubinden?


    Grüße
    cinfo

    (VDR) NUC10i3FNK * BM2LTS * Octopus NET S2 Max * Reel NetCeiver * (Sound) Cinebar Lux Set * (UHD-Player) LG UP970 * (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Das löschen ist nur relevant wenn vorher schon eine xbmc version im Einsatz war.
    Bei mir ist das plugin in diesem Ordner:
    C:\Program Files\XBMC\addons\pvr\VDR
    dann muss das plugin nur noch in XBMC aktiviert werden.
    Aber vergiss nicht das skin zu ändern. In diesem neuen Skin ist es nicht möglich den Punkt TV zu wählen bzw. das Plugin zu aktivieren.


    mfg Thomas

    VDR:
    Hardware: Thermaltake DH102, Zotac ION ITX-F-E, 2Gig Ram, TechnoTrend
    dual DVB-S2 6400, TechnoTrend Connect CT-3650,


    Software: EasyVDR 1.0

  • Hi,


    Quote

    C:\Program Files\XBMC\addons\pvr\VDR
    dann muss das plugin nur noch in XBMC aktiviert werden.
    Aber vergiss nicht das skin zu ändern. In diesem neuen Skin ist es nicht möglich den Punkt TV zu wählen bzw. das Plugin zu aktivieren.


    OK, "C:\Program Files\XBMC\addons\pvr\VDR" stimmt mit meinem.
    Den Skin hatte ich nicht gewechselt und ohne dem kann ich das Plugin nicht aktivieren.


    Ist es normal das beim nächsten Start nur das Logo kommt und die PC Kiste rappelt und rappelt - wird hier noch die channels.conf erstellt?



    Was macht xbmc hier?


    Grüße
    cinfo

    (VDR) NUC10i3FNK * BM2LTS * Octopus NET S2 Max * Reel NetCeiver * (Sound) Cinebar Lux Set * (UHD-Player) LG UP970 * (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Der erste start hat bei mir auch ewig gedauert.
    vermutlich werden die Channels und EPG Daten erstellt.


    mfg Thomas


    PS: hab mir gerade den aktuellen Confluence Skin aus dem pvr-testing2 geladen. Damit funktioniert Live TV.
    svn co http://xbmc.svn.sourceforge.ne…-testing2/skin/Confluence

    VDR:
    Hardware: Thermaltake DH102, Zotac ION ITX-F-E, 2Gig Ram, TechnoTrend
    dual DVB-S2 6400, TechnoTrend Connect CT-3650,


    Software: EasyVDR 1.0

    The post was edited 1 time, last by googles ().

  • Hi,


    Quote

    PS: hab mir gerade den aktuellen Confluence Skin aus dem pvr-testing2 geladen. Damit funktioniert Live TV.
    svn co http://xbmc.svn.sourceforge.net/svnroot/...skin/Confluence

    Habe ich auch mal geladen sieht und läuft super.


    Nur habe ich noch ein Problem mit den Fehlermeldungen in xbmc.


    Ich sehe meine TV Programme aber wenn ich eines starten möchte bekomme ich nur die Meldung: "Kanal konnte nicht wiedergegeben werden"


    [Blocked Image: http://www.onlinemappe.de/download/vdr/xbmc-f1.jpg]



    Was fehlt oder was muß anders eingestellt werden?


    Log:


    Grüße
    cinfo

    (VDR) NUC10i3FNK * BM2LTS * Octopus NET S2 Max * Reel NetCeiver * (Sound) Cinebar Lux Set * (UHD-Player) LG UP970 * (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

    The post was edited 2 times, last by cinfo ().

  • Hi,


    ich hab ebenfalls ein Problem. Folgende Konfiguration:


    Server:
    Ubuntu 9.10
    VDR 1.7.10-4tvt1
    Streamdev 0.5.0~pre20090706


    Client:
    Windows 7
    XBMC und VDR Plugin aus dem obigen Post
    Confluence Skin aus dem Repository


    Streamdev scheint zu funktionieren, ich kann mit VLC LiveTV anschauen, wenn auch nur über die volle URL in der Form http://192.168.100.101:3000/PES/S19.2E-1-1107-17501.


    Im XBMC kann ich in den Settings auch das Addon auswählen, die IP und den Port ändern (Standard Streamdev 3000, Standard XBMC 2004 !?), aber dann... "Addon lost connection. Try to reconnect?"


    Hier mein Log (auszugsweise!!):


    Code
    1. 22:35:13 T:1300 M:1170415616 NOTICE: PVR: PVRManager starting
    2. 22:35:13 T:1300 M:1170403328 NOTICE: ADDONS: Attempting to parse special://masterprofile/addons.xml
    3. 22:35:13 T:1300 M:1170386944 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting C:\Users\daniel\AppData\Roaming\XBMC\addons\pvr
    4. 22:35:13 T:1300 M:1170386944 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting special://home/addons/pvr
    5. 22:36:13 T:1300 M:1172643840 ERROR: AddOnLog: PVRDLL/VDRClient: CVTPTransceiver::SendCommand - select failed
    6. 22:36:13 T:1300 M:1172643840 ERROR: AddOnLog: PVRDLL/VDRClient: CVTPTransceiver::Open - server is unable to provide mpeg-ts
    7. 22:36:13 T:1300 M:1172631552 ERROR: ADDON: Dll VDRClient - Client returned bad status (1) from Create and is not usable
    8. 22:36:13 T:1300 M:1172627456 ERROR: PVR: couldn't load clients


    Gruß,


    Daniel

  • XBMC läuft über VTP Streaming port 2004, und das muss im VDR aktiviert werden. Vlc läuft über http streaming port 3000 und hat nix mit XBMC zu tun.


    mfg Thomas

    VDR:
    Hardware: Thermaltake DH102, Zotac ION ITX-F-E, 2Gig Ram, TechnoTrend
    dual DVB-S2 6400, TechnoTrend Connect CT-3650,


    Software: EasyVDR 1.0

  • Hi,


    wenn man den aktuellen streamdev-Verrsion aus dem cvs ausgecheckt hat, braucht man dann noch eine Patch für XBMC?


    Wenn ja wo findet man den dann?


    Grüße
    cinfo

    (VDR) NUC10i3FNK * BM2LTS * Octopus NET S2 Max * Reel NetCeiver * (Sound) Cinebar Lux Set * (UHD-Player) LG UP970 * (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Hi,


    wollte mal kurze Rückmeldung geben...


    Klappt hervorragend mit Archvdr und den hier zur Verfügung gestellten Dateien. Einfach nach Anleitung vorgegangen - läuft. Benutze Windows7. Umschaltverhalten erstaunlich schnell und stabil. Habe im Anschluss das PVR-Testing unter Arch compiliert und auch da läuft es jetzt recht Ordentlich mit VDPAU. Ist jetzt schon fast eine perfekte Alternative zu Xine.


    Kenne noch die ersten Versuche mit dem PVR Testing Zweig... nicht mehr zu Vergleichen.


    Gruß
    Atech

    HTPC:
    Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
    Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, TT3650-CI USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

  • Hi, bin auch zur Installation des XBMC unter Win7 animiert wurden. Auf meinem VDR mit Gen2VDR V3Beta2 läuft das TV im XBMC, leider bekomme ich im Win7 keine Verbindung zum Server, PVR-Klient wird nicht gefunden. Wo wird eigentlich das Logfile unter Win7 gespeichert, finde das leider nicht ?


    Uwe

    VDR: Asus M3N78-VM, AMD Athlon II X2 240 2x 2.8 GHz, G210 passiv,2x2 GB DDR2 800MHz; HDD S-ATA 1 TB; TT Budget S2-3200; gLCD 240x128; Gen2VDR V5 Update 6

    The post was edited 1 time, last by S04sauger ().

  • Hi,


    versuche erts einmal eine Verbindung mit einem anderen Player wie z.B. dem VLC Player herzustellen. Bei mir war es zunächst so, dass von extern gar keine Zugriffe auf den streamdev server Erlaubt waren. Es gibt dafür eine config in /etc/vdr/plugins/streamdev ...


    Gruß
    Atech

    HTPC:
    Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
    Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, TT3650-CI USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

  • So, TV funktioniert jetzt, habe die config bearbeitet. Wo finde ich eigentlich die Einstellungen für OSD-Einblendung (Arbeitsspeicher) deaktivieren und Untertitel, das nervt.


    Uwe

    VDR: Asus M3N78-VM, AMD Athlon II X2 240 2x 2.8 GHz, G210 passiv,2x2 GB DDR2 800MHz; HDD S-ATA 1 TB; TT Budget S2-3200; gLCD 240x128; Gen2VDR V5 Update 6