hvr-4000 + vdr 1.6.0 + ubuntu 9.04 problem

  • Hi ...


    I have installed my hvr-4000 + ubuntu 9.04 ...+ new kernel.


    With kaffeine dvb-t and dvb-s works perfect .


    But when installing vdr 1.6.0 , i have always no signal message , and canal no dispononible ( channel not found !!! ).... I want to use vdr only in the dvb-t part nod dvb-s .


    What's the problem ?
    Can be solved?


    If i used a nova-t , all works ok ...


    Thanks for all

  • Hallo golvellius,


    habe das gleiche Problem mit Ubuntu 9.10 beta. Hast du dein Problem mittlerweile gelöst? Kurze Info wäre nett.


    Gruß sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • also soweit ich weiss kann vdr mit mehreren frontends pro karte nicht umgehen. nun ist es so dass die hvr4000 und hvr3000 zwei frontends zu verfügung stellen wobei das erste immer sat ist. falls man nur dvb-t will reicht es in /dev/dvd/adapterX/ (X = nummer der hvr) adapter0 und video0 loschen und mit einen gleichnamigen link auf adapter1 bzw video1 zu ersetzen. nach jedem reboot.

  • Quote

    Original von Knutty
    also soweit ich weiss kann vdr mit mehreren frontends pro karte nicht umgehen. nun ist es so dass die hvr4000 und hvr3000 zwei frontends zu verfügung stellen wobei das erste immer sat ist. falls man nur dvb-t will reicht es in /dev/dvd/adapterX/ (X = nummer der hvr) adapter0 und video0 loschen und mit einen gleichnamigen link auf adapter1 bzw video1 zu ersetzen. nach jedem reboot.


    Hallo Knutty,


    was meinst du mit adapter0 und video0?


    Ich finde unter /dev/dvb/adapter0/


    nur folgende Dateien:


    crw-rw----+ 1 root video 212, 1 2009-10-20 21:13 demux0
    crw-rw----+ 1 root video 212, 5 2009-10-20 21:13 demux1
    crw-rw----+ 1 root video 212, 2 2009-10-20 21:13 dvr0
    crw-rw----+ 1 root video 212, 6 2009-10-20 21:13 dvr1
    crw-rw----+ 1 root video 212, 0 2009-10-20 21:13 frontend0
    crw-rw----+ 1 root video 212, 4 2009-10-20 21:13 frontend1
    crw-rw----+ 1 root video 212, 3 2009-10-20 21:13 net0
    crw-rw----+ 1 root video 212, 7 2009-10-20 21:13 net1



    Was also meinst Du genau?


    Gruß Sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • ups, mein fehler. sollte natürlich frontend0 heissen. also das verzeichniss dass du gelistet hast ist schon das richtige. dort alles was eine null hinten dran hat löschen (das ist "der sat teil") und dafür machst du lauter links, etwa so


    ln /dev/dvb/adapter0/demux1 /dev/dvb/adapter1/demux0
    ln /dev/dvb/adapter0/frontend1 /dev/dvb/adapter1/frontend0
    ln /dev/dvb/adapter0/net1 /dev/dvb/adapter1/net0
    ln /dev/dvb/adapter0/dvr1 /dev/dvb/adapter1/dvr0

  • Hallo Knutty,


    vielen Dank für die Info! Leider habe ich mich zwischenzeitlich selbst ins Knie geschossen, vermutlich in dem ich die distri upgedated habe. Jedenfalls lässt sich sich das Fenster des vdr nicht mehr dauerhaft öffnen.


    Siehe dazu auch hier


    Werde mich erst darum kümmern, bevor ich wieder das mit dem "No Signal" angehen kann.


    Gruss sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • Hallo liebe Leute,


    Habe gerade das selbste Problem: VDR funktioniert nicht mit 2ten frontend des HVR-4000...


    Kan jemand mir betätigen ob das zu lösen ist?
    Nur dvb-t?


    Besten Dank,


    Erwin

  • Als Nachtrag: Habe mit yavdr 0.4 und folgendem Skript DVB-T mit der WinTV HVR-4000 zum laufen gebracht.


    /bin/dvb-t-frontend0


    Das Skript wird in der rc.local aufgerufen:


    /etc/rc.local

    Code
    1. # Start DVB-T Frontend0 Skript
    2. /bin/dvb-t-frontend0


    Das Ganze ist nicht besonders elegant und auch nicht flexibel und auch sonst wohl eher gruselig aber ich kann damit den VDR betreiben. :(


    Für Verbesserungsvorschläge bin ich offen und dankbar. :]


    Gruß Sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • mini73 aka Lars Hanisch hatte die Tage einen Patch für den vdr auf der ML gepostet (freilich noch nicht yavdr-0.4 kompatibel - aber das kommt dann sicher noch) der das handling dieser Art Karten implementiert.

  • Moin!


    Und bis der Multi-Frontend-Patch fertig ist, könntet ihr per udev auch einfach ein "dynamite_attach=no" an frontend0 hängen, dann wird das Frontend auch nicht benutzt.
    Und für die Nicht-dynamite-Nutzer: den vdr einfach mit "-D 1" (plus evtl. weitere "-D x" für andere Devices) starten, dann wird das erste Device ignoriert und nur das zweite genommen.


    Das ganze funktioniert bei der HVR4000, weil es für jedes Frontend auch demux und dvr anlegt. Bei der Cine-CT sieht das anders aus, da klappt das nicht so einfach.
    Siehe hier


    Morgen abend ist wieder vdr-Abend, dann hoffe ich, den Patch soweit fertig zu haben, dass man DVB-S und DVB-T bei der HVR benutzen kann, allerdings nicht gleichzeitig natürlich, weil die Karte das nicht hergibt.


    Lars.

  • mini73 :


    Wie schnell kommt dein Patch dann ins aktuelle yavdr? Und wie funktioniert der Patch dann? Kann das frontend dann dynamisch ausgewählen?


    Auch für die anderen Lösungshinweise reicht mein aktuelles Wissen leider nicht aus. Kannst du das mit der udev-Regel genauer erklären? Am schönsten wär ein HOWTO :D


    Gruß Sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • Wie schnell kommt dein Patch dann ins aktuelle yavdr?


    Wenn der Patch von Lars als testbar deklariert wurde, muss er von irgendjemand an den VDR in yaVDR angepasst werden. Dann wird der VDR in Launchpad für unstable neu gebaut, danach alle Plugins. Wenn dann genügend Leute in unstable getestet haben, geht der neue VDR mit Plugins nach stable. Wie lange das dauert? Keine Ahnung.

    Auch für die anderen Lösungshinweise reicht mein aktuelles Wissen leider nicht aus. Kannst du das mit der udev-Regel genauer erklären? Am schönsten wär ein HOWTO :D


    Da halte ich nicht viel von. Es wäre für alle viel besser, wenn Lars seine spärliche Zeit für die Entwicklung des Patches verwenden würde.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Wenn der Patch von Lars als testbar deklariert wurde, muss er von irgendjemand an den VDR in yaVDR angepasst werden. Dann wird der VDR in Launchpad für unstable neu gebaut, danach alle Plugins. Wenn dann genügend Leute in unstable getestet haben, geht der neue VDR mit Plugins nach stable. Wie lange das dauert? Keine Ahnung.

    Das klingt als wenn es mehrere Monate dauern kann. Dann werde ich mich wohl gedulden und mit meiner Brachiallösung leben müssen. Oder ich schaue nochmal wo ich das -D 1 eintragen muss. :(

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • Moin!


    Ich denke, den Patch bis Weihnachten fertig zu haben. :-) Bei (meistens) einem Abend Zeit pro Woche dauert's leider ein bisschen...
    Außerdem wird an der Treiberfront gerade heftig in diesem Bereich entwickelt, den ich im Auge behalten muss, damit nicht alles umsonst ist.


    Es wird so funktionieren, dass der vdr automatisch das richtige Frontend auswählt, je nachdem, welcher Kanal angezeigt/aufgenommen werden soll. Man hat also alle DVB-S/-T/-C-Kanäle in seiner channels.conf und muss sich um nichts weiter kümmern. Wird DVB-S z.B. durch eine Aufnahme blockiert, kann man keine DVB-T-Kanäle gucken, ganz normal, wie sonst auch.


    Wenn du yaVDR mit dynamite benutzt, hilft dir "-D" nicht, das wird dann ignoriert, dann musst du es über udev machen.


    Wenn du DVB-S nutzen willst, musst du dem vdr sagen, dass er frontend1 ignorieren soll:
    z.B. /etc/udev/rules.d/90-dynamite.rules (aus dem Kopf erstellt, muss nicht funktionieren)

    Code
    1. ACTION=="add", SUBSYSTEM=="dvb", ENV{DVB_DEVICE_TYPE}=="frontend", KERNEL=="dvb*.frontend1", ENV{dynamite_attach}="no"


    Wenn du nur DVB-T nutzen möchtest (und du keine anderen Karten drin hast!):

    Code
    1. ACTION=="add", SUBSYSTEM=="dvb", ENV{DVB_DEVICE_TYPE}=="frontend", KERNEL=="dvb*.frontend0", ENV{dynamite_attach}="no"


    Wenn du noch andere Karten mit frontend0 drin hast, dann muss die Regel durch KERNELS=="irgenwas" ergänzt werden. Was, das sagt dir

    Code
    1. udevadm info --query=all --name=/dev/dvb/adapterX/frontend0 --attribute-walk


    X bitte passend ersetzen.


    Ich hoffe, das hilft dir erst mal.


    Lars.

  • Hallo mini73,


    ja danke, dass sollte mir helfen. Werde es ausprobieren sobald ich mein geschlachtetes Netzteil ausgetauscht habe. Das sollte am Wochenende passiert sein.


    Ansonsten viel Erfolg beim programmieren des Patch. Das klingt sehr viel versprechend was du da schreibst. UNd Weihnachten ist ja auch gar nicht mehr lang hin.


    Gruß Sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • Hallo,


    habe jetzt so eine UDEV-Regel erstellt, wie mini73 es vorgeschlagen hat. Hat soweit auch funktioniert, nur dass dann Bild und Ton immer wieder stocken. Bin dann auf den Trichter gekommen, dass ich zusätzlich das dynamite-plugin installieren muss. Richtig? Sorry, wenn ich mich besonders doof anstelle, bin halt ein echter Newbie!


    Da ich dieses nicht im Webfrontend von yaVDR gefunden habe und es auch nicht manuell installieren oder kompilieren wollte, bin ich jetzt wieder zu meiner Lösung zurückgekehrt und warte bis das multifrontend-plugin fertig ist.


    Gruß Sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • Moin!


    Wenn du yaVDR 0.4 benutzt, ist dynamite standardmäßig installiert und aktiv. Du hast es nicht zufällig in der order.conf deaktiviert? Da muss ein Sternchen vor dynamite sein, kein Minuszeichen!
    Ansonsten:

    Code
    1. sudo apt-get update
    2. sudo apt-get dist-upgrade
    3. sudo apt-get install vdr-plugin-dynamite


    Lars.

  • mini73


    Deaktiviert habe ich es definitiv nicht. Werde heute Abend in der order.conf nachschauen ob es aktiv ist oder gegebenenfalls installieren.


    Sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F

  • Moin!


    Im Zweifelsfall dann sonst einmal posten, was "udevadm info --query=all --name=/dev/dvb/adapterX/frontendY" ausgibt, vielleicht ist ja auch nur ein Vertipper im Variablenname oder so.


    Lars.

  • Hallo,


    habe gestern leider keine Zeit gehabt um nachzuschauen. Einen Vertipper hätte ich aber erst mal ausgeschlossen, weil es ja im Prinzip funktioniert, nur das es eben Aussetzer gibt. Und bei einem Vertipper wäre die Regel ins Leere gelaufen und vdr hätte sich den device0 geschnappt und es hätte gar kein Bild kommen dürfen. Oder verstehe ich das falsch?


    Gruß Sindbad6

    yavdr 0.5 mit XBMC Frodo 12.2 auf: JCP MI-101, ASUS AT3N7A-I, WD10EADS, HL GSA-H31N, Hauppauge HVR-4000, Mushkin 2 x 1024 MB, über HDMI an TV: Panasonic TX-37LZD85F