pvr-testing jetzt mit Teletext

  • Hallo,


    habe zum XBMC pvr-testing branch Teletext Unterstützung hinzugefügt. Dazu muß streamdev leider wieder gepatcht werden. Patch liegt unter "XBMC/xbmc/pvrclients/vdr/patches". Der Code ist größtenteils von osdteletext übernommen. Es werden derzeit aber nur englische und deutsche Sonderzeichen unterstützt.


    FRAGE
    Wenn jemand einen True Type Font hat der alle Teletext Zeichen beinhaltet würde mir sehr helfen.


    Werde jetzt wieder weiter an Bugfixes arbeiten.
    Bitte posted Bugs im folgenden Thread:
    http://www.vdr-portal.de/board/thread.php?threadid=87754
    oder im XBMC trac unter:
    http://xbmc.org/trac/
    laut alcoheca werden Bugreports zu pvr-testing gedulded. Macht dort dann bitte einen Eindeutigen Hinweis dazu, wie z.B.:
    "pvr-testing: Frezzes during channel switching"


    Grüße,


    Alwin


  • Hallo,


    das PVR-Testing-Tickets im XBMC-Trac nun geduldet werden, finde ich aus drei Gründen super:
    [list=1]
    [*]Es bietet pingpong eine bessere Übersicht als die verstreuten Bugreports hier im Forum.
    [*]Die Sprache dort ist englisch und dadurch grenzen wir die große englischsprachige XBMC-Community etwas weniger aus von den neuen Entwicklungen.
    [*]Als Resultat von 2) haben wir die Chance, dass mehr Leute mithelfen / mitentwickeln, mittesten (inkl. der XBMC-Experten). Es ist ja oft Usus, dass man an ein Trac-Ticket schon gleich einen Patch mit einem Vorschlag anhängt, wie ein bestimmter Bug zu fixen sein könnte.
    [/list=1]
    Deswegen fände ich es cool, wenn möglichst viele Leute hier Trac benutzen würden. Man könnte dann in Zukunft beispielsweise mit Hilfe des folgenden Links im Trac nach Tickets suchen, die mit pvr-testing zu tun haben:


    http://xbmc.org/trac/search?q=pvr+testing&noquickjump=1&ticket=on


    Wenn man eingeloggt ist, kann man unter View Tickets / Custom Query aber auch alle Tickets suchen, die dem User "alwinus" aka pingpong gehören. Wenn man einen User im XBMC-Forum hat, kann man sich mit den gleichen Anmeldedaten auch im Traq einloggen.


    Gruß
    hepi

  • Component "PVR - Personal Video Recoder" tuts auch ;)

    HomeServer: Athlon 64 X2 3800+ EE SFF + Gigabyte GA-M61P-S3 - Debian Etch (2.6.22-3-686) + 1.6.0-3ctvdr1 + 2x KNC1 .v1 (DVB-C)

  • Ging das bisher mit dem osdteletext-plugin?

    Currently: AMD X2 2,6GHz, 4 GB RAM, NVIDIA 9500, 3x Terratec Cinergy 1200-C, 2 TB HDD, Mythbuntu 9.04, XBMC+VDR 1.7.8
    Retired: Celeron 1.8 GHz, 1 GB RAM, Intel Board, Nvidia FX5200, Technotrend C-2300 Debian Etch, VDR 1.4.7,

  • Ja eben: ich hab mich grad am Kopf gekratzt, weil doch das OSD gar nicht verfügbar ist mit dem PVR-XBMC-VDR-Connector. Ich dachte, ich hab die Hälfte nicht mitbekommen.


    Ist natürlich klasse, dass es jetzt Teletext gibt.

    Currently: AMD X2 2,6GHz, 4 GB RAM, NVIDIA 9500, 3x Terratec Cinergy 1200-C, 2 TB HDD, Mythbuntu 9.04, XBMC+VDR 1.7.8
    Retired: Celeron 1.8 GHz, 1 GB RAM, Intel Board, Nvidia FX5200, Technotrend C-2300 Debian Etch, VDR 1.4.7,

  • pingpong  

    Quote

    Hab allerdings noch einen Fehler drin, streamdev synchronisiert die Seiten nicht richtig, hab immer noch den Text von gestern (VDR nicht neu gestartet).


    ich hab heute nur noch "seite 100-00 nicht gefunden"
    gleicher fehler ?



    und anderer fehler :
    bei den aufnahmen stimmt die "zuordnung" irgendwie nicht....
    d.h. mlchte ich z.b. terrax sehen wird creepshow abgespielt :D


  • Genau das habe ich auch so festgestellt, build von gestern abend:
    1. teletext nur "seite 100-00 nicht gefunden"
    2. wenn ich im Startmenü einen Sender auswähle wird der Sender eins drunter gestartet, im EPG OSD menü stimmt die Zuordnung wieder.


    EDIT
    Ich beantworte mich in letzter Zeit immer häufiger selbst.
    Man muss mal wieder den Profil-Ordner .xbmc löschen, dann funktioniert alles wieder wie gewohnt, inkl. teletext (ich hatte gehofft ich müsste nicht wieder alle Filminfos neu einrichten)

  • Quote

    Original von raoul
    (ich hatte gehofft ich müsste nicht wieder alle Filminfos neu einrichten)


    Dann sichere Dir doch einfach davor die MyVideos34.db und spiele sie nach Neustart wieder ein - und fertig ist die Laube

    Mein VDR:


    ASRock H67M, 2GB RAM, Cine-S2, Patriot Torqx (120GB), 1TB S-ATA Samsung
    Software: XBMC 11

    The post was edited 2 times, last by unzulaessig ().

  • Quote

    Man muss mal wieder den Profil-Ordner .xbmc löschen, dann funktioniert alles wieder wie gewohnt,


    hmm hab ich eigentlich gemacht .... erkennt man ja auch daran, dass danach die standardsprache englisch ist.....
    trotzdem das problem mit den aufnahmen und mit 100-00



    EDIT : ok hab mal weiter gesucht
    xbmc wird 3mal angelegt (auwei)
    einmal /usr/share/.xbmc
    dann /root/.xbmc
    und /home/xxx/.xbmc


    da hab ich wohl einen ordner übersehen :schiel


    EDIT 2: nö bringt nichts hab leider trotzdem kein teletext ?
    und die aufnahmen sind weiter vertauscht (vdr-1.7.8)
    xbmc rev.-21559


    EDIT 3: so hab mal ein paar sender getestet ...
    rtl rtl2 --> teletext funktioniert
    ard zdf ndr --> gehen nicht (100-00)


    falls nötig auszug aus der channels.conf

    Code
    1. RTL Television,RTL;RTL World:650000:B8C0M64:C:6900:163=2:104=deu;106=deu:105:0:12003:1:1089:0
    2. RTL2;RTL World:650000:B8C0M64:C:6900:166=2:128=deu:68:0:12020:1:1089:0


    wie gesagt rtl geht ndr nicht ?


  • Muss ich leider doch bestätigen, ich war zu vorschnell, weil bei rtl (hatte ich gerade laufen) das teletext ging, vorher halt nicht, ausserdem war die Kanallist wieder richtig.
    Heute war dann aber die Kanalliste wieder durcheinander und ein nach oben (kanal weiter) funktionierte nicht. Nach erneutem löschen von MyTV1.db war es dann wieder richtig. Mal schauen wie lang...


    Gruss, raoul

  • Hallo,


    ich habe heute nach einigen Wochen wieder eine neue Build von XBMC kompiliert,
    läuft echt super, großes Lob!!!!


    VDPAU mit etwa 5-10% ohne Probleme (ORF1-HD) , sonst hatte ich meistens etwa 10% mehr


    mfg


    edit: das Schicksal wollte mich wohl nicht weiter testen lassen, eine Stunde später komme ich zum Rechner zurück und seha da nichts reagiert, Netzteil aus und eingeschalten und schonliefert es keinen Strom mehr :(

  • Hallo,
    wie hier im Thread beschrieben, habe ich auch ein vollkommenes durcheinander bei den Aufnahmen.


    Teste gerade: Aufnahme Der Hundeprofi vom 05.07.2009 um 08:10 und er spielt:


    Jul 19 13:23:26 elwms02 vdr: [6238] openFile called for index 1 string:/archiv/aufnahmen/Tierische_Weltreisen_mit_Steve_Leonard/2006-12-03.12.40.50.99.rec/00001.ts
    Jul 19 13:23:26 elwms02 vdr: [6238] openFile called for index 1 string:/archiv/aufnahmen/Tierische_Weltreisen_mit_Steve_Leonard/2006-12-03.12.40.50.99.rec/001.vdr


    Oder: Hundkatzemaus vom 18.07.2009 um 18:00 und der Schlumpi spielt:#


    Jul 19 13:30:17 elwms02 vdr: [6238] openFile called for index 1 string:/archiv/aufnahmen/Flicka_(Flicka)/2008-07-30.21.13.50.99.rec/00001.ts
    Jul 19 13:30:17 elwms02 vdr: [6238] openFile called for index 1 string:/archiv/aufnahmen/Flicka_(Flicka)/2008-07-30.21.13.50.99.rec/001.vdr


    .xbmc Verzeichnis schon komplett gelöscht............ohne Erfolg:-(


    Build vom XBMC ist vom 18 Juli. Hmmmmm, wo ich gerade ungewünscht Flicka sehe.........dat is ja in Englisch:->>>>>> Wie stellt man die Tonspur in XBMC um:-)))) In den Systemeinstellungen ist Germany eingestellt!! (falls das was damit zu tun hat).


    Tschau, Karsten.

    Mein VDR: LianLi-Gehäuse, AMD X2 64 5200+ auf Biostar TA690G, 768MB Ram, 250 GB HD, TT S3200, ne Airstar2 DVB-T und nen Touchpanel:-), Ubuntu Karmic , VDR 1.7.12 Extensionpatch mit x-vdr gebaut.

  • osd -menü, oberster button (lautsprechersymbol) wählen, so kommt man in die Einstellungen für Sound, Ton und Untertitel.
    Hier kann man die Tonspur wählen, einmal auswählen und als Standard speichern.


    Beim ersten Mal hat man auch bei den Öffentlich Rechtlichen immer Untertiteln an, die muss man auch immer erst ausschalten und speichern, arte ist standardmäßig französisch.


    gruss,
    raoul