[Howto] Mac Mini als Client für VDR & XBMC unter Ubuntu

  • Hallo Jondalar,


    ich bin jetzt auch schon leicht genervt und ich überlege auf Windows (Mediacenter mit XP) zu wechseln.


    Gruß tcash

    IR-Fernbedienung X10 Medion, ASUS P5N7A-VM E5200 , 8GB CF Karte, Hauppauge WinTV NOVA HD S2, Sharp LC-46X20E


    yavdr 4.0

    The post was edited 1 time, last by tcash ().

  • Hallo Eisbaer128,


    ich habe die Probleme nur, wenn vdr-sxfe mit läuft (unter Xbmc nur Navigationssound), als Test habe ich mal XBMC einzelnt gebootet und dann geht der Sound ohne Probleme.
    Unter XBMC habe ich schon alle möglichen Einstellungen getestet, aber ohne Erfolg.


    Wie ist bei Dir die TV Qualität mit SD Sendern, ich hatte zum Vergleich mal Easyvdr und was soll ich sagen zwische Ubuntu und Easyvdr liegen Welten zu Gunsten von Easyvdr.


    Gruß tcash

    IR-Fernbedienung X10 Medion, ASUS P5N7A-VM E5200 , 8GB CF Karte, Hauppauge WinTV NOVA HD S2, Sharp LC-46X20E


    yavdr 4.0

    The post was edited 1 time, last by tcash ().

  • Hallo tcash,


    Dann sollte es wohl wie von mir vermutet an einer Blockierung der Soundkarte durch den anderen Prozess liegen. Ich habe damit zwar keine Erfahrung, aber schau Dir doch mal alsa dmix an damit sollte man das hinbekommen. Hier z.B. ein Link zu einem Howto:
    http://alsa.opensrc.org/home/w…ndex.php?title=DmixPlugin


    Zur Bildqualität: Ich habe keinen wirklichen Vergleich aber da die Software ja die selbe ist kann es nur an den Voreinstellungen für X Server oder xinelibout (z.B: deinterlacer) liegen. Ich bin eigentlich ziemlich zufrieden, der Deinterlacer den ich eingestellt habe ist noch nicht so wirklich das ware aber ich bin ja eh gerade dabei das ganze auf VDPAU umzustellen deshalb habe ich da keine Zeit reingesteckt.

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • Hallo Eisbaer128,


    danke für den Tip wegen dem Soundproblem. Ich habe meinen VDR erst einmal still gelegt, wegen der Qualität vom SD Sendern, bei mir waren ständig kleine ruckler und Ton knackser drin. Bei meiner config_xineliboutput Datei habe ich folgende Einstellungen vorgenommen


    engine.buffers.video_num_frames:5000
    video.output.vdpau_deinterlace_method:temporal


    Aber an der bescheidenen Anzeige hat sich nichts geändert, wäre es möglich wenn Du mir deine Einstellungen mal postest?


    Ich verwende Xine-VDPAU 261 und NVIDIA-Linux-x86-185.18.14.


    Dann habe ich noch festgestellt, das unter XBMC kein File (720p, 1080i und 1080p) mit vdpau abgespielt bekomme, wenn ich o drücke bekomme ich nur folgende Anzeige.


    vq:xxx dc: ff-mpeg4


    Wie sieht es bei Dir mit vdpau und xbmc aus?


    Danke schon im Voraus.


    Gruß tcash

    IR-Fernbedienung X10 Medion, ASUS P5N7A-VM E5200 , 8GB CF Karte, Hauppauge WinTV NOVA HD S2, Sharp LC-46X20E


    yavdr 4.0

  • Hallo tcash,


    Also xbmc fuktioniert bei mir ziemlich gut mit VDPAU. Achtung wird in xbmc nur für HDTV verwendet. Per xbmc Infoanzeige wird vdpau bei HDTV Aufnahmen verwendet und ich sehe auch nur eine sehr niedrige Prozessorlast auch bei 1080p Material. Ich habe zwar einen aktuellen xbmc pvr-testing am laufen das ging aber auch schon vorher mit der ganz normalen 9.04 Release. HDTV Fernsehen geht damit auch aber umschalten zwischen HDTV Kanälen für noch mi sehr hoher Wahrscheinlichkeit zu einem Crash.
    Beim xinelibout bin ich noch nicht zu einer laufenden VDPAU Version gekommen, ich kann deine Frage also nicht wirklich beantworten, das aktuelle xinelibout passt aber noch nicht wirklich gut zu meinem vdr 1.7.8.

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • Hat jemand mit dem Mini auch ab und an das Problem, dass der kleine nicht herunter fährt?


    Installiert ist bei mir Kernel 2.6.29.2 und die NVIDIA Treiber 180.60.


    Wenn der Shutdown nicht klappt, steht im LOG folgendes:


    Das wiederholt sich dann jede Minute.


    Ich habe gerade mal die NVIDIA Treiber 185.18 installiert, in der Hoffnung, dass der Fehler verschwindet.


    Edit: Habe gerade gelesen, dass der Kernelparameter "noapic" helfen könnte.
    EDIT2: Ist keine Lösung, da dann der Soundchip nicht mehr gefunden wird.


    Gruß

    ASUS M4A78LT-M GL | AMD Athlon II X2 250 | 2GB RAM | Asus ENGT430 | Digital Devices OctopusNet mit 2 x Digital Devices DuoFlex S2 | PS3Remote | yaVDR 0.6.1

    The post was edited 3 times, last by BOP ().

  • Quote

    Original von Eisbaer128
    Reboot ist ein bekanntes Thema.
    Shutdown geht reboot geht nicht mit allen neuen Mac Minis. Scheint auch noch so zu sein mit einem neuen 2.3.30 Kernel aus dem 9.10 Alpha Ubuntu. Es gibt dazu ein Feher Ticket bei Ubuntu aber keine Lösung. Nehme das noch in die Liste der Probleme auf.


    Reboot geht mit
    "reboot=pci"


    z.B. bei mir aus /boot/grub/menu.lst
    title Ubuntu 9.04, kernel 2.6.29.2
    kernel /boot/vmlinuz-2.6.29.2 root=/dev/sda2 ro reboot=pci
    initrd /boot/initrd.img-2.6.29.2

    1.VDR mac mini 2009 4GBRam/ freevdr2.0a / TeVii S650 (oder TerraTec_Cinergy_S_USB oder TerraTec_S7>noch ohne HD/CI>) / Harmony 785
    2.VDR - Fanless: ATC620BX1/ AOpeni855GMEm-LFS/ CPU-M1,7GHz/ SST-NT01/ 512MB/ EFN-300/ 3*DVB-S-FFRev1.3/ avBoard/ IREinRev.4 / CF
    3.VDR - Fanless: Rebach-DT-HIFI-01/ ViaEpia5000/ 256MB/ DVB-S-FFRev1.5/ 120GBHD-SV1203N / GLCD/ IREinAus / opt. SPDIF
    4.VDR Samsung-SMT7020s

  • Hallo Celica,
    Danke für die Information, aber bei meinem Mac Mini hilft das nichts. Beim Reboot bleibt er immer noch hängen.

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • Gerade nochmal getestet, nach 4Tagen uptime > reboot, kein Problem.


    Hatte aber auch schon mal Probs mit reboot, wenn sich vdr-sxfe weghängt,
    (Bild nur noch im XBMC) dann ging komischerweise kein reboot mehr.


    Wo und warum das dann nicht geht habe ich noch nicht genauer analysiert.


    Könnte sein das evtl. mehrere vdr-sxfe Processe dann vorhanden sind und vorher gekillt werden müssten?



    Quote

    Original von Eisbaer128
    Hallo Celica,
    Danke für die Information, aber bei meinem Mac Mini hilft das nichts. Beim Reboot bleibt er immer noch hängen.

    1.VDR mac mini 2009 4GBRam/ freevdr2.0a / TeVii S650 (oder TerraTec_Cinergy_S_USB oder TerraTec_S7>noch ohne HD/CI>) / Harmony 785
    2.VDR - Fanless: ATC620BX1/ AOpeni855GMEm-LFS/ CPU-M1,7GHz/ SST-NT01/ 512MB/ EFN-300/ 3*DVB-S-FFRev1.3/ avBoard/ IREinRev.4 / CF
    3.VDR - Fanless: Rebach-DT-HIFI-01/ ViaEpia5000/ 256MB/ DVB-S-FFRev1.5/ 120GBHD-SV1203N / GLCD/ IREinAus / opt. SPDIF
    4.VDR Samsung-SMT7020s

  • Ich habe dein script für mein system angepasst. Nutze als Frontend Xine und dein script erkennt erfolgreich das laufende programm und schaltet auch zwischen xbmc und xine-vdr hin und her. Ich habe aber folgendes problem: wenn dein script xine-vdr startet dann hängt das script in einer art warteschleife und ich kann per irexec kein weiteres starten. erst wenn ich xine per hand beende dann läuft dein script weiter. was mache ich hier falsch??
    mein script:
    #!/bin/bash


    XBMC="/usr/bin/xbmc -fs"
    VDR="/usr/bin/vdr-sxfe xvdr:tcp://localhost:37890 --nokbd --lirc --fullscreen --reconnect --syslog --post tvtime:method=Linear,cheap_mode=1,pulldown=0,use_progressive_frame_flag=1"
    #PIDFILE=/var/run/xine.pid




    if [ "`ps -ef | grep -v grep | grep 'xine -V'`" != "" ];then
    echo "VDR application is running => starting XBMC ..."
    killall xine
    sleep 1
    /usr/bin/xbmc


    elif [ "`ps -ef | grep -v grep | grep '/usr/bin/xbmc'`" != "" ];then
    echo "XBMC application is running => starting VDR ..."
    killall xbmc-bin

    else
    echo "no application is running => starting VDR ..."
    xine -V vdpau -f -g --no-splash --post tvtime:method=use_vo_driver --post vdr_video --post vdr_audio --post vdr "netvdr://127.0.0.1#demux:mpeg_pes"
    fi

    VDR1: RPI3, DVB-Sky S960, VDR 2.20, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.
    VDR2: RPI1, DVB-Sky S960, VDR 2.32, Raspbian Jessie, Grundig LCD.
    VDR3: RPI2, DVB-Sky S960, VDR 2.20, Raspbian Jessie, 55´er Grundig Röhre

  • Gibt es hier schon ne Lösung?
    Genau so ein Script suche ich auch um den easyVDR mit XBMC zu betreiben.


    Bitkit

    ARCTIC COOLING Silentium T2 - ASUS M3N78 Pro AMD X2 4850e 2GB RAM - 250+400+500GB Samsung

    Skystar1(TT Rev. 1.3) - Skystar HD S2 - AV-Board 1.2 - PS2 TFT - MediaMVP

    easyVDR 0.7.10

  • Problem gefunden, man sollte richtig lesen.
    "begin
    prog = irexec
    remote = MacMini
    button = F1
    config = /usr/local/bin/switchtv & \n
    "end


    Das "& \n" in der .lircrc war das Problem. Zur verständissfrage, was bedeutet das: & \n

    VDR1: RPI3, DVB-Sky S960, VDR 2.20, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.
    VDR2: RPI1, DVB-Sky S960, VDR 2.32, Raspbian Jessie, Grundig LCD.
    VDR3: RPI2, DVB-Sky S960, VDR 2.20, Raspbian Jessie, 55´er Grundig Röhre

    The post was edited 1 time, last by Asta ().

  • "\n" bedeutet Newline oder Line feed (Zeilenumbruch oder Zeilenvorschub) und ist ein Steuerzeichen. Hast Du die Datei mal mit einem Windows Editor bearbeitet? Dann passiert so etwas ganz gerne. Das & hat damit aber wiederum nichts zu tun.


    http://de.wikipedia.org/wiki/Steuerzeichen

    ASUS M4A78LT-M GL | AMD Athlon II X2 250 | 2GB RAM | Asus ENGT430 | Digital Devices OctopusNet mit 2 x Digital Devices DuoFlex S2 | PS3Remote | yaVDR 0.6.1

    The post was edited 1 time, last by BOP ().

  • Habe alles im ubuntu mit "nano" bearbeitet. Wenn ich das "& \n" weglasse, dann kann ich das script einmal ausführen. Beim zweiten Druck auf die Taste reagiert "irexec" nicht mehr. Komisch. Aber eigentlich auch egal, denn jetzt funktioniert es wie es soll.

    VDR1: RPI3, DVB-Sky S960, VDR 2.20, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.
    VDR2: RPI1, DVB-Sky S960, VDR 2.32, Raspbian Jessie, Grundig LCD.
    VDR3: RPI2, DVB-Sky S960, VDR 2.20, Raspbian Jessie, 55´er Grundig Röhre

  • Quote

    Original von Asta
    Habe alles im ubuntu mit "nano" bearbeitet. Wenn ich das "& \n" weglasse, dann kann ich das script einmal ausführen. Beim zweiten Druck auf die Taste reagiert "irexec" nicht mehr. Komisch. Aber eigentlich auch egal, denn jetzt funktioniert es wie es soll.


    switchtv wird mit dem & im Hintergrund ausgeführt und irexec ist sofort wieder bereit ein weiteren Tastendruck zu bearbeiten. Ohne das & wartet irexec auf die Beendigung von switchtv, die aber wohl nicht passiert, deshalb gibt es keine Reaktion von irexec mehr. Ich kenne switchtv nicht, vom Namen würde ich eigentlich nicht erwarten, dass er sich nie beendet, seltsam.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

    The post was edited 1 time, last by gda ().

  • Mein neues Script:
    #!/bin/bash


    XBMC="/usr/bin/xbmc -fs"
    VDR="/usr/bin/xine -V vdpau -f -g --no-splash --post tvtime:method=use_vo_driver --post vdr_video --post vdr_audio --post vdr "netvdr://127.0.0.1#demux:mpeg_pes""
    PIDFILE=/home/user/xine.pid


    if [ "`ps -ef | grep -v grep | grep 'xine -V'`" != "" ];then
    echo "VDR application is running => starting XBMC ..."
    PID=`pidof -s /usr/bin/xine`
    kill $PID
    killall -9 xine
    killall -9 xbmc.bin
    sleep 2
    $XBMC
    sleep 1
    PID=`pidof -s /usr/share/xbmc/xbmc.bin`
    echo $PID > $PIDFILE


    elif [ "`ps -ef | grep -v grep | grep '/usr/bin/xbmc'`" != "" ];then
    echo "XBMC application is running => starting VDR ..."
    PID=`pidof -s /usr/share/xbmc/xbmc.bin`
    kill $PID
    killall -9 xine
    killall -9 xbmc.bin
    sleep 2
    $VDR
    PID=`pidof -s /usr/bin/xine`
    echo $PID > $PIDFILE


    else
    echo "no application is running => starting VDR ..."
    killall -9 xine
    killall -9 xbmc.bin
    $VDR
    PID=`pidof -s /usr/bin/xine`
    echo $PID > $PIDFILE
    fi


    Die .lircrc


    begin
    prog = irexec
    remote = technisat
    button = tv/sat
    config = /home/user/scripte/./umschaltscript & \n


    end


    Damit funktioniert bei mir das Umschalten zwichen vdr-xine und xbmc problemlos.

    VDR1: RPI3, DVB-Sky S960, VDR 2.20, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.
    VDR2: RPI1, DVB-Sky S960, VDR 2.32, Raspbian Jessie, Grundig LCD.
    VDR3: RPI2, DVB-Sky S960, VDR 2.20, Raspbian Jessie, 55´er Grundig Röhre