XBMC friert ein, wenn TV aktiviert wird

  • Hi,


    habe nun unter Ubuntu jaunty 9.04 ein aus den Sourcen ein Debian Paket gebaut (mit dem Patch 19616) Es läuft soweit. Unter Videos erstelle ich den VDR Client. Wenn ich nun die TV Option aktiviere, dann friert das komplett xbmc ein. Schade eigentlich, war schon ganz guter Dinge. Nunja, leider erscheint auch kein Logeintrag. Gibt es dafür einen Lösungsansatz?


    Gruß, Heinzelrumpel


    p.s


    VDR läuft auf dem Server mit streamdev, lokal läuft nur xbmc

  • .. muß mich nach einem langen Kompiliertag leider mal wieder mit dem gleichen Problem hier anhängen. :( Habe allerdings bereits mit externem Server und lokalem Streamdev getestet. Fehler bleibt. Die Logeinträge der jeweiligen Server besagen nur, dass sie den Stream nicht loswerden können.


    Ich fürchte ja, es war einfach mal wieder der falsche Tag für einen Test. Wahrscheinlich sind die xbmc Sourcen mal wieder matschig und Übermorgen geht's mal wieder von alleine...


    Gruß
    Holger

  • Quote

    Original von hotzenplotz5
    versuch den vdr-client auszuwählen -> absturz ..... war bei mir auch ,
    beim nächsten xbmc neustart dann nur noch aktivieren (nicht mehr auswählen)
    dann ging es bei mir.


    wäre zu schön, wenn sich die problem immer so erledigen liessen. leider bei mir heute nicht. vielleicht es es wirklich einfach der falsche tag. naja, dann mache ich eben etwas anderes..

  • Quote

    Original von heinzelrumpel


    wäre zu schön, wenn sich die problem immer so erledigen liessen. leider bei mir heute nicht. vielleicht es es wirklich einfach der falsche tag. naja, dann mache ich eben etwas anderes..


    ... mach ich auch. Letztes mal habe ich auch gegen Windmühlen gekämpt. Zwei Tage später mit den dann verfügbaren Sourcen alles exakt genauso noch mal gemacht=lief. So schön das alles ist mit den tagesaktuellen Sourcen für Ubuntu: Man weiß halt nie, ob's läuft. Die helfenden Poster geben sich alle Mühe, einen auf den richtigen Weg zu bringen, aber meistens läuft's dann bei denen schon... mit den Sourcen vom Vortag ;)


    Gruß
    Holger

  • o.k habe mal den lokalen pvr client auf lokal, also 127.0.0.1 gestellt und dann lies sich tv aktivieren, nur leider findet er den server jetzt nicht. das wird auch gleich beim start von xbmc bemängelt und xbmc beendet sich dann von selbst. das ist nicht so günstig,da ich jetzt keine möglichkeit mehr finde, ihm eine andere ip unterzuschieben bzw. tv wiederzu deaktivieren. auch das installieren von vdr inkl. streamdev-server lokal brachte nichts.

  • Quote

    Original von heinzelrumpel
    o.k habe mal den lokalen pvr client auf lokal, also 127.0.0.1 gestellt und dann lies sich tv aktivieren, nur leider findet er den server jetzt nicht. das wird auch gleich beim start von xbmc bemängelt und xbmc beendet sich dann von selbst. das ist nicht so günstig,da ich jetzt keine möglichkeit mehr finde, ihm eine andere ip unterzuschieben bzw. tv wiederzu deaktivieren. auch das installieren von vdr inkl. streamdev-server lokal brachte nichts.


    Code
    1. sudo rm -rvf /home/<username>/.xbmc


    mfg
    aelo

  • Hallo,


    bei mir war die Lösung dafür zu sorgen, dass der VDR nur wenige Aufnahmen hat. (neues /video0 Verzeichnis).


    Den Tipp hab ich aus einem anderen Thread, somit könnte das System haben.


    Gruß,
    Hendrik

  • Falls XBMC beim Starten crasht, weil der PVR-Manager aktiv ist, kann man ihn durch Änderung einer Konfigurationsdatei deaktivieren: In /home/ich/.xbmc/userdata/guisettings.xml sucht man diesen Abschnitt:

    Code
    1. <pvrmanager>
    2. <enabled>true</enabled>
    3. <pvrsources></pvrsources>
    4. <sep1></sep1>
    5. </pvrmanager>

    Nun die Zeile mit "enabled" wie folgt ändern:

    Code
    1. <enabled>false</enabled>


    Somit kann man XBMC wenigstens wieder starten und benutzen und mit der Fehlersuche weitermachen.


  • das hat in der Tat System! Mit dem "aus-dem-Weg-räumen" des Videodirs friert xbmc tatsächlich nicht mehr ein und TV läßt sich aktivieren. Danke für den Tipp!


    Ne Lösung ist das natürlich nicht, aber immerhin geht schon mal einen Schritt weiter...


    Gruß
    Holger