Fehler beim kompilieren auf ubuntu

  • Hi,


    habe mir von xbmc die svn19616 gezogen und den patch darauf angewendet. Nun meldet make dies



    Was kann ich da machen?


    Gruß


    Heinzelrumpel

  • 8.10 oder 9.04 ?
    9.04:
    https://launchpad.net/~team-xbmc/+archive/jaunty-ppa


    quellen in die sources.list
    apt-get update
    apt-get source xbmc
    cd xbmc_9.04~beta1-jaunty1_i386
    apt-get build-dep xbmc
    wget http://xbmc.org/trac/attachmen…bmc-svn19616-pvr.patch.gz
    gunzip xbmc-svn19616-pvr.patch.gz
    patch -p1 < xbmc-svn19616-pvr.patch
    in der Datei "debian/xbmc-common.install" ist die Zeile "usr/share/xbmc/pvrclients" hinzuzufügen
    dpkg-buildpackage -tc
    tata:
    xbmc-common_9.04~beta1-jaunty1_i386.deb
    ....
    ....
    moment.............für vdrdevel:
    deb-src http://e-tobi.net/vdrdevel-experimental lenny vdr-multipatch
    ->sources.list
    apt-get update
    mkdir vdrdevel
    cd vdrdevel
    apt-get source vdr <---- ACHTUNG TOMG hat auf 1.7.6 umgestellt deshalb wird das so nicht funktionieren
    cd vdr-1.7.5
    dann von hier:
    http://www.schvestka.de/debian-patches.tar.gz
    die patches ziehen .....
    damit den debian/patches ordner ersetzen !
    apt-get build-dep vdr
    SPECIAL_VDR_SUFFIX=devel fakeroot dpkg-buildpackage -us -uc -tc
    wichtig das -dev paket auch installieren sonst kann das mit streamdev nicht klappen....



    für streamdev :
    apt-get source vdr-plugin-streamdev
    cd vdr-p*
    cvs -d:pserver:anoncvs@vdr-developer.org:/var/cvsroot login
    cvs -d:pserver:anoncvs@vdr-developer.org:/var/cvsroot co -D 4/22/09 streamdev
    dann den "neuen" streamdevordner packen in tar.gz und umbenennen z.b"vdr-plugin-streamdev-0.5.0pre~cvs20092604"
    dann uupdate -0.5.0pre~cvs20092604
    cd ..
    cd vdr-plugin-streamdev-0.5.0pre~cvs20092604
    in der datei debian/vdr-plugin-streamdev-server.links
    dievorhandene zeile ändern in

    Code
    1. etc/vdr/plugins/streamdevhosts.conf var/lib/vdr/plugins/streamdev/streamdevhosts.conf


    den patch vom anhang nach debian/patches
    dann in debian/patches die datei 00.list anpassen :

    Quote

    01_include-fix


    #Patch required by XBMC
    opt-20_xbmc-v6


    debian-buildpackage -tc -us (und was man alles noch für optionen hat :D )


    cd ..
    tata .....
    vdr-plugin-streamdev-server_0.5.0pre~cvs20092404-0ubuntu1_i386.deb

  • :moin


    achso, ich habe gedacht, man müsse sich direkt die revision 19616 des svn holen, damit der patch korrekt funktioniert. Die sources hatte ich schon in apt drin, aber nur wegen apt-get build-dep xbmc. Probiere ich doch gleich mal aus.


    Gruß, Heinzelrumpel

  • Quote

    achso, ich habe gedacht, man müsse sich direkt die revision 19616


    ich glaube das war genau DIE rev.nummer bei der beta !!!


    bei zweifel nimmt man halt die svn-ubuntu sourcen !:
    https://edge.launchpad.net/~team-xbmc-svn/+archive/ppa


    da ist man auf dem aktuellen stand, und kann trotzdem (soweit ich weiss)
    mit svn spielen (up und downgraden zu anderen versionen)


    es braucht auch KEIN vdpau enable ........ und trotzdem geht es :D


    apt-get build-dep sollte eigentlich alles nötige "ziehen" damit xbmc übersetzt werden kann

  • habe gerade mal einen durchlauf gemacht mit den sourcen von https://launchpad.net/~team-xbmc/+archive/jaunty-ppa. dort musste ich aber noch ein dk-make durchführen. leider brach der buildpackage-vorgang mit dem patch auch dort ab. probiere mal weiter

  • Quote

    dort musste ich aber noch ein dk-make durchführen


    DAS kann und darf nicht sein :schiel


    da produzierst du ja wieder einnen debian ordner..........
    bitte nur so wie ich das oben beschrieben hab
    was ich vergessen hab ist apt-get update nach dem neuen eintrag in der sources.list !!!


    wichtig ist der eintrag mit deb-src !!!

  • Mal ne blöde Frage: Wie aktiviere ich das TV-Modul in dieser xbmc-Version? "Früher" konnte man da "VDR" auswählen. Jetzt gibt's an der Stelle der Video-Settings nur noch "Enabled" und "Manage Clients". Letzteres ist leer und hinzufügen lässt sich auch nichts...


    Hab's so gemacht wie in den obigen Post's beschrieben.


    Gruß
    Holger

  • ... das ist vermutlich genau mein Problem: Auf dem Rechner, auf dem xbmc läuft, ist das nicht der Fall. Der gepatchte VDR+passendes Streamdev befindet sich auf dem Server. Bisher konnte man ja aber auch andere Rechner angeben. :(


    Kann ich xbmc irgendwie beipulen, dass er nicht nur lokal suchen soll?


    Gruß
    Holger

  • du musst den Ordner pvrclients nach
    /usr/share/xmbc/pvrclients
    kopieren und danach findest du auch deinen VDR :-)


    da läuft beim bauen der Pakete etwas schief und deshalb werden die Files nicht installiert


    mfg
    aelo

  • In der Datei "debian/xbmc-common.install" ist die Zeile "usr/share/xbmc/pvrclients" hinzuzufügen, wie ich schon im anderen Thread geschrieben habe. Dann neu bauen und siehe da: die pvrclients sind enthalten im Binary-Paket.