Noad für 1.7.4 TS-Aufnahmen

  • Was passiert denn, wenn du Noad (den "normalen") auf eine TS-Aufnahme loslässt?
    Ein paar Fehlermeldungen oder so könnten hilfreich sein.


    Welche Noad-Version setzt du ein?
    Sind alle Patches drin?

    Gruss
    SHF


  • Hi,


    Also natürlich hab ich es mit dem original Noad probiert, aber der findet natürlich keine Aufnahme
    in dem Ordner, da alle Dateien ander heißen als bei den PES Aufnahmen
    (001.vdr ist jetzt 00001.ts, index.vdr wurde zu index).


    Auch nach dem einfachen anpassen der Dateinamen im Quelltext, kann er mit den Aufnahmedateien nichts anfangen.


    Dann hab ich mal die Noad Version aus dem Link in meinem ersten Post ausprobiert, in der der TS-Support
    mit drin sein soll, ist aber für die Dreambox angepasst.
    Leider sucht auch auch diese Version nach xxx.vdr Dateien. Also dort auch die Dateiname und Endungen
    im Quelltext geändert, und siehe da er probiert wenigstens. Hört aber nach 2 Sekunden wieder auf
    mit der Meldung kein Logo gefunden.


    Hier bin ich dann erstmal nicht weitergekommen.


    Logmeldungen kann ich erst heute abend liefern.


    Bin ich wirklich der einzige, der entweder
    A: Probiert noad mit der 1.7.4'er, mit TS-Aufnhamen zum laufen versucht zubekommen, oder
    B: zu doof ist den richtigen Patch zu finden :-)


    Gruß Patrick

  • zu A: ja
    zu B: nein. Es gibt derzeit vermutlich nicht viele, die VDR 1.7.4 einsetzen. Das ganze ist bleeding edge und sollte ja sowieso nur in Entwicklungsumgebungen eignesetzt werden, nicht im produktiven Umfeld. Das schreibt Klaus ja auch immer wieder in die Ankündigungen. Es ist auch nicht ganz auszuschleßen, dass sich das TS-Format nochmal etwas ändert wenn es notwendig ist. Deshalb hat wohl momentan keiner großartig Lust, dort Aufwand reinzustecken ...

  • Zitat

    Originally posted by maverick-me
    .....
    Bin ich wirklich der einzige, der entweder
    A: Probiert noad mit der 1.7.4'er, mit TS-Aufnhamen zum laufen versucht zubekommen, oder
    B: zu doof ist den richtigen Patch zu finden :-)


    zu A: nein (Habe ich auch schon versucht, tut natürlich nicht)
    zu B: Ehrlich: Habe noch nicht danach gesucht, schneide wieder "von Hand". Kann aber manchmal ganz schon lästig sein, wäre mal Zeit für nen patch ;-)


    Ansonsten läuft die 1.7.4 hier bei mir seit es sie gibt völlig problemlos, maximal ein kosmetisches Problem (nach dem Spulen ist bei ner FF der Ton manchmal nicht lippensyncron, aber das Problem gabs früher ja auch schon mal)
    Was die Plugins betrifft: "Meine" laufen fast alle: mp3/mplayer, epgsearch, skinenigmang, live, femon. Nur extrecmenu läuft nicht mehr, dafür nehme ich jetzt liemikuutio


    Umwandeln in DVD mit externen Tools (ProjectX und DeVeDe) ist auch problemlos.


    Grüße, Peter

    VDR1: vdr-latest, arch x86_64, Octopus net 2 x Duoflex C/C2/T2 , NUC7i3BNH, Crucial MX300 2TB, LG LM 669S
    VDR2: RasPI 2, MLD
    VDR-User #81

    Linux is the best OS I have ever seen -- Albert Einstein

  • Zitat

    Original von maverick-me
    Also natürlich hab ich es mit dem original Noad probiert, aber der findet natürlich keine Aufnahme
    in dem Ordner, da alle Dateien ander heißen als bei den PES Aufnahmen
    (001.vdr ist jetzt 00001.ts, index.vdr wurde zu index).


    Auch nach dem einfachen anpassen der Dateinamen im Quelltext, kann er mit den Aufnahmedateien nichts anfangen.

    Da hast du ja schon das naheliegenste probiert.


    Zitat

    Dann hab ich mal die Noad Version aus dem Link in meinem ersten Post ausprobiert, in der der TS-Support
    mit drin sein soll, ist aber für die Dreambox angepasst.
    Leider sucht auch auch diese Version nach xxx.vdr Dateien. Also dort auch die Dateiname und Endungen
    im Quelltext geändert, und siehe da er probiert wenigstens. Hört aber nach 2 Sekunden wieder auf
    mit der Meldung kein Logo gefunden.

    War das eine HDTV Aufnahme?
    Evtl. sollte man mal versuchen die Änderungen zum Standard-Noad nachvollziehen (diff, die Frage ist nur, gegen welche Version) und diese dann übertragen.

    Gruss
    SHF


  • OK,


    Jetzt hab ich mal etwas experimentiert, und es sieht so aus, als ob
    ich mit etwas abgucken von der Dreambox Version einen Patch erstellen konnte, der auch soweit funktioniert.


    Jetzt das große ABER:


    es wird jeweils nur die erste Datei (also 00001.ts) der Aufnahme gescannt.


    Da komm ich jetzt erstmal nicht weiter.


    Jemand anderes noch eine Idee, wie man Noad jetzt noch überredet bekommt alle Datein durchzuscannen?


    hier mal die erste Testversion des Patches gegen Noad 0.6.0.
    Wie schon geschrieben wird aber nur die erste ts Datei gescannt.

  • Die Funktion, die die Dateien durchschaltet seint auskommentiert zu sein (vdr_cl.h).
    Ob es reicht den Kommentar zu entfernen bezweifele ich nach diesem Kommentar:


    Zitat

    (von Hier )
    [...] Daher muß die 7025 Aufzeichnung, die im TS-Format vorliegt in das VDR-Format konvertiert werden. D.h. es wird auf der Harddisk für die Berechnung der Werbeunterbrechungen eine temporäre Kopie der Aufzeichnung angelegt, damit wird für die Berechnung je nach Aufzeichung 2-5GB freier Speicher benötigt.

    Irgendwie sieht das mir nicht nach einer sauberen Lösung aus. Das zum laufen zu bringen dürfte eine menge Frickelei werden, da kann man das wahrscheinlich gleich gescheit neu schreiben.


    Ich denke man sollte sich eher nach einer Lib umsehen mit der man die PES-Daten aus dem TS quasi transparent beim einlesen extrahieren kann. Das müsste es eigentlich irgendwo bei den DVB-Toools oder so geben.


    Zitat

    Original von maverick-me
    es wird jeweils nur die erste Datei (also 00001.ts) der Aufnahme gescannt.

    Da setzt er dann aber auch die Schnittmarken?


    Wo du es schon am laufen hast, was passiert denn mit HD-Aufnahmen?

    Gruss
    SHF


  • Hallo, hab ein neues Patch angelegen, das das alles von maverick gemachten beinhaltet, jetzt aber auch alle die .ts Dateien scannt. Ausserdem sind ein paar Korrektierungen drin die wohl bei mir (?) nötig beim Übersetzen sind. Jetzt scheint noad wirklich wie vorher mit den PES funktionieren.

  • Hi!


    Habe das mal bei Schlag den Raab von gestern probiert und das Ergebnis sah sehr gut aus. Allerdings scheint das Springen zwischen den Marken nicht mehr einwandfrei zu funktionieren.
    D.h. wenn man z.B. 9 drückt und auf eine Marke kommt, kann man davon nicht mehr wegspringen (mit 7 oder 9) und diese auch nicht verschieben. Mit Play oder einem Minutensprung kommt man dann schon weg.
    Kann es sein, dass die Timecodes keine I-Frames mehr angeben oder sowas in der Richtung?


    Test unter vdr-1.7.8.


    Gruß,
    Brougs78

    - -- --- ================================================================ --- -- -
    Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), DD CineS2 v6 + DD DuoFlex CI // yavdr-0.6.1
    - -- --- ================================================================ --- -- -

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Brougs78 ()

  • Hm, das problem kenn ich aber schon länger. Zur zeit läuft 1.7.7.

    - VDR: Thermaltake DH 102 mit 7" TouchTFT * Debian Jessie/vdr-2.1.8/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W) * satip-Plugin
    - Server: Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hi!


    Hatte ich sonst eigentlich selten. Ab und zu hatte ich mit älteren noad-Versionen den Effekt, dass es eine Marke ganz am Anfang erstellt hat die nicht gelöscht werden konnte.


    Bei einer Folge "Two and a Half Men" waren die Marken einwandfrei anzuspringen.


    Gruß,
    Brougs78

    - -- --- ================================================================ --- -- -
    Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), DD CineS2 v6 + DD DuoFlex CI // yavdr-0.6.1
    - -- --- ================================================================ --- -- -

  • Moinmoin !
    Ich weiss nicht, ob mein Problem auch damit zusammenhängt, aber bei meiner vdr-1.7.8 Version funktioniert die Eingabe einer 2 beim Springen zu einer bestimmten Position in der Aufnahme (Taste rot) nicht.
    Ein Sprung zu z.B. 1:59 funktioniert einwandfrei, wenn man aber zu 2:00 springen möchte, wird sofort der Schnitt gestartet, wenn man die Taste 2 drückt.

  • Nochmal moinmoin !


    Ich habe jetzt in der Gen2VDR 3 das noad mit emerge --unmerge noad deinstalliert, die plain noad-0.6.0 gezogen, den TS-Patch angewendet (eine Wanung, dass die config.h bereits existiert wurde angezeigt), ./configure, make und make install ausgeführt. Bis dahin sah alles gut aus.


    Allerdings wird das noad nicht fertig.


    Es laufen jetzt inzwischen (nach ca 20 Stunden Betriebsdauer) 4 noad-Prozesse mit je ca. 20% CPU-Last.


    Fehlt mir noch ein Patch?

  • Hallo,


    ich habe den hier geposteten patch mit diesen:


    http://git.gekrumbel.de/?p=noad.git


    Patches verbunden. Leider in 2 Dateien, wegen maximaler erlaubter Dateigröße für Dateianhänge im Forum. Also die Dateien verbinden, das Ergebnis mit bzip2 entpacken und auf noad-0.6.0 anwenden.


    Erste Tests mit TS sehen gut aus. Muss aber natürlich noch weiter getestet werden, ist also im Moment noch alpha.


    Markus