Zeit über Transponder geht falsch

  • Hi,
    schon seit geraumer Zeit geht die Uhrzeit falsch.


    Ich hab unter VDR - Einstellungen - EPG -
    Systemzeit stellen: ja
    Transponder für Systemzeit: 2 ZDF



    Code
    1. root@SMT-7020S:/etc# date
    2. Sat Mar 14 03:13:17 CET 2009
    3. root@SMT-7020S:/etc# hwclock
    4. Sat 14 Mar 2009 04:05:26 AM CET -0.147645 seconds


    Die Uhrzeitausgabe von "date" stimmt !
    Die Zeit von hwclock geht falsch.


    Aber die Uhrzeit im VDR geht nicht immer falsch, Abends gegen 21 -22 Uhr geht sie wieder richtig bis in die Nacht bis sie irgendwann Mittags wieder falsch geht.


    Welcher Befehl von den beiden zeigt die Systemzeit ?


    In einem anderem Forum wurde mir nahe gelegt die Uhrzeit übers Internet zu stellen mit dem NTP-Protokoll.
    Dafür brauch ich das Programm nptdate, habe ich aber nirgends gefunden und auch keine Installationsanleitung. Für die Configuration habe ich ne schöne Anleitung gefunden.


    Geht das auch ohne nptdate ?

    Samsung SMT7020S 160 HDD @ Zenslack 1.0rc5 + 1.3 Patch & VDR 1.4.7
    ===============================================
    Wenn sie zwei Hühner haben und die vermehren sich und sie haben irgendwann 100 und dann kommt ne Flut und alle sind ersoffen und wenn sie dann sagen hätt ich mal Enten gekauft, das ist Börse !

  • nimm mal phoenix. zumindest ging dies damals bei mir anstandslos.

    [size=7]x2 4400+, 2gb ram, mcp61, twinhan dvb-t, lenny, vdr-1.6 - xineliboutput(sxfe) - vodcatcher(helper) - iptv(doesnt work) - wirbelscan[/size]
    on PAT (program administration tool = windows) problems = reboot
    on linux problems = be root

  • Phoenix ? Habe nichts zu gefunden in Google. Geht das nicht einfacher ?
    Was ist denn der Unterschied zwischen "date" und "hwclock" ?

    Samsung SMT7020S 160 HDD @ Zenslack 1.0rc5 + 1.3 Patch & VDR 1.4.7
    ===============================================
    Wenn sie zwei Hühner haben und die vermehren sich und sie haben irgendwann 100 und dann kommt ne Flut und alle sind ersoffen und wenn sie dann sagen hätt ich mal Enten gekauft, das ist Börse !

  • Hi,


    auf einem Linux-System (x86) gibt es zwei Zeiten:
    Die Systemzeit, welche über 'date' abrufbar ist und in einem laufenden System die einzig interessante Zeit ist.
    Die zweite Zeit ist die Hardware-Uhr, die man im allg. über das BIOS stellen kann. Deren Zeit wird mittels 'hwclock' ausgegeben (oder gesetzt).
    Die Uhrzeit der HW-Uhr wird beim Booten ausgelesen und die Systemzeit damit eingestellt, denn direkt nach dem Booten kennt das System nicht die aktuelle Uhrzeit. Traditionell läuft auf einem Linux-only-System die HW-Clock nicht mit der aktuellen, lokalen Uhrzeit (CET oder CEST), sondern mir UTC (ehemals GMT). Da das System aber weiß, in welcher Zeitzone der Rechner ist (beim Installieren festgelegt), kann der aktuelle Offset (+1 im Winter, +2 im Sommer) beim Booten auf die HW-Uhrzeit aufgeschlagen werden und damit die Systemzeit richtig gesetzt werden.
    Das deine HW-Uhr eine Stunde vorgeht, kann mehrere Gründe haben:
    - sie geht tatsächlich eine Stunde vor (mal im BIOS nachschauen)
    - sie ist auf Localtime (also CET) eingestellt, aber in /etc/adjtime steht UTC


    Wenn man eine Internetverbindung hat, die immer online ist, dann sollte man besser NTP nutzen, um eine korrekte Uhrzeit zu erhalten. Bei NTP wird beim Booten oftmals einmalig mittels 'ntpdate' die lokale Systemzeit mit der Zeit eines anderen NTP-Servers gesetzt, danach wird die Systemzeit vom ntp-Daemon ständig nachgeregelt, sodaß keine Sprünge in der Systemzeit auftreten, was einigen Programme überhaupt nicht mögen.


    Noch fragen?


    Gruß,
    Juri

  • Hi,


    erstmal vielen Dank jha für die ausführliche Erklärung.


    So sieht meine /etc/adjtime aus:


    Code
    1. root@SMT-7020S:/etc# cat adjtime
    2. -0.000319 1235974752 0.000000 1235974752 LOCAL


    Jetzt gehen wieder beide Uhrzeiten falsch


    Code
    1. root@SMT-7020S:/etc# hwclock
    2. Sun 15 Mar 2009 03:20:13 AM CET -0.587037 seconds
    3. root@SMT-7020S:/etc# date
    4. Sun Mar 15 03:20:18 CET 2009


    Ich würde ja gern mittels NTP die Zeit aktkuell halten aber ich hab jetzt nirgends wo die erforderlichen Programme dafür gefunden.
    Und ohne Anleitung bekomme ich das auch nicht hin.


    MfG



    DeuS

    Samsung SMT7020S 160 HDD @ Zenslack 1.0rc5 + 1.3 Patch & VDR 1.4.7
    ===============================================
    Wenn sie zwei Hühner haben und die vermehren sich und sie haben irgendwann 100 und dann kommt ne Flut und alle sind ersoffen und wenn sie dann sagen hätt ich mal Enten gekauft, das ist Börse !

    The post was edited 1 time, last by De_uS ().

  • Quote

    Original von De_uS
    Ich würde ja gern mittels NTP die Zeit aktkuell halten aber ich hab jetzt nirgends wo die erforderlichen Programme dafür gefunden.
    Und ohne Anleitung bekomme ich das auch nicht hin.


    Mit zenslack habe ich zwar nichts am Hut, aber HIER ist eine Anleitung, die für dich passen sollte.
    Das aktuelle NTP-Paket (enthält ntpdate) findest du auf www.ntp.org im Download-Bereich.

    VDR1: AMD Duron-1300, 512mb RAM, Nexus-S rev2.1, Airstar 2, Debian Lenny, kernel: 2.6.28-etobi.3, VDR 1.6.0-17 experimental/extensions von Tobi
    VDR2: Athlon XP-M-2600+, 512mb RAM, TT Prem 1.3 DVB-S, Skystar2, Airstar 2, Debian Lenny, kernel: 2.6.28-etobi.3, VDR 1.6.0-17 experimental/extensions von Tobi
    Extern: Activy300, Gen2VDR V2

  • Hi,
    ich bin jetzt nach der Anleitung vorgegangen allerdings


    Quote

    danach fügt man per MC oder vi in die Datei /etc/rc.d/rc.local unter mount /video noch folgende Zeilen ein: ntpdate de.pool.ntp.org hwclock --systohc


    Bei mir in der Datei /etc/rc.d/rc.local gibt es keinen Eintrag mit "mount /video"!


    Also habe ich einfach die Befehle so ausgeführt:


    Code
    1. root@SMT-7020S:/# ntpdate de.pool.ntp.org
    2. Looking for host de.pool.ntp.org and service ntp host found : hosting1.mysnip.de 15 Mar 17:53:20 ntpdate[9653]: step time server 80.239.150.94 offset -3091.356657 sec
    3. root@SMT-7020S:/# hwclock --systohc
    4. root@SMT-7020S:/#


    reicht das nicht aus ?


    Anscheinend nicht, habe jetzt mal den Befehl "nptdate" ausgeführt und bekam eine Fehlermeldung:


    Code
    1. root@SMT-7020S:/# ntpdate
    2. 15 Mar 17:56:01 ntpdate[9985]: no servers can be used, exiting


    Und wohin wurde jetzt ntpdate installiert ? /usr/sbin/ntpdate


    Wenn ich jetzt "date" ausführe zeigt er mir immerhin die richtige Uhrzeit:


    Code
    1. root@SMT-7020S:/# date
    2. Sun Mar 15 18:15:54 CET 2009


    Edit:


    Ok habe jetzt die beiden Zeilen in die rc.local eingefügt.
    Neugestartet und die Uhrzeit stimmt !


    Wie kann ich mir anzeigen lassen, welcher Zeitserver gerade genutzt wird bzw. wie kann ich einen weiteren, also 2, Zeitserver nutzen, falls mal einer ausfällt ?


    ntpdate server1 server2 ?

    Samsung SMT7020S 160 HDD @ Zenslack 1.0rc5 + 1.3 Patch & VDR 1.4.7
    ===============================================
    Wenn sie zwei Hühner haben und die vermehren sich und sie haben irgendwann 100 und dann kommt ne Flut und alle sind ersoffen und wenn sie dann sagen hätt ich mal Enten gekauft, das ist Börse !

    The post was edited 3 times, last by De_uS ().

  • Wenn es diese Zeile in deiner rc.local nicht gibt, dann hänge die beiden Befehle

    Code
    1. ntpdate de.pool.ntp.org
    2. hwclock --systohc

    einfach am Ende der rc.local an.


    Prinzipiell läuft es ja laut deinen Meldungen.


    Der Befehl ntpdate ohne Angabe des Zeitservers funktioniert nicht.

    VDR1: AMD Duron-1300, 512mb RAM, Nexus-S rev2.1, Airstar 2, Debian Lenny, kernel: 2.6.28-etobi.3, VDR 1.6.0-17 experimental/extensions von Tobi
    VDR2: Athlon XP-M-2600+, 512mb RAM, TT Prem 1.3 DVB-S, Skystar2, Airstar 2, Debian Lenny, kernel: 2.6.28-etobi.3, VDR 1.6.0-17 experimental/extensions von Tobi
    Extern: Activy300, Gen2VDR V2

  • Hi,


    immer wenn ich die SMT7020S boote, steht immer kurz was zu ntp, irgendwas mit connection failed.
    In welcher log könnte ich dazu was finden ?

    Samsung SMT7020S 160 HDD @ Zenslack 1.0rc5 + 1.3 Patch & VDR 1.4.7
    ===============================================
    Wenn sie zwei Hühner haben und die vermehren sich und sie haben irgendwann 100 und dann kommt ne Flut und alle sind ersoffen und wenn sie dann sagen hätt ich mal Enten gekauft, das ist Börse !

    The post was edited 1 time, last by De_uS ().

  • Vermutlich im Syslog oder boot.log.
    Eventuell steht deine Netzwerk-/Internetverbindung noch nicht, wenn ntpdate ausgeführt wird?


    Zu deinem anderen Posting:
    Welchen Zeitserver ntpdate genommen hat, sollte auf der Kommandozeile stehen. Wenn du das aus einem Skript heraus (rc.local z.B.) ausführst, empfielt sich die Option '-s', welche die Meldungen ins Syslog schreibt.


    Überhaupt kann ich grundsätzlich nur die Lektüre der man pages (z.B. man ntpdate) empfehlen... :rtfm


    Gruß,
    Juri

  • Ich hab die rc.lokal mal ausgeführt, dann kam folgende Meldungen:


    Code
    1. root@SMT-7020S:/etc/rc.d# ./rc.local
    2. swapon: /zenswap: Device or resource busy
    3. ./rc.local: line 59: ntpdate: command not found
    4. ./rc.local: line 60: hwclock: command not found
    5. mv: Aufruf von stat für ,,/var/log/epg.data" nicht möglich: Datei oder Verzeichnis nicht gefunden
    6. mkdir: kann Verzeichnis ,,/tmp/vdr" nicht anlegen: Die Datei existiert bereits



    In /var/log finde ich keine boot.log

    Samsung SMT7020S 160 HDD @ Zenslack 1.0rc5 + 1.3 Patch & VDR 1.4.7
    ===============================================
    Wenn sie zwei Hühner haben und die vermehren sich und sie haben irgendwann 100 und dann kommt ne Flut und alle sind ersoffen und wenn sie dann sagen hätt ich mal Enten gekauft, das ist Börse !

    The post was edited 1 time, last by De_uS ().

  • Gibt es auch nicht bei jeder Distribution - keine Ahnung, wie das jetzt genau bei Zenslack ist - sorry (mir ist gerade erst aufgefallen, daß ich hier ja im Zenslack-Forum bin, halte mich zukünftig zurück ;)