x-vdr - Fragen und Antworten

  • Hallo,


    damit die Annonce ein bisschen übersichtlicher wird und wir nicht immer die News voll spamen, habe ich hier einen zweiten Thread eröffnet.


    Also Fragen, Probleme oder Anregungen bitte hier posten.


    Gruß
    Marc

  • Hi Marc,


    habe eben mal sidux neuinstalliert und dann den 0.8.3 laufen lassen.


    Die Iinstallation bricht ab mit "Fehler in apt.sh xdialog"


    im x-vdr log:
    Do 5. Mär 10:18:51 CET 2009 SUCCESS - M2VRequantizer erstellt
    Do 5. Mär 10:18:56 CET 2009 ERROR - apt.sh



    Ich hab die Installation dann nicht abgebrochen und versuche ihn weiter laufeb zu lassen.


    Danke für die neue Version.


    Gruß,
    Chris

    <font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

  • Moin Chris,


    Zitat

    "Fehler in apt.sh xdialog"


    Da konnte xdialog nicht installiert werden.
    Das kann ich mir nur mit einem temporären Problem auf dem Debian Server oder mit deiner Internet Verbindung erklären.


    Probier bitte mal ein "apt-get install xdialog".


    Gruß
    Marc

  • Moin,


    mag scheinbar heute nicht:


    root@siduxbox:~# apt-get install xdialog
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Lese Status-Informationen ein... Fertig
    Paket xdialog ist nicht verfügbar, wird aber von einem anderen
    Paket referenziert. Das kann heiÃen, dass das Paket fehlt, dass es veraltet
    ist oder nur aus einer anderen Quelle verfügbar ist.
    E: Paket xdialog hat keinen Installationskandidaten


    root@siduxbox:~# apt-cache search xdialog
    python-dialog - Python module for making simple Text/Console-mode user interfaces
    libui-dialog-perl - OOPerl wrapper for the various dialog applications
    root@siduxbox:~#

    <font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

  • Hab eben ein 'apt-get update' probiert:


    mal abwarten...

  • nimm doch einfach nen anderen mirror.

    mfg traxanos
    ____________________
    Ist das neu?, Nein Linux!


    VDR1: Zotac NM10-ITX Wifi - 2GB Ram - S2-6400 HD mit IR - yavdr 0.4 (development) - LianLi PC-Q11


    Tags: VDR-HD - AT5IONT-I - 4GB Ram - 512MB ION - TT 3600 DVB-S2 - TT6400-FF - Sundtek DVB-S2 Sundtek DVB-C - Tevii S480 (dank an L4M für kostenlose Bereitstellung) - yaVDR 0.5 (development) - SKY - HD+ - Atric - X10 FB - Zotac ID41 PLUS - SilverStone LC19B-R - Yamaha RX-V671 - Samsung 8Series 55"

  • Hi,


    irgendwie unterstützt die aktuelle svn Version vom ffmpeg den Schalter --enable-swscale beim ./configure nicht mehr, nur so als Hinweis.
    Grade mal im svn nachgesehen die Option wurde vor 18 Stunden entfernt :lachen3


    MfG
    Atti

  • Zitat

    Original von Atti
    Hi,


    irgendwie unterstützt die aktuelle svn Version vom ffmpeg den Schalter --enable-swscale beim ./configure nicht mehr, nur so als Hinweis.
    Grade mal im svn nachgesehen die Option wurde vor 18 Stunden entfernt :lachen3


    MfG
    Atti


    Warum wundert mich das jetzt nicht wirklich ;)

  • Hi, zulu


    Hast du schon mal versucht den patch;
    burn-0.1.0-pre22_i18n-gettext.diff
    ins burn einzubauen ?


    Wäre für deutsche Sprache des Burn Plugins
    Ich habs grade versucht, wobei das patchen selbst einwandfrei klappt, aber
    burn bleibt dennoch nur in Englischer Sprache.


    Die vdr-burn.mo in "/usr/local/src/VDR/locale/de_DE/LC_MESSAGES"
    wurde zwar angelegt, aber nix zu machen, burn bleibt in Englischer Sprache.


    Gruss, Bert

    Dateien

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Hi, zulu


    Zitat

    damit der VDR die Übersetzung findet, muss die nach /usr/share/locale/de_DE/LC_MESSAGES.


    Das wars, Danke !
    Nun is Burn in Deutsch.


    Übernimmst du das in x-vdr, oder gibts nen Grund warum man den Patch nicht verwenden sollte ?


    Gruss, Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Für das music-plugin liegt dem Plugin ein eigener Font bei. Liegt in /music/music/fonts. vdrmusic_symb.ttf kommt nach /usr/share/truetype/vdrsymbols


    Gruß,
    Chris

    <font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

  • Hallo,


    wie bekommt man eigentlich den mplayer im xine gestartet. Ich habe eine xineplayer.sh gefunden. Wo wird die eingetragen? In der mplayer.sh oder in der mplayer.sh.conf?


    Übrigens kann man den mplayer seit neustem auch mit "--enable-vdpau " bauen.


    Gruß,
    Chris

    <font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

  • Zitat

    Übernimmst du das in x-vdr, oder gibts nen Grund warum man den Patch nicht verwenden sollte ?


    Den kannte ich schlicht noch nicht. So wie er jetzt ist kann ich ihn aber nicht übernehmen.
    Da ich aber nun den Kanal voll habe, von den ganzen Patches für das Plugin, packe ich eine Version zusammen und lade die auf meinen Server.


    Für das leidige Problem mit ffmpeg und den im Wochentakt geänderten Optionen habe ich auch was gebastelt. Damit sollte das nun endgültig vom Tisch sein.


    apt-get update geht wieder und nachher gibt's die 0.8.4

    >>>> x-vdr <<<< Installations-Skript für einen VDR mit Debian als Basis

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von zulu ()


  • xine und mplayer zusammen ist nicht ganz einfach. In x-vdr/extra/xine-mplayer-sh findest du eine uralte mplayer.sh mit der ich damals experimentiert habe. xineliboutput bietet aber die bessere Lösung.


    Zitat

    --enable-vdpau enable VDPAU acceleration [autodetect]


    Kann mal jemand, der die passende Hardware hat, schauen ob es automatisch aktiviert wurde?

  • Zitat

    Original von zulu


    Kann mal jemand, der die passende Hardware hat, schauen ob es automatisch aktiviert wurde?


    Ich hatte die utilities.sh angepasst und das dort eingetragen. Weiss auch nicht wie ich das überhaupt testen soll.
    Im announce-thread von xine schrein rnissl, dass in der mplayer.sh der xineplayer eingetragen werden muss. Ich werde nochmal suchen wo das sein soll.
    Mit xineliboutput muss ich nochmal gucken. xine wär mir schon lieber. Auch wegen dem dort laufendem music-plugins....


    Gruß,
    Chris

    <font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

  • Einfach mplayer ohne "--enable-vdpau" bauen und eine HD-Aufnahme abspielen.
    Wenn es dann warm um die Füße wird, wurde es nicht automatisch aktiviert.


    Läuft music denn nicht mit xineliboutput?


    Gruß
    Marc

  • Mit xineliboutput-1.0.4 habe ich wohl ein Eigentor geschossen.
    Wer ein Bild mir vdr-1.7.4 haben möchte muss auf die CVS Version aus x-vdr-0.8.2 zurückgreifen.

  • Hi,


    ich hab nachdem die Kiste heute nacht ausgeschaltet war keinen Ton mehr. Ausser bei sendern, die dolby senden. Stereo ist stumm. Das komische, gestern gings noch und ich hatte nichts verändert?


    Ich hab audio.device.alsa_front_device:iec958 in meiner config von xine eingetragen. Echt seltsam. Ich hatte gestern definitiv noch stereo-ton am optischen ausgang.
    Kann mir jemand einen Tipp geben, wie ich das xine-plugin optimal einstelle? Was ist den richtig bei Sound: Kein, ja (software), ja (hardware)?


    Gruß,
    Chris

    <font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>


  • Hi Chris,


    Da musst du eventuell in der ~/.xine/config_xineliboutput den Eintrag audio.device.alsa_front_device:default auch auf iec958 ändern. Das hatte mich auch mal einen ganzen Abend beschäftigt, genau so wie bei dir am Abend vorher ging es noch.


    MfG
    Atti