[Announce] tvm2vdr-0.0.2 (Plugin Version!)

  • Quote

    Das sind nur Warnings, sollten keine Auswirkung haben.


    Hats aber leider, wenn ich die Kompilierte Lib dann ins Plugins Verzeichnis kopiere und aktiviere, startet zwar der VDR noch durch ich kann dann aber keine Daten mehr von tvm2vdr holen!


    Ich häng die Fehlermeldung später an, wenn mein VDR wieder läuft!




    lg prudentis

  • Quote

    Original von prudentis


    Hats aber leider, wenn ich die Kompilierte Lib dann ins Plugins Verzeichnis kopiere und aktiviere, startet zwar der VDR noch durch ich kann dann aber keine Daten mehr von tvm2vdr holen!


    Du solltest dich mal entscheiden. Ein Post vorher kompiliert das Plugin nicht. Jetzt kompiliert es plötzlich doch, aber es funktioniert nicht. Was denn nun?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Sorry mein Fehler!


    durchlaufen tuts immer, es funkt aber nur wenn ich HAVE_IMAGEMAGIC =1 draußen lasse! Dann auch nur ohne EPG Images



    lg prudentis

  • Ich hab das Plugin jetzt auch mal installiert.


    Noch ein paar Fragen:


    Brauch ich für das Plugin noch das NoEPG Plugin? Wo finde ich das get_channel_mappings.pl Skript?


    EDIT: Das Skript hab ich nun gefunden. Welche Bedeutung hat die erste Zahl in der channelmap? Ist das die Kanalnummer und ist diese wichtig?


    Grüsse
    TheChief

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 2 times, last by TheChief ().


  • Hast du es mal wie oben verlinkt, versucht abzuändern ?

  • ich poste mal mein anliegen hier, warscheinlich hat man mein thread übersehen ;)



    ich habe manchmal das Phänomen, so auch gestern, das bei einigen Sendern das komplette EPG fehlte. Zb. gestern bei allen Sky Sendern, auf den ÖRs wars vorhanden.
    Oftmals fehlt urplötzlich auch nur das EPG des aktuellen Tages, ab 0Uhr des nächsten Tages ist das aber EPG vorhanden.


    Alle Sender werden von dem tvmovie2vdr Plugin verwaltet und sind natürlich per noepg Plugin vom VDR-EPG befreit ;)


    Kennt jemand das Problem??


    Um das EPG wieder herzustellen muss ich immer das komplette EPG (svdrpsend DELE) sowie im tvmovie2vdr Plugin Ordner alle XML-Files löschen. Nach einem NEustart lädt das Plugin wieder alle XML Files herunter und das EPG stimmt wieder.


    Gibts da ein (verstecktes) Feature im Plugin das das EPG einließt und die bereits heruntergeladenen Files nutzt?


    Oder wenn ich einen neuen Sender im Plugin einstelle muss ich genauso mit der löschaktion verfahren weil das Plugin warscheinlich nicht erkennt das die ersten Tage von diesem einen Sender neu heruntergeladen werden müssen...

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Ich hab mir für den Fall ein Script gebastelt, welches ich über das OSD aufrufe. Macht allerdings auch nix anderes als alles wegzuschmeißen, den VDR neu starten und die EPG-Daten neu aufzubauen. Geht so halt mit einem Tastendruck ohne groß Aufwand zu verursachen...


    Gruß
    iNOB

    The post was edited 1 time, last by iNOB ().

  • Quote

    Original von prudentis


    Ich steh auf dem Schlauch was muss ich wie verlinken ???


    Du sollst nichts verlinken. Du sollst auf die Links in Steffens Post klicken und machen was da steht.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Alles klar.... Kann ich nicht! hab keinen Plan was gemacht werden muss?!


    bei mir steht in der update.c von tvm2vdr in der Zeile 98

    Code
    1. #ifdef USE_IMAGEMAGICK
    2. InitializeMagick("vdr-plugin-tvm2vdr");
    3. #endif


    und in der Zeile 145

    Code
    1. #ifdef USE_IMAGEMAGICK
    2. DestroyMagick();
    3. #endif


    was muss ich ändern ?



    lg prudentis

  • Hallo,


    kurze Verständnisfrage:
    Ich verwende tvm2vdr für zwei Sender (MTV und Nick/CC). Bei diesen Sendern wird bei mir kein EPG mitgesendet, daher hole ich mir die Daten über tvm2vdr.
    Das funktioniert soweit auch, d.h. es werden die Daten im Menü angezeigt.


    Allerdings findet epgsearch keine Sendungen, die über tvm2vdr rein kommen. Suchtimer anlegen funktioniert also leider nicht.
    Ist das ein grundsätzliches Problem von tvm2vdr oder habe ich bei der Konfiguration einen Fehler gemacht?


    mfG,
    f.
    PS: Im vdradmin scheinen die EPG-Daten der betreffenden Sender auch nicht auf.

    VDR-neu: HW: HP M01-F0000ng, Ryzen 3 3200G, Vega8, DigitalDevices Cine C2/T2, IR-Empfänger: Atric USB Eco,

    FB: HarmonyHub . SW: yavdr ansible focal

    VDR-alt: HW: Asrock Q1900M, Celeron J1900, Nvidia Geforce 210, DigitalDevices Cine C2/T2, IR-Empfänger: Atric USB Eco, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr ansible focal
    VDR3: Raspberry Pi3 als Streaming Client, MLD 5.1

    The post was edited 1 time, last by fatzgenfatz ().

  • Quote

    Original von fatzgenfatz
    PS: Im vdradmin scheinen die EPG-Daten der betreffenden Sender auch nicht auf.


    Dann ist schonmal etwas grundsätzlich falsch.


    Folgendes Vorgehen:


    1. betreffende Sender per noEPG-Plugin von der EPG-VErsorgung per DVB ausschließen
    2. in der tvm2vdr_channelmap.conf die betreffenden Sender aktivieren (Zeichen "#" entfernen)
    3. in der tvm2vdr_channelmap.conf die betreffenden Sender mit der richtigen Kanalkennung aus der channels.conf versehen (siehe Wiki zum Plugin, da ist ein Konvertierungsscript gepostet)
    4. Pluginparameter überpüfen
    5. Pluginupdate starten
    6. freuen über das qualitativ bessere EPG

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Hallo,


    vielen Dank für deine Antwort.
    Scheinbar war ich nur zu ungeduldig. Ich hatte alles so gemacht wie von dir beschrieben. Allerdings waren weder im vdradmin noch im epgsearch die EPG-Daten drin.
    Jetzt, ohne dass ich was geändert habe funktioniert plötzlich alles :)


    Vielen Dank noch mal!


    mfG,
    f.

    VDR-neu: HW: HP M01-F0000ng, Ryzen 3 3200G, Vega8, DigitalDevices Cine C2/T2, IR-Empfänger: Atric USB Eco,

    FB: HarmonyHub . SW: yavdr ansible focal

    VDR-alt: HW: Asrock Q1900M, Celeron J1900, Nvidia Geforce 210, DigitalDevices Cine C2/T2, IR-Empfänger: Atric USB Eco, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr ansible focal
    VDR3: Raspberry Pi3 als Streaming Client, MLD 5.1

  • Quote

    Original von Mase
    Die alten EPG-Bilder werden ja nicht automatisch entfernt.
    Wie sieht es mit alten xml-Dateien aus?


    Eigentlich sollten die alten Bilder schon entfernt werden, da mag natürlich ein Fehler drin sein. Das Selbe gilt für die XML-Dateien.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Quote

    Original von Mase
    Und in welchem Zyklus sollen die alten Daten entfernt werden?


    Bei jedem VDR-Start. Vorausgesetzt du benutzt nicht eine ältere Version, aber für Details bitte in die Quellen sehen. Wie in einem anderen Thread schon gesagt, mache ich daran nichts mehr.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Ich mach das so:
    killoldepg.sh

    Shell-Script
    1. #!/bin/sh
    2. # Epgimages bereinigen
    3. CLEANUP="14"
    4. IMAGEPATH="/media/epg"
    5. find "$IMAGEPATH" -follow -type f -mtime +${CLEANUP} -exec rm -f {} \;

    Wann das Script gestartet wird, ob beim Start oder Beenden, ist völlig egal. Hauptsache es wird gestartet ;)


    Gruß
    iNOB

  • hoffe, das das EPG-Daten abholen von TVMovie noch länger so wie jetzt funktioniert. Siehe hier:


    http://satundkabel.de/index.ph…ronischer-programmfuehrer

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550