Popcornhour + VDR 1.7.2 - kein Ton???

  • Hallo zusammen,


    habe folgendes Problem mit der Popcornhour:


    Habe VDR-1.7.2 mit VDR-Extension Patch V65 (LiveBuffer aktiviert)
    Streamdev CVS Version von letzter Woche


    DVB-C im Kabelnetz München.


    Ich versuche mit dem Popcornhour über streaming Live-TV zu sehen, Bild funktioniert auch soweit, aber kein Ton!


    Mit Xinelibout wird der Ton normal ausgegeben (dafür ist Livebuffer aktiviert, das funktioniert soweit)


    Konfiguration Streamdev:
    HTTP Streamtype TS
    HTTP Serverport 3000


    Irgendeine Idee, was ich falsch mache??

    Produktiv-VDR1 ASUS Pundit-AB 2.4 GHz Celeron - Suse 10.3 - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan
    Bastel-VDR2 Athlon64 selbstgebaut - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan

  • Hi.


    Wie "verlinkst" Du die Channels ?


    Code
    1. <a href="http://vdr:3000/PES/1+1.vdr" VOD>SENDER X</a>


    für SD und

    Code
    1. <a href="http://vdr:3000/TS/1+1.ts" VOD>SENDER X HD</a>


    für HD.


    Ton geht bei mir SD/HD eigentlich ohne Probleme.


    lg,
    Knurz

  • Hallo Knurz,


    ich hab vorher auf die automatisch generierte Seite http://vdr:3000 zugegriffen. (wie in dem anderen PCH-Thread beschrieben)


    Von den von dir vorgeschlagenen Links funktioniert komischerweise nur der mit PES (aber richtig mit Audio), bei dem mit TS bleibt der PCH mit "Buffering..." komplett hängen. (beides nur mal bei SDTV Sendern getestet)


    Das Puffern am Anfang dauert bei PES ganz schön lang ( 5-10 Sekunden) aber hauptsache es geht überhaupt mal!!


    Noch irgendeine Idee wg. dem TS + Audio??


    Razorblade hattest du es auch mit vdr-1.7.2 oder mit 1.7.1 ??

    Produktiv-VDR1 ASUS Pundit-AB 2.4 GHz Celeron - Suse 10.3 - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan
    Bastel-VDR2 Athlon64 selbstgebaut - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von orca2 ()

  • also ich verwende die aktuelle Version von streamdev aus dem CVS (von heute früh) ohne weitere Patches. Ist das soweit richtig?? Ich dachte, die wären alle schon in die CVS-Version eingeflossen?


    also dieser Link funktioniert

    Code
    1. <a href="http://192.168.2.21:3000/PES/1+1.vdr" VOD>ARD deu PES</a>


    und dieser nicht

    Code
    1. <a href="http://192.168.2.21:3000/TS/1+1.vdr" VOD>ARD deu PES</a>


    (Bild bleibt komplett schwarz, Netzwerkleuchte am PCH flackert)


    viele Grüsse...!

    Produktiv-VDR1 ASUS Pundit-AB 2.4 GHz Celeron - Suse 10.3 - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan
    Bastel-VDR2 Athlon64 selbstgebaut - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan

  • Zitat

    Originally posted by orca2
    und dieser nicht

    Code
    1. <a href="http://192.168.2.21:3000/TS/1+1.vdr" VOD>ARD deu PES</a>


    (Bild bleibt komplett schwarz, Netzwerkleuchte am PCH flackert)


    viele Grüsse...!


    Code
    1. <a href="http://vdr:3000/TS/1.ts" VOD>blabla</a>


    lg,
    Knurz

  • Oh je, typischer Fall von "vor lauter Wald die Bäume nicht gesehen!!!"
    Die Endung hier ist ja .ts und nicht .vdr!!!


    Wunderbar, ihr habt mir sehr geholfen! Vielen Dankl!

    Produktiv-VDR1 ASUS Pundit-AB 2.4 GHz Celeron - Suse 10.3 - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan
    Bastel-VDR2 Athlon64 selbstgebaut - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan

  • Hallo, ich bin's (leider) nochmal...


    Wie siehts denn bei euch so mit der Stabilität aus? Wenn ich Streams ansehe, bleibt der PCH bei mir reproduzierbar so alle 15 Minuten hängen (schwarzer Bildschirm, nur durch Reset wiederzubeleben).


    Der VDR läuft weiter, wenn man den PCH wieder bootet gehts wieder.


    Ähnliche erfahrungen???

    Produktiv-VDR1 ASUS Pundit-AB 2.4 GHz Celeron - Suse 10.3 - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan
    Bastel-VDR2 Athlon64 selbstgebaut - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan

  • Hi,
    ich habe leider das gleiche Problem... Nach einiger Zeit bleibt die PCH hängen bzw. beendet die Wiedergabe einfach und springt zurück auf die HTML-Seite vom Streamdev. Danach gehts erst nach einem reboot wieder. Ist besonders nervig bei HD, da ja hier die Aufnahme (bisher...) nur in PES erfolgt. Über Weihnachten waren so schöne Bilder bei EinsFestival HD zu sehen...



    Gruß Dakrstar.

    Hardware: Seagate Dockstar@1500MHz, GSS Box DSI 400 SAT>IP Server, VDR 2.1.6 mit Streamdev-Server
    Videoausgabe: RaspberryPi mit MLD-4.0.1-RPi an LG 42LM660

  • :weinen


    ähnliche Stablilitätsprobleme waren im englischen PCH-Forum auch zu finden.


    http://www.networkedmediatank.com/showthread.php?tid=1696&page=2&highlight=vdr
    Sehr schade eigentlich, sonst sind nämlich VDR und PCH ein prima Team...!

    Produktiv-VDR1 ASUS Pundit-AB 2.4 GHz Celeron - Suse 10.3 - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan
    Bastel-VDR2 Athlon64 selbstgebaut - vdr-1.7.7 - VDPAU - cvs-xinelibout - skinenigmang - femon - wirbelscan

  • Habe gestern mal etwas intensiver getestet und konnte die Stream-Abbrüche bestätigen, mit dem Ton habe ich aber nach wie vor keine Probleme (getestet mit vdr 1.7.4 und stremdev pre-0.5.0).


    Was allerdings wunderbar funktioniert ist das was man live streamen möchte aufnehmen und dann die Aufnahme währenddessen im Poppi abspielen...

  • Mit der neuen A-110 Firmware (stand heute) gibt es bei mir keine Abbrüche beim Streamen mehr.
    Habe direkt nach dem Update mal nebenbei einen Live-HD-Stream gestartet der läuft jetzt (nach mehr als 1,5h) immernoch.


    Ab und zu gibt es immernoch Probleme mit der ersten Audio-Spur, neustarten des Streams oder wechseln der Audiospur (wenn vorhanden) hilft aber immer.


    Ich vermute mal folgender Fix (aus dem Changelog) hat das Problem gelöst:
    - Fixed TS with stream6 as teletext playback cause out of memory


    Edit: Achja, getestet mit vdr 1.7.4 und streamdev aus dem cvs (stand von vor ca. 2 wochen)