Zengames2 Iso Soundproblem

  • Hallo , habe mir heute mal die Zengames2 aus dem Boxcracker Forum aufgespielt. Soweit habe ich mir alles wieder eingerichtet wie in der in der Zengames1 . Nur habe ich ein gravierendes Problem mit der Lautstärke. Alle Einstellungen die ich gemacht habe ( Alsamixer,Freevo_config.py ) habe ich genauso wieder eingestellt. Dennoch zeigt mir der Alsamixer verrückte Sachen an. Wenn ich die Lautstärke auf der Fernbedienung aktiviere , bewegen sich Masterkanal und PCM Kanal in völlig unregelmäßigen Abständen.Das OSD zb. im Freevo zeigt korrekt an , nur springen die Kanäle im Mixer absolut unregelmäßig. Soll heißen ich erhöhe die Lautstärke und mittendrin wirds auf einmal leiser und dann sprunghaftig lauter.
    Der Fehler tritt im Freevo genauso auf wie im Vdr und daher muss es wohl irgendwo ein grundliegender Fehler sein.


    Hat jemand schon die Zengames2 aufgespielt und vielleicht ähnliche Probleme? Bin für jeden Tipp dankbar
    Wäre lieb wenn mir auch noch jemand mal die originale freevo_config.py zukommen läßt , da ich nicht weiß ob der Fehler schon von Anfang an in der Iso so ist.


    Gruss leonjoeann

    2 x NokiaDbox +1GB MicroSd
    1 x Samsung SMT +720er +MMS 109
    1 x Freecam
    2 x Xcam

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von leonjoeann ()

  • Frohes Neues Jahr ! :welle


    Habe das ganze jetzt nochmal unter Putty im Alsamixer angeschaut. Der Masterkanal ist aktiviert und liegt bei mir auf 45%. Der angesprochene PCM Kanal für die Lautstärke im Vdr geht bei Lautstärke leiser problemlos. Wenn ich aber die Lautstärke erhöhe , so springt der PCM Kanal unregelmäßig höher , meißtens der Wert 61 dann wieder runter und nach öfteren betätigen der Lautstärkentaste dann auch wieder höher,teilweise bis in den roten Bereich. Woher kommt das nur ?

    2 x NokiaDbox +1GB MicroSd
    1 x Samsung SMT +720er +MMS 109
    1 x Freecam
    2 x Xcam

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von leonjoeann ()

  • Danke erstmal das du geantwortet hast. In der Zengames1 habe ich lediglich im Alsamixer den Masterkanal sowie den PCM Kanal mit 40% abgespeichert.


    In der freevo_Config.py habe ich vor dem Eintrag : MIXER_MAJOR_MUTE_CTRL = 'PCM' lediglich eine Raute gesetzt damit es nicht gelesen wird.


    Die restlichen MIXER_VOLUME Werte habe ich dann per Hand angepasst bis es einigermaßen passte.


    Soweit funktioniert es auch alles wieder , nur wie gesagt der PCM-Kanal hüpft halt mit der Lautstärke nach oben. Als wenn im VDR diesesmal ein konflikt herrscht ( falscher Kanal angesprochen ) ?.


    Irgendetwas ist in der Grundeinstellung gegenüber der Zengames1 anders,denn dort funktionierte es auf Anhieb. Vergleich doch bitte mal die Installationen , wenn einer in der Lage ist den Bug zu finden dann bestimmt du. Der Fehler ist jedenfalls nicht im Freevo denn es betrifft den VDR genauso , soviel weiß ich schon.


    Wäre Klasse wenn du das hinbekommst , ich finde dieses Image mit Abstand eines der Besten :]


    Gruss leonjoeann

  • 1. Tip




    begin
    button = TONLINE
    prog = irexec
    repeat = 0
    config = /etc/zenslack/xinevdr.sh
    end
    begin
    button = POWER
    prog = irexec
    repeat = 0
    config = /etc/zenslack/SMT-powerstate.sh poweroff
    end
    begin
    button = POWERFP
    prog = irexec
    repeat = 0
    config = /etc/zenslack/SMT-powerstate.sh poweroff
    end
    begin
    button = EXIT
    prog = irexec
    repeat = 0
    config = /etc/zenslack/exit-games.sh
    end
    #begin
    # button = VOLUP
    # prog = irexec
    # repeat = 0
    # config = /etc/zenslack/alsa.sh
    #end
    begin
    button = ASPECT
    prog = irexec
    repeat = 0
    config = /usr/bin/tvout_setup
    end


    begin
    button = TEXT
    prog = irexec
    repeat = 2
    config = /etc/zenslack/reboot.sh
    end




    Ändere bitte mal deine /etc/lirc.conf genau so um!


    Dann springt dein PCM kanal nicht mehr hoch und runter beim Lauter stellen!






    2. Tip


    Ersetze diese Zeilen mit dem Original! Ab Zeile 412


    /usr/share/freevo/freevo_config.py



    # ======================================================================
    # General freevo settings:
    # ======================================================================


    POLL_TIME = 0.01 # time in seconds that the poll handlers are called
    # a lower rate of 0.05 is less demanding for less
    # powerful processors


    AUDIO_DEVICE = '/dev/dsp' # e.g.: /dev/dsp0, /dev/audio, /dev/alsa/?
    AUDIO_INPUT_DEVICE = '/dev/dsp1' # e.g.: /dev/dsp0, /dev/audio, /dev/alsa/?


    MIXER_MAJOR_CTRL = 'VOL' # Freevo takes control over one audio ctrl
    # 'VOL', 'PCM' 'OGAIN' etc.
    MIXER_MAJOR_MUTE_CTRL = 'PCM' # used in alsamixer.py, There are systems where
    # volume and mute use different controls


    MIXER_DEVICE = '/dev/mixer' # mixer device
    MIXER_CONTROL_ALL = 0 # Should Freevo take complete control of audio
    MIXER_VOLUME_STEP = 30 # Amount to increment the mixer volume
    MIXER_VOLUME_MAX = 100 # Set what you want maximum volume level to be.
    MIXER_VOLUME_DEFAULT = 94 # Set default volume level.
    MIXER_VOLUME_TV_IN = 60 # Set this to your preferred level 0-100.
    MIXER_VOLUME_VCR_IN = 90 # If you use different input from TV
    MIXER_VOLUME_RADIO_IN = 80 # Set this to your preferred level 0-100.



    Dann bleiben deine gespeicherten Alsamixer einstellungen erhalten wenn du zu Freevo umschaltest!

  • Ja , das wars die Rauten davor bewirken ein wahres Wunder.


    Jetzt habe ich ein Backup Iso erstellt , nur leider funktioniert dieses nicht ganz richtig. Beim beschreiben der neuen Festplatte sagt mir Zenslack immer das der Bootbereich nicht ok wäre ??? Das habe ich wirklich noch nie gehabt , was könnte das denn sein ??


    mfg leonjoeann