VDR 1.6.0: Nixxraff mit Lirc , UTF8, Gentoo und dem Ollie

  • Tach,


    jo, ich bin tatsächlich wieder am Arbeiten :) In den 2 Jahren meiner Abwesenheit habe ich doch tatsächlich mal wieder etwas gemacht.
    Also es hat sich sehr, sehr viel getan und ich kapiere nichts mehr. Es hat sich, auch bei den Gentoo-typsichen Eigenheiten, sehr viel verändert.


    Der von mir derzeitig eingesetzte Kernel 2.6.26-r4 von den gentoo-sourcen hat´s auch in sich: Da gibt es mittlerweile einstellbare Optionen, von denen ich noch nie etwas gehört habe.


    Ich habe mir mal das Lirc-Howto im Wiki für Gentoo reingezogen. Klappt aber nicht so wirklich: Ich bekomme einen Fatal Error bei dem Versuch das Lirc-Model zu modproben. emerge lirc läuft soweit durch, ich bin auch der Meinung, in der kernelconfig alles so weit richtig drin zu haben.


    Aber ich bekomme diesen Error inserting lirc_serial Unknown symbol in module etc. Brrrr.


    Ich habe logischerweise auch kein /dev/lirc oder /dev/lirc0-Device., /dev/lircd gibts, ttyS0 auch. Ich hab immer noch den irdeo-REMOTE Empfänger. Beim emergen von lirc gabs selber keine Probleme. Das ebuild lief durch. Lircd geht also.


    Wie bekomme ich jedoch das Modul ans Laufen ? Wo liegen mögliche Fehlerursachen ?? Anderer Kernel ? Andere Lirc-Version ? Wieder was vergessen ? Ausser dem Howto im Wiki habe ich noch so enige Spielchen. Es geht leider net.


    Genau wie dieses UTF8-Problem. Ich habe hier einiges gefunden, jedoch auch nichts, was mir da weitergeholfen hätte. Keymaps sind auf de gesetzt, beim Booten wird UTF-8 gemeldet, ich habe die entsprechende 02locale angelegt, habe das Makefile gändert und den Pfad für localedir angepasst. Es ging dann zwischenzeitlich auch mal und dann wieder nicht. Ich kann echt nicht nachvollziehen, woran´s gelegen hat. Das Teil komplett neu gebaut und dann gings mal wieder und dann auf einmal wieder nicht mehr. Auch hier keinen Plan, woran´s gelegen hat.


    Der DVB-Treiber hat irgendwie auch ne Macke. Ich habe zwar ein Bild und solange ich nur in die Röhre glotze, geht auch alles. Den Treiber an sich habe ich mir mit wget von linuxtv gezogen, nach /lib/firmware kopiert und den Kernel entsprechend angepasst. Aber diese Version liefert mir bei meiner Nexus filter errors irgendwas und sobald ich über zwei Aufnahmen gleichzeitig geht, steigt die Kiste aus. War die 2622 Version, an dem VDR 1.7.2 bin ich wegen der API-Version 5 gescheitert. Ich habe auch keinen Treiber bei linuxtv gefunden, den man da nehmen könnte. Da gabs nur ein Verzeichnis für 4er. Die Files waren auch alle schon etwas älter.


    Wie bekomme ich die Mühle jetzt ans Laufen ??? Ich komme mir irgendwie vor, als wenn ich damals noch mit Suse rumkaspern würde und drei Wochen rumgeeiert bin, bis ich mal auch nur ein Bild gesehen habe.


    Gut, die ganze Aktion hat jetzt "nur" 3 Tage gedauert, aber das scheint mir dann doch etwas lang zu sein, für so eine popelige Gentoo-Installation und das Grundgerüst.


    Bitte Freiwillige vor, die mir helfen, wieder in die Materie einzusteigen. Soviel Zeit zum Lesen hat leider wohl niemand, 2 Jahre des Rückstands aufzuholen.


    Wäre echt nett :-)


    Greets Olaf


    P.S.: An den Hausmeister Herrn F. aka Morone: Keine dummen Kommentare bitte, ich weiss ja, dass du mehr Ahnung hast als ich.

    Ollie jetzt auch im Internet !!! ->> http://www.ohms.ws << VDR mit ASUS A7V8X-X, Athlon XP 2 Ghz, 512 MB DDR-RAM und gentoo 2008.0 Linux, ner Menge Platten (1 TB), 2 Brennern und Karten-Vollausstattung (1 X Nexus 4 MB Mod, 3 x Nova, 1 PVR 350) , TFT/Sony PSOne, Nvidia Graka und und und * Linux - wir geben ihrem Computer das Leben zurück *

  • Quote

    P.S.: An den Hausmeister Herrn F. aka Morone: Keine dummen Kommentare bitte, ich weiss ja, dass du mehr Ahnung hast als ich.


    lol
    ..bin ich so durchschaubar ??? ;)


    Gut dasse es geschrieben hast.


    Aber paar Tips duerfen es doch sein oder ??
    Na was frag ich ...


    Bei Gentoo 2008.x hast schon UTF-8 (glaube ich zumindest).
    Einfach mal checken mit "locale".
    Sollte dann sowas kommen :



    Ansonsten http://www.gentoo.org/doc/de/utf-8.xml
    Kann ja net so schwer sein ;)


    Treiber gibts im Kernel also warum laedst du sie dir von linuxtv runter ??
    Wenn du sie separat laden moechtest , dann kopierst du sie eben
    aus /lib/modules/kernel/driver/media/blubb an entsprechenden Ort und
    entweder du deaktivierst autoloading modules oder setzt sie
    auffe blacklist (-udev)



    Zu Lirc kann ich nix sagen . Hoert sich aber so an als wenn da
    ne Abhaengigkeit fehlt. Vielleicht mal mit "modinfo lirc_serial" unter
    depends checken.



    Quote

    Also es hat sich sehr, sehr viel getan und ich kapiere nichts mehr


    So und nun der Spruch.
    Zum 2. Teil..wars schon mal anders ??? :mua


    bye :-|

  • was is denn jetzt dein utf-8 problem ?? kann ich dem vielen Text nicht entnehmen.
    Makefile angepasst ?? baust du den VDR selber ?

  • @Morone: Ich hoffe ja stark, dass wir beide Zeit finden und uns mal persönlich auf irgendeinem Camp begegnen...hehe. Du bist einfach unverbesserlich.


    Ich verstehe nicht, wenn UTF-8 auf der Kiste installiert ist und davon gehe ich aus, da ich die Schritte des Howtos nach Nachlesen zu 99.9 % eingehalten und diese Ausgaben ebenfalls habe (wobei da der Parameter -a fehlt), das Makefile des VDR auf das locale-Verzeichnis angepasst ist, wieso ich dann trotzdem kein Deutsch sehe. LOCALEDIR=/usr/local/src/VDR/locale müsste doch richtig sein, wenn das Hauptverzeichnis /usr/local/src/vdr-1.6.0 ist und ein Symbollinks mit ln -s auf VDR gelegt wurde ? Er meckert ja auch nicht, dass er sein locale-DIR nicht findet. Hängt das vielleicht mit gettext zusammen ? Ich erinnere mich, irgendwo gelesen zu haben, dass VDR dessen Routinen benutzt.


    Zu den Treibern: Wenn ich eine Meldung bekomme: no primary device found-using first device, dann zeigt es doch, gerade bei schwarzem Bildschirm nach Start des VDR, dass der Treiber für die FF nicht aktiv ist, oder ? Die Novas fand er alle, aber da Budget-Cards halt no picture on screen. modprobe dvbttpci bzw. das Einbinden des Moduls in den runlevel brachten dann die Meldung, dass er die Firmware nicht finden würde. Erst das Kopieren der dvb-ttpci.fw.226 oder so und die Umbenennung des Files (also ohne .226) brachten denn den gewünschten Effekt.


    tr500 Das UTF-Problem ist das, dass man doch angeblich die Schrift für die Konsole, Dateisysteme, X individuell einstellen kann, unabhängig vom VDR. Offenbar geht´s dann aber doch nicht, da ich zwar 2-mal bereits ein deutschsprachiges OSD hatte, dann aber irgendwie auf einmal wieder nicht mehr. Und nein, ich habe nicht mitbekommen, wann´s geht und wann nicht :-( Gehen gingen tat´s auf jeden Fall schon mal.


    Und jaaaa, ich baue die Kiste komplett selber. Am Angang stand eine leere Festplatte. Eine normale stage3-Installation gemäss dem Gentoo-Handbuch und dem wenigen, was ich noch im Kopf hatte bzw. habe.


    Klar, wie man mir schon vorgeschlagen hat, ich könnte auch gen2vdr oder was anderes nehmen, aber dann wäre ich ja nicht mehr der Oberdepp, sondern einfach nur schlau und faul, gelle ?


    Greets Olaf

    Ollie jetzt auch im Internet !!! ->> http://www.ohms.ws << VDR mit ASUS A7V8X-X, Athlon XP 2 Ghz, 512 MB DDR-RAM und gentoo 2008.0 Linux, ner Menge Platten (1 TB), 2 Brennern und Karten-Vollausstattung (1 X Nexus 4 MB Mod, 3 x Nova, 1 PVR 350) , TFT/Sony PSOne, Nvidia Graka und und und * Linux - wir geben ihrem Computer das Leben zurück *

  • hi olaf


    Code
    1. locale -a

    gibt dir sämtliche locale aus die auf deinem System vorhanden sind.


    und

    Code
    1. locale

    (ohne -a) zeigt die aktuell aktivierte locale und zwar die in 02locale aktiviert is.


    Warum emergst du den VDR nicht ?? Aus überzeugung oder Gewissensgründen ? :)
    damit tuts hier problemlos


    Der vdr-1.6.x is im portage aber noch ~x86 masked.

  • und svdrpsend.pl zeigt was vdr nutzt (seit 1.6.0-2)

    Code
    1. mona ~ # svdrpsend.pl chan
    2. 220 mona.simpsons SVDRP VideoDiskRecorder 1.6.0-2; Mon Dec 29 18:49:12 2008; ISO-8859-15
    3. 250 7 * ProSieben
    4. 221 mona.simpsons closing connection
  • Quote

    svdrpsend.pl -d server chan
    220 server SVDRP VideoDiskRecorder 1.6.0-2; Mon Dec 29 18:51:08 2008; UTF-8
    250 4 RTL Television
    221 server closing connection


    jo stimmt :lol2