Handbrake, wäre das was für uns?

  • Ja ich kenne yacoto und hatte in der Vergangenheit (nicht im Zusammenhang mit gen2vdr) meine Probleme damit. Zu deiner Frage "wozu auch?": Vielleicht weil einem eine bestimme Software einfach gefällt und beim Wechsel von einer Distribution zu einer Anderen versucht diese weiter einzusetzen.


    Gruß


    Obelix




  • So auf die Schnelle fand ich hier :


    http://www.htpc-forum.de/forum/index.php?showtopic=3961


    Zitat

    ...
    Wie ändere ich die reccmds.conf?
    QUOTE


    Die Befehle befinden sich in einem Verzeichnis /etc/vdr/reccmds, nicht mehr nur in einer Datei.
    Die darin enthaltenen Dateien werden der Reihe nach (alphabetisch sortiert) zur reccmds.conf zusammengefuegt.
    ....




    Ich würde also mal schauen, ob gen2vdr das script in die reccmds.conf hinein arbeitet.
    eventuelle mal die reccmds.vdrtranscode.conf in vdrtranscode umbenennen und ins Verzeichnis /etc/vdr/reccmds kopieren.


    Grüße vom Alex

    Wer Rechtschreibfehler findet, darf sie behalten


    Meine Konfiguration :


    Ion 2, 2 x S2 3600, 4 Gig Ram, OS : Kubuntu 12.04 LTS, Kernel 3.2.0-40-generic , x86_64, vdr.2.0.1 ( yavdr-testing ) , vdr-xine 0.9.4 ( yavdr-testing ) , xine-lib 1.2 ( yavdr-testing )

  • hi,
    hab n kleines problemchen mit dem (ansonsten top funktionierenden) vdrtranscode. und zwar stirbt das teil beim versuch einen teil von einer 5-teiligen aufnahme umzuwandeln, bzw. das umbenennen von [cut] nach [work] geht schon in die hose! habs mal an der konsole gestartet und bekommen folgenden meldungen


    auch die bash kann mit den pfad bzw. dateinamen so einfach nix anfangen:


    liegt da der hund begraben??


    gruß,lars


    Alex : nur mal so ne frage am rande - entwickelst du das teil nochmal weiter? meine mich errinnern zu können du hättest u.a. noch ne fortschrittsanzeige aufm plan 8) frage halt weil ichs schon über "bgprogress" versucht hab, aber gescheitert bin...

    Asus M3N78-EM, AMD Athlon II X2 240e, 4GB DDR21066GeilGreen, Crucial M4 SSD+3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • das Problem liegt wohl beim Gartenzaun (#) :


    bash: Syntaxfehler beim unerwarteten Wort `2#2F5'


    Das Zeichen wird nicht richtig gequotet und von der Bash falsch interpretiert.
    Workaround wäre, das Zeichen im Aufnahmenahmen erstmal heraus zunehmen.


    Aus :


    /var/lib/video.00/Naturparadiese_Afrikas/[cut-mkv|HD-smallHD|VHQ|all](2#2F5)_Der_Regenwald_im_Kongobecken/2012-01-01.15.30.39-0.rec/


    Würde dann z.B.


    /var/lib/video.00/Naturparadiese_Afrikas/[cut-mkv|HD-smallHD|VHQ|all]Der_Regenwald_im_Kongobecken/2012-01-01.15.30.39-0.rec/


    Sollte so funktionieren.


    Grüße vom Alex

    Wer Rechtschreibfehler findet, darf sie behalten


    Meine Konfiguration :


    Ion 2, 2 x S2 3600, 4 Gig Ram, OS : Kubuntu 12.04 LTS, Kernel 3.2.0-40-generic , x86_64, vdr.2.0.1 ( yavdr-testing ) , vdr-xine 0.9.4 ( yavdr-testing ) , xine-lib 1.2 ( yavdr-testing )

  • Zitat

    das Problem liegt wohl beim Gartenzaun (#) :

    nee das wars nich, aber mittlerweile "brain found error"!! das waren noch aufnahmen aus der zeit als der vdr bei mir noch als user root lief, sprich berechtigungsproblem :wand nu geht das, auch mit "#"... sorry!


    bliebe noch meine frage im ps an dich :D 

    Zitat

    Alex : nur mal so ne frage am rande - entwickelst du das teil nochmal
    weiter? meine mich errinnern zu können du hättest u.a. noch ne
    fortschrittsanzeige aufm plan 8) frage halt weil ichs schon über "bgprogress" versucht hab, aber gescheitert bin...

    sonnige grüße,lars

    Asus M3N78-EM, AMD Athlon II X2 240e, 4GB DDR21066GeilGreen, Crucial M4 SSD+3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • sooooo, da alex sich mit aussagen bzgl. "fortschrittsanzeige" vornehm zurückhält ;D hab ich mich nochmal drangesetzt.
    habs jetz hinbekommen das ich übers das bgprocess-plugin immer informiert bin was Handbrake grad am Wickel hat. dazu starte ich aus dem "vdrtranscode_server.pl" script direkt nach dem aufruf von handbrake über folgende 2 zeilen


    Code
    1. ## execute script for sending status to bgproc vdr-plugin
    2. system 'bash /usr/local/bin/vdrtranscode_status.sh';
    3. ## separate log for STOUT ( progress ) and STERR


    einfach dieses (teilweise hier geklaute) scriptchen


    iss absolut low-end und könnte bestimmt eleganter gelöst werden, tut aber bei mir seinen dienst! vielleicht kanns ja jemand gebrauchen...


    so long,
    lars

    Asus M3N78-EM, AMD Athlon II X2 240e, 4GB DDR21066GeilGreen, Crucial M4 SSD+3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • Hallo faup.


    Mit gen2vdr habe ich erstmal auf Eis gelegt. Auf der Suche nach einer anderen VDR Distribution bin ich auf MLD gestoßen. Habe Handbrake und vdrtranscode auch schon paketiert bekommen. Leider funktioniert es noch nicht richtig. Hier die Konsolenausgabe:



    An dem fehlenden "which" kann es doch nicht liegen, oder?



    Gruß


    Obelix


  • Doch, es fehlt das Programm "which".


    Ein apt-file search ergibt hier in Kubuntu :
    ...
    debianutils: /bin/which
    debianutils: /usr/bin/which
    ...


    Which ermittelt den Pfad zu Handbrake , also z.b: /usr/bin/HandbrakeCli.
    Fehlt diese Ausgabe , kann Handbrake nicht gefunden werden.


    Grüße vom Alex

    Wer Rechtschreibfehler findet, darf sie behalten


    Meine Konfiguration :


    Ion 2, 2 x S2 3600, 4 Gig Ram, OS : Kubuntu 12.04 LTS, Kernel 3.2.0-40-generic , x86_64, vdr.2.0.1 ( yavdr-testing ) , vdr-xine 0.9.4 ( yavdr-testing ) , xine-lib 1.2 ( yavdr-testing )

  • Hallo Alex,


    danke für die Info das darüber der Pfad von Handbrake ermittelt wird. Dachte es wird mit festen Pfaden gearbeitet und deshalb meine Vermutung. which ist glaube ich bei allen großen Distributionen standardmäßig installiert. Das bereitstellen von which unter MLD ist allerdings nicht durch ein apt-get / aptitude install möglich. Habe aber schon eine Info im MLD Forum bekommen, wie man dies am besten macht.


    Danke und Gruß


    Obelix


  • danke für die Info das darüber der Pfad von Handbrake ermittelt wird. Dachte es wird mit festen Pfaden gearbeitet und deshalb meine Vermutung. which ist glaube ich bei allen großen Distributionen standardmäßig installiert. Das bereitstellen von which unter MLD ist allerdings nicht durch ein apt-get / aptitude install möglich. Habe aber schon eine Info im MLD Forum bekommen, wie man dies am besten macht.


    Warum denn so umständlich? Mach doch das was which machen sollte. Such nach den vollständigen Pfaden und trage sie statt der which-Aufrufe ein. Die gesuchten Pfade werden sich doch nicht ständig ändern.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Hallo. vdrtranscode unter MLD funktioniert :] Leider haben die konvertierten Aufnahmen keinen Ton.


    Code
    1. ° Invalid codec -B, using default for container.
    2. ° Audio codecs and no valid audio tracks, skipping codec -B
    3. ° Ignoring drc, no audio tracks


    Dies passiert bei mkv und mp4.


    Gruß


    Obelix


  • Hallo,


    sieht so aus, als wenn ein Parameter für Handbrake nicht gesetzt wird.
    Ich tippe auf den Parameter vor -B , im Log zu finden als:


    $param_E -E faac


    Wie sieht denn der relevante Teil im Log aus, also ab
    ...
    -> found /Foo/bar


    bis zum beginn des Encodings
    ....
    Encoding: task 1 of 2, Searching for start time, 9.39 % (ETA 00h00m45s)



    Grüße vom Alex

    Wer Rechtschreibfehler findet, darf sie behalten


    Meine Konfiguration :


    Ion 2, 2 x S2 3600, 4 Gig Ram, OS : Kubuntu 12.04 LTS, Kernel 3.2.0-40-generic , x86_64, vdr.2.0.1 ( yavdr-testing ) , vdr-xine 0.9.4 ( yavdr-testing ) , xine-lib 1.2 ( yavdr-testing )

  • Hallo. Anbei ein komplettes Log.


    Gruß


    Obelix

    Dateien


  • Hallo Obelix,


    ändere bitte mal die Zeile 257 in vdrtranscode_server.pl von



    Code
    1. if ( $Atracks[$i][1] =~/mp2/ ) { $nr_of_mp2++ ; push @arr_of_track_contain_mp2 , $i }

    in

    Code
    1. if ( $Atracks[$i][1] =~/mp2|MPEG1/ ) { $nr_of_mp2++ ; push @arr_of_track_contain_mp2 , $i }


    Da wird eine Audiospur mpeg1 Audio im TS gefunden, ( -> Atracks : Deutsch, MPEG1, ).


    Das Script ging bis heute davon aus, dass nur mpeg2 Audio oder ac3 vorkommen kann.


    Das könnte es schon gewesen sein.


    Grüße vom Alex

    Wer Rechtschreibfehler findet, darf sie behalten


    Meine Konfiguration :


    Ion 2, 2 x S2 3600, 4 Gig Ram, OS : Kubuntu 12.04 LTS, Kernel 3.2.0-40-generic , x86_64, vdr.2.0.1 ( yavdr-testing ) , vdr-xine 0.9.4 ( yavdr-testing ) , xine-lib 1.2 ( yavdr-testing )

  • Hallo Alex. Jupp nun funktioniert es :respekt


    Gruß


    Obelix


  • Na, sehr schön...


    habe mit dieser Änderung mal den letzten stabilen Snapshot aktualisiert.


    http://faup.fa.funpic.de/Vdrtr…napshot_2011-05-04.tar.gz


    Grüße vom Alex

    Wer Rechtschreibfehler findet, darf sie behalten


    Meine Konfiguration :


    Ion 2, 2 x S2 3600, 4 Gig Ram, OS : Kubuntu 12.04 LTS, Kernel 3.2.0-40-generic , x86_64, vdr.2.0.1 ( yavdr-testing ) , vdr-xine 0.9.4 ( yavdr-testing ) , xine-lib 1.2 ( yavdr-testing )

  • Habe das Thema Handbrake/konvertieren für mich nochmal neu aufgriffen.


    Habe mir den letzten Snapshot geladen und installiert (unter yavdr 0.4).


    So bin ich vorgegangen:


    cd /tmp
    wget http://faup.fa.funpic.de/Vdrtr…napshot_2011-05-04.tar.gz
    ausgepackt und dateien entsprechend in die Pfade kopiert. Konfig Datei angepasst (Pfade + Benutzer: vdr)
    sudo ln -s /etc/vdr/command-hooks/reccmds.vdrtranscode.conf /usr/share/vdr/command-hooks/
    sudo apt-get install libproc-daemon-perl und liblogfile-rotate-perl



    wenn ich mit: /usr/local/bin/vdrtranscode_server.pl -v auf der Kommandozeile starte steht waiting
    Dann gehe ich auf eine Aufnahme und definiere mit der roten Taste die entsprechende Qualität.


    Nix passiert :-( steht immer noch auf waiting


    Im syslog steht:
    executing command 'vdrtranscode_touch_cuted_flag.pl mkv HD-HD VHQ all "/srv/vdr/video.0
    0/%Bud's_Best/2012-03-31.02.20.12-0.rec"


    *edit
    wenn ich: vdrtranscode_touch_cuted_flag.pl mkv HD-HD VHQ all "/srv/vdr/video.0
    0/%Bud's_Best/2012-03-31.02.20.12-0.rec" das auf Kommandozeile abschicke, kommt -> marked as cut
    aber nix wird angelegt


    Da sollte doch ein extra Ordner mit cut... erzeugt werden die sich der Server dann greift ?


    Stehe auf dem Schlauch.


    Munter bleiben, Rossi

  • hallo vdr_rossi,


    Ich vermute mal, dass vdr unter einem anderem Nutzer läuft , als der Nutzer aus vdrtranscode.conf.


    Überprüfe das mal mit :

    Code
    1. ps -C vdrtranscode_server.pl -o user
    2. ps -C vdr -o user


    Auch möglich ist, das das Aufnahmeverzeichniss andere Rechte, als der VDR hat ( von früheren vdr Starts als anderer User z.B. )


    Überprüfbar mit :

    Code
    1. ls -lha1 /video/VDR_AUFNAHME/


    Mal sehen, ob wir da weiter kommen.


    Grüße vom Alex

    Wer Rechtschreibfehler findet, darf sie behalten


    Meine Konfiguration :


    Ion 2, 2 x S2 3600, 4 Gig Ram, OS : Kubuntu 12.04 LTS, Kernel 3.2.0-40-generic , x86_64, vdr.2.0.1 ( yavdr-testing ) , vdr-xine 0.9.4 ( yavdr-testing ) , xine-lib 1.2 ( yavdr-testing )