[ANNOUNCE] vdr-femon-1.6.3

  • A new version of femon with a preliminary H.264 support is now available. As I don't have any H.264 streams available in my development setup there might be some problems with the support. Also there were heavy restructuring of source code that might provide some unwanted regression,. Please send all bug reports and patches to the author.


  • Thanks 4 the new version,

    but ...

    if i start the plugin from vdr menu, i see nothing.

    In syslog i get following output

    1. Nov 10 02:02:20 vdr1 vdr: [25263] ERROR: cOsd::SetAreas returned 4
    2. Nov 10 02:02:20 vdr1 vdr: [25673] femon receiver thread started (pid=25263, tid=25673)
    3. Nov 10 02:02:20 vdr1 vdr: [25674] femon osd thread started (pid=25263, tid=25674
    4. ...
    5. ...
    6. Nov 10 02:03:44 vdr1 vdr: [25674] femon osd thread ended (pid=25263, tid=25674)
    7. Nov 10 02:03:46 vdr1 vdr: [25673] femon receiver thread ended (pid=25263, tid=25673)

    Looks like, it starts but osd can not handle it.

    The osd high in plugin i'm set it to 410, like the same high for osd menu of VDR.

    Any hints ?

  • Zitat

    Originally posted by hd.brummy
    Looks like, it starts but osd can not handle it.

    Well, I had to increase the size of used OSD by one row in order to include missing information for S2API. This change might break up OSD on 2MB FF cards due to memory limitation, but I couldn't test it on my setups (4MB FF & xineliboutput). However, your logs indicates about overlapping areas (the status window and detailed information window overlaps), so it seems that you should increase your OSD height until the OSD error number 4 vanishes.

  • Tested with my Testsystem.

    found the this entry in logfile:

    1. Nov 10 10:41:48 [vdr] [24449] ERROR (femonosd.c,447): Die Operation wird nicht unterstützt

    It seems it won't work correctly with my TT-3200.

    Some parameters wil not shown in OSD.

  • Zitat

    Originally posted by C-3POIt seems it won't work with correctly wit my TT-3200.

    The femon is still using the old DVB api and it seems that your TT-3200 drivers don't support all those legacy ioctl commands. I'll wait for vdr-1.7.2 before implementing any S2API changes...

  • ok,

    it works now :)

    im setup the Osd "high" to 420; lower, then i get an overlap in the 2 areas and an error in the syslog.

    Maybe this parameter should be hardcoded in the sources to this high ?

    output from a h264 channel: ( damnd quality from my mobilfone, sry )

    Cheers :prost2