Unter Ubunut auf c´t vdr zugreifen

  • ich hab mal ne generelle Frage.
    ICh habe auf dem ctvdr Samba installiert um von meinem Windowsrechner auf das video.00 file als auch auf das video.00/film/dvd file (da liegen die .iso´s rum) zugreifen zu können.
    So, ich benutze aber mittlerweile fast ausschließlich Ubuntu statt windows, greife aber immer noch über Samba auf die laufwerke zu.
    Aufgefallen ist mir das ich nicht auf .../video.00/fil/dvd schreibend zugreifen, warum auch immer. Ich wollte ein ISO File hinlegen und dann am VDR brennen. (ok ich weis die meisten machens andersrum :-) )
    Jetzt mal ne Frage.
    1) Warum eigenltich Samba? ISt nich nfs besser? da der nfs server eh schon läuft, weil ich auch ne S100 als Client habe? Also kurzum, soll ich Samba runterwerfen und nfs installieren?
    Wie macht ihr das wenn ihr auf den VDR vom Linux zugreift?
    Danke

    HD: yaVDR 0.3, AT3IONT-I, CINE2S, NVRAM, X10, 2.5´ 320GHDD
    SD: ctvdr 7 vdr 1.6.0, MSI 6318 (Medion2000), 667MHz, NVRRAM, WOL 500G HD
    TV: Sharp LC52XL2E (100Hz), Beamer: Sanyo Z5

    The post was edited 1 time, last by videoman ().

  • Hi,
    nichts hindert Dich daran, beide Services (samba und nfs) auf den VDR laufen zu lassen.
    Unter Ubuntu geht Du dann auf nfs, unter Windoof auf samba.
    Warum samba ? Na, wegen Windoof halt ;-)
    Wenn Du unter samba schreiben willst, mußt Du samba auf dem Server (VDR) entsprechend konfigurieren. Kannst ja Deine samba.conf mal posten.


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Quote

    Original von beagle
    unter Windoof auf samba.
    Warum samba ? Na, wegen Windoof halt ;-)


    nicht unbedingt gibt NFS auch für Windows Stichwort SFU
    http://de.wikipedia.org/wiki/M…Windows_Services_for_UNIX
    http://technet.microsoft.com/e…opmigration/bb380242.aspx

    Hardware: Elitegroup 741GX-M + AMD Athlon 1400 (läuft auf 1200 wegen Temperaturgründen) + Technotrend FF + IR Empfänger

    The post was edited 3 times, last by stev ().

  • Na ok, für Geld gibt es alles ;-)


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • SFU ist umsonst und blöd :)
    Das mir schon das ein andere mal doof verreckt.
    Im wesentliches wollte ich einfach mal blöd schreiben. sorry Leute ;)


    Grüz
    Hibbelharry

    - HTPC mit zerbasteltem Yavdr 0.6 , Origen ae X15e, MCE Remote, Asus P5N7A-VM, 1x Digibit R1, Kodi und vdr an Pana 46PZ85E
    - Diverse HTPCs im Umfeld bei Familie und Freundenm die sich vor mir fürchten, mit allen möglichen gruseligen Konfigurationen.
    Auch gern Debian, aber wehe jemand kommt mir mit Suse.

  • Sodala, hier mal meine Samba conf:


    [global]
    workgroup =
    server string = %h server (Samba %v)
    wins support = no
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    encrypt passwords = true
    passdb backend = tdbsam
    obey pam restrictions = yes
    invalid users = root
    os level = 33
    socket options = TCP_NODELAY
    unix charset = iso8859-15


    [video]
    comment = VDR-Aufzeichnungen
    path = /var/lib/video.00
    browseable = yes
    writeable = yes
    public = yes

    [videoserver]
    comment = DVD-Sicherungen
    path = /var/lib/videoserver
    writeable = yes
    public = yes

    [film/dvd]
    comment = ISO Dateien
    path = /var/lib/video.00/film/dvd
    writeable = yes
    public = yes

    [DVD Laufwerk]
    comment = DVD Laufwerk im CTVDR
    path = /cdrom
    writeable = yes
    public = yes



    es geht um die Iso Datein verzeichnisse, aber weil ich grad dabei bin, den DVD Brenner bindel man so wahrscheinlich nicht ein oder :-)

    HD: yaVDR 0.3, AT3IONT-I, CINE2S, NVRAM, X10, 2.5´ 320GHDD
    SD: ctvdr 7 vdr 1.6.0, MSI 6318 (Medion2000), 667MHz, NVRRAM, WOL 500G HD
    TV: Sharp LC52XL2E (100Hz), Beamer: Sanyo Z5

  • Hi,
    sieht eigentlich gut aus. Du solltest mal überprüfen, wie die Rechte des video Verzeichnisses aussehen. Dieses muß natürlich für den Windows User auch freigegeben sein.
    Der mount Punkt /cdrom kommt mir etwas merkwürdig vor. Bist Du Dir da sicher ?


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • doppelpost

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

    The post was edited 1 time, last by beagle ().

  • danke,


    wie müssen denn die Rechte aussehen, das ich über Samba zugreifen kann? Wohlgemekrt, ich benutze ja Samba im Linux netz Windowsbenutze ich nicht mehr. Einfach nur die Schreibrechte setzen wie gehabt? (ist ja sowieso, sonst könnte der vdr ja nichts aufnehmen..:-) )


    Der Mountpunkt /cdrom..tja ne sicher bin ich mir da nicht.
    Also ehrlich gesagt bin ich mir da gar nicht sicher. Ich hab das aus der Literatur (stand halt irgendwo und es gibt ja /cdrom nur wie gesagt ich kann nicht auf mein DVD LAufwerk im VDR zugreifen, alsoirgendwas ist falsch....


    Danke



    FRAGE: ich kann mich gar nicht erinnern, aber wie ist den üblicherweise das LW wo video.00 drinliegt formatiert? weil wenn das ext.3 wäre kann damit Samba umgehen bzw kann ichdas dann von Windows aus beschreiben? Obwohl...ich greif ja über Ubuntu zu (fragen über Fragen)

    HD: yaVDR 0.3, AT3IONT-I, CINE2S, NVRAM, X10, 2.5´ 320GHDD
    SD: ctvdr 7 vdr 1.6.0, MSI 6318 (Medion2000), 667MHz, NVRRAM, WOL 500G HD
    TV: Sharp LC52XL2E (100Hz), Beamer: Sanyo Z5

    The post was edited 1 time, last by videoman ().

  • der zugreifende user sollte samba vorher bekanntgegeben werden...
    smbuser -a <username>
    und dieser user sollte auf der Freigabe schreiben oder zumindest lesen dürfen.
    wenns für vdr freigegeben ist evtl. den user in die group vdr aufnehmen (in /etc/group unten hinter vdr-blabla mit :user erweitern)
    root zugriff ist standardmässig abgestellt in samba... also nen anderen user benutzen


    Und wenn Du eh kein Windows nutzt wäre nfs wohl die bessere Wahl...

  • dem clienten muss das dateisystem auf dem server egal sein.
    der spricht per smb mitn server.
    was der server intern draus macht hat dem clienten egal zu sein.


    hatte hier auch das problem, das ich zwar von win aus schreibend auf samba zugreifen konnte, aber nicht von linux aus.
    mir half in der smb.conf:

    Code
    1. unix extensions = no
  • Quote

    Original von videoman
    ...
    Der Mountpunkt /cdrom..tja ne sicher bin ich mir da nicht.
    Also ehrlich gesagt bin ich mir da gar nicht sicher. Ich hab das aus der Literatur (stand halt irgendwo und es gibt ja /cdrom nur wie gesagt ich kann nicht auf mein DVD LAufwerk im VDR zugreifen, alsoirgendwas ist falsch....


    was sagt denn ein 'cat /etc/fstab'? Da sollte dein optisches Lw ja drin stehen...


    Gruss,
    - berndl

  • @ berndl das macht sinn es ist nämlich /media/cdrom0 mal sehen.


    Das Problem das ich habe ist das mir Ubuntu sagt wenn ich auf film/dvd klicke "Einhängen der Ortes nicht möglich, Datei existiert nicht.
    das kapier ich nicht...weil das Directory gibt es weil ich es ja unter /video.00 öffnen kann (nur eben nix reinschreiben)


    allerdings glaub eich das der samba user in die Gruppe vdr aufgenommen werden sollte...denn die verzeichnisse in denen ich nicht schreiben kann sind vdr/vdr ...

    HD: yaVDR 0.3, AT3IONT-I, CINE2S, NVRAM, X10, 2.5´ 320GHDD
    SD: ctvdr 7 vdr 1.6.0, MSI 6318 (Medion2000), 667MHz, NVRRAM, WOL 500G HD
    TV: Sharp LC52XL2E (100Hz), Beamer: Sanyo Z5

    The post was edited 1 time, last by videoman ().