Fehlermeldung "Kanal nicht verfügbar" bei 2ter TV-Karte

  • Moin,


    VDR wurde um eine Budget TV-Karte Creatix CTX946 erweitert (vorher nur USB-DVB-T-Stick). Unter openSUSE11 mit Kaffeine funktioniert DVB-T-Empfang auch mit der CTX946. Mit dem ctVDR bekomme ich leider kein Bild und kein Ton (Ausgabe über Xine). Startet man den ctVDR nur mit der CTX946 (d.h. ohne DVB-Stick) erscheint das Bild "No signal" und die Meldung "Kanal nicht verfügbar". Die channels.conf ist korrekt, da diese mit USB-DVB-T-Stick fehlerfrei funktioniert. Vielleicht nicht ganz unwichtig: CTX946 ist eine Budget Hybrid-Karte: DVB-T, Analog-TV mit MPEG2-Hardwareencoder, FM-Radio. Ziel ist es erstmal (nur) DVB-T zum Laufen zu bringen. Hat wer eine Idee, wie man weiterkommen könnte? Danke.


    modprobe-Konfiguration prinzipiell wie unter openSUSE11 (saa7134 Einstellungen von hier übernommen):
    /etc/modprobe.d/tv

    Code
    1. alias tv-card-0 saa7134
    2. options saa7134 card=12 tuner=63 alsa=1


    /etc/modules ergänzt um tv-card-0


    dmesg


    hwinfo


    user.log

    c'tVDR v7 @ FSC Esprimo P5615, AMD Ahtlon 64 X2 4000+, 2GB RAM, Nvidia GeForce 6150SE onboard; 1GB VDR-Rootpartition; Budget: 2*Anubis Typhoon DVB-T PCI Card Lite (50667)

  • So bin jetzt einen Schritt weiter. Im VDR-Wiki habe ich diesen Hinweis gefunden.

    Code
    1. modprobe -v saa7134-dvb


    Nach "/etc/init.d/vdr restart" erkennt der VDR jetzt zusätzlich "tda1004x". Folgende Ausschrift ist neu

    Code
    1. tda1004x: setting up plls for 53MHz sampling clock
    2. tda1004x: found firmware revision 29 -- ok


    Jetzt gibt es von der TV-Karte CTX964 schon mal Bild&Ton. Umschalten hakt noch d.h. manche Kanäle funktionieren - manche nicht - obwohl vom selben Transponder.


    BTW: Gibt es für Linux auch eine "Sendung mit der Maus". Da wird immer alles so schön einfach erklärt - z.Zt. Solarzellen. :)

    c'tVDR v7 @ FSC Esprimo P5615, AMD Ahtlon 64 X2 4000+, 2GB RAM, Nvidia GeForce 6150SE onboard; 1GB VDR-Rootpartition; Budget: 2*Anubis Typhoon DVB-T PCI Card Lite (50667)

  • Für mich hat sich das Problem gelöst. DVB-T funktioniert jetzt auch mit der Creatix CT946 zufriedenstellend.


    In die /etc/modules wurde nur noch die Zeile saa7134-dvb hinzugefügt

    Code
    1. tv-card-0
    2. saa7134-dvb


    Die Probleme beim Umschalten sind wahrscheinlich auf den bekannten Umschaltfehler des USB-Sticks zurückzuführen. Allein funktioniert die TV-Karte problemlos. So kann derzeit nur einer von den DVB-T-Empfängern gleichzeitig genutzt werden. 8o :(

    c'tVDR v7 @ FSC Esprimo P5615, AMD Ahtlon 64 X2 4000+, 2GB RAM, Nvidia GeForce 6150SE onboard; 1GB VDR-Rootpartition; Budget: 2*Anubis Typhoon DVB-T PCI Card Lite (50667)