respawning too fast… [kapituliert]

  • Hallo Kollegen,


    wer den Satz "never change a running system" mißachtet, wird mit "respawning" nicht unter… bestraft…


    Ich hatte das ja schonmal vor Jahren, jetzt habe ich Mahlzeit 4.0b2 drübergebügelt - und da kam es wieder.


    Habe alle Plugins raus (außer dxr3), aber es bleibt.


    Was kann tun? - Irritieren tut mich, daß er für "PAL60" konfiguriert, haben wir nicht "PAL50"?


    Herzliche Grüße,


    herrdeh


    Hier das Logread:



  • Quote

    Mit -c wird das config-Verzeichnis mitgegeben, aber evtl. fehlt beim vorhergehenden Parameter ein Wert, so dass diese Fehlermeldung generiert wird.


    Servus und Dankeschön - aber was lernt uns das? - Ich habe ein völlig unmodifiziertes .iso gebrannt, das sollte doch alle Dateien und Verzeichnisse anlegen, oder?


    Herzliche Grüße,


    herrdeh

  • Hallo,


    zwischenzeitlich ist mir aufgefallen, daß dxr3config eine [FAILED]-Meldung ausgegeben hat. Ich hatte das zuerst nicht weiter beachtet, weil ja ein Testbild kam.


    Inzwischen kriege ich (ohne weitere Veränderungen) kein Testbild mehr hin, der Bildschirm bleibt einfach blau.


    Hier die Meldungen von dxr3config:


    This is dxr3config 0.3.2


    Checking your dxr3 hard- and software.........


    loading module adv717x [ OK ]
    loading module bt865 [ OK ]
    loading module em8300 [ OK ]
    detecting dxr3-hardware [ OK ]
    dxr3 hardware revision [ 01 ]
    detecting adv717x/bt865 [ adv717x ]
    Card revision: [ 1 ]
    Chip revision: [ 2 ]
    Video Encoder: [ ADV7175 ]
    Module Version: [ 0.16.1-rc1 ]
    looking for em8300setup [ /usr/bin/em8300setup ]
    looking for Microcode [ FAILED ]
    detecting device /dev/em8300-0 [ OK ]
    detecting device /dev/em8300_mv-0 [ OK ]
    detecting device /dev/em8300_ma-0 [ OK ]
    detecting device /dev/em8300_sp-0 [ OK ]
    trying to remove the modules...
    removing modul em8300 [ OK ]
    removing modul adv717x [ OK ]
    removing modul bt865 [ OK ]



    Press -> -> [ RETURN ]
    Loading dxr3-modules with paramset: 3


    modprobe adv717x pixelport_16bit=0 pixelport_other_pal=1
    modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=1


    Good bye...


    Habe den Eindruck, daß das "respawning2 doch mit der dxr3 zusammenhängt.


    Herzliche Grüße


    Wolf

  • Du müsstest mal einen vollständigen Logabschnitt posten, wo man den Grund für die respawning-Meldung sieht. Also ringbuffer syslog im setup ausschalten und ein Log inklusive des Abschnittes, wo vdr mit plugins startet, posten.


    für die dxr3 könnten auch folgende Einträge *) passen:


    modprobe adv717x pixelport_16bit=0 pixelport_other_pal=0
    modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=0


    Bei meinem letzten Test mit mahlzeit 3.2 war die darin enthaltene dxr3config nicht in der Lage, diese Einstellungen zu ermitteln.
    *) ich glaube dxr3config legt dazu /etc/modprobe.d/dxr3 an

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Servus Dr. Seltsam,


    nett, sich nach Jahren mal wieder zu lesen.
    Habe mal die /var/log/messages angehängt, ich hoffe, es ist die, die Du meinst.


    Deine anderen Parameter habe ich ausprobiert - leider kein Erfolg.


    Herzliche Grüße,


    herrdeh

  • Die "-c"-Fehlermeldungen scheint tatsächlich von vdr zu kommen und das Starten zu verhindern.


    Schau bitte mal in die Datei /etc/init.d/runvdr


    steht dort ziemlich am Anfang
    export CONFDIR="/etc/vdr"
    Ist dieser Ordner auf Deiner Platte vorhanden?


    Danach such nach einer langen Zeile

    Code
    1. CMD="$BINDIR/vdr -L $PLUGINDIR $PLUGINS $COMMON_PARAMETER -v $VIDEODIR -c $CONFDIR -w $WATCHDOGTIMER -E /video0/epg.data -s /usr/bin/poweroff.pl -r /usr/bin/recordinghooks.sh < /dev/tty$VDRTTY"


    Hier wird der Parameter -c übergeben: -c $CONFDIR
    Also muss da irgendwo der Wurm liegen

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Hallo,


    Danke für die schnelle Antwort. Habe die Dateien und Verzeichnisse nachgesehen - mE ist alles so, wie von Dir beschrieben.


    Ich habe die Mahlzeit4.0b2 ja nicht frisch installiert, sondern über eine alte drübergebügelt. Kann es sein, daß es ein Rechteproblem ist - d.h. der VDR versucht auf eine vorhandene Datei/Verzeichnis zuzugreifen, hat aber keine Lese- oder Schreibrecht??


    Herzliche Grüße,


    herrdeh

  • soweit ich weiss, läuft auch bei mahlzeit4 der vdr als root, also dürfte es kein Rechteprobelm geben.


    Was ist, wenn Du explizit -c /etc/vdr statt -c $CONFDIR vorgibst?


    poste mal die Ausgabe von

    Code
    1. -ls -l /etc/vdr

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Quote

    Was ist, wenn Du explizit -c /etc/vdr statt -c $CONFDIR vorgibst?


    Macht keinen Unterschied, das Fehlerbild ist das gleiche wie vorher.


    Die Ausgabe von ls -l /etc/vdr habe ich angehängt.


    Herzliche Grüße,


    herrdeh

  • das sieht so aus, als wenn da beim updaten etwas mit den Konfigurationsdateien schief gegangen ist. Diverse haben eine Größe von 0 Bytes.


    Versuch mal folgendes:


    cd /etc/vdr
    mv commands.conf.new commands.conf
    mv reccmds.conf.new reccmds.conf
    mv setup.conf.new setup.conf
    mv svdrphosts.conf.new svdrphosts.conf


    und dann nochmal neu starten

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    The post was edited 1 time, last by Dr. Seltsam ().

  • Servus,


    gemacht wie von Dr. Seltsam geraten… - leider noch immer der
    "ERROR: -c: No such file or directory"-Fehler…


    Was kann ich nun noch machen…?


    Herzliche Grüße,


    herrdeh


    PS.: Fahre morgen früh gegen 9.30 für eine Woche weg - daher werden Antworten dann etwas dauern.

  • ganz ehrlich? ich würde die mahlzeit 3.2 neu installieren, dazu das vdr-Paket 1.4.7-ext40 von Toxic-Tonic und einen neuen Kernel von mir. Dann hast Du ein weitgehend ausgereiftes System.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • o.k. - Mahlzeit 3.2 ist installiert. Patches und Dr-Seltsam-Kernel habe ich noch seinlassen - dachte, das ist "Kür" oder??


    System startet - der "respawning"-Fehler kommt wieder… - aber immerhin: Die Fehlermeldungen von logread sind andere…


    Mit dxr3config kriege ich nach wie vor kein Testbild - aber die Fehlermeldung "loading microcode - [FAILED] kommt jetzt nicht mehr.
    Aber auch mit den Parametern von Dr. Seltsam kommt der VDR nicht ans Laufen.


    Ich hoffe, das ist jetzt ein Fortschritt… (-;


    Herzliche Grüße,


    herrdeh

  • Hallo,


    habe mich nun zu einer Neuinstallation entschlossen - Mahlzeit ISO4.0b2 lief fast glatt durch, die alten Aufnahmen sind schon rüberkopiert. Ich denke, das ging letzten Endes schneller als noch ein paar Tage Fehlersuche.


    Dank an alle, die sich bemüht haben!


    Herzliche Grüße,


    herrdeh

  • mit solchen 1min Pausen wurde ich auch zur Neuinstallation animiert, nur ging dann immer noch nichts.
    Nach einigen Testen katte ich bemerkt, dass sich das Netzwerk auf meinem Jetway heimlich verabschiedet hatte. Als ich das Netzwerk dann abschaltet, startet alles wieder problemlos. Ein nachträgliches Zuschalten hinterte den VDR-Startbis zu TV-Ausgabe nicht, aber die Hardware war eben tot.
    Habe das Board zum Tausch zurückgesandt.

    easyVDR2.2.0-64bit-stable
    es ist traurig, wenn alles für die Katz ist, aber nicht's für die Katze